Version 1.2 Release Notes 



CorelXARA version 1.2 extends bitmap handling options. These new options are especially useful for creating graphics intended for publishing on the World Wide Web (WWW). Also included are some additional functions requested by users.



  New features of this release:

	•	importing color palettes

	•	RGB colors can be specified as 0-100% or 0-255

	•	new Pixel measurement unit

	•	new optional default document 

	•	optimized palettes and bitmap dithering

	•	new "Convert to bitmap" menu option

	•	improvements to GIF import

	•	more options for exporting in GIF format (including animated GIFs)

	•	optional on-screen dithering

	•	changes to the keyboard shortcuts 

	•	new "print text as shapes" print option

	•	change to snapping



Importing color palettes 

Color palettes are files containing a series of color definitions. Importing a color palette is a quick way of adding colors into a document and so easily extending the range of predefined colors. 



The original version of CorelXARA imported CorelDRAW (.cpl & .pal) palette files. 



CorelXARA 1.2 can also import:

Windows palettes (.pal files) – produced by a variety of programs.

Adobe Color Tables (.act files) – used by Photoshop in paletted images. Saved using Color table on the Mode menu in Photoshop (select Indexed color on the Mode menu first).

Adobe Color Swatches (.aco files) – used by Photoshop to store collections of colors for external use. Colors can be defined in RGB, CMYK or HSV – the other formats define RGB colors.

Paint Shop Pro Palettes (.pal files) – these are created using Save Palette on the Colors menu in Paint Shop Pro.



To import a palette into the current document, drag-and-drop the file icon onto the document page or the gray page margins at the sides of the page. To import into a new, blank document, drag-and-drop onto any other part of the CorelXARA window. 



Colors in palette files are unnamed so CorelXARA allocates names based on color composition. For example, "R100%G50%B0%" is an RGB color comprising 100% red, 50% green and 0% blue. (If you have selected Decimal as the way to specify RGB colors, the color name would be "R255G128B0". For details on specifying RGB colors in decimal, see Specifying RGB colors.)



Specifying RGB colors in the Color Editor

Many users like to specify RGB (Red-Green-Blue) colors as 0-255 rather than 0-100%. CorelXARA 1.2 permits this. Default is 0-100%. To enter a value in the default units, just type in the number (for example, 55). (You can change the default – see below.)



To enter a value in the other units follow the number by either % (75%) for a percentage value or d (205d) for 0-255.



Colors defined in the CMYK and HSV color models are always defined as 0-100%.



Changing the default for the current document

1.	Display the Units tab of the Options dialog box. (Options on the Utilities menu). 

2.	Click the appropriate radio button in the Color units section. 

�

3.	Click OK to close the dialog box.



Changing the default for all new documents

1.	Open a new document (New on the File menu). This will become the Template document so do not alter this document in any way. 

2.	Display the Units tab of the Options dialog box (Options on the Utilities menu). 

3.	Click the appropriate radio button in the Color units section.

4.	Click OK to close the dialog box.

5.	Save the document as the Template document (Save template on the File menu).



The manual contains more information on:

the Color Editor – pages 120-125

color models – page 116

Options dialog box – pages 170-176; Units tab – page 24



Pixel measurement unit 

For graphics that will be displayed on a computer screen (such as WWW graphics), it's often easiest to enter and display measurements in screen pixels (96pixels=1 inch). CorelXARA 1.2 lets you do this using a new measurement unit of pixels (abbreviation pix). 



You can always enter dimensions in pixels by typing pix after the dimension (120pix).



Sometimes the edge of an exported bitmap shows a thin border. This happens when the size of the bitmap is not a round number of pixels. You can avoid this by using Snap to grid for positioning objects. Set the grid spacing to, for example, 10 pixels. Page 22 of the manual describes the on-screen grid; page 71 snapping.



Making Pixels the default for the current document

To show dimensions in Pixels in the current document, display the Units tab of the Options dialog box (Options on the Utilities menu). Set Page units to pixels. The current units are saved when you save the document. The next time you open the document, dimensions are shown in pixels.



Making Pixels the default for all new documents

1.	Open a new document (New on the File menu). This will become the Template document so do not alter this document in any way. 

2.	Display the Units tab of the Options dialog box (Options on the Utilities menu). 

3.	Set Page units to Pixels.

4.	Click OK to close the dialog box.

5.	Save the document as the Template document (Save template on the File menu). 



The manual contains more information on:

Options dialog box – pages 170-176; Units tab – page 24

on-screen grid – page 22

snapping – page 71



New template document 

Supplied with CorelXARA 1.2 is a new template document (WWW.xar) that includes colors identical to those used by both Netscape Navigator and Microsoft Internet Explorer. Netscape and Explorer display these colors without dithering which gives the best results on screen. (Intermediate colors in blends and graduated fills will not match palette colors and so will be dithered.) Also included are other features useful for creating WWW graphics such as a grid spacing in pixels. Using WWW.xar makes it easier to create top-quality graphics for use on the WWW. 



You can find WWW.xar in the same directory as the program (CORELXRA by default).



To create a document based on WWW.xar:

1.	Load WWW.xar.

2.	Create your document. Use only the colors provided on the Color Line or Color gallery. If you create your own colors they won't match and won't display so well.

	Tip: (Choosing Small icons in the Color gallery lets you display all the colors in a compact square. See page 28 of the manual for more information.)

3.	Make sure you save the new document using a different filename so you don't overwrite WWW.xar.



To replace the existing template document with WWW.xar:

1.	Load WWW.xar. Do not make any changes.

2.	Save it as the template document (Save template on the File menu). This new template document is then used for all new documents.

3.	Close WWW.xar. This avoids any chance of accidentally overwriting it.



Also in the CorelXARA directory is a palette file (WWW.pal) containing the Netscape/Explorer palette. Drop WWW.pal onto a document to load the colors.



Optimized palettes and bitmap dithering

These two export options provide you with a range of options for improving the appearance of exported bitmaps. 



The Bitmap export dialog box controls both the palette and dithering:

 �	 

Click the radio buttons to select the options you require. Page 164 of the manual describes the Bitmap export dialog box.



Palette options

The Standard palette is good for showing the widest range of colors and it's the one used on screen by CorelXARA. However, as most images use only a limited range of colors, it's possible to create an Optimized palette. (Optimized palettes contain a selection of colors best suited for the image.) Combined with our advanced diffusion dithering it's possible, in nearly all cases, to get near perfect quality images – practically indistinguishable from real 24-bit images.



Not all programs make use of optimized palettes. However, optimized palettes display well in programs such as CorelXARA, Netscape, Internet Explorer, Adobe Photoshop and Corel PhotoPaint.



Dithering options

It's possible to create the illusion of a bitmap containing more colors than it actually does by dithering between two colors. Ordered and Diffusion dithering are different ways of dithering between colors. Diffusion (error diffusion) gives better results and the dither pattern is less noticeable. The drawback is that the exported GIF files may be larger.



Note: Ordered dithering is dimmed when Optimized palette is selected as the two options are incompatible. 



Our recommendations:

When exporting GIF images for the WWW, our general recommendation is to use Diffusion dithering and an Optimized palette. If the web pages are likely to be viewed in a 256-color mode only, you sometimes get better results with Diffusion dithering and a Standard palette.



GIF import

Version 1.1 users:

Previously transparent GIFs appeared in the Bitmap gallery as two separate bitmaps: the GIF and a transparency mask. CorelXARA 1.2 now creates only one bitmap. This makes handling them in documents easier.



GIF export 

Pages 165-166 of the manual have more information on GIF export.



The original version of CorelXARA could export GIFs as 16-colour (4-bit) without GIF transparency or 256-color (8-bit) with transparency. CorelXARA 1.2 can also export GIFs as 2-color (1-bit) with optional transparency and 16-color (4-bit) with optional transparency and optimized palette. The greater the number of colors used, the larger the file size. This is important when creating graphics for the WWW as small files take less time to download.



Transparency in a GIF bitmap means you can see through parts of the image to the background. If you export just a selection, then only the selected objects appear – all other areas are transparent. Note that GIF supports only a simple on-off transparency mask and not the more advanced graduated transparency that CorelXARA offers. Therefore semitransparent objects are not possible in GIF files. GIF transparency is really suitable only for masking around the outside of objects.



2-color GIF export

With Standard palette selected, the two colors are pure black and white (Transparency off) or pure black and transparent (Transparency on).



With Optimized palette selected, CorelXARA scans the colors used and selects the most common or 'dominant' color. The second color is either the background color (Transparency off) or transparent (Transparency on).

	Export options:	Colors

	standard palette, no transparency	black/white

	standard palette, with transparency	black/transparency

	optimized palette, no transparency	dominant color/background color 

	optimized palette, with transparency	dominant color /transparency



With all options you can choose No dithering, Ordered dithering or Error diffusion. These are described in Bitmap dithering. For 2-color GIFs, selecting both Transparency and Ordered dithering/Error diffusion causes dithering between the color and transparent. This may give strange results with some images.



16-color GIF export

With Standard palette selected, a fixed 16-color (or 15+transparency) palette is used. This palette includes all the primary colors.



With Optimized palette selected, an optimized 15 or 16-color palette is used.



With either palette you can choose No dithering, Ordered dithering or Error diffusion. These are described in Bitmap dithering. 



Version 1.1 users:

Older versions of CorelXARA exported with a standard palette and ordered dither.

Note that transparent GIFs contained in CorelXARA 1.2 documents will not load into CorelXARA 1.1.



"Create bitmap copy" menu option

This option (on the Arrange menu) saves the current selection as a bitmap to the Bitmap gallery.  Its main use is for creating animated GIFs (see below). But you can also use it, for example, to create custom bitmap fills or make grouped objects transparent.



Selecting this option opens a create dialog box similar to the Bitmap export dialog box described on page 164 of the manual. (The Palette and Dithering options are described in these Release Notes. These options are dimmed if you select 24 bits per pixel.)



The only extra control is the Transparent button. (Dimmed if you select 24 bits per pixel.)

�  	

With Transparent selected, the bitmap shows:

all selected objects

and those parts of unselected objects that overlap selected objects.

Other areas are transparent.



With Transparent unselected, the bitmap shows all objects, selected and unselected, within the area containing the selected objects.



Clicking Create puts the bitmap in the Bitmap gallery and also places a copy of the bitmap in the center of the window.



SHIFT-clicking on Create puts the bitmap in the Bitmap gallery and also places the copy exactly on top of the original objects. Note that, because the bitmap is exactly on top of the objects, it may appear nothing has happened.



Caution:

Bitmaps are saved with the document only if they appear on the page of the document. Bitmaps in the gallery that are not used in any document are automatically discarded when you close the document.



Creating a bitmap using Create bitmap copy automatically copies the bitmap into the document. However, if you delete that copy and don't use the bitmap elsewhere, it is unused and will be deleted when you close the document.



To keep a copy, you can move the bitmap to the gray page margin that surrounds the page area. Anything on the page margin is saved with the document.



Note also that the Delete button in the Bitmap gallery deletes all unused bitmaps. Normally you don’t need to manually delete bitmaps from the gallery because of the automatic deletion when you close a document.





Animated GIFs

Animated GIFs are becoming increasingly popular in Web browsers such as Netscape Navigator (version 2 onwards) and Microsoft Internet Explorer (version 3 onwards). They are a quick and easy way to show simple animated sequences. An animated GIF is just a GIF file that contains a sequence of bitmap images, rather than just a single image. Programs such as Netscape display the sequence of images one after another, much like frames in a movie. CorelXARA supports the creation of animated GIFs by providing an easy way to convert illustrations to bitmaps, and by allowing a sequence of bitmaps in the Bitmap gallery to be saved as a single animated GIF.



The Bitmap gallery is an ideal tool for managing animated GIFs because it shows all the separate images or frames that make up the animation as individual bitmaps. You can rearrange and reorder the images in the gallery to rearrange the animation sequence, and select exactly which images are used to make up the animated GIF. (You can rearrange images by simply dragging them to the required place in the gallery.)



The usual sequence to create the frames is:

1.	Draw what you want as the first frame.

2.	Select just the drawing.

3.	Select Create bitmap copy on the Arrange menu to save the drawing as a bitmap in the Bitmap gallery.

	(Or right-click on the drawing and choose Create bitmap copy from the pop-up menu.)

4.	Edit the drawing as appropriate for the next frame in the animation.

5.	Create bitmap copy in the same way. 

6.	Repeat steps 4 & 5 until you have built up the sequence of frames in the Bitmap gallery. 



See Caution: in the section on Create bitmap copy for important information of saving bitmaps that appear in the Bitmap gallery but not in the document.



Animated GIF files tend to be much larger than single-image GIFs and so your animation sequence should normally use small drawings or only a few frames.



To create the animated GIF:

Select all the bitmaps you want in the animation. To select a block of bitmaps, click on the first then SHIFT-click on the last. To select or deselect individual bitmaps, CTRL-click.

Click Save in the Bitmap gallery. This opens a dialog box similar to the Export dialog box described on page 162 of the manual.

	When you have entered the filename and destination, click Save. This opens a dialog box similar to the GIF Bitmap Export dialog box described on pages 164-165 of the manual. (The Palette and Dithering options are described in these Release Notes.) 

GIFs do not include resolution information and so there is no control over this. (GIFs are normally displayed at the screen resolution of the viewing program.)

	The Width and Height fields apply to all the bitmaps in the animation. If necessary, bitmaps in the Gallery are scaled to match these parameters. Similarly, the color depth of individual bitmaps is changed to match the value set in this dialog box.

�

	Delay: lets you specify a delay (in 1/100ths of a second) between successive frames. This lets you control the animation speed. Note that for short delays, speed is usually limited by how quickly frames can be loaded by the viewing program.

	Restore: tells the viewing program what action to take after completing the display of the GIF.

Nothing: action is determined by the viewing program.

Leave as is: continue to display the last frame of the animation.

Background: remove the frame from screen and redisplay the background.

Previous image: restore the image displayed before animation began.

	Loop: the number of times to repeat the animation loop. Enter 0 for continuous play.

	Note that Delay, Restore and Loop insert commands into the GIF. The implementation of these commands is controlled by the viewing program and so is beyond the control of CorelXARA. For example, Netscape 2 ignores all loop values except 1; other values give continuous play.

4.	Click Export to create the animated GIF.



The easiest way to preview an animation is to drop the saved GIF file directly onto the Internet Explorer or Navigator window. (But note that Navigator 2 flickers badly between runs - this doesn't normally happen when the GIF is part of an HTML page. Also it has the habit of flickering the Stop button when displaying animated GIFs. It is expected these quirks will be addressed in later Navigator versions.)



Not all Web browsers can display animated GIFs. Those that don't usually just display the first or last frame of the animated sequence.



Loading animated GIFs into CorelXARA

Load these in the same way as other types of bitmap. That is, you can Import them into the current document or Load them into a new document. 



The bitmaps appear in the document stack on top of each other. You can then move them around the page, change the stacking order, edit them, as you wish.



The bitmaps are loaded into the Bitmap Gallery in their animation sequence. (First bitmap in the animation is highest in the Bitmap gallery.)



On-screen dithering 

On-screen dithering is useful in 256 color screen modes because it gives the illusion of many more colors on the monitor screen. It has no advantage for deep-color screen modes (more than 256 colors). The disadvantage is that dithering can slow down screen redraw times. (It takes longer to display objects on the screen.)



Options provided by CorelXARA are:

No dithering. This is gives the fastest screen redraw times but poorest display quality. No dither is only really useful to see how exported 8-bit bitmaps will look with no dither.

Ordered. This is the normal setting. It gives good results and is as fast as No dithering

Error diffused – gives the best results but, because more processing is required, slowest redraw. The actual redraw time depends on the hardware in your computer. 



On-screen dithering is a user option controlled from the View tab of the Options dialog box (Options on the Utilities menu). 

�



The manual contains more information on:

Options dialog box – pages 170-176; View tab – page 175



Keyboard shortcuts 

The original version of CorelXARA used a few CTRL+ALT combinations for keyboard short cuts. These gave problems with some  languages such as Polish. CorelXARA 1.2 now uses: 

CTRL+SHIFT+A	Paste attributes (was CTRL+ALT+V)

CTRL+SHIFT+C	Create bitmap copy – new option, described above

CTRL+SHIFT+D	Move object to layer behind (D for Down) (was CTRL+ALT+B)

CTRL+SHIFT+U	Move object to layer in front (U for Up) (was CTRL+ALT+F)

CTRL+SHIFT+Z	Zoom to selection (was CTRL+SHIFT+D)

There's a full list of keyboard short cuts on pages 188-190 of the manual.



Print options dialog box

Some printers cannot print colored text. This is a printer problem and not a fault with CorelXARA.



The Output tab of the Options dialog box now lets you print text as shapes. This gets round the colored text not printing problem but increases printing time. We recommend setting this option only if you have problems with colored text not printing.

�		

This option prints all text as shapes. There's a similar option on the text pop-up menu that lets you print individual text objects as shapes. 



The manual contains more information on:

Options dialog box – pages 170-176; Output tab – page 154-155

Text pop-up menu – page 106



Change to snapping

This change affects how objects with thick lines snap to the grid and to other objects. The original version of CorelXARA snapped to the outside of lines. CorelXARA 1.2 snaps to the center of lines. See page 71 of the manual for more information on snapping.









These Release Notes ©1996 Xara Ltd.

Version 1.0.

Trademarks:

CorelXARA is a trademark of Corel Corporation & Xara Ltd.

CorelDRAW & Corel are trademarks of Corel Corporation

Netscape is a trademark of Netscape Communications Corporation

Microsoft Internet Explorer. Is a trademark of Microsoft Corporation

Photoshop is a trademark of Adobe Systems Inc.

Paint Shop Pro is a trademark of JASC Inc.

All other trademarks acknowledged.

– � PAGE �7� –








