
Selecting text

sing any tool but the Text tool, double-click-
ing allows you to select objects at different

levels (a grouped word, a letter, faces, etc.). Each
double-click goes one level farther down. At the
lowest level, double-clicking pops you back up to
the top level. At any level, a single click selects only
other objects at that level: if you’ve selected a letter,
single clicks will only select other letters, not the
whole word. Click in an empty space to deselect
everything. When you click again on text, you’ll be at
the highest level again.

In general, for extruded objects in Typestry there
are three levels, or groupings, from which you can
select. (Rubber Sheets have two, and Tubes have
only one.) From highest level to lowest these are:

• The whole text object. When nothing is select-
ed, clicking on a text object selects that object.

• One letter of the object (sides and faces togeth-
er). When an object is selected, double-clicking on a
letter selects just that letter.

• The faces of a letter (no sides). When a letter is
selected, double-clicking on that letter selects just
the letter’s faces.

For more information on grouping and levels, see
the chapter on Group Therapy.

Selecting hard-to-get text

You can select text in the project window that’s
obscured by other text, or otherwise hard to select:

1. If the Score window isn’t showing, select Show
Score from the Windows menu.

2. Find the object in the Score window on the left
side and select it.

3. Hold down the Control key as you manipulate
the object in the project window.

The Tools

Use the tools to manipulate text. Tools that have a
dot in the lower right have pull-down menus with
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variants of that tool. Click and hold to display the
menu.

The Text tool

Use the Text tool (F2) to bring up the
Details dialog, which allows you to type in your text
or shapes, and set its attributes. (See the chapter on
Getting Text In for more on this.)

The Illustrator Import tool

Use the Illustrator Import tool (F3) to bring
up the Details dialog, which allows you to select an
Adobe Illustrator file for import, and set its attribut-
es. (See the chapter on Getting Text In for more on
this.)

The Move tool

Use the Move tool (F9) to move text around
in the project window. You may see its perspective
change as you move it.

Note: Holding the Shift key down while starting to
move an object constrains its motion to the hori-
zontal or vertical.

The Rotate tool

Use the Rotate tool (F10) to rotate
text. This tool rotates the object as if it were
enclosed in a sphere (the way a trackball
works): side-to-side mouse motion spins the
object around its vertical axis, forward-back
motion spins it around the horizontal axis,
etc.. If you’d like to use a rotation tool that
constrains the rotation to one axis at a time,
click and hold on the tool and a pull-down
menu will appear. You can pick the appropri-
ate tool from there.

Note: If you get the text in a weird orientation that
you can’t seem to get out of, use Reset Orientation
from the Edit menu. This will get the selection
straightened out and face-on.

Using the unconstrained rotation tool (and not the
others in the pull-aside menu):

• Move the mouse to the right for east-to-west
rotation (the right side of the text moves toward
the back).

• Move the mouse away from you for south-to-
north rotation (the top of the text tips backwards).

• Holding down the Shift key after you’ve started
to rotate text temporarily stops the rotation, allow-
ing you to reposition the cursor. Let go of the Shift
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key to resume rotation.

With the Rotate tool selected, clicking on the text
with the right mouse button brings up this dialog:

With this you can rotate a specified amount (from
–360º to 360º) around any of the selection’s three
axes. The arrows in the dialog box show the direc-
tion of positive rotation.

The Scale tool

Use the Scale tool (F11) to resize
text along one or more of its axes. This tool
affects the text’s width, height, and depth
together. Use the pull-down menu to get a
tool that allows you to constrain the scale
along one axis.

• Rightward mouse motion enlarges text,
leftward shrinks it.

Holding down the Shift key while dragging constrains
the resize to horizontal or vertical, depending on
which direction you first move the mouse.

Clicking on the text with the second mouse button
brings up this dialog:

With this you can resize a selection in two ways:

• Uniform, which resizes an object as a whole.

• Nonuniform, which resizes width, height, and
depth differently).

To use this, just select Uniform or Nonuniform, and
enter a percentage by which to resize the selection.

Holding down the Control and Shift keys while drag-
ging forces one dimension to grow while the other
one shrinks by the same amount (“volume-preserv-
ing” resize). This is useful in creating an object that
looks “squashed and stretched,” as a rubber ball
does when it hits the floor.
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Note: Changing some text’s thickness will change
the shape of a rounded bevel: thickening will tend to
smooth it out, thinning will exaggerate it (see the
images in section Getting Text In). You can restore
an object’s size to the size it was when you first cre-
ated it using Reset Scale under the Edit menu.

Here are some examples of non-proportional scale:

The Skew tool

Use the Skew tools (F12) to give text
a slant along one of its axes. The pull-down
menu provides tools to skew along individ-
ual axes.

Clicking on an object with the second
mouse button brings up this dialog:
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With this, you can skew a selection along any of its
axes by any amount. To use this, just select an axis,
and enter an angle by which to skew the selection.

The images at right show the Skew tool being
applied.

The Crop tool

Use the Crop tool to restrict the area to be
rendered: you don't always have to render the con-
tents of the whole window. You can “crop out”
areas you don't need to see by using this tool; just
the contents of the crop window will be rendered.
In the illustration on the next page, you only see the
area within the crop box when you render.
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To get rid of the crop window, just toggle the Crop
tool button off by clicking on it. When you toggle it
on again, the crop window will be as it was when
you left it last.

With this tool selected, clicking in the crop window
with the second mouse button brings up the Render
Cropping dialog:

Here you can do three things:

• Make the crop window active or inactive.

• Determine numerically what area the window
covers. Use percentages to specify where the edges
of the window are. For example, values of 50, 100,
50, 100 specify an area that covers the bottom right
quarter of the project window.

• Determine how the crop window should work.

The crop window works in two ways:

Crop. This the normal mode, where the partial
image is rendered at the size of the crop window as
you see it on your screen.

Zoom. The partial image is rendered “zoomed up:”
the crop window is expanded proportionally so one
of its dimensions matches the project window's. This
is especially handy when you want to create an ani-
mation that has an object disappear from view. You
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can have the object in your project window, and
control the animation normally, but when it’s outside
the crop window it won’t appear in the rendered
frames with this option turned on.

• Click and drag the handles (in the upper left and
lower right corners) to adjust the crop window.

• Click and drag anywhere inside the crop window
to move it.

Only what's in the crop window will be rendered.

• To force the crop window to take the shape of
the project window, hold the Shift key down while
resizing the crop window. This is useful when used
in conjunction with the Zoom setting: it allows you
to create animations where objects enter the frame
from one side.

Viewing the text

You can use different camera views to get a differ-
ent view of the scene. These are the bottom four
choices in the Views menu. View to Fit moves the
current “camera” (From Front, From Left, or From
Top) in such a way as to fit everything in the scene.
So if you find you’ve moved some text off-screen, or
made it too large to see the whole thing, just use
View to Fit to see everything. If you’ve used View to

Fit and need to get the original view back, select
Reset View under the Edit menu.

The views are also useful when you want to move
text in front of or behind other text. Using the From
Top or From Side view lets you see exactly where
things are.

Grouping

The Group Therapy chapter goes into some depth
explaining grouping concepts. This section deals with
the practical issues: how to group, what it's good for,
etc.

Extruded text objects have a default grouping when
you create them. Whatever characters you type in
are automatically grouped into one object. Within
this group, each letter is itself a group consisting of
two elements: 1) the front and back faces (which
are a single object), and 2) the sides (also one
object). Type in another text string and you have a
new group. However, you can rearrange and
regroup things quite simply.

If the Score window isn't already showing, select
Show Score from the Windows menu. The left side
of this window displays the groups' elements as if
they were files and directories in the File Manager.
All “directories” are groups. And you can move
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things around and restructure the hierarchy just as
you do in the File Manager, by clicking and dragging.
Use the grey bar at the left end of the “directory” as
a handle for dragging. Drag an item into a different
“directory” and the item and anything in it automati-
cally becomes a member of that group. Additionally,
you can change the order of things by dragging the
elements or groups up or down. You'll see why this
is useful in a moment.

When you click and drag an element (slowly) you'll
see a purple cursor appear at the drag bar. This tells
you where the element would end up if you were
to release the mouse button. If you don't see the
cursor, the element won't change places.

Why would you want to group things? Well, for four
reasons.

• You can apply Looks to many objects at once.

• You can manipulate the position, orientation,
scale, and skew of many things at once.

• You can perforate objects.

• You can gain incredible control over animations.

You can read about this in the Animation chapter.

Groups and Looks

You can organize words and letters around Looks, if
this serves your purpose. Applying a Look to a
group makes it unnecessary to apply the Look to
each of the group's elements. Additionally, once you
have things positioned the way you want them you
can regroup things into Look-based groups, putting
pairs of letters together, for example, to apply Looks
in groups of two.

Groups and the tools

If you've worked with any of the popular drawing
programs, you're no stranger to grouping things to
have one operation apply to many things at once.
It's a simple idea. The Move, Rotate, Resize, and
Skew tools operate on whatever's selected. If the
selection is a group that contains many objects, you
can get a lot of work done at once. Use grouping to
have an operation apply equally to multiple objects:
when you resize a group, all its elements will have all
three dimensions scaled exactly proportionally.
When you rotate a group, some elements may end
up behind others, which you can use as a tool to
gain depth in a scene.
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Creating a group

To create a new group:

1. Select Group from the Edit menu. This creates a
new group. If an element was selected when you
used the Group command, that element will be
included in the new group.

2. If you wish, type in a name for the group by
highlighting the name and typing in a new one.

To ungroup grouped elements:

1. Select the group you want to delete.

2. Select Ungroup from the Edit menu.

Warning: Don’t use the Delete key to try to
ungroup! This will delete the group and everything in
it.

Perforating objects

You can get some quite interesting effects by com-
bining objects in unusual ways. You can do various
sorts of perforation, embossing, debossing, and over-
lapping. For example, the IBM logo is an easy effect
to create. You’re not limited to using a few shapes
for these operations — you can use any object you
can get into Typestry.

There are three basic steps. We’ll lay them out here,
and then explore them in detail in a tutorial:

1. Create one object that overlaps another. (An
object can itself be a group.)

2. Group the objects.

3. Set the group’s perforation (perf) mode.

The perf modes are available in a popup menu in
the Score window. To display the menu, just click
and hold on a group’s perf icon, just to the right of
the gray drag bar:

Once you’ve created a group in which two objects
overlap, here's what you can do:
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• Create a composite object from the two ele-
ments. This is the default behavior. The group’s
name will be preceded by the “Simple Group” icon,
indicating that it’s a simple group.

• Render only the overlapping areas. This is called
an “intersection.” For this effect, set the perf mode
to Perfs Intersection. The group’s name will be pre-
ceded by the Perfs Intersection icon ( ).
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• Remove any overlapping areas. This is called a
“difference.” For this effect, set the perf mode to
Perfs Difference. The group’s name will be preceded
by the Perfs Difference icon ( ). In the group you
create to hold the objects, the second (lower) ele-
ment in the group gets subtracted from the first
(higher) element.

Warning: Using perforations increases rendering
time. Using multiple characters for perforations can
make a dramatic difference, slowing things down
and increasing memory requirements significantly.

Perfs tutorial

Ok, let’s try one. Let’s make the N in the word
“ONE” have the word “two” carved out of it. If
your Score window isn’t showing, bring it up now
by selecting Show Score from the Windows menu.

1. In Typestry, type in the word “ONE” (all caps) in
some fat font, as bold as possible. Use the Bevel
Build Method, and any bevel you wish.
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2. Type in the word “two” (in lower case) in a thin-
ner font, also using Bevel, with any bevel.

3. Now you should have two words on your
screen, something like this:

4. In the project window, make the “ONE” big, and
the “two” small: adjust the sizes of the words so the
“two” is small enough to fit into the N in “ONE.”

5. Place the “two” somewhere in the N:

For the “two” to create a hole all the way through
the N, it must stick out both the front and the back
of the letter. If the front of the “two” is behind the
front of the letter, all we’ll see is the front of the let-
ter, and not the hole inside where the “two” is. If it
sticks out the front but not the back, it’ll seem like
the “two” doesn’t poke all the way through.

6. So make the “two” thicker than the N. Be sure
to use the Top and Left views, available under
Camera in the Effects menu, to check that the “two”
sticks out in front and back of the letter. (If you
want, you can also use the Telephoto lens, available
under Camera in the Effects menu to get rid of the
perspective distortions. But don’t forget to set this
back to Normal when you’re done.)

• If you’re having trouble selecting the right object
to scale, select it in the Score window, hold down
the Control key, then click and drag in the project
window.

Now for the subtraction.

• Remember, within a group the first element is
the one subtracted from. All the other elements get
subtracted from the first.

So we’re going to have to group things carefully to
get the effect we want: “two” subtracted from the
N. To be safe, let’s make a group that includes only
the letter and the “two.” It doesn’t matter if this
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group is inside another group, or at some other
level. The subtraction will apply only within the
group we create. Just for practice, let’s make the
group at the level of the letters in “ONE.”

7. We’ll need to see the contents of the ONE
string, so in the Score window click on the triangle
to the left of the ONE string. Now you should see
ONE’s elements (the individual letters).

8. Select the N; then select Group from the Edit
menu. Now there’s a group that has just the N in it.

Now let’s add the “two” to the new group:

9. In the Score window select the “two” and drag it
(by its gray bar) into the group. The purple cursor
should be directly below the N’s drag bar. Your
Score should look something like this:

10. Now all you have to do is change the perf mode
of the group holding the N and the “two:” click and
hold on the group’s perf icon, and select Perfs
Difference in the popup menu.

Now you can render. Be forewarned though, perfo-
rations do increase rendering time, so just use the
Reasonable rendering setting for this session, unless
you can afford to use Excellent ‘n’ Slow.

• Don’t forget, you’re not restricted to using letters
for doing perforations. You can use any character at
all — characters in the PixarPerfs font (see below),
characters in a dingbats font (e.g., Zapf Wingdings),
characters created using Corel symbols, or shapes in
imported Adobe Illustrator files. (For more on
importing Illustrator files see the section on
“Importing Illustrator files” in the Getting Text In
chapter.) If one of the font creation packages are up
your alley, you can make shapes in them, too.
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The PixarPerfs font

We used Fontographer to build a font with special
characters just for perforating objects (though you
might also use some of them to add interest to your
image). You really should try some of these, now
that you know how to do perforations — they’re
much more fun than letters!

You should have installed this font in your system at
the time you installed Typestry. The character set
appears at the end of this manual. Alternatively, you
can use the Character Map program in the
Accessories group from the Program Manager. desk
accessory to view all the characters. These are just a
small sample of the kinds of shapes you might want
to use to get away from your basic “image with let-
ters in it.”

Using the Grid

Use the grid to help you with aligning things in the
project window. Select Toggle Grid from the Edit
menu to turn the grid on and off. The dimensions of
the grid are set in the Preferences dialog, available
under the File menu. This is most profitably used in
conjunction with the Telephoto setting, available in
the Camera menu under Effects. This combination
provides you with an orthographic (2D) view, which
is ideal for aligning things.

Note: The grid divides up the window itself, not the
space in the window. This means that if you resize
the window, the number of grid lines doesn’t change
— the grid resizes along with the window.
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