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The tools menu provides various 
options that will help you manage your 
web site and edit documents with ease. 
You can check spelling, make image 
maps, import text, images, even an 
entire web site! You can customize 
toolbars and set the preferences of the 
Namo WebEditor within the Tools menu.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SPELLING
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Select this option to check spelling errors in the current document.

The spell checker will display the spelling errors and offer 
corrections. You can also add custom words into the dictionary, 
such as your name or the name of a city.

The spell checker also has an auto correct feature. It will perform a 
check of the spelling and display incorrectly spelled words by 
underlining them in red. You can turn this option on and off.

To set the options for Namo 
WebEditor’s spell checker, 
click on Preferences... in the 
Tools menu. Select the 
Loading Documents Tab.

When Hide Spelling Errors 
option is turned off in the 
Preferences option box 
(unchecked being off), 
spelling errors will appear as 
below, underlined in red.
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You can correct the unrecognized word in two ways, manually or by 
allowing the spell checker to suggest the corrections. You do this by 
selecting the Spelling command from the Tools menu or pressing 
<F7>. 

When you select the Spelling command from the Tools menu, or 
press <F7> on your keyboard, the Spelling Check dialog box 
appears. The spell checker will then check the document from the 
beginning for spelling errors. 

When the spell checker finds an unrecognized word, it displays the 
word in the Not In Dictionary field, and shows the possible 
corrections in the Suggestions field. The proposed correction is 
located in the Change To field. 

Not In Dictionary
Displays the unrecognized word that is to be 
corrected.

Change To Displays the correction for the unrecognized word. Here 
appears the most possible correction from the words in 
the Suggestions field. When there are no possible 
corrections, the unrecognized word is displayed in this 
field. If you disagree with the choices or know of 
another spelling, you can enter it into this field.

Suggestions Displays possible corrections for the unrecognized 
word. One or more words, sometimes none, will be 
displayed in this field. 
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Ignore This option allows you to ignore the spelling of a 
specific word. This is helpful if you are misspelling a 
word on purpose. 

Ignore All This option allows you to ignore the spelling of a 
specific word throughout the entire document. Please 
note that this does not add the word to the dictionary. 
To do that you must select Add.

Change Choose this to change the current word to the spelling 
displayed in the Change To field.

Change All Allows you to change all misspellings of this word to 
the spelling displayed in the Change To field. 

Add Select this to add the current word to the dictionary.

Suggest To manually check the spelling of a word, enter it into 
the Change To field and click the Suggest button. The 
correct spelling(s) (if any) will then be displayed in the 
Suggestions field. 

Document Top
Click this to make the spell checker restart from the 
beginning of the document. 

User Dic... Selecting this button will open the user dictionary. 
Here you may add or remove words.

User Dictionary
You can also change dictionaries by clicking the combo 
box to the right of Dictionary. This is only available if 
there are more than one user dictionaries available.
Namo WebEditor 3.0 User Manual 9-3



TOOLS
User Dictionary99
Close This will close the spell checker.

Reference If you make a mistake in changing the spelling of a word, you can 
easily undo it. Place the cursor inside the text you wish to change, 
click on the Edit menu and select Undo, you can also do this by 
pressing <Ctrl+Z>. This will revert the word to its form before it 
was corrected.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . USER DICTIONARY
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This option allows you to add new words to a user dictionary. You 
can examine or delete any of the words displayed here. The words 
displayed in the user dictionary are recognized as correct spellings 
by the spellchecker. 

When you select the User Dictionary command from the Tools menu 
or click the User Dic... button in the Spelling Check dialog box, the 
User Dictionary dialog box will then appear. 

Word This field is used to enter a new word into the 
dictionary. When a new word is entered here, the Add 
Word button is activated.

List Displays the words in the user dictionary. 

Dictionary When several user dictionaries exist, you can select 
from them here. 
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Add Word Allows you to add the word that is displayed in the 
Word field to the user dictionary. 

Remove Word Removes the selected word from the user dictionary. 

Making User Dictionary

The user dictionary is saved to the 'Lib/Speller' folder in the Namo 
directory where Namo WebEditor is installed. The filename of the 
default user dictionary is 'user.dic'.

There is no limit on the number of the words you can add to the 
user dictionary, but when you go over ten thousand, it can slow 
your system down and take up valuable space. 

To create a new user dictionary follow these steps: 

1 In the Windows Explorer, move to the Namo directory and open the 
'Lib/Speller' folder.

2 Move the cursor onto the 'User.dic' file and click on the right mouse 
button. Select Copy from this menu. 

3 Deselect the 'User.dic' file by clicking anywhere outside the file. 
Right click and chose the Paste option. 
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4 The 'Copy of User.dic' file is now created.

5 You can now change the filename to whatever you prefer, for this 
example we will use ‘User1.dic’. 
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6 Go back into Namo WebEditor and open the User Dictionary dialog 
box by selecting the User Dictionary command from the Tools 
menu. Click on the combo box and you will see the dictionary you 
created is available. You can now add or delete words from your 
newly made dictionary by clicking on it.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . AUTO CORRECT
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Choose this to modify the options in the auto correction feature. 
You can add or delete items from this list. There is a default list of 
over a thousand commonly misspelled words. 

This feature will allow you to correct your most commonly 
misspelled words. It can also be used for other useful purposes.

• You can correct words you commonly misspell.

Sample) "I cna do it." => "I can do it."
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• A hyperlink can be automatically created by entering in a specific 

word. This can be very convenient if you often link to a specific 
web site, such as Microsoft or Netscape. In the sample below 

'@Namo' will return http://www.namo.com. 

Sample) "@Namo" => "http://www.namo.com"

• To save time and effort, Namo WebEditor can automatically 

complete frequently used words or phrases. In the sample 
below, #Namo returns Namo Interactive.

Sample) "#Namo" => "Namo Interactive" 

Reference To undo an Auto Correct action, use the Undo command in the Edit 
menu or by pressing <Ctrl+Z>.

When you select the Auto Correct command on the Tools menu, the 
Auto Correct dialog box will appear as shown below. 

Add This allows you to add a new auto correction item. 
When it is clicked, the Auto Correct Edit dialog box 
appears.

Remove Allows you to remove an item from the list. 

Edit Allows you to modify the selected item in the list. 
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Enable This option will enable the auto correction feature.

Beep When this option is selected, a "Beep" sound is used to 
notify the replacement of a word by the auto 
correction feature. 

Check Box When this option is selected, the dialog box shown 
below will appear before auto correct applies any 
changes.

Add to Auto Correct When you click the Add button in the Auto Correct dialog box, the 
Auto Correct Edit dialog box will then appear as shown below.

Replace Enter the word to be changed by the auto correction. 

With Field used to enter the new word. 

Tip When this option is selected, you can enter in a 
description of the rule. This description appears in the 
Tip area in the Auto Correct Replace and Auto Correct 
dialog box.
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Apply This Rule
If this is selected, the created rule will become 
activated. 

Auto Correct Rule It is best to have your rule planned out beforehand, as it will save 
time and unneeded effort. Below are some tips to note when using 
the auto correction feature:

• You can use wildcard to help you in your correction process.

"-" can double for anything before or after a word, "*" will allow 

the auto correct feature to finish if something is typed beyond 
they key word. Do not use wildcard if you want to be specific in 

your correction. Note the examples below. 

Sample) "-atoin" will correct the following:
"gestatoin"  "gestation"

Sample) "*Ntscp*"  "Netscape"
This allows you to type information before and after 
the keyword, while still being able to utilize the auto 
correction feature. An example is "*Ntscp*4.0"  
"Netscape4.0"

• To create a hyperlink from the particular word, it must be 

preceded by the "@" symbol. Then simply enter the full URL into 

the With field.

Sample) "@Namo*" s"http://www.namo.com*"
If you enter "@Namo", the hyperlink 
"http://www.namo.com" is displayed as a hyperlink 
from the word "Namo".
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This option allows you to record a sequence of keyboard input for 
playback. This can prove to be useful if you have a selection of text 
or commands which need to be repeated.

You can only record keyboard input, actions such as mouse 
movement are not able to be recorded.

Defining Key Macro To begin recording a macro, follow the instructions below:

1 Select the Start Recording option from the Key Macro command in 
the Tools menu or by pressing <Ctrl+Shift+M>. This will start the 
recording. You will notice the REC in the bottom right of the status 
bar. 

2 Type in the key sequence you wish to record, please note that you 
cannot record the start/stop macro record command, 
<Ctrl+Shift+M>, into your macro as it will end the recording.

3 When you are done, you can select the Stop Recording option from 
the Key Macro command in the Tools menu or press 
<Ctrl+Shift+M> on your keyboard. The REC symbol then 
disappears from the status bar, showing that you are finished with 
the recording. 

Playback Recording To playback the recorded keyboard input follow the instructions 
below: 

1 Place the cursor at the location you wish the macro to play. 

2 Select the Playback Recording from the Key Macro command in the 
Tools menu or press <Ctrl+Shift+M>.

3 You can repeat the macro as often as you want.
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Caution Only one key macro can be recorded at a time. Therefore if you 
record a new macro or exit Namo WebEditor, the previous one will 
be deleted.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . IMAGE MAP
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Select this to specify a hot zone image map in the image of your 
choice. The image map is an image that includes one or more 
invisible regions called hot zones. From these hot zones, you can 
create hyperlinks. By doing this, you can move to different locations 
on one image. For example, you can link a picture of a car to the 
various parts it contains. Clicking on the tires would take you to the 
tire shop, and so on. Namo WebEditor provides rectangular, circular 
and polygon shaped hot zones. 

When you highlight the image you wish to create an image map 
from, two things will happen. First a small toolbar will appear 
allowing you to select the various hot zones. You can also select 
these shapes from the Image Map command inside the Tools sub-
menu.

Select a Hot Zone Select this to move, resize or delete the 
existing hot zone.

Draw a Rectangle Select this to create a rectangular shaped 
hot zone.
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Draw a Circle  Select this to create a circular shaped hot 
zone. 

Draw a Polygon Select this to create a polygon shaped hot 
zone. 

Make Transparent Select this to make a particular color of GIF 
image transparent.

Making Hot Zone A hot zone is an area partially selected to make a hyperlink in an 
image file. We are going to make three hot zones as shown below.

1 Click on the image you wish to create a hot zone on. 

2 Select a shape from either the Image Map menu or from the 
toolbar.

3 When the mouse arrow changes to a cross, move it to the location 
you want to create the hot zone on.

4 Click the left mouse button and drag the cursor. While doing this 
you will see the hot zone increase in size. When it reaches the size 
you want, release the mouse button. You will then be prompted to 
edit the hot zone information. The size and location of the hot zone 
can be adjusted later. 
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5 When the Create Hyperlink dialog box appears, fill in the hyperlink 
information. When you are finished, click OK. 

6 The hot zone is then displayed inside the dotted line. You may now 
resize the image and change its location.

7 Repeat the above if you wnat more hot zones. To exit from the 
image map mode, click outside the image or press <ESC>.

Reference Drawing a polygon hot zone can be rather tricky. When the polygon 
hot zone tool is selected, you will need to set the various corners 
(apexes) of the polygon. To do this, click on the image in the 
locations you wish the corners to be set. You can do this an infinite 
amount of times, so when you have the size and shape you were 
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looking for, double click and the Create Hyperlink dialog box will 
appear as before.

Modifying Hot Zone To modify or move the existing hot zones follow the instructions 
below:

1 Select the image that contains the hot zones by clicking on it.

2 Choose the Select a Hot Zone command from the Image Map menu 
or click the Select button from the Image Tools toolbar.

3 When the hot zone is displayed as a dotted line, click the hot zone 
to allow it to moved or resized.

4 Simply drag the hot zone to move it. To resize it, put the cursor 
over the corners of the hot zone. The cursor will then turn into a 
resize arrow, allowing you to resize the hot zone. 
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5 To adjust the hyperlink information, double click on the hot zone. 
The Edit Hyperlink dialog box will appear and you can then adjust 
the information.

Making Transparent To make a particular color in a GIF image transparent, follow the 
instructions below: 

1 Select the image you want to make transparent. 

2 Select the Make Transparent on the Image Map menu or click the 
Make Transparent button in the Image Tools toolbar. 

3 When the mouse pointer changes to a dropper, click on the color 
you wish to make transparent.
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4 Save the image by clicking the OK button in the Save Image As 
Transparent GIF dialog box. If you do not want to overwrite the 
original image, you change the filename. 

5 The color you selected will no longer appear in the image.

Reference If you select the Interlaced GIF option in the Save Image As 
Transparent GIF dialog box, it will be saved in interlace format. 

Interlaced files are displayed gradually in web browsers. This 
means that if your image is very large, it will start out in a low 
quality format and slowly become clearer. This will allow the visitor 
to see your image from the start, rather than leaving an empty 
space while the full image loads.
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This option allows you to change the case of letters inside in a 
selected area. 

To change the case, you must first click and drag the mouse over 
the text you want to change, this will highlight the text. 

When you select the Change Case command on the Tools menu, the 
Change Case dialog box will appears. After selecting the options as 
you want, click the OK.

Capitalize First Letter of Sentence
Namo WebEditor  Namo webeditor

Change All Letters to Lowercase
Namo WebEditor  namo webeditor

Capitalize All Letters Namo WebEditor  NAMO WEBEDITOR

Capitalize First Letter of Words
Namo WebEditor  Namo Webeditor

Toggle Case Namo WebEditor  nAMO wEBeDITOR
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(Only available for double byte character version)

Select this option to make illegible 2 byte characters readable.

If a document has been incorrectly encoded, 2 byte characters that 
are entered in the 2 byte character Windows system are illegible in 
the system of different language. If you can not read an e-mail 
because it is full of odd signs, copy it by pressing the short cut key 
<Ctrl+A> on your keyboard. Then select the Symbol to DBCS 
command on the Tools menu. Then you can read the e-mail.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . IMPORT FROM BROWSER
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This option will allow you to import a web site from a specific web 
browser to the Namo WebEditor. This is the same as opening a URL 
from the Open command in the File menu. 

If you cannot view the imported site properly, chances are it has 
been incorrectly cached. You can fix this by clicking on Refresh or 
Reload in your browser window. After this is done, open the URL 
again.

If you select the Save command from the File menu after editing 
the contents of imported web site, it has the same effect as 
publishing it. You may be required to enter in login name or 
password, however it is rare this will be needed to simply download 
a site.

If all you have is the URL of a web site, you cannot save it back 
onto the server. If you try to save it, the following message will be 
displayed. If this happens and the site you are trying to publish is 
one of yours, enter in the FTP data as shown in the picture. You can 
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save the imported web site on your hard disk by selecting the Save 
As command from the File menu.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . IMPORT FROM WEB
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This option will import an entire web site from the Internet. It 
allows you to view and edit it while you are offline after you 
download the web site from Internet. If an entire project becomes 
deleted or corrupted on your hard drive, this tool comes in handy 
by allowing you to download the entire site back onto your hard 
drive. However, a huge web site import from web may be 
impossible.

When you select the Import from Web command from the Tools 
menu, the Download From Web dialog box will then appear. The first 
time you use this function, the Import Property dialog box will 
appear. You must then enter the information on the web site you 
want to import.

Basic Specify the information on the web 
site to import.
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URL Enter the URL of the web site to import. 

Project to Store Select the project name in which the 
imported web site will be saved. It can only 
be saved into an existing project.

Directory to Store Specify the folder where the imported web 
site is to be saved.

Download Pictures Select this if you wish to download the 
images along with the web site.

Download Pictures from Other Site
This option allows you to import pictures 
and files that are in a location outside the 
web site. An example of this would be a 
Geocities page using an image from a 
Microsoft page.

Download Files Under the Specified Location
If selected, only files in a specific location 
will be downloaded.

Level When you import a site that contains links, 
these need to be downloaded as well. A link 
may have a link to a link to a link. They can 
go very deep into a site, therefore you must 
specify a level. The default is 10. The larger 
the level limit, the slower the download of 
the site.

Option This selection gives you the option of using 
a cached version of the files from the web 
site to save time. If you chose the slower 
setting, you will download straight from the 
internet site, getting the most recent 
version and ignoring any previously cached 
copies.
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Authentication There may be times where you will need to enter a login and 
password to a site. You can set this up within the Authentication tab 
under Import Property dialog box.

User ID Enter the web site User ID (this is your login name).

Password Enter the web site User Password.

Verify Re-enter the password to verify there were no typos.

Advanced Select detailed options on importing files from the web site here.
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Limit These options allow you to put a limit on 
the number of files to import.

Do Not Change Links Select this to simply import the hyperlinks. 
This will not import the pages the hyperlinks 
are attached to. Do not select this option if 
you plan on editing the document offline. 

File Type to Include or Exclude
This is used to choose what file types to 
download from the web site. 

Choose Download All to import all the files from the web site. This is 
the default option. 

You can import files of a particular type by specifying them in the 
Extension field. Select either the Download These Files or Except 
These Files option and click on the Add button. You can specify 
multiple file formats at a time by repeating this process. Below is 
the sample of specifying the files that have 'html', 'gif', and 'jpg' 
extension.

You can also chose files that you do not want to import. This is 
done simply by selecting the Except These Files option, entering the 
extension name of the format you don't want to import into the 
Extension field, and clicking on the Add button.
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Download From Web When you click the Download button after selecting the URL and 
specifying the various information, Namo WebEditor will connect to 
the web site and begin downloading these files. 

URL window Shows the URL list of the web site to import.

Status window Monitors the download status.

Download When this is clicked, Namo WebEditor will connect 
to the internet site specified in the URL window. 

Stop Click this to stop Namo WebEditor from 
downloading any further files. 

Close This closes the Download from The Web dialog box.

New Entry Click this to add another site to the URL list for 
downloading.

Modify Entry This will modify the properties of the URL to be 
downloaded.

Remove Removes the URL from the URL list. 

When the site is downloaded, the dialog box below will appear.
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This is used to manage the web site that you created using the 
project feature.

When the Site Management command in the Tools menu is clicked, 
a menu containing 5 items will appear as shown below.

Incremental Verify Link

Checks the hyperlinks of the entire project. The results are then 
displayed in the Link Check tab in the Result Window.

Broken Indicates that the target of the hyperlink is 
missing or the URL is incorrect.

Alone Indicates a page that stands alone, with no linkage 
to it. This is a page that web surfers will not see.

External Link Indicates that the hyperlink is external and has not 
been checked. 

Reference Namo WebEditor 3 no longer supports the external node check 
option as it has proven to be too time consuming. If you need to 
check an external URL, use the external utility. 

Followings are the result of the link verification. The files displayed 
in red or yellow have errors that need to be fixed.
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Verify Link This option will check all the hyperlinks in an entire project and 
display the results. They are displayed in the Link Check tab in the 
Result Window.

Change Characterset According to the HTML protocol 3.2 and 4.0, a character set that 
corresponds to the language used in the HTML document must be 
specified. Netscape Navigator and Internet Explorer can display 
HTML documents that do not have a specified character set but not 
everyone uses Internet Explorer or Netscape Navigator and the 
Windows OS. Therefore it is best to specify the character set as 
recommended by the W3C. 

When you select the Change Characterset 
on the Site Management command on the 
Tools menu, then the Change Character Set 
dialog box appears. Specify the range of 
change and type of the character set, then 
click the Change button.

Selected Files Select to change the character set of selected files. 
The selected files indicate the ones you select in the 
Project Window by clicking them. You can select and 
change several files at a time.
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All Files in Project Select to change the character set of all the 
files in the project at a time. 

Characterset Type Specify the type of character set.

Caution Be cautious, when there are documents written in different 
languages in a project. If you use the English and 2 byte character 
in the documents, you must specify the respective character sets. 
That is, to the documents written in English, specify the 
US/Western European. To the documents written in 2 byte 
character, specify the respective characterset. For example, to 
document written in Korean, specify the Korean (EUC-KR). Thus to 
the project in which two or more languages are used, do not 
changing with selecting All Files in Project option.

The simplest way to take care of specifying the characterset is not 
to specify the characterset to the files at all. To do this, select the 
All Files in Project option in the Change Characterset dialog box and 
specify the type of characterset as User Defined then click the 
Change button. However, in this case, you may have problems, in 
the Netscape Navigator, in reading a document written in 2 byte 
character.

Make Site Map When you select the Make Site Map command from the Site 
Management option in the Tools menu, Namo WebEditor will verify 
all links in the current file. It will then create a sitemap and save it 
in a file named "sitemap.html". This file is a map of your site, 
showing all the pages that are linked to the project. 

When the site map file is created, a dialog box will appear as shown 
below. Click the OK button and make sure you link the site map to 
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your project or it will not be seen! The site map file is located in the 
same directory as your index file.

Publish Information Publish Information contains information for the web server on 
which your files are to be published. 

You can register your site host on this list to directly publish files to 
the internet site without ever having to use an FTP client. If you do 
not have this information, consult your web server administrator. 

For more information on registering and modifying the publish 
information, see Manage Site Information(2-23).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SOURCE CONTROL
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Usually multiple people work on a web site simultaneously, 
especially if the project is quite large. To allow for this, Namo 
WebEditor 3.0 supports Microsoft SourceSafe. However, to use the 
SourceSafe function in Namo WebEditor, the SourceSafe server 
software must be installed on the network server, and the 
SourceSafe client software installed on the user's computer. 

When files are stored on a SourceSafe enabled server, a protection 
method is put into effect. Whenever a user copies a file from the 
server to their computer via the Get Latest Version command and 
then works on that file, other users are notified. This method is 
called "check out" and is similar to checking out a book from the 
library. To check out, select the Check out from the Source Control 
command in the Tools menu. After finishing the work, save the file 
and copy it back to the server by using the "check in" option. To 
check in, select Check In from the Source Control command in the 
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Tools menu. By doing this, multiple people working on the same 
files will always get the latest versions and are notified of any 
changes made. 

Namo WebEditor 3.0 supports and can execute many important 
features of SourceSafe. By doing this, Namo WebEditor users could 
use the SourceSafe functions without having to actually launch 
SourceSafe. Namo WebEditor's SourceSafe supporting feature is 
available only while you are working on a project.

The SourceSafe options are listed in the Source Control sub-menu. 
If you select the Source Control command from the Tools menu, you 
will see the menus shown below.

SourceSafe Project Setting
Select this to save the original web site 
documents on the SourceSafe server. When 
you select this option, the SourceSafe 
project is created on the server and the web 
site documents are transferred to the 
SourceSafe project.

SourceSafe Status Update
If you select this option after making 
changes to a file, the latest change will be 
shown. Use it on the project file in Namo 
WebEditor. 

Get Latest Version Select this to copy files from the SourceSafe 
server onto your computer. Until you 'check 
out' the copied files, the read only attribute 
will remain on the files. Once you 'check 
out', you will be able to save the files.
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Check Out If you 'check out', the read only attribute of 
the files you copied is removed. Your ID will 
then be shown on the SourceSafe server to 
show you have checked out the file. 'check 
out' files are inaccessible to other users, 
thereby making it impossible for more than 
one person to work on a file at a time.

Check Out is the same as the Get Latest 
Version command by copying the files from 
the server. The only difference is whether 
the read only attributes are remain or not.

Check In When someone 'check in' after making 
changes on a file, it is copied back onto the 
SourceSafe server with the read only 
attribute applied. By doing this, the latest 
version is saved on the SourceSafe server. 

Add to Source Control Choose this to add new files to the 
SourceSafe server.

Remove from Source Control
Choose this to delete the files that are no 
longer needed on the SourceSafe server. 

SourceSafe Project Setting

To use the SourceSafe feature in Namo WebEditor, you must follow 
the instructions below. After you have, you can go onto step 1.

Make sure that:

• The web site document files you are going to use are saved 

(checked in) on the SourceSafe server.

• The local directory, in which you will be working on the files 

copied from the SourceSafe server, is specified on your 

computer.
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• The web site document files are saved in the working directory. 

Do this by using the Get Latest Version command.

1 Choose Open Project from the File menu. Make sure you select the 
project in the local directory that is specified in Set Working 
Directory.

2 Specify the files in the project as SourceSafe project files by 
selecting the SourceSafe Project Setting from the Source Control 
command in the Tools menu. 

3 Right click on the project name in the Project window and choose 
Get Latest Version. This will copy the latest files from the 
SourceSafe server.

Reference After you have specified a project as a SourceSafe project, this 
information is saved in a project file (*.wej). This makes it so that 
whenever you open the project in Namo WebEditor, you will 
automatically be connected to the SourceSafe server. 

The options on the Source Control command are available only 
when the SourceSafe client software is installed on the user's 
computer. The SourceSafe Project Setting command is available 
only when the SourceSafe server software is on the network server. 

Your ID must also be registered in the SourceSafe server software. 
If it is not, consult your network server administrator. 

Working on SourceSafe Projects

To edit using the SourceSafe feature, do the following: 

1 Choose Open Project from the File menu. If the project is not open, 
you cannot use the SourceSafe features.

2 To edit the files, use the 'check out' option to remove the read only 
attribute.

3 When you are done editing, save the file and use the 'check in' 
option.
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Reference If you right click the files in the Project window, a menu will appear 
containing various SourceSafe commands. Using this can save you 
time and effort.
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This feature allows you to launch the external programs listed on 
the External Program menu. NotePad and PaintBrush are available 
by default. You can register up to 2 more external programs. 

If you have already specified the external programs, you can select 
the User Defined (1 or 2) from the External Programs command in 
the Tools menu. This will launch the selected program. If there are 
no programs specified, the External Program tab will appear to allow 
you to add an external program. 

You must specify the executable file of the external programs that 
are to be registered as User Defined 1 and 2 in the User Defined 
fields. If you do not know the exact path, click the Browse button 
and you can browse your hard disk for the file. The sample above is 
the result of specifying the "Namo GIF Animator", a program 
offered with Namo WebEditor 3.0.
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This option allows you hide, display, and customize Namo 
WebEditor’s toolbars.

When you select the Customize 
Toolbar command from the Tools 
menu, the Customize dialog box 
will then appear as shown below.
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Toolbars The list of toolbars are shown here. To make a 
toolbar appear, place a check mark by it. To hide 
it, remove the check. 

Show Tooltips When this option is checked, it will make tips 
appear when the mouse points to a toolbar button. 

New Select this to create a new toolbar.

Reset This option will reset the currently selected toolbar 
to its default setting. 

Customizing Toolbars

Customizing your toolbars is simple to do! Simply open the 
Customize dialog box from the Tools menu and click on the 
Commands tab. From here you will see a list of categories to the 
left of the window. Select the category you want and the buttons 
that relate to it will appear on the right. Simply click and drag the 
button you want onto the toolbar of your choice. If you want to 
remove a button, simply drag it off of the toolbar area. 

For example, if you rarely use the Change Font button, you can 
drag it to the side of the Help menu. If you never use the Underline 
button, you can get rid of it by dragging it out of the screen. 
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Creating New Toolbar

Using the customize toolbar feature, you can easily create a new 
toolbar.

1 When you click the New button in the Customize dialog box, the 
New Toolbar dialog box will appear. 

2 Enter the name of the new toolbar and click OK.

Adding Toolbar Buttons

To add buttons on the toolbar follow the instructions below:

1 After selecting the Commands tab, select the categories that contain 
the buttons you wish to add to your toolbar. After this is done, you 
can simply select the button(s) you wish to insert and drag them 
onto the new toolbar.

2 By dragging the buttons you want onto the toolbar, your very own 
customized toolbar is created. See, we told you it was easy!

3 Click the OK button in the Customize dialog box to finish. 
Namo WebEditor 3.0 User Manual 9-37



TOOLS
Preferences99
Deleting Toolbars The default toolbars (Menu, Format, Etc.) cannot be deleted, they 
can only be set to their default status. You can, however, delete any 
toolbars you have created. To do this, select the toolbar from the 
Toolbars tab and click the Delete button.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PREFERENCES
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This option allows you to set the general preferences for Namo 
WebEditor. 

When you select the Preferences command on the Tools menu, the 
Program Preferences dialog box will then appear.

Document Default Allows you to specify default values for new documents. Note that 
all changes made in this menu are applied to all documents created 
after this setting is applied. 
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Colors
Specify the color of the background, font and links of new 
documents.

Background Allows you to specify the background color of 
new documents. The default value is white.

Text Allows you to specify the default font color in 
new documents. The default value is black. 

Hyperlink Allows you to specify the color of links that have 
not been visited. The default value is blue.

Visited Hyperlink Allows you to specify the color of links that 
have been visited. The default value is purple.

Active Hyperlink Allows you to specify the color of links that are 
currently being visited. The default value is red. 

Reference If you select Custom Colors, you will be able to choose from the 
entire color scale, rather than being limited to the 16 default colors. 

The Color dialog box only appears when the system color depth is 
set to at least 256 colors. There are a wide variety of colors to 
choose from here, we recommend you stick with the browser safe 
colors. You can also check the HTML color value here. For more 
information, see Color(6-3).
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Encoding and Fonts
Here you can specify the characterset, default font size, and type in 
new documents.

Charset Specify the encoding type of new documents. The 
MIME type is decided by the type of characterset. The 
default value is User Defined.

Proportional Specify the font type and size that are to be used in 
Namo WebEditor. The default value is Times New 
Roman, 12 pt.

Fixed Specify the fixed font type and size to be used in 
Namo WebEditor. The default value is Courier New,
10 pt.

Author Specify the name of the person who will be authoring 
the web sites. The name specified here will be 
automatically entered as the author name in all new 
documents. This can also be changed from the 
Information tab in the Document Properties dialog box 
that appears when you select the Document command 
from the Format menu.

Reference The font you specified in the Document Default tab is the font in the 
edit window of the Namo WebEditor. Therefore if you specify the 
font size as 14, it will only be seen this way in Namo WebEditor. 
When it is loaded in a web browser like the Internet Explorer or 
Netscape Navigator, it will be displayed as the font specified there.

Loading Documents Displays options pertaining to the editing of documents.
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Settings
Specify the general editing options.

Lock Insert Key When this is selected, you will no longer be 
able to toggle the <Insert> key on or off. It 
will stay in the mode it was in at the time 
this option was activated. 

Load Last Editing Documents
If you launch Namo WebEditor after 
selecting this option, the last document you 
edited will automatically open. This only 
works with documents that were open at 
the time you closed Namo WebEditor. If you 
finished editing by actually closing a 
document with the Close command it will 
not be automatically opened. 

Automatic URL Conversion
When you select this option, links will be 
automatically created each time a URL or e-
mail address is entered. For example if you 
enter the text "www.namo.com", Namo 
WebEditor will create a link to the Namo 
web site. You can cancel this action by 
pressing <Ctrl+Z> or selecting Undo.
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Loading Documents
Provides options for documents at the time of loading.

Always show a dialog box asking whether remove comments
With this option selected, a dialog box will 
appear each time you open a document 
containing Comments. It will ask or not 
they should be deleted. 

Remove Comments If this option is selected, all the Comments 
in the document will be deleted at the time 
of loading. 

Preserve Comments When you select this option, all Comments 
will be preserved. Comments appear in 
Namo WebEditor via a formatting mark, and 
cannot be seen in web browsers.

Tab Width This specifies the amount of space that 
appears when the <Tab> key is pressed. 
The default value is 8.

Caution When you open the document that contains commented scripting 
such as JavaScript while the Remove Comments option is selected, 
they will be deleted along with any other comment fields. Take heed 
when you choose to delete all comments.

Reference If Namo Web Editor is specified as the 'Generator' inside a Meta Tag, 
the Comments in the document will not be deleted even if the 
option to delete them is selected.
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Speller
This allows you to specify the options for the automatic spelling 
checker. 

Automatic Spelling Check
When this option is selected, your spelling will be 
corrected automatically as you type. 

Hide Spelling Errors
When this option is activated (checked), spelling errors 
will appear with a red line underneath them. This 
option is available only when the Automatic Spelling 
Check option is activated.

Save Documents
Specifies the options when saving documents. 

Make Backup File When this option is selected, Namo 
WebEditor will save a backup copy of the file 
you are working on. This file will be the 
same other than its extension, which Namo 
WebEditor changes to '.bak'. 

Auto Save If selected, the file you are working on will 
automatically be saved in the specified 
interval.

Save Interval This will allow you to specify how often the 
file is to be auto saved. It is only operational 
when Auto Save is activated. The unit is in 
minutes, therefore placing '10' into this field 
will save the file you are working on every 
10 minutes.

HTML Source Width Specify the width of window where the 
HTML source is displayed. The unit here is 
one letter.
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External Program Specify the external programs which will be set as the User Defined 
1 and 2 from the External Programs command in the Tools menu. 
The web browsers are also specified here. 

You can specify the path and type of web browser to preview your 
web document in. Internet Explorer and Netscape Navigator are 
suggested by default. 

Namo WebEditor is a WYSIWYG editor, but there are nuances in 
HTML documents that can cause variations between web browsers. 
Because of this, you need the ability to preview how a document 
will look in various web browsers. You can easily do this in Namo 
WebEditor once you have specified the browser path by pressing 
<F12> or <F11> on your keyboard. 

Editor
Specify the external software to be launched when you select the 
User Defined (1 or 2) from the External Programs command in the 
Tools menu. NotePad and PaintBrush are registered here by default.

Web Browser
You can specify up to two web browsers here.

Browser 1, 2 Specify the web browsers you want to use here. If you 
are using a browser other than Internet Explorer and 
Netscape Navigator, specify (Other) by pressing the 
pull-down menu button.
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Program Location
Enter the path and filename of the web browser. If you 
do not know the exact path, click the Browse button 
and search where the program file locates.

DDE Service Specify the DDE (Dynamic Data Exchange) service 
name of the first web browser. If you specify Internet 
Explorer or Netscape Navigator this will be 
automatically entered. 

Internet This allows you to specify how you connect to the internet to 
transfer files or import sites. 

HTTP
Specify whether Namo WebEditor should use HTTP (Hyper Text 
Transfer Protocol) or not.

Use FTP When Saving Remote Files
This will allow you to save a file onto the web 
server via FTP. This is useful if you plan on creating 
directories. If you do not have this selected, you 
can only save the files without creating directories.
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Show HTTP Transfer Status
If this is selected, Namo WebEditor will display the 
transfer progress when you are publishing a file. 

Off-Line Mode Select this to edit in offline mode. 

DLL
Specify the options on the DLL (Dynamic Link Library) file used to 
import or transfer files.

Use NamoNet.DLL If this is selected, the 'NamoNet.DLL' file will 
be used when importing or transferring 
documents.

Use WinInet.DLL If this is selected, the 'WinInet.DLL' file 
offered with Internet Explorer will be used 
when importing or transferring documents.

Reference It is recommended that you use the 'WinInet.DLL' file. By selecting 
this, you do not have to specify complex proxy settings or cache 
information. If the 'WinInet.DLL' file is not installed on you system, 
you can install it from the Namo WebEditor CD-ROM. The path is as 
follows, where X is the drive letter of your CD drive. 
'x:\Comm\WinINet\Axdist.exe'.

Caution If the web server's operating system uses a 2 byte language, file 
names may be not recognized when you use the 'WinInet.DLL' file. 
If this happens, switch to the 'NamoNet.DLL' file. 
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Proxies
A proxy is a type of cache server installed by your ISP to offer 
faster connections to the Internet. The default value is not to use a 
proxy. If you decide to use a proxy, enter the proxy values in the 
HTTP and FTP field. 

HTTP Enter the URL and port number of the proxy server 
needed to use HTTP.

FTP Enter the URL and port number of the proxy server 
needed to use FTP.

Exceptions Enter the URL of web site to which you want to 
connect without using the proxy server. To enter 
multiple web sites, you can distinguish them by using 
a colon(:) or semi-colon(;). You can also use the 
wildcard(*) symbol to specify multiple servers. For 
example, when you enter "*.namo.com", all the 
servers included in the 'namo.com' domain will not use 
the proxy server.

Cache Policy
The cache is the place for the temporary saving of internet files to 
the hard disk. It allows for quick access to them. The default value 
is to utilize the cache.

Directory Specifies the directory in which the cache is to be 
saved. 

Maximum size Specify the maximum amount of disk space to be 
used in saving the cache.

Clear Cache This option will clear the cache of all files.
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Project Specifies various project options.

Check When Correct Links If this is selected, a dialog box will 
appear every time you repair a link 
in a project file.

Check When Download Files If this is selected, a dialog box will 
appear every time you import a 
file.

Check When Remove Files If this is selected, a dialog box will 
appear before you can delete files.

Check When Overwrite Files If this is selected, a dialog box will 
appear before you can overwrite 
files.
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