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Building A Web Site 1

Namo WebEditor offers an easy way to build your web site. With 
Namo WebEditor you don't have to know complex and difficult 
HTML syntax. This is something that had once prevented ordinary 
users from creating their own web site. In this chapter you will see 
just how easy it is to build and publish your web site using Namo 
WebEditor.

Getting Started with the Namo WebEditor 3.0
This is a guide for people who are using the Namo WebEditor for 
the first time. You will get some basic knowledge about using Namo 
WebEditor. Once you finish this guide, you will be able to easily 
enter and edit text and images.

Building a Web Site Quickly
This will show you how to create your web site in just a few 
minutes using the template wizard function.

Publishing Your Web Site
Once your web site is created, you are ready to publish it. We have 
made drastic improvements in the publishing feature since our 
previous release.

Handling Internet Information
Namo WebEditor 3.0 is equipped with new features that make it 
one of the most indispensable HTML editing and publishing 
programs on the market.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . GETTING STARTED

Before you arrive at your final HTML document, you must have 
some knowledge on how to use Namo WebEditor.

Launching WebEditor

Launch the Namo WebEditor from the desktop icon. If you did not 
make the desktop icon, please select Start-Program-Namo 
WebEditor3-Namo WebEditor3, or the location specified by you. The 
Namo WebEditor window will then open.

The Namo WebEditor screen consists of a title bar, toolbars, edit 
window, scroll bar, status bar and buttons.

When you launch Namo WebEditor, a blank document will appear as 
shown below.

Entering Text After Namo WebEditor is launched, the cursor is the only item that 
will blink in the white space. This space is called the edit window, 
this is where you will enter text. 

Mouse pointer. Its shape 
varies with your editing 
actions. You can enter text 
when it is in I shape. 

Cursor. The blinking vertical line. 
Indicates the position where the text 
is entered.
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As you enter text you will notice it becoming underlined in red. The 
red underline indicates that the auto spelling check function of the 
Namo WebEditor is active. Once a word is completed, the red line 
will disappear if the spelling is correct. If the spelling is not correct, 
or the word happens to be a pronoun not currently in the 
dictionary, the red line will remain. For further information on the 
spell check feature, see Spelling(9-1).

If you press the <Enter> key while entering text, a new paragraph 
will begin and the cursor position moves back to the left margin. 
Where a paragraph ends, a Paragraph Mark appears. You can make 
the mark appear or disappear by clicking the Show/Hide Paragraph 
Marks button on Standard toolbar.

The difference between an HTML document and a text document is 
that a blank line is inserted between paragraphs in HTML. To begin 
a new line without starting a new paragraph, press <Shift+Enter>. 
This new line begins without a blank line separating it.

When you enter the e-
mail address, the 
hyperlink is created from 
it automatically. 

Where a new paragraph begins, 
the Paragraph Mark appears 
and the new line is inserted.

Where you change the line by 
pressing the <Shift+Enter>, the 
Line Break appears. A new line 
is not inserted. If you continue entering 

the text to the end of 
one line, the new line 
begins automatically. It 
doesn't start a new 
paragraph. 

Standard toolbar
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Editing Text In the early days of HTML, anyone who edited the HTML document 
had to remember and enter all the complex tags. But with Namo 
WebEditor you no longer have to do this!

For example, to adjust the shape of characters and paragraphs, just 
use the Format menu or Format toolbar. For more information on 
the Format menu, see Format(6-1).

By using Namo WebEditor, beginners could enter text or change the 
font type and size as easily as in a word processor. Where you show 
your work is really the only main difference between using Namo 
WebEditor and a word processor. With Namo you display the HTML 
document on the Internet, or send it as an e-mail. Whereas with a 
word processor, you print it on paper. Note that you can also print 
an HTML on paper.

To change a paragraph to a Heading, place the cursor position on 
the paragraph and select the paragraph type you want from the 
Change Paragraph Style sub menu on the Format toolbar. The shape 
of the characters and paragraph will then change as your selection. 
If you don't like how it looks, you can easily try another type.

The Format toolbar contains tools to control character and paragraph appearance.
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With the cursor position on a paragraph, click the Align Center button on the Format
toolbar. The paragraph will then be centered on the screen.

To display text in yellow, select the text and specify yellow as the background from
the drop down menu. To select the text, drag the mouse over the text or click the
beginning of the text and then click the end of the text while holding <Shift> key.
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Inserting Image Inserting images into the HTML document is also very easy. You can 
select from over 3,400 clip art images provided by Namo WebEditor.

Place the cursor position where you want to insert an image, then 
click the Insert Clip Art button on the Toolbar.

In the Clip Art window, select the image type in the left window, 
then select the image you want in the right widow. Then click the 
Insert button.

The image is inserted at the current cursor position. You can then 
modify the size of the image. 
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Inserting Background Image

This allows you to insert background colors and images. When you 
select the Document Properties command from the Format menu, 
the Document Properties dialog box will appear. Click on the Clip 
Art... button from the dialog box to specify the background image.

In the Clip Art window, select the image you want from the Texture 
sub folder in the Background folder. Then click the Insert button. 
The image you specify will appear as the background of the 
document. For more information on the background image, see 
Document Properties(6-16).
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Viewing HTML Code At the bottom of the edit window are the Edit, HTML and Preview 
tabs. Until now the edit window has been the only one visible on 
the screen, because the Edit tab was selected. 

When you click the HTML tab or press the <F6> key, the HTML 
window will open. You can now see HTML tags along with the text 
you entered. Once you see these HTML tags, you will appreciate 
how easy it is to use Namo WebEditor! 

The text you entered is displayed in black, while the HTML syntax is 
displayed in purple (tag) or red (attribute). The words displayed in 
blue are the attribute values. 

If you have no knowledge of HTML, you should not adjust or delete 
these tags. This could cause your document to show improperly in 
the browser. To return to the edit window, press the <F6> key or 
click on the Edit tab.
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Preview in Web Browser

If you click the Preview tab, you can then see how the document 
will look in Internet Explorer. Internet Explorer 4.0 or higher is 
required for this function. 

When you are using Netscape, press the <F12> key on your 
keyboard. Netscape will start and will display your document.
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Saving Documents You can save the document by: selecting the Save command from 
the File menu, pressing <Ctrl+S>, or by clicking the Save button on 
Standard toolbar. Since this is the first time that you save the 
document, the Save As dialog box appears. Find the folder where 
you want to save the document, enter the file name, and click the 
Save button.

If you used images in your document, the dialog box will then 
appear asking whether Namo WebEditor should save the image files 
to a path inside the directory of your HTML file. When there is no 
particular reason not to save them, click the Yes button. You can, 
however, specify the folder where you would like them saved. If this 
folder does not exist, a dialog box will appear asking whether Namo 
WebEditor should create it. Click the Yes button in the dialog box.

For more information on saving a document, see Save(2-16).
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Closing Document After you are finished editing a document, you should close it. To do 
this, select the Close command from the File menu or press 
<Ctrl+F4> on your keyboard. You can also do this by selecting 
Close on the menu that appears when you right click on the current 
document tab in the edit window.

If you close the document after making changes to it, a dialog box 
will appear asking “Save changes to filename.htm?”. To save it, 
click the Yes button.

Click the Cancel button, if you want to cancel this dialog box and 
return to your document.

Exiting WebEditor If you are done with all editing work and want to close Namo 
WebEditor itself, select the Exit command from the File menu. You 
can also exit by pressing <Alt+F4> on your keyboard. When there 
are documents that have been changed but have not yet been 
saved, a dialog box asking whether Namo WebEditor should save 
the documents or not will appear. To save, click the Yes button or if 
you choose not to save, click the No button.

If you changed the 
contents this sign 
appears.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . BUILDING A WEB SITE QUICKLY

Using the Template Wizard feature in the Namo WebEditor is a 
quick and easy way for you to build an entire web site. With the 
Template Wizard you will use a model, called a theme, as the base 
of your web site; thereby giving you consistency to its structure. It 
is up to you to fill in the substance of the site once the template has 
been created.

Template Wizard When you select the New Project command from the File menu, the 
Create New Project dialog box will appear. A document makes up an 
element of your web site whereas a project manages multiple 
documents as an integrated part of your site. This will allow 
convenience and speed when editing and maintaining your site.

Select the Template Wizard from within the Create New Project 
dialog box and click the Next button. You can then specify the folder 
for the project using the Browse button.

When a folder doesn't exist as you specified, a dialog box asking 
whether Namo WebEditor should create the folder or not will 
appear. To create the folder, click the Yes button, or click No and 
select a pre-existing folder.
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With the Select Theme dialog box open, you can view the themes in 
the Preview window by clicking the theme name. Namo WebEditor 
has 71 themes for you to choose from. To get a more realistic view, 
click the Actual View button. 

When you click the Actual View button, the Theme Gallery dialog box 
appears. In this dialog box, you will have a larger view of the 
selected theme. You can also arrange the buttons in the theme 
horizontally, rather than vertically, by selecting the Horizontal 
option. In the preview box you can also see the rollover effect that 
pertains to the images when they are pointed with the mouse. After 
selecting the theme you want, click the Apply button.
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When you click the Apply button in the Theme Gallery dialog box, 
then the Select Theme dialog box appears. If the selected theme 
appears in the Preview window, click the Next button.

You now are given two options; Personal and Company. These will 
give you a general topic layout for your site. Decide which one suits 
your need and click the Next button. If you select the Horizontal 
Button option in the Select Template dialog box, the buttons will be 
arranged horizontally.

The list of pages to be included in the selected template will be 
shown in the Select Pages dialog box. Click the Next button after 
selecting, or deselecting the pages you don’t want to be included.
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Enter the web site name (note this name will be displayed on your 
banner. It is for your personal use only, not as a filename) and click 
the Finish button.

The web site will be created, saved and the first page of your web 
site is displayed in the edit window.

Congratulations! Now you have your own web site waiting to be 
filled up with information.
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At the left is the Project Window. It allows you to easily manage 
your web site.

Editing a Theme Object

Of the images that make up the theme such as the Banner, Button, 
Bullet, Horizontal Ruler, Cool, Hot and New, you can enter any text 
you want, without using a graphic program!

Select the banner on the top by clicking in it, then right click or 
select the Theme Object... command from the Insert menu. The 
Theme Object Property dialog box then appears. The dialog box will 
also appear when you double click the banner in the edit window.
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You can edit the text and specify the new font and size in the 
Theme Object Property dialog box.

In your HTML document you should not use strange or uncommon 
fonts. When the font you specify is not installed in the browsers 
computer, the document will be displayed in the first font available 
on their system. However, the text that is entered on the Banners 
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and Buttons are converted onto the image, allowing you can specify 
any font you want.

The Banner then appears as specified. 

When you make 
changes to the project 
document, a '*' mark 
appears to the right of 
the file in the Project 
Window. 
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Changing Image Let's now change the image on the first page of the sample web 
site. When you double click on the image in the first page, the 
Image Properties dialog box appears. To change this image to one 
from your hard disk, click the Browse button and search for another 
image (.GIF or .JPG) file. Then the Open dialog box will appear.

We are going to change the existing ‘Personal Homepage’ image to 
a flower. You can choose whatever image file you have instead of a 
flower. Move to the folder where the flower image file locates by 
pressing the drop down menu button. Select the flower image and 
click the Open button.

If you want to insert an image from the web, enter the exact URL, 
including the filename, into the Location(URL) field. For example, 
http://www.namo.com/image/flower.gif.
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The selected image now appears, replacing the previous image.

After saving the document, you can preview it in the web browser 
by pressing the preview button in Standard toolbar.
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To publish your web site on a web server you must first have an 
account setup on it with login, password, and folder information for 
your files. Any host that allows you to upload your web site via FTP 
will be acceptable.

Registering Publish Information

When you select Publish Information from the Site Management 
command in the Tools menu, the Site Information dialog box will 
then appear. Commonly used site hosts are registered here by 
default.

If your host is on the list, it is easy to register the information. To 
do this, select your host and then click the Modify button.

Because all the information needed is entered by default, simply 
complete the user ID and password field.
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After entering the user ID and password, modify the user ID in the 
Location field, then click OK.

Close the Site Information dialog box by clicking the Close button.

When you are publishing on your company's web server, you will 
need to consult the server administrator. After getting the 
information you need, click the Add button in the Site Information to 
enter the Site Information. See Manage Site Information(2-23).
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Checking Hyperlinks Before you publish your site, you will need to check everything on 
your web site works. You can do this by previewing your site in a 
web browser. Sometimes, if you are making updates to a very large 
web site you can not view the entire site easily.

When you select the Verify Link option from the Site Management 
command in the Tools menu, Namo WebEditor will check all the files 
in the project and their linkage to each other. It then displays all 
broken hyperlinks in the Link Check section of the Result Window. 
For more information on checking links, see Incremental Verify 
Link(9-25).

Above, the image file 'flowers.gif', linked to 'index.html', is shown 
as having a problem. If the 'flowers.gif' file is not found, the 
hyperlink would be shown as broken. However, in this case, the fact 
that the 'flowers.gif' file is not included in the project is what 
caused the problem. 

This is because the change of the images on the first page 
(index.html) is not reflected in the project. Therefore you need to 
add the image file 'flowers.gif' to the project. To publish your web 

All the open files 
are displayed in 
yellow. 

Document 
designated as 
having a problem. 
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site without errors, all files that are linked to the web site should be 
included inside the project. 

Now you will need to find the image file 'flowers.gif'. According to 
the Target Link, the file is located in the 'images' folder. Click the 
'images' folder in the Project Window. A list of the image files found 
appears.

Find the 'flowers.gif' file in the list. When you find it, right click to 
open the menu. If you select the Add to Project on this menu, the 
file will be added to the project. 

If you check the hyperlinks again, no errors will be found. You may 
now save the project by selecting the Save Project command from 
the File menu.

When the link check is through, you can publish your site on the 
web server.

When you click 
the folder where 
the file is saved, 
the list of the 
image files 
appears.

Here the image 
file is found. 
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Publishing the Whole Web Site

When you select the Publish command on the File menu, or press 
the <F4> key while a project is open, the Publish dialog box will 
appear. In the left window the files in the current project folder are 
displayed. In the right window the files in the specified directory on 
the web server are shown. To connect to your host, choose its 
name from the drop down menu in the upper right hand corner.

After connecting to the server, select the files you want to publish. 
Since this is the first time you are publishing the files, you should 
select them all by clicking the Select All button at the bottom of the 
Publish dialog box.

The files and image 
folder of the project 
are shown. Because 
the files to be 
published are not 
selected yet, the 
check( ) marks do 
not appear in the 
squares at the left.

The check( ) 
marks are displayed 
at the left of the 
files selected to be 
published.
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When you click the Publish button, Namo WebEditor will begin to 
transfer the files one by one while displaying the transfer status of 
each.

When the squares to the left of the published files become green, it 
means they have been transferred. When prompted, click the OK 
button and Close the Publish dialog box. 
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If the squares at the left of the files turn red, it indicates the files 
have not been published. It is possible that the files have been 
moved or deleted from your computer, and have not been saved or 
shown in your project. Check your links again.

Publishing Unmodified Files

Once you have published the project, and have modified your site, 
you will only need to republish a certain number of files.

When you select the Publish command from either the File menu or 
by pressing <F4> while the project is open, the Publish dialog box 
will appear and you will be automatically connected to the web 
server.

If you click the Select Modified button from the Publish dialog box, 
only the files modified after your last publish are selected. This 
saves you the time from having to select each individual file. 

The files and image 
folder of the project 
are shown. Because 
the files to be 
published are not 
selected yet, the 
check( ) mark 
doesn't appear in 
the squares at the 
left. 
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When you click the Publish button, Namo WebEditor will begin to 
transfer the selected files, one by one, while displaying their status. 

Your web site is now updated. Check that your web site works 
correctly in a web browser, make sure you refresh/reload your page 
once you view it.

The check( ) marks 
appear in the squares 
at the left of the 
selected files. The 
obscure check marks at 
the left of the 'images' 
folder indicate that not 
all the files in the folder 
are selected. 

You can select the files you are editing at the 
time by clicking the Select Editing Files button 
and adding the image files linked to the 
documents by clicking the Select Images Used 
in HTML Files button.

The squares at the 
left of the published 
files turn to green. 
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The importance of HTML documents has been growing as more 
people use the Internet to receive and transfer information. With 
Namo WebEditor you can effectively handle the information in web 
sites and e-mails. Even if you don’t have your own web site, Namo 
WebEditor can still be a great help to you by allowing you to 
process the information you receive from the Internet.

Importing Information from the Web

It's not easy to import specific web site information to a word 
processor. Namo WebEditor, however, supports the all HTML format 
so that all the contents you copy from Internet Explorer or 
Netscape will preserve their full HTML properties. Any graphics you 
see in your browser, including animated GIF files, will also be 
imported into Namo WebEditor.
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When you paste the contents copied from the web browser, Namo will display the
image after it has been downloaded. 

To select specific 
contents from the 
web browser, click at 
the beginning and 
drag to the end. To 
be more specific, click 
the cursor at the 
beginning of the 
document, and click 
another location 
while holding the 
<SHIFT> key down.

Press <Ctrl+A> to select 
the entire document. 

If you select the Copy 
Image option after 
selecting an image by 
double clicking it, you 
can then save the image. 

The image download 
status is shown. 
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Namo WebEditor excels in 
filtering the advertisements 
and logos that are no use to 
you, while importing the 
information you want. For 
example, when you import the 
feature story on the 
millennium bug, you can 
import only the linked lists of 
the related web sites. You can 
import the entire web site by 
selecting the Import from Web 
command on the Tools menu. 

Namo WebEditor can 
import not only images 
but also hyperlinks as 
well. If you import a 
highly detailed linked 
list, it can be more 
convenient than simply 
using a bookmark. 
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E-mail and WebEditor

Namo WebEditor helps you easily save multimedia information 
received via e-mail as well. You can also send an HTML document 
edited by Namo using e-mail software that is compatible with HTML 
documents, like Outlook Express. You could surprise your friend by 
sending a multimedia card on his or her birthday!

Let’s say you received this birthday card from your friend via your e-mail.

After pasting the contents into Namo WebEditor, edit it as you wish and you can
send it back to someone else!

After clicking 
the contents of 
the e-mail, 
press the 
<Ctrl+A> to 
select the 
whole 
contents. Then 
copy it by 
pressing 
<Ctrl+C>. 

In many softwares, 
it is very difficult to 
delete a table. But 
in Namo 
WebEditor, it is 
easy. Place the 
cursor position in 
the table, then 
move it out of the 
table by pressing 
<Shift+Esc>, then 
press <Delete> or 
<Backspace> on 
your keyboard. 
The table will then 
be deleted. 
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Auto Document Outline/TOC

In an HTML document where paragraphs style are applied to its 
titles, a document outline is automatically created. When you select 
the Document Outline option from the Tool Windows command in 
the View menu, or press <Alt+3>, the Document Outline window 
will appear to the left. In this window the titles of paragraph styles 
are displayed. 

If the '+' mark 
appears at the left, 
the sub outlines are 
hidden. While the '-' 
mark indicates all 
the sub outlines are 
shown.

If you right click the 
Document Outline 
window, you can specify 
up to which level of sub 
outlines are shown. 

When you click one 
of the outline 
headings, then the 
paragraph appears in 
the edit window. In 
this way you can 
move easily around a 
long document. 
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Making a TOC The outline is the same as the table of contents, therefore you can 
create a hyperlink from the table of contents by selecting the Make 
TOC command from the shortcut menu that appears when you right 
click the Document Outline window.

Select Make TOC 
after right clicking 
the Document 
Outline window.

Specifications such as the 
hyperlink and bookmark are 
created on the document outline. 

The table of 
contents is 
created at the 
beginning of the 
document. In 
Namo WebEditor 
if you click the 
table of contents 
while pressing 
the <Ctrl> key, 
you can move to 
the linked 
position. 
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