
. . .
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Frame 8

Frame menu helps you 
create frames in the Namo 
WebEditor window and manage 
them easily. For beginners the 
frames may seem rather 
difficult. However, once you 
follow this chapter step by 
step, you will have enough 
knowledge to create and 
modify them as you want. 
Namo WebEditor offers you 
pre-designed framesets as templates. You will find them useful.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . FRAME AND FRAMESET

There are many web sites that split the screen horizontally and 
vertically thus dividing it into several regions and they then display 
the HTML documents in those regions.

We call each sub window region a 'frame'. 'Frameset' indicates the 
HTML document that contains the information on the number, 
arrangement, name, size and attribute of the frames.

To create a web page that consists of three window regions 
(frames), there must be four HTML documents; 3 frames and 1 
frameset. If you open the frameset file in a web browser, other 
attached frames open automatically. When publishing, you must 
publish all 4 frames so that one can see all the frames in the web 
browser.

When you create a hyperlink from a web page which uses frames, 
you must specify both target frame name and target document 
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name, otherwise the specified target document will not be 
displayed in the specified target frame.

If you open the frameset document, then the current frame name 
and the name of the document file being displayed in the frame 
appear in the brackets on the Title Bar. To the right of the bracket 
the title of the current frame document (title in the head tag) is 
displayed.

If we take the example below, the current frame name is 'detail', 
the current document file name is 'frame3.htm' and the document 
title is 'DHTML’.
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Now you can create a new document that uses frames. You can add 
frames by selecting the Split Frame Horizontally/Vertically command 
on the Frame menu. However, when creating a new document using 
frames, select the New Frameset command on the Frame menu, it 
will be more convenient.

When you select the New Frameset command on the Frame menu, 
then the New dialog box appears. Select the frame set you want in 
this dialog box, and click OK. Now the frameset you have selected 
appears in Namo WebEditor window.
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When you create or open the frameset document, the No Frame 
Msg, Frameset Source and Frameset Preview tabs are shown at the 
bottom of the window along with the Edit, HTML, and Preview tabs.

No Frame MSG Tab When someone opens the frameset document in a web browser not 
supporting the frame, he or she won’t be able to see the document. 
You can prepare the description for this occasion. Most of the web 
browsers that are used now support the frame so that the 
description for the occasion can't be seen in them. However, in a 
text web browser not supporting the frame like the Link, the 
description is displayed.

When you click the No Frame Msg tab, a window appears displaying 
the message, "Viewing this page requires a browser capable of 
displaying frames". You can edit this message or open other HTML 
document in this window. After you finish editing, click the Edit tab 
to return to the edit window.
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Caution The contents of the No Frame Msg tab are saved in the frameset 
document, therefore, after editing it you must save the contents by 
selecting the Save Frameset command on the Frame menu.

Frameset Source Tab

When you click the Frameset Source tab, Namo WebEditor displays 
the source file of the current frameset. The frameset includes 
information on the number, rows, columns and size of the frames 
that belong to the current frame. It also contains the description for 
the web browser that can't display the frames. To display the 
source of each frame, not frameset, click the HTML tab or <F6> 
key on your keyboard with the insertion position on the respective 
frame.

When you select the Frameset Source tab, the window displaying 
the frameset source appears. If you select the Show Source with 
Color on the short cut that appears when you right click, the Namo 
WebEditor displays the HTML tags in colors to help you tell them 
from the other contents of the window.
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Frameset Preview Tab

When you click the Frameset Preview tab, you can see how the 
entire frameset looks in the Internet Explorer. If the Internet 
Explorer is not installed on you system, the preview functionality is 
not available. If you use Netscape, select the Preview in Netscape 
command on the Frame menu or press the <F12> key on your 
keyboard.

With the Preview tab, you can only preview the shape of each 
frame.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . NEW PAGE
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Select to create a new document after closing the document at the 
current cursor position. The New Page command is used to create a 
new document in one of the frames where the cursor position is, 
not to create new documents in all the frames of the frameset.

When you select the New Page command on the Frame menu, 
Namo WebEditor closes the document in the current frame and 
creates a new one in it.

If you didn't save the documents in the editing frame, then a dialog 
box appears asking whether Namo WebEditor should save the 
document or not.

Yes Indicates closing the document after saving it.

No Indicates closing the document without saving it. If 
you click the No button after making changes on the 
document, you can not revive the changes.
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Cancel Select to cancel the close action. Click this button 
when you are not sure whether you save the 
document after making changes. You can select the 
New Page command on the Frame menu later.

Caution The New Page command on the Frame menu is the same as the 
New command on the File menu in that it creates a new document, 
but differs in its basic concept. The New command on the File menu 
opens a new edit window, then creates a new document in it, while 
the New Page command on the Frame menu creates a new 
document in one of the several frames.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . OPEN PAGE
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This allows you open an document saved onto the hard disk into 
the current frame. To do this:

1 Place the cursor in the frame in which the new document will open.

2 When you select the Open Page command from the Frame menu, 
the Open dialog box will appear.

3 Move to the folder where the document you want is saved.

4 Click the document to select it and then click the Open button. The 
document will now open in the current frame.

For more information on the Open dialog box, see Open(2-4)
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Caution As for the attributes of the document that you opened using the 
New Page command on the Frame menu, it is something you must 
change yourself. This is necessary because Namo WebEditor opens 
documents in the frame, but does not properly set their attributes.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SAVE ALL
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This allows you to save all documents open inside the current frame 
document. This will not save files open in another edit window. 

If you have not saved your frame document since its creation, the 
Save As dialog box will appear for each document. For more 
information on the Save as dialog box, see Save As(2-17).

Reference When you select the Save All command on the Frame menu, Namo 
WebEditor saves only the frames and the frameset documents in 
the current document tab. But if you select the Save All command 
from the File menu, all open documents will be saved. You will also 
get a chance to save documents that have never been saved 
before.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SAVE FRAMESET
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This saves the frameset. The frameset document contains 
information on the number, arrangement, name, size and attribute 
of each of the frames. This means if you adjust the size or shape of 
the frames, you will need to save the frameset along with the rest 
of the frames. Saving the frameset does not save all the 
corresponding frames, they still need to be saved on their own.

Caution Because the extension name of a frameset document is exactly the 
same as other HTML documents, it is difficult to tell the difference 
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between a frameset file and a regular HTML file. It is recommended 
that you name the frameset document in a way that implies its 
location or function. For example, save your left frame as 
‘frameleft.htm’, and save your right frame as ‘frameright.htm’.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SAVE FRAMESET AS
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This allows you to save your frameset as something different than it 
already is. When you select this command, the current frameset is 
saved as the name you specify. 

For more information on the Save as dialog box, see Save As(2-17).

Reference The Save Frameset As command on the File menu is used to change 
the name of the frameset and doesn't affect the names of any 
frame documents inside the frameset. To change the frame 
document name, select the Save As command from the File menu.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PRINT FRAMESET
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Select this to print the current frameset onto paper or into a file. 
This command prints the contents of the current window.

For more information on the Print dialog box, see Print(2-29).

Reference The Print Frameset command on the Frame menu is for checking the 
shape of the frameset. To print the contents of each frame, select 
the Print command from the File menu.
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Caution To print, the default printer must be registered in Windows. You can 
check this by selecting Start-Settings-Printers. For more information 
on how to add a printer to your system or register a default printer, 
see your Windows user manual.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PRINT PREVIEW
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This option allows you to get a full view of the frameset before 
printing. You will find the Print Preview feature useful because you 
don't have to print the entire frameset to see the how it looks.

For more information on the Print Preview command, see Print 
Preview(2-30).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SPLIT FRAME HORIZONTALLY

�����������	�����	����������� 

This option splits the current frame into two horizontal frames, one 
on top of the other. You can make the frame even if the current 
document is a plain HTML file.

When you select the Split Frame Horizontally command on the 
Frame menu, Namo WebEditor divides the current window 
horizontally and displays the current contents in the upper window, 
while it creates a blank frame in the lower window.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SPLIT FRAME VERTICALLY
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Select to split the current frame into two frames vertically. You can 
make the frame even if the current document is plain HTML.

When you select the Split Frame Vertically command on the Frame 
menu, Namo WebEditor divides the current window vertically and 
displays the current contents in the left window, while it creates a 
blank frame in the right window.
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Reference To remove the frames made by the Split Frame 
Horizontally/Vertically command, drag the frame border out of the 
Namo WebEditor window. A dialog box then appears asking 
whether or not Namo WebEditor should remove the frame. Click the 
Yes button. The frame that was dragged off is now gone!
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . FRAMESET PROPERTIES
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This option allows you to adjust the properties of the frameset 
document. To do this, select the Frameset Properties command from 
the Frame menu to change the frameset properties.

When you select the Frameset Properties command from the Frame 
menu, the Document Properties dialog box will appear as shown 
below. For more information on the Document Properties dialog box, 
see Document Properties(6-16).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . FRAME PROPERTIES
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Here you can specify frame properties like the layout, margin, 
options, border thickness etc.

When you select the Frame Properties... command on the Frame 
menu, the Frame Properties dialog box as shown below.
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Source Shows the name and location of the frame document. 
You can change the document that is displayed in the 
current frame by changing its name here. However, 
You cannot change the file name. To change the 
document name, select the Save As... command from 
the File menu.

Name This is where you should specify the frame name. 
Every frame should have a name, it is used to create a 
hyperlink between all the frames in a frameset. To 
specify the frame name is recommended.

Default Target Frame
This shows which frame the hyperlink will go to. It can 
be either one of the frame names or one of the 
defaults shown below.

_parent The target document will be displayed in the 
parent/main document. 

_self The target document of the hyperlink will be displayed 
inside the frame containing the hyperlink.

_top This will display the target of the hyperlink in a window 
free from frames.

_blank This will display the target of the hyperlink in a new 
window, also free from frames.
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Layout
You can specify the width and height of a frame using the units 
below:

*(relative) Sets the frame size as a proportion. If you set this 
proportion to 3, and another frame gets set to 1, this 
frame will be 3 times as large as the latter. 

% Similar to relative spacing above, except here you 
indicate the actual percentage of the entire frameset 
that the current frame should take up. If you specify a 
frame will take up 50% of the screen, it will have 50% 
of the screen no matter what size the browser window 
is.

pixel This allows you to specify the frame size in pixels. It 
will give you a fixed amount. For example, if you set 
the height to 100 pixels, it will always be 100 pixels, 
and other browsers will have to adapt to this size. It is 
recommended that if you are going to create frames, 
use a percentage or proportion, otherwise you risk the 
visitor suffering because their resolution isn’t good 
enough.

Margin
Specifies the frame margin in pixels. The Width specifies the left 
margin and the Height specifies the top margin.

Resizeable
With this option selected, you can resize the frames in the web 
browser by dragging the mouse. When not selected, the frame 
sizes are fixed. You can see the result of selecting the Resizeable 
option in a web browser or in preview mode.

Scroll Bar
Lets you specify if you want a scrolling bar in your frame. If this 
option is selected, scroll bars only appear when the frame contents 
extends beyond the available screen space.
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Border Thickness
Indicates the border thickness. When you specify the thickness as 
0, the border will not be seen in a web browser. Frame borders are 
always shown in Namo WebEditor (edit mode only) to help you 
editing.

Style
This option will allow you to adjust the appearance of the paragraph 
style in more detail. When you click the Style... button in the Frame 
Properties dialog box, the Style dialog box appears. The options you 
select here apply to the paragraph of the current cursor position 
and do not affect the styles of other paragraphs.

Extended
To use a tag that is not bound by the HTML protocol that the Namo 
WebEditor supports, click the Extended button. The Extended 
Attribute dialog box will appear. Click the Add button here, then 
enter the name and value of the attribute. Click OK.

Reference You cannot undo or redo the actions taken on the location of the 
frame border or background images of a document. In short, 
changing document structure is not reversible.
8-16 Namo WebEditor 3.0 User Manual


	Frame
	Frame and Frameset
	New Frameset
	No Frame MSG Tab
	Frameset Source Tab
	Frameset Preview Tab

	New Page
	Open Page
	Save All
	Save Frameset
	Save Frameset as
	Print Frameset
	Print Preview
	Split Frame Horizontally
	Split Frame Vertically
	Frameset Properties
	Frame Properties
	Layout
	Margin
	Resizeable
	Scroll Bar
	Border Thickness
	Style
	Extended



