
Section Maker
Windows and Macintosh Version 5.1

User Manual

© Formation Design Systems Pty Ltd 1984 – 99





 iii

License & Copyright
Section Maker Program
© 1990-99 Formation Design Systems
Section Maker is copyrighted and all rights are reserved. The license
for use is granted to the purchaser by Formation Design Systems as a
single user license and does not permit the program to be used on
more than one machine at one time. Copying of the program to other
media is permitted for back-up purposes as long as all copies remain
in the possession of the purchaser.

Section Maker User Manual
© 1990-99 Formation Design Systems
All rights reserved. No part of this publication may be reproduced,
transmitted, transcribed, stored in a retrieval system, or translated
into any language in any form or by any means, without the written
permission of Formation Design Systems. Formation Design Systems
reserves the right to revise this publication from time to time and to
make changes to the contents without obligation to notify any person
or organization of such changes.

DISCLAIMER OF WARRANTY
Neither Formation Design Systems, nor the author of this program
and documentation are liable or responsible to the purchaser or user
for loss or damage caused, or alleged to be caused, directly or
indirectly by the software and its attendant documentation,
including (but not limited to) interruption on service, loss of
business, or anticipatory profits. No Formation Design Systems
distributor, or agent, or employee is authorized to make any
modification, extension, or addition to this warranty.
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About this Manual
This manual is about Section Maker, a section properties calculation
and design system. Section Maker works with the Multiframe range
of structural design software.

Chapter 1 Learning Section Maker gets you started drawing, calculating
properties and installing a section in the Multiframe Sections Library.
It is a series of exercises designed to help you learn the basics of
Section Maker and become confident in using it to design your own
custom sections.

Once you are familiar with the basic concepts used, you may refer to
the step-by-step instructions in Chapter 2.

Chapter 2 Using Section Maker will explain most of the tasks you will
carry out in designing and installing a section.

Chapter 3 Section Maker Reference gives an overview of the operations
of Section Maker and a summary of the commands used.

Chapter 4 Sections Calculations discusses the numerical methods used
by Section Maker. It is important for you to understand these
methods and their limitations before using Section Maker for
sections properties calculations. The chapter ends with a summary of
the capabilities and limitations of Section Maker.
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Chapter 1
Learning Section Maker
This chapter provides a tutorial to help you learn the basics of
working with Section Maker.

Getting Started
Before you get started using Section Maker, you will need to learn
some of the basic concepts of using your computer. If terms like
windows, menus and scroll bars are not familiar to you, now is a
good time to read your owners' guide which will explain the basic
concept. If you are familiar with the standard operations continue
reading.

If you are not familiar with the calculation of sections properties of
structural shapes, it will be necessary for you to review the concepts
outlined in Chapter 4. If you are familiar with the analysis, you can
proceed at your own pace.

Section Maker may be used to calculate the sectional properties of
arbitrary structural shapes and install them as sections in the
Multiframe Sections Library.

If you are running Section Maker on a Windows computer, be careful
when using Section Maker with Multiframe or Steel Designer. If you
have both Section Maker and Multiframe open at the same time, any
changes you make to the Section Library with Section Maker will not
be reflected in the sections available to Multiframe. To make the new
sections available to Multiframe you will have to quit Multiframe
and restart the program.

On Macintosh computers, Section Maker and Multiframe will
automatically exchange information to keep the library up to date.

Multiframe will run on any Macintosh computer with at least 8 Mb
of memory, or any Windows 95/98/NT computer with at least 16
Mb of memory.

Installing Section
Maker on Windows

Insert Disk 1 into your floppy drive. Select Run from the Start menu
(Windows NTv3.51 users choose Run from the File menu of the
Program Manager). A dialog box will appear asking you to enter the
name of the program to run. Type 'A:\SETUP' in the space provided,
then click on OK, and then follow the instruction on screen.

After installation, Section Maker should be accessible through the
Start Menu. Simply select Section Maker from the Multiframe menu
under the Start menu. Section Maker is automatically installed in the
Multiframe folder in the Program Files directory unless you specify
otherwise.
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Installing Section
Maker on Macintosh

Insert the Section Maker disk and double click on the Installer
program. This will prompt you to specify a location on your hard
disk where Section Maker will be installed. You should install
Section Maker into the same folder as the Multiframe program on
your hard disk.

Starting Section
Maker

Start up the Section Maker program and then use the Drawing
Layout command from the Window menu to lay out three windows
on the screen titled Shape, Properties and Data. This will provide
you with the most convenient window arrangement for creating new
sections.

Drawing a Shape
To introduce you to the concepts and techniques you will use in
Section Maker, this chapter will describe the creation of a structural
section step by step. The section you will draw is shown below.

First, you will draw the section to scale, inside the Shape window.
First insure that your units are set up correctly by using the Units
command from the View menu. This example is carried out in
American units, you can use other units if you wish.

It is necessary to set up the sizes for drawing in the Shape window.

• Choose Size… from the View menu.

A dialog box will appear with four fields in it specifying the
maximum dimensions of the section.

• Type 4 for the maximum x coordinate and then press the Tab key
to move to the second field

• Type in -4 for the minimum x coordinate and then use the Tab
key to move to the next two fields entering 6 and -6 for the
maximum and minimum y coordinates.

• Click the OK button when you have finished entering the values.
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If you make a mistake entering the numbers, you can use the
backspace or delete key to delete the character just to the left of the
blinking cursor and you can use the Tab key to move from one field
to the next.

Placing a Shape
To create the I beam which forms the basis of the section, you can use
Section Maker's commands for automatically generating a common
structural shape.

A note on terminology:
Section Maker uses the term "section" to refer to a structural cross
sectional shape and its associated sectional properties which is stored
in the Multiframe Sections Library. The term "shape" is used to refer
to a geometric shape such as a polygon, circle or rectangle or an
assemblage of these shapes. A section is made up of one or more
shapes.

• Choose Place Shape from the Shape menu.

A dialog will appear with icons for the common structural shapes

• Click on the I beam icon

• Click OK

A second dialog will appear with a picture of an I shape and fields
where you can enter the dimensions of the shape.

• Type in 12 for the depth then enter 8 for the width, 0.25 for the
web thickness and 0.5 for the flange thickness.

• Click the OK button

The I shape will be drawn on the screen centered in the Shape
window. The I shape is generated as an assembly of three rectangles.
The corners of the rectangles will be highlighted with small black
boxes (called handles) to indicate that the rectangles are selected.
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Notice also that the properties for the section are displayed in the
Properties window. Some of the properties will be negative because
as yet no material types have been assigned to the shape. Any shape,
which does not have a material type, is assumed to be a hole and is
subtracted from the property calculations.

Placing a Section
To place the channel on the top of the I shape, you can take an
existing channel from the Sections Library.

• Choose Place Section… from the Shape menu

A dialog will appear allowing you to select a section from the
Sections Library

• Click on the C name in the list of groups

The names of the channel sections stored in this group will be
displayed in the list on the right

• Click on the name C9x13.4 to select this section

• Click the OK button

The dimensions of the section will be taken from the library and the
section will be drawn in the center of the Shape window. This C
shape will be made up of three rectangles modeling the web and two
flanges. The corners of the rectangles will be highlighted to indicate
that the rectangles are selected.

Rotating the Shape
Before you can place this C shape on top of the I shape, you need to
rotate it by 90 degrees

• Choose Rotate … from the Shape menu

A dialog will appear allowing you to enter the number of degrees to
rotate the shape. The angle of rotation is measured in degrees with
positive being anti-clockwise

• Type in -90 for the angle of rotation

• Click the OK button

The C shape will be rotated so that it is oriented ready to move on to
the top of the I shape.
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Dragging the Shape
You can move shapes in Section Maker by dragging them with the
mouse.

To drag the C shape

• Point anywhere inside the C shape but away from the black
boxes, which show that it is selected.

• Press and hold down the mouse button.

• Drag the shape until its sits evenly on top of the I shape

• Release the mouse button.

As you drag the shape it will be redrawn at its new position

At every change that you make to the section, the new section
properties will be automatically recalculated and updated in the
Data window.

Drawing a Shape
Now you can draw the additional plate on the bottom flange of the
section.
To make it easier for you to draw the frame, you can use Section
Maker's Grid option to make drawing automatically align to a grid
with regular spacing.

• Choose Grid… from the View menu.

A dialog box will appear with values for the x (horizontal) and y
(vertical) spacing of the grid.
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• Type 0.5 for the x spacing, use the Tab key to move to the y
spacing and type 0.5 for it also

• Click on the On radio button to make subsequent drawing align
with the grid.

This will also turn on the Visible button to make the grid visible in
the Shape window.

• Click on the OK button to confirm your settings.

Now move the pointer inside the Shape window and notice that as
you move the mouse, the coordinates of the pointer are shown at the
bottom left hand corner of the window. The coordinates are shown
in the same units as Deflection in the Units dialog. The coordinates
will automatically align to the nearest point on the grid. You can now
begin to draw the shape to scale in the Shape window.

• Click on the Rectangle tool to select it

• Press the mouse button at the bottom left corner of the I shape

• Drag down and to the right to draw the bottom plate

• Release the mouse button when the plate is the correct size, i.e.
when the coordinates read x=4, y=-6.5

Selecting Materials
In order to compute the deflections in a structure, Multiframe needs
to know the Young's Modulus and Shear Modulus for the materials
in the section. You can choose what type of material each shape in
the section is made of by choosing from the range of materials
properties stored in the Sections Library.



Chapter One Learning Section Maker

Page 9

To set the material types for the shapes in this section

• Choose Select All from the Select sub-menu under the Edit menu

This will select all the shapes in the section, all the shapes in this
section are made from steel.

• Choose Select Material from the Material menu

A dialog box will appear with a list of the materials in the library.

• Click on the name Steel in the list

• Click the OK button

This will define all the shapes in the section to take their material
properties from those for steel stored in the library.

The shapes will be drawn filled with the pattern for their material,
black for steel in this case.

Aligning to the
Centroid

Before you install your section in the Sections Library you will
probably want to align the Centroid of its area with the x-y axes so
that all properties will be calculated relative to the Centroid.

To align the Centroid of the section with the axes

• Choose Select All from the Select sub-menu under the Edit menu

This will select all the shapes in the section

• Choose Align To Centroid from the Shape menu

All of the selected shapes in the Shape window will be moved so that
their common Centroid is aligned with the x-y axes.

• Choose Size To Fit from the View menu
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This will make the whole section visible in the window.

Once the shapes move the properties will be automatically
recalculated and displayed in the Properties window. You can check
that the section is aligned with the axes by verifying that the
coordinates of its Centroid (xc, yc) are 0.000,0.000.

Installing the
Section

Now that you have created the section you want, you can install it in
the Sections Library.

Macintosh
If Section Maker finds a library named "Sections Library" in the same
folder as Section Maker or in the System Folder, it will automatically
open it on startup.

Windows
If Section Maker finds a library named "SectionsLibrary.slb" in the
same directory as Section Maker, it will automatically open it on
startup.

If you have installed Section Maker correctly, this library should
automatically have been opened.

• Choose Install… from the Shape menu

A dialog box will appear with the properties of the section, a list of
groups and a list of symbols indicating the shape of the section. The
section's properties displayed in the table will be the same as those
calculated in the Data window. If you wish you can change them
before installing the section in the library. In this case we will leave
them set to the calculated values.

• Click on the name of the group where you would like to store the
section.

• Type in a name for the section

• Click on the icon that indicates the shape of the section

Since it is not one of the standard shapes, in this case just leave the
shape set to the question mark icon.

• Click the OK button



Chapter One Learning Section Maker

Page 11

Viewing Sections
You can verify that your section has been correctly installed into the
library by checking its properties in the Section window.

• Choose Section from the Window menu

The Section window will be brought to the front. Tables of sections
are displayed in this window. One group at a time is displayed.

To choose which group to display

• Choose Select Group… from the Section menu

A dialog box will appear with a list of the names of the groups in the
library.

• Click on the name of the group you stored your section in

• Click the OK button

The table of sections for that group will be displayed in the Sections
window. You can check the name and properties are correctly stored
by scrolling through the table to view the section's name and
properties.

Saving your Work
You can save the changes you have made to the Section Library by
using the Save command from the File menu.

• Choose Save Library from the File menu

The Sections Library will be saved to disk complete with the section
you added to it.

Printing your work
You can print the shape and properties you have created

• Bring the Shape window to the front

• Choose Page Setup from the File menu and choose your paper
size

• Choose Print Window from the File menu

• Click OK or Print to print out the shape or its properties
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Chapter 2
Using Section Maker
This chapter describes the use of all of the commands available in
Section Maker.

Introduction
If you have read Chapter 1 you are now familiar with some of the
features of creating a section using Section Maker. This chapter
presents a series of step-by-step instructions to the tasks covered in
Chapter 1 as well as other procedures you will want to know about.

The chapter begins with a summary of basic skills and this is
followed by a description of the tasks involved in creating a section
using Section Maker. The following sections describe working with
materials and working with groups and sections in the Sections
Library.

Summary of
Mouse Techniques

You will use the following mouse techniques to do just about all of
the tasks in this chapter.

• Click to select or activate something
• Press to cause a continuous action
• Drag to select, choose from a menu or move something
• Shift-Click to select or to extend or reduce a selection
• Double-Click to choose from a dialog box

To Click
Position the pointer on what you want to select or activate
Press and quickly release the mouse button

To Press
Position the pointer on something
Without moving the mouse, press and hold down the mouse button.

The effects of pressing continue as long as the mouse button is held
down. Pressing on a scroll arrow results in continuous scrolling.
Pressing on a menu title pulls down the menu and keeps it down
until you release the mouse button.

To Drag
Position the pointer on something
Press and hold down the mouse button and move the mouse
Release the mouse button

To Shift-Click or Command-Click
Command-Click (or Shift-Click or Macintosh) is used to extend or
reduce the selection of joints and members.
Hold down the shift or command key and click on the joints or
members you wish to add to the selection or which you wish to
remove from the selection

To Double-Click
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Double click is used as a short cut equivalent to clicking OK in a
dialog box.
Point to the item you wish to double click and then click twice
quickly in succession without moving the mouse.

Summary of
Keyboard
Techniques

This section describes keyboard techniques you can use as shortcuts
when using Section Maker.

Tab
You can use the Tab key to move horizontally within a table or to
move from one field in a dialog to the next.

Return
(Macintosh Only)
The Return key can be used to move to the next entry down in a table
or the next line down in the CalcSheet and is the same as clicking on
the OK button in a dialog.

Enter
The Enter key can be used to confirm the entry of numbers into a
table and is the same as clicking OK in a dialog.

Arrow Keys
The ↑ ← → ↓  keys may be used to move the selection in their
respective directions in the Data or Result tables.

Delete
(or Backspace on earlier Macintosh models)
The Delete key may be used to delete the current selection. If nothing
is selected and you are typing text or numbers, it will delete the
character to the left of the blinking cursor. In the Shape window it
will delete the currently selected shapes.

Command/Control
The Command/Ctrl key may be held down while typing another
key to choose a command from a menu without using the mouse.
Menu items, which have a key to the right of the name, may be
chosen in this way. For example, to choose Undo from the Edit Menu
you could hold down the Ctrl key and type Z.

Shift
You can hold down the shift keywhile clicking on something to add
it to the current selection or remove it from the selection if it is
already selected.

Holding down the shift while drawing a member, dragging a
member or dragging a joint will constrain the movement to be
horizontal, vertical or at a 45 degree angle.

Scrolling
Scrolling is a technique for moving a table of data up, down, left or
right in a window so that you can bring any part of the table into
view.

To scroll a table one line up or down
Click the appropriate arrow at the top or bottom of the vertical scroll
bar
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To scroll a table one column left or right
Click the appropriate arrow at the left or right of the horizontal scroll
bar

To scroll a table continuously line by line
Press the appropriate arrow at the top or bottom of the vertical scroll
bar

To scroll a table continuously column by column
Press the appropriate arrow at the left or right of the horizontal scroll
bar

To scroll up or down by the windowful
Click in the gray area above or below the scroll box in the vertical
scroll bar.

To scroll left or right by the windowful
Click in the gray area to the left or right of the scroll box in the
horizontal scroll bar.

To go to the beginning or the end of the table
Drag the scroll box to the top or the bottom of the vertical scroll bar.

To go to the left or right hand edge of the table
Drag the scroll box to the left or the right of the horizontal scroll bar.

To go to any part of a large table
Drag the scroll box to a place in the scroll bar that's about equivalent
to where the data is in the table.
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Working with Windows
A window frames and displays its contents. There are five windows
in Section Maker; they are titled Shape, Properties, Data, Group and
Section.

Zoom, Pan, Shrink
and Size To Fit

The Zoom, Pan, Shrink and Size To Fit commands in the View Menu
may be used to control the scale of the graphics displayed in the
Shape window

Zoom
Zoom allows you to increase the size of the drawing in the Shape
window.

• Choose Zoom from the View Menu

• Move the pointer to the top left hand corner of the area you wish
to view in close detail

• Drag a rectangle down and to the right, which encloses the area
of interest, and release the mouse button

The window's contents will be re-drawn to display the part of the
shape contained in the rectangle you have drawn.

Pan
Pan allows you to shift the display of the shape within the window
upwards, downwards, to the left or right.

• Choose Pan from the View Menu.

The cursor will change to a hand.

• Press inside the window and hold down the mouse button

• Drag the drawing to its new location.

• Release the mouse button to re-draw the contents of the window.

If not enough memory is available to move the image, a rectangle the
size of the window will be moved around as you move the mouse.

Shrinking the View
Shrink allows you to decrease the size of the drawing on the screen
by 50%.

• Choose Shrink from the View Menu

The drawing will shrink down to 50% of its current size and be re-
drawn.

Sizing To Fit
Size To Fit automatically resizes the drawing in the Shape window so
that the section just fits inside the window in the current view. This
is most useful after you have been zooming, panning or shrinking as
it returns you to a viewing scale that just fits the section inside the
window.
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Working With Shapes
Creating a section with Section Maker involves defining the
geometry of the shapes by drawing in the Shape window. You can
also use the pre-defined generation aids to automatically place
common structural shapes into the section.

The next part of this chapter describes the drawing techniques you
can use to create a section. This is followed by a summary of how to
select shapes in the section and how to use Section Maker's
capabilities to assist in generating commonly used shapes.

Drawing
The shapes, which make up a section, may be drawn directly in the
Shape window.

The scale at which this drawing is carried out may be specified by
choosing the Size… command from the View Menu. The maximum
and minimum coordinates to be used in the x and y directions may
be entered and Section Maker will scale these coordinates to the
current size of the Shape window. All movements in the window are
accompanied by a display of the current pointer coordinates in the
lower left hand corner of the window. All coordinates are shown in
the current units. You can change units using the Units command
form the View menu.

Setting the Size
Before starting drawing, you will need to set up the drawing area for
the size of section you intend working with. To do this

• Choose Size…from the View Menu

A dialog box will appear with the dimensions of the section

• Enter the maximum and minimum coordinates you wish to use
in each direction

• Click the OK button

Using the Grid
Section Maker has a built-in facility to allow you to have your
drawing automatically align with an evenly spaced grid. You can
control the spacing, display and use of this grid with the Grid
command from the View Menu.

• Choose Grid… from the View Menu

• Type in values for the x and y spacing of the grid

• Click on the On button if you want drawing to align to the grid

This will switch on the Visible button to make the grid to visible.

• Click the OK button
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If you want to have the shapes automatically align with the grid but
don't want to see the grid, simply click on the Invisible button before
clicking OK. Similarly you can click on the Visible button to have the
grid displayed as a visual guide but click on the Off button to disable
the automatic alignment with the grid.

All drawing and dragging in the Shape window will align to the grid
while the grid is switched on.

Drawing Tools
Section Maker has six drawing tools for drawing different types of
shapes. A gray or black background surrounding the tool’s icon
indicates the drawing tool, which is currently active. If the Arrow
tool is selected this allows you to select, move and resize shapes with
the mouse.

Before you start drawing a new section, if there are any shapes in the
Shape window Choose Select All from the Select sub-menu under the
Edit menu and press the Delete (or Backspace key). This will remove
the existing shapes.

Rectangle Tool
The rectangle tool can be used for drawing solid rectangular shapes
or for drawing rectangular holes in a section.

To draw a rectangle

• Click on the rectangle tool to select it

• Press at the position of the top left corner of the rectangle you
wish to draw

• Drag down to the right until the mouse points to the bottom right
corner of your rectangle



Chapter Two Using Section Maker

Page 19

• Release the mouse button

If you have the Grid turned on then the corners of the rectangle will
align to the grid. The new shape will be immediately added to the
list of shapes displayed in the Data window.

Hollow Rectangle
Tool

The hollow rectangle tool can be used for drawing hollow
rectangular shapes (rectangular or square structural tubing).

To draw a hollow rectangle

• Click on the hollow rectangle tool to select it

• Press at the position of the top left corner of the rectangle you
wish to draw

• Drag down to the right until the mouse points to the bottom right
corner of your rectangle

If you have the Grid turned on then the corners of the rectangle will
align to the grid.

• Release the mouse button

When you release the mouse button a dialog will appear allowing
you to enter the wall thicknesses of the shape you have drawn

• Type in values for the web and flange thicknesses

• Click the OK button

The new shape will be immediately added to the list of shapes
displayed in the Data window.
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Circle Tool
The circle tool can be used for drawing solid circular shapes or for
drawing circular holes in a section.

To draw a circle

• Click on the circle tool to select it

• Press at the position of the center of the circle you wish to draw

• Drag down outwards from the center until the mouse points to
the radius you require

If you have the Grid turned on then the center and radius of the
circle will align to the grid.

• Release the mouse button

The new shape will be immediately added to the list of shapes
displayed in the Data window.

Tube Tool
The tube tool can be used for drawing hollow circular shapes or
tubes.

To draw a tube

• Click on the tube tool to select it

• Press at the position of the center of the tube you wish to draw

• Drag down outwards from the center until the mouse points to
the radius you require

If you have the Grid turned on then the center of the circle and the
position of the circle will align to the grid.
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• Release the mouse button

A dialog will appear allowing you to enter a wall thickness for the
tube.

• Type in a value for the wall thickness

• Click the OK button

The new shape will be immediately added to the list of shapes
displayed in the Data window.

Polygon Tool
The polygon tool can be used for drawing solid polygonal shapes or
for drawing polygonal holes in a section. Note that the calculation of
sections properties for a polygon will be accurate for all properties
except for the torsion constant J. For convex polygons the calculation
of J will be a reasonable approximation however for any polygon
with one or more re-entrant corners the calculation of J can not be
relied upon.

To draw a polygon

• Click on the polygon tool to select it

• Click at the location of the first vertex of the polygon

The first side of the polygon will be drawn as you move the mouse

• Click at the location of each of the other vertices of the polygon

• Double click at the location of the last vertex to close the polygon
or …

• Press Return or Enter to close the polygon or …

• Click close to the first vertex to close the polygon
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If you have the Grid turned on then the vertices of the polygon will
align to the grid. The new shape will be immediately added to the
list of shapes displayed in the Data window.

Open Polygon Tool
The open polygon tool can be used for drawing polygonal shapes
made of thin material. Thin means the thickness of the material is
very small compared with the size of the shape. This is most useful
for modeling structural shapes made from cold rolled thin steel or
aluminum.

To draw an open polygon

• Click on the open polygon tool to select it

• Click at the location of the first vertex of the polygon

The first side of the polygon will be drawn as you move the mouse

• Click at the location of each of the other vertices of the polygon

• Double click at the location of the last vertex to complete the
polygon or …

• Press Return or Enter to complete the polygon

If you have the Grid turned on then the vertices of the polygon will
align to the grid. The new shape will be immediately added to the
list of shapes displayed in the Data window.

Drawing Multiple
Shapes

(Macintosh Only)
Each time after you have drawn a shape, the current drawing tool
will revert to the arrow tool. If you wish to draw a number of shapes
of the same type in succession, you can double click on the drawing
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tool. This will highlight the tool in black rather than gray and will let
you use it any number of times until you select a different tool.

Moving a Shape
You can move a shape by dragging it with the mouse in the Shape
window

To move a shape

• Point anywhere inside the shape

• Press the mouse button

• Drag the shape to the new location

• Release the mouse button

Moving a Number of
Shapes

You can move a number of shapes at once by selecting them and
dragging them to the new location with the mouse.

To select a shape

• Click on or in the shape with the mouse

If you have turned off the display of materials, you must click on the
boundary of the shape rather than inside it. The shapes handles will
be highlighted to indicate that it is selected.

To add a shape to the current selection

• Shift-click on or in the shape

To move a number of shapes

• Select the shapes to be moved

• Press on or inside any one of the selected shapes

If you have turned off the display of materials, you must click on the
boundary of a shape rather than inside one

• Drag the shapes to their new location

• Release the mouse button

The shapes will be re-drawn in their new position.

Moving Shapes
Accurately

You can also move the selected shapes with great accuracy by using
the Move command from the Shape menu.

• Choose Move...from the Shape menu
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• Type in the distance to move in each direction

• Click the OK button

Resizing a Shape
You can change the size of a shape by dragging its handles (the small
black boxes which appear when it is selected).

To resize a shape

• Press on the handle closest to the part of the shape you want to
move

• Drag the handle to its new location

• Release the mouse button

When you resize a polygon each of the vertices moves independently
of the others.

Deleting a Shape
To delete a shape or shapes from the section

• Select the shape or shapes to be deleted

• Press the Delete (or Backspace) key or …

• Choose Clear from the Edit menu

Duplicating a
Shape

To duplicate a shape or shapes in the section

• Select the shape or shapes to be duplicated

• Choose Duplicate from the Shape menu

A dialog box will appear allowing you to specify the spacing of the
duplicated shapes and how many are to be created

• Type in the spacing in each direction and the number of
duplicates

• Click the OK button

The duplicated shapes will be drawn and selected in the Shape
window.
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Rotating a Shape
Section Maker allows you to rotate shapes that you have already
drawn. Shapes are rotated about the axes at an angle measured
positive in the anti-clockwise direction. Rectangles may only be
rotated in increments of 90 degrees.

To rotate a shape or shapes

• Select the shape or shapes to be rotated

• Choose Rotate from the Shape menu

A dialog box will appear with a field for the angle of rotation

• Type in the angle of rotation

• Click the OK button

The selected shapes will be rotated about the origin of the axes and
re-drawn in the Shape window

Rescaling a Shape
Section Maker allows you to rescale shapes that you have already
drawn. The coordinates of the shapes are multiplied by a scaling
factor in each direction to rescale the shape.

To rescale a shape or shapes

• Select the shape or shapes to be rescaled

• Choose Rescale from the Shape menu

A dialog box will appear with two fields for the scaling factor in each
direction

• Type in the x and y scaling factors

• Click the OK button

The selected shapes will be rescaled and redrawn in the Shape
window

Reflecting Shapes
You can reflect shapes in Section Maker by using the Flip Horizontal
and Flip Vertical commands from the Shape menu

To reflect the selected shapes about a vertical axis passing through
the center of area of the selected shapes

• Choose Flip Horizontal from the Shape menu

To reflect the selected shapes about a horizontal axis passing through
the center of area of the selected shapes
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• Choose Flip Vertical from the Shape menu

Aligning to
Centroid

Most times when you create a section you will want to calculate its
properties relative to a set of axes at the centroid of its area. The
Align To Centroid command moves all of the selected shapes so that
their common center of area is aligned with the origin of the axes.
After using Align To Centroid the coordinates of the centroid of the
selected shapes will always be x=0,y=0.

To align the centroid of a shape or shapes with the axis origin

• Select the shape or shapes to be aligned

• Choose Align To Centroid from the Shape menu.

The shapes will be moved as a group to center their area about the
axis origin

Generating
Standard Shapes

Rather than having to draw common structural shapes such as I
beams, channels and angles, Section Maker lets you generate such
shapes by typing in a few key dimensions.

To generate a standard shape

• Choose Place Shape from the Shape menu

A dialog box will appear with a list of icons representing the
standard shapes

• Click on the icon you require

• Click the OK button

A dialog box will appear with a diagram of the shape and its key
dimensions
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• Type in the dimensions of the shape

• Click the OK button

The generated shape will be placed in the Shape window centered
about the origin of the x-y axes.

Using Existing
Sections

If you want to create a section, which is made up from other sections,
you can place the existing sections using the Place Section command
from the Shape menu. You can place standard sections from the
Sections Library as well as sections you have drawn and stored
previously.

To place a section

• Choose Place Section from the Shape menu

A dialog box will appear allowing you to pick the section you wish
to place

• Click on the group and section name of the required section

• Click the OK button

The chosen section will be placed in the Shape window. If the chosen
section is one of the standard Sections Library sections, an
approximate shape will be generated. For example, if you choose an I
section, the generated shape will not have the small fillets that the
real section has. This will result in a slight discrepancy between the
calculated and actual properties however for structural analysis
purposes, the accuracy of the properties calculation should be quite
sufficient.

Importing a Shape
You can import a shape into Section Maker in two ways, either by
pasting a picture from the clipboard or by placing a DXF file.



Chapter Two Using Section Maker

Page 28

To paste a picture

• Copy the picture to the clipboard in the originating program

• Choose Paste from the Edit menu in Section Maker

All rectangles, circles and polygons in the picture will be placed in
the Shape window. Because the accuracy of pictures in the clipboard
is limited to 1/72nd of an inch, pasting pictures is not a very accurate
way of importing data into Section Maker.

If you have a shape in another CAD system you can import it into
Section Maker by way of a DXF file.

• (Windows) Choose Import DXF from the File menu

• (Macintosh) Choose Place DXF from the Shape menu

The standard file dialog will appear and you can choose the DXF file.
Section Maker will extract all the rectangles, circles and polygons
from the DXF file and place them in the Shape window. If there are
lines in the DXF file which form a polygonal shape, Section Maker
will joint them together at the ends during the import process.

Setting Materials
To enable Multiframe to calculate deflections in structures, values for
Young's Modulus and Shear Modulus need to be stored with sections
in the Sections Library. Section Maker takes these values from the
materials you choose for the various shapes, which make up a
section. Section Maker allows you to use a number of different
materials within the one section. Materials are stored in the Sections
Library, standard steel and concrete data is included and you can
add your own custom materials to the library.

If you do not assign a material to a shape, Section Maker will assume
the shape is a hole and will deduct its properties from the overall
properties of the section. Shapes, which are holes, will have negative
properties displayed in the Data window.

When shapes you have drawn lie inside each other, you may find it
difficult to see which is which, especially when the material patterns
are displayed in the shapes. You can control the order in which the
shapes are displayed by using the commands under the Arrange
sub-menu under the Shape menu.

To move the selected shapes to the front of all the others

• Choose Move To Front from the Arrange menu

To send the select shapes behind all the others

• Choose Move To Back from the Arrange menu

To move the selected shapes just in front of the ones currently in
front of them

• Choose Move Forwards from the Arrange menu

To move the selected shapes just behind the shapes behind it

• Choose Move Backwards from the Arrange menu

Note that shapes can be contained inside other shape e.g. steel bar
inside a concrete beam or a void inside a beam but shapes can not
overlap partially. See Overlapping Shapes in Chapter 4 for more
information.
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Setting Material Types
To set the material type of a shape

• Select the shape

• Choose Select Material from the Material menu

• Click on the name of the material you require

• Click the OK button

See "Adding a Material" below for information on how to add
materials to the library.

Viewing Properties
When you draw a shape and specify its material properties, as each
change is made the sectional properties are automatically
recalculated and displayed in the Properties window

The properties displayed in this table are as follows.

Property Description
Weight Weight per unit length
Area Cross sectional area
Ix Moment of inertia about x axis
Iy Moment of inertia about y axis
J torsion constant
E Young's Modulus
G Shear Modulus
Sxt(or Zxt) Elastic Modulus about x axis at top of section
Sxb(or Zxb) Elastic Modulus about x axis at bottom of

section
Syl(or Zyl) Elastic Modulus about y axis at left of section
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Syr(or Zyr) Elastic Modulus about y axis at right of section
rx Radius of gyration about x axis
ry Radius of gyration about y axis
Ixc Moment of inertia about x axis passing through

centroid
Iyc Moment of inertia about y axis passing

through centroid
Ixyc Product of inertia about centroid
I1 Moment of inertia about major(strong) axis

passing through centroid
I2 Moment of inertia about minor (weak) axis

passing through centroid
Ø Angle of major axis from x axis
xc x location of centroid
yc y location of centroid
D Depth
B Width (or breadth)
xl Position of left extent of section
xr Position of right extent of section
yt Position of top extent of section
yb Position of bottom extent of section
Asx Shear area for shear in the minor (x) direction
Asy Shear area for shear in the major (y) direction

If you see properties which are negative, this may mean that you
have forgotten to specify materials for some of the components of the
shape. Also be careful not to overlap shapes unless you are
deliberately inserting a hole or reinforcing steel. See the Overlapping
Shapes section in Chapter 4 for more details.

Installing a
Section

Once you have drawn a section to your satisfaction you can install it
into the Sections Library for later use by Multiframe or Section
Maker.

To install your section

• Choose Install from the Shape menu

A dialog box will appear with a list of names of groups where the
section can be stored, a field for the name of the section, a table with
the calculated section properties and radio buttons to indicate the
shape of the section.
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• Type in a name for the section

• Click on the name of the group where you want to store the
section

• If you wish you can change the sections properties to override
the ones that have been calculated for you. Use the tab key to
move to the number to be changed and type in a new value.

 If the section is one of the standard shapes, you should type in
values for the web and flange thicknesses at the bottom of the table.
This will allow Multiframe3D to render the shape correctly and will
also let you place the section in Section Maker at a later date.

• Click on the radio button which shows the shape of the section

If the section is not one of the standard shapes, leave this set to the
question mark icon.

• Click the OK button

The section will be stored in the library in the group you have
nominated. Note that the library with the new section included will
not be saved permanently on the disk until you choose Save Library
from the File menu.

Tapered Sections
Section Maker allows you to automatically create a number of
sections, which interpolate between two existing sections. This can
be used to model the changing sectional shape in a tapered member.
Suppose you were modeling a tapered beam in Multiframe that
started with a 12inch (300mm) deep rectangular section and tapered
to a 24inch(600mm) deep section. You could draw the first section
and install it in the library, then draw the second section and install
it. To create the intermediate sections you use the Taper command
from the Shape window.

To install a number of intermediate sections between to existing
sections

• Choose Taper from the Shape menu.

A dialog box will appear which allows you to select the start and
finish sections

• Click on the Start Section button

A dialog box will appear listing the available groups and sections

• Click on the group and section names of the starting section

• Click the OK button
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• Click on the End Section button

• Choose the group and section names for the end section and click
OK

The two sections you have chosen will be displayed in the dialog.

• Type in the number of intermediate sections you want to
generate

The sections properties will be calculated at the mid point of each
subdivision of the range between the start and end sections. Section
Maker makes an approximation to the intermediate section
properties by interpolating between the properties at each end. All
the properties except the moments of inertia and the torsion constant
are interpolated linearly and will be exactly correct. The moments of
inertia and torsion constant are interpolated using a cubic
approximation to the variation in property along the tapering
member. This will result in a small error in the moments of inertia
and torsion constant but in most cases this should not impact
significantly on your analysis. If you have a problem, which is
sensitive to the value of torsion or moments of inertia, you should
determine that this error will not have an adverse impact on your
analysis. A quick check of the values at the mid-point will give you a
guide to the maximum error.

• Type in a name for the section

This name will form the basis of the names for the added sections. If
"TestShape" is the name you give to the sections, the intermediate
sections will be named TestShape1, TestShape2 … and so on up to
TestShapen where n is the number of intermediate shapes you
requested.

• If you want to remove the original start and end sections check
the check box at the bottom of the dialog

Most times you will want to do this if you have drawn the sections as
the original sections will not be used in the Multiframe analysis. The
sections will only be deleted if the groups they belong to are not
locked.

• Click the OK button

The sections will be installed in the group you specified. If you want
to view or change the properties of the sections which are created,
you can view them in the Sections window (see Viewing Sections
below)
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Working With Libraries
As well as enabling you to draw and add individual sections to the
library, Section Maker has a number of features, which make it easier
for you to manage your sections library. You can add and remove
groups of sections from the library, add or remove a large number of
sections at once, and store custom or commonly used materials in the
library so that they are available for use.

You can change the contents of the library in the Group and Section
windows. One group at a time is displayed in these two windows.
The group currently on display is referred to below as the current
group. In the Group window you can view and change the
information about the current group, in the Section window you can
view and change any of the section properties for any of the sections
in the current group.

You can also create completely new libraries or read, modify and
write any number of sections libraries. This means you can keep a
number of libraries on your disk and use them for different
applications.

Creating a New
Library

Section Maker allows you to create a new library for use with any of
the Multiframe applications. All you have to do to make the new
library be used by the applications is to place it in the same folder as
the application and name it "Sections Library". If you already have a
sections library in the folder with that name, rename the existing
library to a different name and then name your new library "Sections
Library".

To create a new library

• Choose New Library from the File menu

A new library will be created with no groups or sections. You can
add groups and sections to the library (see Adding a Group and
Adding a Section below) before saving it to disk with the Save As
command from the File menu.

Opening a Library
You do not have to work with the sections library which
automatically opens when Section Maker starts up. (If Section Maker
finds a library named Sections Library in the same folder as Section
Maker or in the System Folder, it will automatically open it on
startup) If you wish you can open any other library and work with it
in the normal way.

To open a sections library

• Choose Open Library from the File menu
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• Click on the name of the library you wish to open

• Click the Open button

The contents of the library will be read in and the groups and
sections in the library will be displayed in the Group and Section
windows respectively.

Saving a Library
If you have installed any sections in the library or you have changed
the section or group properties in any way, you will have to save the
Sections Library to disk to make the changes permanent.

To save the Sections Library to disk

• Choose Save Library from the File menu

To save the Sections Library to disk with a new name

• Choose Save As from the File menu

• Select the folder or disk where you will save the library

• Type in a name for the library

• Click the Save button

Saving as Text
Another way to view the data in the library is to save it in text
format. Text files can be read into a word processor or you could
write your own software which extracts data from a text file of
sections.

To save the contents of the library in a text file

• Choose Export -> Text File from the File menu

(Macintosh) Use Save As -> Text Format

• Type in a name for the text file of data

• Choose which disk or folder you want to store the data in

• Click the Save button

The complete contents of the sections library will be saved to disk in
a text file. The format of this file is documented in Chapter 4.
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Working with Tables
The data for the library is displayed in tables in the Group and
Section windows. The properties for the section are displayed in the
Properties window. You can change data in the group and Section
windows by typing in new names and numbers. If there is more data
than will fit in a window, you can use the scroll bars to scroll
through the table to view rows or columns that are not visible.

Column Widths
If you want to change the width of a column in the table

• Press on the line dividing the column's title from the next
column

• Drag the column divider to make the column wider

• Release the mouse button

Text Styles
If you wish you can change the font and text size used to display the
numbers in the table by using the Font command from the View
menu.

To change the font and/or size of the text in a table

• Choose Font from the View menu

• Click on the name of the font you require

• Click on a font size or type in a size

• Click the OK button

Number Styles
You can also choose what numeric format to use for displaying the
numbers by using the Numbers command from the View menu.

To change the number of decimal places or the decimal format of the
numbers in a table

• Choose Numbers from the View menu
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• Choose Decimal or Scientific notation

• Type in the number of decimal places you require

• Click the OK button

Changing
Numbers or Name

To change a number or name in a table

• Click on the name or number to be changed

• Type in a new value

• Press the Enter key

Selecting Numbers
in Tables

You can also copy and paste data in tables. The copy or paste will act
on the current selection in the window. You can select a number or a
range of numbers, a row or range of rows, or a column or range of
columns.

To select a number

• Click on the number

To select a range of numbers

• Press on the number at the top left of the range to be selected

• Drag the mouse until the last number is selected

• Release the mouse button.

If the last number you want to select is outside the window, drag the
mouse outside the window and the table will automatically scroll to
bring the number into view.

To select a row

• Click on the number at the left of the row

To select a range of rows

• Press in the number at the left of the first row

• Drag down until the last row is selected

• Release the mouse button

If the last row is outside the window, drag outside the window and
the table will scroll to bring the row into view.

To select a column

• Click on the title at the top of the column

To select a range of columns
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• Press in the title of the left hand column in the range

• Drag the mouse across until the right hand column is selected

• Release the mouse button

If the right hand column is outside the window, drag outside the
window and the table will scroll to bring the column into view.

To select the whole table

• Click in the box at the top left corner of the table

Copying and
Pasting Numbers

To copy or paste numbers in Section Maker, first select the numbers
then choose the command you require.

To copy a number or range of numbers

• Select the numbers to be copied

• Choose Copy from the Edit menu

The numbers will be placed on the clipboard. Each row of numbers
will have a return character at the end and the numbers in the row
will be separated by a Tab character. You can transfer data copied
from Section Maker into other programs or you can paste them into
other tables in Section Maker.

To paste the numbers on the clipboard into a table

• Select the numbers in the table that will be replaced by the
numbers on the clipboard

• Choose Paste from the Edit menu
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Working With Groups
Section Maker allows you to add, delete and modify the groups of
sections stored in a sections library.

Adding a Group
Section Maker allows you to add groups to or remove groups from
the sections library you currently have open. This makes it more
convenient for you to choose sections. If there are groups in the
library you never use you could remove them or if there is a table of
custom sections you often use you could add them in a separate
group in the library.

To Add a Group to the
Library

• Choose Add Group from the Section menu

A dialog box will appear with a field for the group's name, a table
showing where key properties will be stored in the group, a text box
for the number of fields of data to be stored with each section in the
group and a list of icons to indicate the shape of sections in the
group.

• Type in a name for the group

If you wish you can type in the number of fields you require,
normally you will leave this set to 23. If you do add extra fields, you
can type a number next to each of the key properties to tell
Multiframe in which field that property will be stored otherwise the
fields will have the names and properties indicated. (For example the
first line of the table indicates that the mass per unit length of the
section is stored in a field named Mass and this is the first field of the
group). If you do change any of these values it is very important that
you keep the naming and units for the property consistent and
always store the property in the field indicated. Multiframe relies on
this information to do analysis and if you make an error entering the
key properties, the results of analysis may be incorrect. If in doubt,
leave the group with the 23 standard fields and properties.

• Click on the icon which represents the shapes stored in this
group

If you have more than one kind of shape or the shape is not one of
the standard shapes, leave the icon set to the question mark icon
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• Click the OK button

The group will be added to the library and made the current group
on display in the Group and Section windows.

Deleting a Group
To remove a group from the Sections Library

• Choose Delete Group from the Section Menu

A list of the groups in the library will be displayed

• Click on the group to be removed

If you wish to remove more than one group, hold down the shift key
while clicking on the names of the other groups

• Click the OK button

The groups selected and all the sections stored in them will be
removed from the library.

Adding a Field
The properties of each section in a group are stored in a number of
fields in the group. When you create a new group the 23 standard
properties are placed in the first 23 fields. If you wish you can add
more fields to a group. You could do this to make data available for
use in Multiframe's CalcSheet or you could store additional data for
easy reference.

To add a field to the current group

• Choose Add Field from the Section menu

A dialog box will appear allowing you to enter the number of fields
you wish to add

• Type in the number of additional fields you need

• Click the OK button.

The additional fields will be displayed in the Group window and
additional columns will be added to the Section window.

Changing a Field
After you have added a field you will need to give it a name and also
tell Multiframe what units the data is to be stored in. You can change
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the information about fields in the Group window. To change the
name of the field, click on its current name, type in a new name and
press the enter key.

In the units column, type in the name of the units you want to use to
store properties in this field. For example, if you added a field named
Iw for a warping constant your units might be in^6 (inches to the
sixth power) so you should type this into the units column. You
should also type in a factor to convert the fields values into
Multiframe's internal units system. This will allow you or another
user to change units and still have the properties displayed correctly.
The factor is the number the entered value must be multiplied by to
convert it into a Newton, meter, kilogram units system. i.e. in the
case where Iw will be entered in units of in^6, the factor will be
6.820907E-12 (i.e. 1/39.37 to the power of six as there are 39.37 inches
in a meter)
Some common units factors are

Name Property Units
Metric English
Unit Factor Unit Factor

Mass Mass per unit length kg/m 1.0 lb/ft 1.488
A,Asx,Asy Cross sectional area mm2 1E-6 in2 6.452E-4

Ix Major moment of inertia mm4 1E-12 in4 1.638E-5

Iy Minor moment of inertia mm4 1E-12 in4 1.638E-5

J Torsion constant mm4 1E-12 in4 1.638E-5

E Young's Modulus MPa 1E-6 ksi 6895000
G Shear Modulus MPa 1E-6 ksi 6895000
D Depth mm 0.001 in 0.0254
B Breadth or Width mm 0.001 in 0.0254
tf Flange thickness mm 0.001 in 0.0254
tw Web thickness mm 0.001 in 0.0254

Deleting a Field
You can delete fields that you have added by using the Delete Field
command from the Section menu.

To delete a field or fields from the current group

• Choose Delete Field from the Section menu

• Click in the name of the field to be removed

If you wish to remove more than one field, shift click on the
additional field names

• Click the OK button

WARNING: Do NOT delete any of first eleven standard fields in a
group as Multiframe uses them in its analysis.

Viewing Sections
The sections stored in the Sections Library can be viewed and
changed in the Section window of Section Maker. The sections are
displayed, a group at a time, in a table in this window.

To make the Sections window visible

• Choose Sections from the Window menu
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Adding a Section
To add a section or a number of sections to the current group in the
library

• Choose Add Section from the Section menu

A dialog box will appear allowing you to specify how many sections
you wish to add.

• Type in the number of sections to be added

• Click the OK button

A number of sections titled Section1, Section2 and son on will be
added to the current group. They will initially have all their
properties set to zero. You can view and edit the added sections in
the Section window.

You will only be able to add sections to a group that is unlocked.

Deleting a Section
To remove a section or a number of sections from the library

• Choose Delete Section from the Section menu

A dialog box will appear with a list of the names of the sections in
the current group

• Click on the name of the section to be removed
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If you want to remove more than one section, hold down the shift
key and click or drag over the additional sections to be removed

• Click the OK button

The sections will be removed from the library. Remember that the
changes will not be made permanent until you save the library to
disk using the Save Library command from the File menu.

Changing Section PropertiesTo change the value of a property stored
with a section

• Click on the property to be changed

• Type in a new value

• Press the Enter key

When you change the properties of a section, you must use the units
indicated at the top of the column for the property displayed in that
column of the table. The standard properties stored in a new group
are

Name Property Example Units
Metric English

Mass Mass per unit length kg/m lb/ft
A Cross sectional area mm2 in2

Ix Major moment of inertia mm4 in4

Iy Minor moment of inertia mm4 in4

J Torsion constant mm4 in4

E Young's Modulus MPa ksi
G Shear Modulus MPa ksi
D Depth mm in
B Breadth or Width mm in
tf Flange thickness mm in
tw Web thickness mm in
fy Yield Strength MPa ksi
fu Ultimate Strength MPa ksi
Sxt (or Zxt) Elastic Modulus about x at

top
mm3 in3

Syl (or Zyl) Elastic Modulus about y at
left

mm3 in3

Syr (or Zyr) Elastic Modulus about y at
right

mm3 in3

rx radius of gyration about x mm in
ry radius of gyration about y mm in
Sx (or Zx) Plastic Modulus about x mm3 in3

Sy (or Zy) Plastic Modulus about y mm3 in3

Iw Warping constant mm3 in3

rz radius of gyration about
weakest axis

mm in

Asx Shear area in weak axis
direction (x)

mm2 in2

Asx Shear area in strong axis
direction (y)

mm2 in2

The following diagram will help you determine the dimensional
properties. These properties are used by Multiframe for rendering
and display of member details and stresses and by Section Maker for
placing standard shapes and existing sections.
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Working With Materials

Adding a Material
To add a material to the library

• Choose Add Material from the Material menu

The material properties dialog will appear.

• Type in a name for the material

• Draw in the pattern box to design a pattern for the material

You can change the pattern by clicking in the left hand box. Clicking
on a dot in the pattern turns it off, clicking on an empty space adds a
dot to the pattern. A sample of the pattern is drawn in the right hand
box.

• Type in values for the material's properties

• Click on the radio button which applies to the material's type

• Click the OK button

The material will be added to the list of materials stored in the
Sections Library.

Deleting a Material
To delete a material from the library

• Choose Delete Material from the Material menu

• Click on the name of the material you want to delete
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• Click the OK button

Changing a
Material

To change the name, pattern or properties of a material

• Choose Edit Material from the Material menu

The material properties dialog will appear.

• Click on the name of the material you want to edit

• Type in a new name, change the pattern or type in new values for
the material's properties

• Click the OK button

Printing
The contents of any of the windows in Section Maker can be printed
and you can also print out a complete table of every section in the
Sections Library. When printing tables they will be printed over
multiple pages as there will generally not be enough room on one
page for all the rows and columns in the table.

(Macintosh Only)
When you print the Shape window, Section Maker will also print out
a summary table of properties alongside the printed shape.

Setting up the Printer
Before printing you should set up the printer with the page size and
orientation that you wish to use.

To Set up the Printer

• Choose Page Setup from the File menu

The standard page setup dialog will appear allowing you to enter the
appropriate information. You may also enter text to be displayed at
the head and foot of each page and set the width of the margins on
the page.

Printing a Window
To print the contents of the frontmost window

• Choose Print Window from the File menu

The standard print dialog will appear.
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If you wish you can check the Preview button to preview your
printed output on screen.

Printing the Library
To print the entire contents of the Sections Library

• Choose Print Library from the File menu

The standard print dialog will appear.

The tables of sections for each group in the library will be printed. If
there are more rows and columns than will fit one a page the
printout will be spread over a number of pages.
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Chapter 3
Section Maker Reference
This chapter summarises the overall structure and menu commands
of Section Maker.
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Windows
Section Maker uses a range of graphical, tabular, graph and report
windows.

Shape Window
This window is used for drawing a sections comprising one or more
shapes prior to installing it in the sections library.

Data Window
This window is used for viewing and editing the data describing the
shapes in the Shape window. It can display tables of section
properties or dimensions of the shapes which make up a section.

Group Window
This window is used for viewing and editing the data stored for each
group in the Sections Library. One group at a time can be viewed in
this window.

Section Window
This window is used for viewing and editing the date for the sections
in the library. One group of sections at a time can be viewed in this
window.

Properties Window
This window is used for displaying the calculated sectional
properties for the shape in the Shape window.
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Toolbars
Users of the Windows version of Section Maker can use the icons on
the toolbars to speed up access to some commonly used functions.
You can hold your mouse over an icon to reveal a pop-up tip of what
the icon does.

File Toolbar

The File toolbar contains icons for open, and saving files.

New Library - Open Library - Save Library - Cut - Copy - Paste -
Print Preview - About

Group Toolbar

The Group toolbar contains icons for changing the current group.

Previous Group - Next Group

View Toolbar

The View toolbar contains icons for changing the view in the Shape
window.

Zoom - Shrink - Pan – Size To Fit – Toggle Grid – Toggle Axes

Shape Toolbar

The Shape toolbar contains icons for drawing shapes in the Shape
window.

Select – Rectangle - Hollow Rectangle - Circle - Tube - Closed
Polygon - Open Polygon
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Menus
Section Maker uses the standard set of Macintosh or Windows menu
commands for File, Edit and Windows operations. It also has a range
of menus for working with sections and groups of sections.

File Menu
The File menu contains commands for opening and saving files as
well as import and export and printing.

New Library
(Windows: Ctrl N / Macintosh: Command N)
Use this to start work on a new library. If you have any changes to
the current library unsaved, Section Maker will prompt you to save
any changes before starting the new work.

Open Library
(Windows: Ctrl O / Macintosh: Command O)
Open a library which has previously been saved on disk.

If you have any changes to the current library unsaved, Section
Maker will prompt you to save any changes before opening the new
file.

Import
(Windows Only)
See “Import Submenu”

Export
(Windows Only)
See “Export Submenu”

Close Library
Closes the library and removes all groups and sections from display.

Save Library
(Windows: Ctrl S / Macintosh: command S)
Save the current library data with the same name you saved with last
time or the same name the file had when you opened it.

Save Library As
Save the current library in a file with a new name. You can also
choose to save the library in a text file format. This can then be read
by word processors or other programs.

Page Setup
Set up the printer for printing.

Allows you to set margins, header and footer titles and options on
printing the date, time and page numbers.

Print Window
Windows users: Print the contents of the front window on the screen.
Allows you to set margins, header and footer titles and options on
printing the date, time and page numbers.

Print Library
Print the entire contents of the Sections Library.
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Recent File
(Windows Only)
Recently opened files will appear at the bottom of the File menu. You
can choose them as a shortcut to open them.

Exit/Quit
(Macintosh: Ctrl Q)
Leave the Section Maker program. If you have any work unsaved,
Section Maker will prompt you to save any changes to the library
before quitting.

Import Submenu
(Windows Only)
The Import submenu provides you with options to import sections
and sections libraries.

DXF
Imports the shapes in a DXF file into the Shape window. See Place
DXF for Macintosh equivalent.

FORTRAN Text
Import the text version of the sections library.

Export Submenu
(Windows Only)
The Export submenu allows you to export a sections library.

FORTRAN Text
Save the sections library in a text file format.

Edit Menu
The Edit menu contains commands for copying and pasting tabular
data, selecting objects and working in tables.

Undo
(Windows: Ctrl Z / Macintosh: command Z)
Undo the last action you carried out. The name of this item will
change to reflect the command that can be undone.

Redo
(Windows Only)
Not currently active in Section Maker

Cut
(Windows: Ctrl X / Macintosh: command X)
Remove the current selection and place it on the clipboard

Copy
(Windows: Ctrl C / Macintosh: command C)
Copy the current selection to the clipboard

Paste
(Windows: Ctrl V / Macintosh: command V)
Paste the contents of the clipboard into the current selection

Clear
Remove the current selection without placing it on the clipboard.
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Select
The Select menu has commands for automatically selecting parts of
the drawing in the Shape window.
See “Select Submenu”

Show Clipboard
Make the clipboard visible/invisible.

Fill Down
(Windows: Ctrl Down Arrow / Macintosh: Ctrl D)
Repeat the cell at the top of the list of selected cells in the Data
window down the list of selected cells.

Fill Right
(Windows: Ctrl Right Arrow / Macintosh: Ctrl R)
Repeat the cell at the left of the list of selected cells in the Data
window across the list of selected cells.

Select Submenu
The Select menu has commands for automatically selecting parts of
the drawing in the Shape window.

Select All
(Windows: Ctrl A/ Macintosh: command A)
Automatically selects all the shapes in the Shape window

Select Polygons
Automatically selects all the polygonal shapes in the Shape window.

Select Circles
Automatically selects all the circular shapes in the Shape window

Select Rectangles
Automatically selects all the rectangular shapes in the Shape window

View Menu
The View menu contains commands for controlling the display in the
Shape window.

Zoom
(Windows: Ctrl W/ Macintosh: command W)
Zoom in on part of the current display. A cross-hair will appear and
the view to be viewed in close-up may be selected by pressing the
mouse button and dragging a rectangle surrounding the area of
interest. Release the button to draw the zoomed view.

Shrink
(Windows: Ctrl E/ Macintosh: command E)
Reduce the size of the drawing in the Shape window to half its
current size.

Pan
(Windows: Ctrl R / Macintosh: command R)
Pan across the drawing displayed in the Shape window. Press and
drag in the window to move the drawing.

Size To Fit
(Windows: Ctrl T/ Macintosh: command T)
Scale the drawing in the Shape window so that it just fits inside the
window.



Chapter Three Section Maker Reference

Page 53

Size
Set the maximum and minimum coordinates available in the Shape
window. Use this to set up the overall coordinates before you begin
drawing a section.

Grid
Switch on or off the use of the grid in the Shape window and set the
spacing of the grid.

Axes
Turn on or off the display of axes in the Shape window

Principal Axes
Turn on or off the display of the principal axes of the section in the
Shape window

Font
Set the font size and style for the text in the frontmost window.

Numbers
Set the type of numeric format you would like to use to display
numbers in the frontmost window. You can choose to use decimal or
scientific notation and specify how many digits of precision you wish
to display.

Units
Choose to work in Metric (mm) or English (inches) units.

Status Bar
(Windows Only)
Allows you to turn on or off the display of the status bar

Toolbar
(Windows Only)
Allows you to turn on or off the display of the toolbar at the top of
the Section Maker program window.
See “Toolbar  Section”  for more information on the toolbars
available in Section Maker.

Shape Menu
The Shape menu contains commands for working with Shapes in the
Shape window.

Place Section
Place an existing section from the Sections Library into the Shape
window. You can use this to build up a section out of existing
sections. If the section you select is one of the standard structural
shapes which come with Multiframe, an approximate shape will be
created.

Place Shape
Place a standard structural shape in the Shape window. This
provides an easy and precise way of automatically placing an I, C, L
or T section or a rectangular or circular tube or a rectangular or
circular bar. You can type in dimensions on a sketch of the shape to
create it.

Place DXF
(Macintosh Only)
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Places the shapes in a DXF file into the Shape window. See Import
DXF for Windows equivalent.

Install
(Windows: Ctrl I/ Macintosh: command I)
Install the shapes in the Shape window as a section in the Sections
Library. You do this to make the sections data available to
Multiframe for analysis or so you can use the section with other
shapes in Section Maker in the future.

Taper
Create a number of sections from two existing sections by
interpolating the sections properties. This is useful for modeling the
sections needed to simulate a tapered sections with a number of
intermediate sections. You can use this in conjunction with the
subdivide command in Multiframe for modeling tapered members.

Duplicate
(Windows: Ctrl D / Macintosh: command D)
Duplicates all the selected shapes in the Shape window a given
number of times in a specified direction. A dialog allows you to enter
the spacing in each direction and the number of duplicates to be
created.

Rotate
Rotates all the selected shapes in the Shape window a specified
number of degrees about the origin of the axes. A dialog allows you
to enter the number of degrees of rotation. Rotation is positive anti-
clockwise.

Rescale
Multiplies the coordinates of all the selected shapes in the Shape
window by a specified scaling factor in each axis direction. This has
the effect of rescaling the selected shapes by the specified amounts.

Move
Allows you to move the selected shapes in the Shape window a
specified distance This provides a more accurate way of moving
shapes rather than dragging them with the mouse.

Flip Horizontal
Reflects the selected shapes in the Shape window about a vertical
axis passing through the centroid of the area of the selected shapes.

Flip Vertical
Reflects the selected shapes in the Shape window about a horizontal
axis passing through the centroid of the area of the selected shapes.

Align
Align the selected shapes in the Shape window. A dialog will let you
specify whether to align the objects to the grid or to each other and
whether the align is done vertically or horizontally.

Align To Centroid
 (Windows Only)
 See “Align To Centroid Submenu”

Arrange Menu
See “Arrange Submenu”
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Align to Centroid
Submenu

(Windows Only)
The Align to Centroid submenu moves the selected shapes in the
Shape window as a group so that the centroid of the area of the
selected shapes is aligned with the origin of either or both of the x
and y axes. You will usually use this command prior to installing the
section in the Sections Library as it will make the calculation of all
the sections properties relative to a set of axes passing through the
centroid of the section.

Centroid
Aligns both x and y centroids to the x and y axes.

X Axis Only
Aligns the x centroid to the x axis

Y Axis Only
Aligns the y centroid to the y axis

Arrange Submenu
The Arrange submenu has commands for controlling the order in
which shapes are drawn in the Shape window. If you have the
display of material patterns turned on, the shapes drawn last may
obscure the shapes drawn first.

Move To Front
Moves the selected shapes forward so that they are drawn last and
will be in front of all other shapes.

Move To Back
Moves the selected shapes backward so that they are drawn first and
may be obscured by other shapes.

Move Forwards
Moves the selected shapes just in front of the shapes in front of them
so that they are drawn after those shapes and will be displayed in
front of them on the screen.

Move Backwards
Moves the selected shapes just behind the shapes behind them so
that they are drawn before those shapes and may be obscured by
them.

Material Menu
The Material menu contains commands for working with materials
in the sections library.

Add Material
Add a material to the Sections Library. This material will then be
available for use in any of the sections you draw. You enter the
properties for the material and can design a pattern to be used in
shapes made from this material

Delete Material
Remove a material or a number of materials from the Sections
Library.
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Edit Material
Change the name, properties or pattern of a material stored in the
Sections Library.

Select Material
Choose a material from the Sections Library to be used for the
selected shapes in the Shape window. When the section properties
for the section are calculated, these shapes will take their Young's
Modulus and Shear Modulus from the data stored with the material.
The pattern of the material will be displayed in the shapes which are
selected when you use this command.

Remove Material
Removes the material types from the selected shapes in the Shape
window. Section Maker then treats these shapes as holes or voids.

Section Menu
The Section Menu contains commands for working with sections and
groups of sections.

Add Group
Add a group to the Sections Library. A new group can be used to
store a number of related sections together. You enter a name and
type for the group. It will be made the current group and displayed
in the Group and Section windows.

Delete Group
Remove a group or a number of groups from the Sections Library.

Add Field
Add a field to the current group in the Sections Library. A field can
be used for storing additional properties for a section. After adding a
field, you should enter the name, units and units factor for the field
in the Group window.

Delete Field
Delete a field or number of fields from the current group in the
Sections Library. You should NOT delete any of the first eleven
standard fields as Multiframe requires them for analysis.

Select Group
Choose which group is to be displayed in the Group and Section
windows. This group is referred to in this manual as the current
group.

Group Info
Displays a dialog allowing you to specify the properties and name of
the current group.

Add Section
Add a section or a number of sections to the current group. The
sections will be displayed in the Section window where you can type
in values for the sections' names and properties..

Delete Section
Delete a section or a number of sections from the current group.

Group Organiser
(Windows Only)
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Displays a dialog allowing you to move groups of sections from one
sections library to another.

Display Menu
The items in the Display menu control the display of tables in the
Data window and symbols in the Shape window.

Properties
(Macintosh Only)
Display the table of calculated section properties for the shapes in the
Shape window

Polygons
Display the table of polygon coordinates, material types and
thicknesses for the polygons in the Shape window

Circles
Display the table of circle coordinates, material types and thicknesses
for the circles in the Shape window

Rectangles
Display the table of rectangle coordinates, material types and
thicknesses for the rectangles in the Shape window

Materials
Turn on or off the display of materials in the Shape window. If this
item is checked, the patterns for the appropriate materials will be
displayed inside the shapes in the Shape window. Is this item is
unchecked, the patterns will not be displayed.

Shape Numbers
Turns on and off the display of the number of each shape in the
Shape window. The number is displayed in the center of the shape
and is prefixed by a letter code for the type of shape, p for polygon, c
for circle and r for rectangle. You can use these numbers to refer to
the shapes in the Data window.

Polygon Numbers
Turns on and off the display of the number of each vertex of each
polygon in the Shape window. You can use these numbers to refer to
the polygon coordinates displayed in the Data window.

Window Menu
The items in the Window menu control the display of windows in
Section Maker

Tile Horizontal
Arranges the currently visible windows down the screen to fill the
screen.

Tile Vertical
Arranges the currently visible windows across the screen to fill the
screen.

Arrange Icons
(Windows Only)
Tidies up the display of window icons in the program window.

Shape
Make the Shape window visible and bring it to the front
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Data
Make the Data window visible and bring it to the front

Group
Make the Group window visible and bring it to the front

Section
Make the Section window visible and bring it to the front

Properties
Make the Properties window visible and bring it to the front

Tile
(Macintosh Only)
Lay out the windows so that they fit together to fill the screen.

Stack
(Macintosh Only)
Stack up the windows on the screen from top left to bottom right so
that the windows are near to their maximum size.

Drawing Layout
(Macintosh Only)
Resizes the windows so that the Shape, Properties and Data
windows are conveniently located for drawing new sections and
viewing their properties.

Help Menu
(Windows Only)
The Help menu contains commands for accessing Section Maker's
on-line help system.

Table of Contents
Displays the Table of Contents for the on-line help system.

About Section Maker
Displays version information for this version of Section Maker.
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Chapter 4
Sections Calculations
This chapter describes the methods that Section Maker uses to
calculate section properties.

Properties for
Analysis

Multiframe uses the matrix stiffness method of solution for solving a
system of simultaneous equations to determine the forces and
deflections in a structure. As part of this analysis it uses sections
properties stored in the Sections Library. The key analysis properties
used by Multiframe are

Name Property Units
Metric English

Mass Mass per unit length kg/m lb/ft
A Cross sectional area mm2 in2

Ix Major moment of inertia mm4 in4

Iy Minor moment of inertia mm4 in4

J Torsion constant mm4 in4

E Young's Modulus MPa ksi
G Shear Modulus MPa ksi

If you use the option to include the affects of shear deformation, then
Multiframe will also use

Asx Shear area in minor direction mm2 in2

Asy Shear area in major direction mm2 in2

For display of rendered shapes and section orientation and for
placing sections into Section Maker the following dimensional
properties are also required

D Depth mm in
B Breadth or Width mm in
tf Flange thickness mm in
tw Web thickness mm in

When you add a section to the Sections Library you must insure that
all of the analysis properties are correctly entered and are all non-
zero. If you want to render in Multiframe or place the section in
Section Maker you must also insure that the dimensional properties
are correctly entered.

Steel Designer also uses additional properties from the Sections
Library. If you add any sections to the library you should insure that
the following properties are entered correctly.

Name Property
Zx (or Sx) Section modulus about x axis
Zy (or Sy) Section modulus about y axis
rx Major radius of gyration
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ry Minor radius of gyration
rz Radius of gyration about weakest axis

When you add a section to the Sections Library you must ensure that
all of the properties above are correctly entered and are all non-zero.

Axes and Sign
Convention

Section Maker uses a simple two dimensional coordinate system for
defining structural shapes. When the shape is used in Multiframe3D
it will be placed in the local coordinate system of the member so that
the x axis in Section Maker aligns with the local z' axis of the
member. This means that in the stiffness matrix of Multiframe3D (see
Chapter 4 of the Multiframe3D user manual) the moment of inertia
Iz' corresponds to the moment of inertia Ix calculated in Section
Maker. Similarly Iy' corresponds to Iy in Section Maker.

The orientation of the section relative to the position of the member
is set using the orientation command in Multiframe 3D. The
orientation is the angle between the y' axis ( the y axis of the section)
and a vertical plane passing through the ends of the member.

Overlapping Shapes
If you create a section which is composed of a number of
overlapping shapes you should be aware of how Section Maker
treats these for calculation purposes.

First, don't partially overlap shapes, the properties won't be
computed correctly. You may have a shape completely inside
another or completely separate but they may not partially overlap.

When you have one shape inside another shape and the inner shape
is not a hole, the properties of any shape made from a material which
is not the reference material will be factored by the ratio of the
Young's Modulus of the material to the Young's Modulus of the
reference material (modular ratio).

For sections made from steel and concrete, Section Maker assumes
that concrete is the reference material and the properties of the steel
shapes will be factored by the modular ratio Es/Ec where Es is the
Young's Modulus of the steel and Ec is the Young's Modulus of the
concrete.
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Capacity
The absolute maximum capacities for Section Makerare as follows

Number of groups in a library 500
Number of sections in a group 800

The size of your library will also be limited by the amount of disk
space you have. As a rough guide, each section in the library will
require about 85 bytes of disk space. This means you can store a total
of approximately 8000 sections on an 800k floppy disk. The standard
sections libraries which come with Multiframe are usually no more
than 200k in size.

Text File Format
When you save a sections library in text format the data is formatted
according to the following procedure

Number of groups in the file
For each group
1 if the group is locked or 0 otherwise
Name of the group
Number of the group in the library
Kind of material 1 for steel, 2 for concrete, 3 for timber, 4
for aluminum, 0 otherwise
Shape of sections in the group I=1, C=2, equal L=3, unequal L
=4, T=5, RHS=6, SHS=7, Tube=8, Circle=9, bar=10, round bar=11.
No of sections, no of fields and no of analysis properties in
the group
Position of the analysis properties in the fields of the group
For the number of fields
Name of the field
For the number of fields
Units of the field
For the number of fields
Factor of the field
For the number of sections
Name of the section
For the number of fields
Value of the field for this section

The easiest way to understand the format is to use the Export
command to save a text file from a sample library and to review or
modify that text file.

References
You may find the following books useful to refer to if you need
information on the methods used to calculate sections properties.
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• Roark's Formulas for Stress and Strain, 6th Edition

W C Young, McGraw Hill, New York, 1989

• The Behavior and Design of Steel Structures

N S Trahair and M A Bradford, Chapman and Hall, London, 1988

• Elements of Strength of Materials

S P Timoshenko and D H Young, Van Nostrand, 1968
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