
his 
Table of Contents
Printable Documentation

Update Information

Executive Summary

Quick Start Guide

The Wizard

Define the Set

Optional Settings

Computer Names

Client Settings

TCP/IP

Licensing

Main Console

Working with Sets

Computer Name List

Assigning Aliase

Preparing a Job

Comma Delimited Files

RapiDeploy Client

Technical Support

Legal

Update Information
Return to this page on-line at www.altiris.com/software/docs to learn about the latest changes to LabExpert and t
documentation. Information about both are updated whenever changes are made.
 1998, 1999 Altiris, Inc. page 1 of 14



ystem 
e only 
chni-

onsult-
w PCs 

ata files 
ments 
que 

undred 

ront-
mpo-

figura-
ber of 
f only a 

 login 
 con-

files 
u insert 
ueue. 

 RDClient 
t of 

nt.to re-
in. These 

cast an 
 the 
gra

s 95/
t runs 
nt to run 
t the Cli-
Executive Summary
RapiDeploy™ is the configuration solution used to fully deploy and configure new PCs by migrating existing s
images. Whether you are using RapiDeploy or RapiDeploy for Technicians, the instructions are the same. Th
difference between the products is the limitation of five computer downloads at a time with RapiDeploy for Te
cians.

RapiDeploy is a powerful time and money saving tool for IS departments, PC configuration centers, contract c
ants, integrators and value added resellers (VARs). RapiDeploy provides the fastest way to fully configure ne
and servers, migrate existing systems and restore previously configured systems. 

RapiDeploy provides all the tools necessary to duplicate the operating system, applications and associated d
of any PC. For the installation of complex system environments, RapiDeploy provides for the security require
necessary in today's networked systems such as NetWare, Windows 95/98/NT. It even includes control of uni
computer names, IP addresses and NT Security ID (SID) numbers. 

RapiDeploy significantly reduces time and costs associated with system configuration by installing twenty, a h
or even thousands of machines at a time—completing in minutes what otherwise takes hours or days.

Components
RapiDeploy simplifies the tasks required to install and configure multiple computers. By combining a unique f
end utility with already proven imaging software, Altiris saves you hours and days of labor and frustration. Co
nents of RapiDeploy are described below.

Configuration Wizard
The RapiDeploy Wizard walks you through the creation of sets. Sets are made up of computers and their con
tion information. By creating multiple sets, each with unique configuration definitions, you can deploy any num
PCs across a network. And best of all, you can deploy two to two thousand PCs in the same amount of timeo
few minutes. 

The Wizard allows you to define computer names, Microsoft Workgroups or Domains, Novell NetWare Client
preferences, TCP/IP, DHCP, DNS/WINS settings and product licensing information. All this data is stored in a
figuration database. 

Management Console
The RapiDeploy Management Console allows you to further define information stored in the RapiDeploy Set 
(.rds files created when sets are saved) and the Configuration Database. From the management console, yo
Sets into a Job Queue. You can even take portions of a predefined Set and create a sub-job within the Job Q

The Job Queue defines the order in which the Jobs are executed or you can use command line switches with
to specify which job or computer to use. This versatility allows you to deploy the desired image to a whole se
computers or several images to smaller groups of PCs. 

ImageBlaster Agent
ImageBlaster technology uses exclusive, network multicast capabilities grouped under the ImageBlaster Age
create a precise system environment. Once you have created a disk image, you can use it over and over aga
images can be compressed, stored and catalogued on a server for future use. Or, you can immediately multi
image of the internal hard drive, an attached CDROM or Tape drive, etc. of any PC on the network. And with
optional AutoImager, you can create self-extracting executable files to be distributed independently of any pro
or utility.

Client Configuration Agent
RapiDeploy includes two versions of the client configuration agent, one for Windows NT, the other for Window
98. Both versions perform similar tasks on their respective operating systems. The Client Configuration Agen
manually or can be included in the image file installed as part of the cloning process by the ImageBlaster Age
as a service following the boot sequence. The Sequence of Operations section of this document assumes tha
 1998, 1999 Altiris, Inc. page 2 of 14
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ent Configuration Agent is installed as a service and runs automatically following the target computer’s next b
sequence.

This Client Configuration Agent requires the use of a source file, which is placed on the hard drive by the Ima
Agent during the imaging process. The source file contains specific configura- tion information such as IP ad
and computer name, which is unique to that PC. If this source file is found, the Configuration Agent makes ch
to the registry as specified by the source file. If the source file is not found the Client Configuration Agent prom
the user for the required information. 

When its task is completed and there have been no errors, the Client Configuration Agent deletes the source
own executable, and the error log file. Optionally, the Client Configuration Agent updates the status for the sp
PC being configured in the Name/Alias object in the Status Database. 

The Client Configuration Agent displays critical error and informational messages on the screen while it is run
regardless of the mode. Other errors and messages are written in a .LOG file at the root of the partition conta
system root directory

RDClient
RDClient is the DOS based utility that instructs a client to search for a RapiDeploy Set file. RDClient can do n
by itself. It is dependant on what already exists in the .rds files, the Configuration Database, the ImageBlaste
and the Client Configuration Agent.

SIDgen
Imaging or cloning Windows NT computers can sometimes present a problem. Typically, Windows NT server
workstations are identified to a Domain-based network by a Security ID (SID). Since this identifier must be u
sharing an image of one Windows NT computer with other computers on the network could cause conflicts. W
this limitation precludes the use of many disk duplicating technologies, SIDgen solves the problem.

SIDgen is a security attribute modification utility for Windows NT. SIDgen works with Microsofts on Windows N
4.0 Workstations and Servers (including Primary and Backup Domain Controllers). This replacement process
transparent to the end user. When it is done, everything appears normal. All security entries still list the same
groups and all user preferences remain intact.

Altiris partnered with Microsoft in the development of the Windows NT 4.0 System Preparation Tool. This coll
tion allows you to use the System Preparation Tool to do part of the work and use SIDgen to complete the job
full support of Microsoft.
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Quick Start Guide
Once the installation and configuration of RapiDeploy is complete, you’ll be able to control the imaging of net
worked computers from a single PC (your Control Console).

The following instructions assume you have already downloaded the RapiDeploy Suite onto a network server
installed it). To simplify the learning process, use only three client computers plus a server to complete the in
tions in this Quick Start Guide. For Windows NT, the Control Console and the server can be the same comput
client computer should be designated as one of the following:

• the RapiDeploy Control Console (RCC)

• the image source computer

• the image recipient computer

When you finish, you’ll know how to simultaneously image hundreds of PCs in just minutes. 

Because this is a Quick Start Guide, explanations and detailed steps are kept to a minimum. For additional in
tion on the configuration and use of the RapiDeploy Suite, see the online manual at www.altiris.com/software/docs/.

Install RapiDeploy 
1. From your future RCC computer, run RD_SETUP.EXE 

2. When prompted for a destination directory, provide a path and directory. 

For example: F:\RDEPLOY

3. When prompted for the Licensee Name and Key (both are case and space sensitive), enter them as supplie
from Altiris or your authorized reseller.

Create Boot Diskettes 
Use the Boot Disk Wizard to create diskettes that boot the computers, connect them to the server, then down
image. You need two blank diskettes to complete this step.

1. Make sure the RCC client has Internet access to retrieve the necessary drivers.

2. Select Start > Programs > Altiris RapiDeploy > Boot Disk Wizard.

3. Select the appropriate DOS for the clients.

4. Select the server type.

5. Select the protocol.

6. Select and configure the appropriate NIC type.

7. Using the directions provided in the information frame of the Server Authentication window, set your network 
drive mapping.

8. Select RapiDeploy for the application type.

9. Define a computer alias for identification within the RCC.

10. Set the duplication count to 2 (two) and change computer name when prompted for the second diskette.

For further instructions, see the Boot Disk Wizard documentation.

Create the Client Install Diskette
To include RapiDeploy’s client configuration agent, include the following components in the source computer’
image:

1. Obtain a blank, formatted diskette.

2. From the RCC computer, choose Start > Programs > Altiris Client Install > Make Client Diskette 

The diskette is created with the appropriate files.

Create the Image File
1. Use a computer with an existing setup, or

i. Load and configure the desired Operating Syste
 1998, 1999 Altiris, Inc. page 4 of 14
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ii. Load desired applications and data files 

Important:  To image PCs that will be Windows NT domain members, the original image must be create
a domain member

2. Insert the new Client Install Diskette in the image source computer (it should currently be up and running W
dows) and run SETUP.EXE. 

a. Select Client Configuration for RapiDeploy. Make any other appropriate selections for your client co
puters

b. When this client installation is complete, remove the diskette.

Note: For Windows 95/98, the install process makes an entry in the registry at the key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunServices

For Windows NT the agent gets loaded as a service viewable within the Services Control Panel.

The future image should now be complete and ready to upload to the server for storage and use.

3. Boot the image source computer with a diskette created earlier with the Boot Disk Wizard. When the scr
plays, “Waiting for any master...”, press <Ctrl> C.

4. From the F:\RDEPLOY, run IBMASTER.EXE

a. Select Upload to Image File
b. Select the Partition(s) to image
c. Enter an image file name such as TESTSET1.IMG
d. Select Start

The ImageBlaster Agent window displays an active status of the upload process.

Create the Configuration Database 
1. The configuration database is created from within the RapiDeploy Console. To open the console, choose

Start > Programs > Altiris RapiDeploy > RapiDeploy Console

2. The Getting Started help window displays. You can either follow the instructions as presented or close it
continue on your own.

Note: The first time RapiDeploy Console opens, the Set Wizard displays automatically once the Getting 
help window is closed.

3. Make selections and complete the fields as requested. Access What’s This? Help to determine the function of 
each option. Create two computers for this exercise.

4. Select File > Save

Important:  All target computer names to be put into an NT domain must be added to the receiving dom
Server Manager list before running  RDCLIENT.EXE.

Establish RapiDeploy Jobs 
The RapiDeploy Management Console consists of three main windows:

• Sets created through the RapiDeploy Wizard or from comma-delimited files

• Job Queue (determines default order of deployment jobs)

• Computer Name List (displays computers and alias names, etc. in each Set or Job)

A Job is created by dragging a Set into the Job window. As clients are booted with a BootWorks Boot Diskette
earlier, each client looks for a job to execute.

Download an Image
1. Boot each target PC with a boot diskette created earlier.

2. Execute RDCLIENT.EXE -w

The -w tells the target computer to wait until the Master is ready to broadcast.

Note: RDCLIENT checks the Configuration Database (created earlier when the Set was created) to dete
which Image File should be used and which configuration values to assign to the target PCs. RDCLIENT
 1998, 1999 Altiris, Inc. page 5 of 14
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restores the hard drive using the assigned image. It then writes the configuration values to the target dri
later use by the configuration agent.  

3. When prompted, remove the floppy diskettes from each target PC.

Each target PC automatically reboots from its local hard disk drive, reads the individual configuration inf
tion and updates the Registry file.

If any check box was marked for “Prompt user for confirmation of these settings,” each image recipient c
puter pauses until you log on after the first time the target PCs boot. Otherwise, ignore all Windows instr
until the computer reboots the last time and comes up to a normal Windows 95/98/NT screen.

The Client Configuration Agent then removes itself, deletes any associated files used with RapiDeploy fr
local hard drive and the process is complete. 

Details are available in the complete documentation at www.altiris.com/software/docs
 1998, 1999 Altiris, Inc. page 6 of 14
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Stepping Through the Wizard 
When you start the RapiDeploy Console, the Getting Started help window displays. You can either follow the 
tions as presented or close it and continue on your own.

The first time RapiDeploy Console opens, the Set Wizard displays automatically once the Getting Started hel
dow is closed. To use the wizard for future set definitions, click the New Set icon below the menu bar.

Define the Set
1. Provide a descriptive name to help you remember which group of computers this set is designed for. Fo

ple, use the computer type such as Compaq or Dell, or a client name such as Fast Computers, Inc.

2. Enter the number of computers you want configured with this set. You can define 10 computers and reus
as often as you want. You can also define a thousand computers, start the set once and deploy only a fe
puters at a time. Each time you run RDCLIENT.EXE from a target computer, that computer automatically
the next computer name in the active set until the computers defined within that set have been complete
Optional switches are available to control changes in the defaults. 

An option allows you to import an existing file with comma-delimited fields. The number of computers an
other data to be used in this set come from the imported file. Read the information about the required fo
comma-delimited files. The Import option is available from the File menu at the main console. 

3. Enter or browse for an image file you created using IBMASTER.EXE. The file name entered here becom
associated with this set. Once selected, the file creation date, size and description (if any) are displayed
information cannot be entered here, it is read from the selected file. You also have an option to resize th
tions on the target PCs. Click the Resize Partitions… button. See: Resizing Partitions in the ImageBlaster 
Agent documentation.

Optional Settings
In general, the four buttons displayed here, allow you to define options. There are existing defaults so you ca
tinue without going into any of these options. Or, you can select from or define the options listed under each.
the selection and provide all the information pertinent to your network and client computers targeted with this

Each of the four main options includes an additional check box to: Prompt user for confirmation of these settings 
during the initial login. 

For each time you check this box, the future user is prompted to confirm or change the information you enter
before their login session continues.

Computer Names
Because some manufacturers expect certain computer names to exist, those names are created along with t
configuration at the manufacturers. In cases like these, click the radio button for: Don’t change Computer Name 
settings.

When the computer name doesn t matter to you or to the user at the final destination, select: Automatically assig
unique names.

If you want a specific name to be used as the core text, select: Use a static range.

Additional characters are prepended by default. You can change them to be appended by selecting the Append check 
box. You can define the text to be used and the starting number range. Based on the number of computers you defined 
in the first Wizard screen, the results of your selections are displayed in the Results field.

You can define the Microsoft Windows 95/98/NT Workgroup or Domain name by clicking the option and filling
the name you want. If these computers won t be connected to a Windows 95/98/NT network, you can leave t
blank.

Reminder! To define a Windows NT Domain at this time, you must have defined the original image as a mem
a Windows NT Domain.
 1998, 1999 Altiris, Inc. page 7 of 14
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NetWare Client Settings
When you’re imaging computers for a NetWare network, include the appropriate information to make the logi
cess easier for the end user. If the target PCs came pre-configured for the specific network adapter already in
you might want to leave that information intact. You can select: Don’t change NetWare Client set-
tings . 

Otherwise, select Connect to NetWare via :

• Preferred Server if you need to be that specific, or

• Preferred Tree when the user’s access point doesn t matter. Be sure to define the NDS Context the user
defined in.

If you want the users to execute login scripts the first time they log into a network, click the Run login scripts box.

As with all these options, you can force confirmation of your selections by clicking the Prompt user for confirma-
tion of these settingsbox.

TCP/IP Settings
There may be occasions when you are re-imaging computers that are already in service. In these cases, you
don t want to reconfigure TCP/IP settings. You can instruct the imaging process to ignore any changes by sel
Don’t change TCP/IP settings. 

NOTE: As a background process during installation of the NT client configuration prograClCfgNT.EXE - 
install , DHCP is temporarily used, no matter what you defined within the Wizard. This releases any predefine
IP address during installation of the client configuration agent. After the image is copied to the local hard driv
client configuration agent reads your defined information and applies it to individual PCs, thus applying or res
your TCP/IP settings.

Many companies today take advantage of Dynamic Host Configuration Protocol (DHCP) servers. DHCP allow
dynamic allocation of TCP/IP addressing every time a computer connects to the network. DHCP eliminates th
potentially heavy overhead required for static configurations. DHCP and its associated usage provides all req
information dynamically.

If you need to create static IP addresses, select Specify range. By including the From range, the appropriate 
addresses is filled in according to the number of computers selected in the first screen. These addresses mus
acquired from the governing authority.

The Netmask, Gateway, Domain and DNS/WINS settings are completely dependant upon the networks to whic
these computers will become a part. Explaining the complexities of TCP/IP is beyond the scope of this progra
document. Before establishing any information through these options, be sure you are fully acquainted with T
and all of its associated requirements.

As with all these options, you can force confirmation of your selections by clicking the 

Prompt user for confirmation of these settings box .

Product Licensing
Product Licensing refers to the Operating System being imaged to each target PC. Since each PC receives t
operating system, with the same license number, the future owners must have a licensing agreement that all

One possible exception may be allowed by selecting the Prompt user for confirmation of these settings box to 
cause users to enter their correct license information the first time they boot the computer.
 1998, 1999 Altiris, Inc. page 8 of 14
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Using the Main Console 
The RapiDeploy Management Console consists of three main windows:

• Sets created through the RapiDeploy Wizard or from comma-delimited files

• Job Queue (determines default order of deployment jobs)

• Computer Name List (displays computers and alias names in each Set)

RapiDeploy’s Control Console provides the interface for configuring jobs and viewing their status. You can ac
each of the following tasks from the Main Console by using Windows’standard drag-and-drop and selection f

• Open sets

• Define new sets

• Create and assign alias names

• Add jobs 
• Create sub-jobs

• Start & stop jobs

• View status of all jobs

When a set is selected, the computer name list displays:

• Computer names

• Alias names (if they have been assigned)

• IP Addresses (DHCP unless otherwise assigned)

When a job  or computer name is selected, the computer name list displays:

• Computer names 

• Alias names (if they've been assigned 

• Status of individual computers

• White (ready/waiting)
• Blue (in progress)
• Green (complete)
• Red (error)

When a job  is selected, the job list  indicates: 

• White (ready/waiting)

• Blue (in progress)

• Green (complete)

• Red (error)

• Grey (on hold)

You can view the properties of any item displayed in the console by double clicking or by right clicking and se
Properties from the menu. Different property options appear according to the item selected. Some property va
can not be altered once the job has been defined.

Working with Sets
Sets are created through the RapiDeploy Wizard or by importing predefined comma-delimited files. After the Get-
ting Started help is closed, the Wizard  opens automatically the first time you run RapiDeploy. Once a set has b
defined, RapiDeploy Console opens directly to the main console. 

To open an existing set and add it to the list, select an image file from File > Open and browse for the image file you
want to use.

To create a new set using the Wizard, click the New Sets icon in the menu bar and the Wizard opens. See Defining
Sets 

To create a set from a comma-delimited file, select File > Import  and browse for the file defining the properties yo
want to use.

From View > Aliases, display a list of all defined Alias names and add or remove names from the list.
 1998, 1999 Altiris, Inc. page 9 of 14
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When you highlight a set, then click anywhere in the computer name list, you can use the New Computer icon. 
Clicking this icon creates a new computer, identical to existing computers in the set, with the exception of the
and address, which is incremented. Alias names are not automatically assigned.

Note: If you highlight a job, then click in the computer name list, you cannot add computers. You must start fro
set’s list.

Computer Name List
The Computer Name listis dynamic and displays information and status according to the set or job selected. 
with computer names, alias names are displayed when they’ve been assigned. 

When a set is selected, the computer name list includes the IP Address column. The IP Address list displays
unless a specific IP address was assigned during creation of the set.

When a job or computer name is selected, the computer name list displays a Status column. 

Assigning Aliases
To view Computer Aliases, select a Set or a Computer Name

Open View > Aliases

To create new Computer Aliases, click Add , enter a name, click OK .

To remove a Computer Alias, highlight a name, click Remove

To assign a Computer Alias to a computer name, right click on a computer name, select Alias.

The menu displays:

[Auto]
Clear
Pick List…
And up to 25 Alias names

[Auto]  assigns an Alias to every computer in the list. Computers are assigned from top to bottom in the list, u
last Alias created and working backwards through the alias names as they were created.

Clear removes the Aliases from every highlighted Computer Name in the list.

Pick List… allows you to select a specific Computer Alias to be assigned to the Computer Name already high

If you have fewer than 26 Computer Alias names in your list, all the Computer Aliases appear in the menu be
Pick List…  If you have more than 25 Computer Alias names in your list, none appear in the menu below the Pick 
List…

Preparing a Job
The Job Queue displays sets that have been added to the job queue. Add jobs to the job queue by dragging se
the job queue. You can create sub-jobs by highlighting some computer names and dragging them into the Job
This creates a temporary Set within the Job Queue. 

Each PC booted with the RapiDeploy Client looks at the Job Queue and takes the next configuration definitio
the current job and its unused computers remaining in the computer name list. This process continues until a
and their computers are deployed. 

Optional command line switches for RDCLIENT.EXE  allow overriding this default job selection by specifying 
which job and computer definition to use.

Accessing AutoImager
RapiDeploy AutoImager is another adaptation of Altiris’ ImageBlaster technology. By creating a self-extractin
cutable file from either a new or existing image, you can give your clients an instant disaster recovery solution
whether they’re in the next cube or around the world. AutoImager is a seperately licensed option to RapiDepl
can access AutoImager from the the File > Export menu. For complete documentation, see AutoImager.
 1998, 1999 Altiris, Inc. page 10 of 14



s must 
ches 

he last 

e is no 

der they 
er of the 

 the 
Formatting Comma Delimited Files
To make a comma-delimited file usable by RapiDeploy, you must create it with the correct format. All 26 field
exist, in the proper order, even if the field is empty. Some fields require unique information, others act as swit
requiring only a 1 or 0. Still other fields accept specific number configurations such as IP addresses.

The fields are divided into two categories:

• Computer Parameters

• Set Parameters

The first six fields are in the Computer Parameters group. Data for these fields can change from row to row. T
twenty fields are Set Parameters and must be the same for all rows in the import file.

As the name implies, commas are used to separate the fields.  There are 26 fields requiring 25 commas, ther
comma before the first field nor following the last field. 

The name of each field with its corresponding description is listed in Table 1 and the fields are listed in the or
must appear in the comma-delimited file. The order of the fields you see in the Wizard does not match the ord
fields in a comma-delimited file. To execute RDCLIENT.EXE, boot your Windows 95/98/NT client with one of
diskettes prepared with the Boot Disk Wizard.

Table 1: Field Definitions for Comma-Delimited Files

Computer Parameters

 1 Computer name This name is applied to each computer created in a set. When left blank, the 
name is left unchanged from that of the image.

 2 Alias Aliases are generally reused over and over. They might be assigned to a par-
ticular configuration station or slot, so the operator doesnt need to care about 
the computer name. It can also be applied to a specific user’s computer for 
restoration purposes.

 3 User name The user name assigned to the use of the operating system license.

 4 Organization 
name

The organization name assigned to the use of the operating system license.

 5 Product id The identification number assigned to the operating system product license.

 6 IP address The static dotted-decimal IP address to be assigned during the imaging pro-
cess.

Set Parameters

 7 Hostname The TCP/IP hostname for the computer.

 8 Image file File name of image to be used.

 9 Change TCP/IP A 1 (one)  uses ip-addr from above. A 0 (zero) leaves IP address 
unchanged.

10 Use DHCP A 1 (one)  sends the client, upon booting, to a Dynamic Host Configuration 
Protocol (DHCP) server for its IP address. A 0 (zero) does not.

11 Netmask The dotted-decimal number designating classes of addresses and subnets.

12 Gateway The address of the computer that provides an access point to the Internet.

13 Domain The TCP/IP Domain Name for this computer.
 1998, 1999 Altiris, Inc. page 11 of 14
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RDCLIENT
RDCLIENT.EXE looks for the first available job and the first available computer in that job. You can prevent th
default instructions from executing by including one or more available switches.The three available switches a
independent from each other, can be used in any combination and include the following: 

By including the actual computer or alias name from an active job, RDClient starts looking for the specified co
in the current job. If it isn t found there, it looks through subsequent jobs until it either finds the computer nam
executes it or doesn t find it and displays this message:

RDCLIENT Error: No jobs available to process

By including the job description of a job in the job queue, RDClient looks for that job in the job queue. If found
job begins with the first available computer. If that job is not found, this message is displayed:

RDCLIENT Error: No jobs available to process

You can execute RDClient even without jobs and/or computers available by including the -w switch. It tells the
puter on which it is executed to wait until a master computer multicasts a ready message AND a job/compute

14 DNS1 Domain Name Server entry one.

15 DNS2 Domain Name Server entry two.

16 DNS3 Domain Name Server entry three.

17 WINS1 Windows Internet Naming Server entry one.

18 WINS2 Windows Internet Naming Server entry two.

19 Change NWcli-
ent

A 1 (one) uses the rest of the NetWare client information from this file. A 0 
(zero) ignores the other information and leaves the client unchanged.

20 Use tree? A 1 (one)  uses the preferred tree specified by the pref-tree field. A 0 (zero)  
uses the preferred server specified by the pref-sv field.

21 Preferred 
Server

Name of the preferred server to use.

22 Preferred Tree Name of the preferred tree to use.

23 Context Context where the user’s name should be found at login.

24 Run scripts A 1 (one)  causes login scripts to be executed upon login. A 0 (zero)  
ignores scripts.

25 Use workgroup A 1 (one)  causes Windows 95/98/NT to use the workgroup name defined in 
the wg/dom-name field. A 0 (zero)  causes Windows 95/98/NT to use the 
domain name defined in the wg/dom-name field.

26 wg/dom-name The name used according to the use-workgroup field.

Table 2: RDCLIENT SWITCHES

c:<computer-name> Select this computer (name or alias)

j:<job-description> Select this job

w Wait until something to do

Table 1: Field Definitions for Comma-Delimited Files
 1998, 1999 Altiris, Inc. page 12 of 14
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becomes available. If a job/computer is available, RDClient continues normally. When no job/computer is ava
this message is displayed:

Waiting for job ( Esc  to abort) [  \   ]

The rotating line inside the square brackets lets you know that this client is waiting. 

As soon as a job/computer becomes available, the job begins and the SLAVE status screen displays. When down-
load completes, RDClient instructs the computer to reboot, execute the Configuration Client Agent already co
that computer, and apply the specific information appropriate for that computer. For a Windows NT computer,
gen may also execute establishing unique SID information.

Technical Support
Altiris is dedicated to giving you the best support possible. Please check the Automated FAQ System on our w
before contacting us with your questions. 

Be sure to include a detailed description of your environment, the problem, and any error messages you have
received. We welcome and encourage all feedback and enhancement requests. 

You can contact the Altiris Support staff by phone, fax, mail or e-mail.

Mail
Altiris, Inc.

387 South 520 West

Lindon, Utah 84042

Email 
Quick response E-mail support at support@altiris.com 

Phone 
Call us at (801) 226-8500 (Monday through Friday, 8am to 5pm MDT). Phone support is always free during a 
evaluation period and for at least 90 days following purchase. 

Fax 
Send a Fax to Altiris’ Support by using (801) 226-8506.  

Web
www.altiris.com

Feedback
To submit comments and suggestions about this documentation, send an email to:

support@altiris.com 

Please include complete details of your questions, suggestions and examples.

Thank you for using Altiris products!
 1998, 1999 Altiris, Inc. page 13 of 14
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Legal

Disclaimer
Information in this document is subject to change without notice. The software described in this document is 
nished under a license agreement or nondisclosure agreement. The software may be used or copied only in 
dance with the terms of those agreements. No part of this publication may be reproduced, stored in a retrieva
or transmitted in any form or any means electronic or mechanical, including photocopying and recording for a
pose other than the purchaser’s personal use without the express written permission of Altiris, Inc. 

Limitation of Liability
ALTIRIS’ AGGREGATE LIABILITY ARISING FROM OR RELATING TO THIS AGREEMENT OR THE SOFT-
WARE, DOCUMENTATION, OR SERVICES (REGARDLESS OF THE FORM OF ACTION OR CLAIM - E.G.,
BUT NOT LIMITED TO, CONTRACT, WARRANTY, TORT, MALPRACTICE, FRAUD AND/OR OTHERWISE)
IS LIMITED TO THE TOTAL OF ALL PAYMENTS RECEIVED BY ALTIRIS FROM CUSTOMER UNDER 
THIS AGREEMENT. ALTIRIS SHALL NOT IN ANY CASE BE LIABLE FOR ANY SPECIAL, INCIDENTAL, 
CONSEQUENTIAL, INDIRECT OR PUNITIVE DAMAGES EVEN IF ALTIRIS HAS BEEN ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGES. ALTIRIS IS NOT RESPONSIBLE FOR LOST PROFITS OR REVENUE
LOSS OF USE OF SOFTWARE OR OTHER PROGRAMS, LOSS OF DATA, COSTS OF RE-CREATING LOS
DATA, THE COST OF ANY SUBSTITUTE EQUIPMENT OR PROGRAM OR CLAIMS BY ANY PARTY 
OTHER THAN CUSTOMER.

Copyrights
Copyright © 1997-1999 Altiris, Inc. All rights reserved. 

Portions of the software described in this document copyright © Novell Corporation. All rights reserved. 

Portions of the software described in this document copyright © Microsoft Corporation. All rights reserved. 

Patents
U.S. PATENT NO.: 5,764,593 was issued for “BootWorks,” a METHOD AND SYSTEM FOR THE INTERCEP
TION AND CONTROL OF THE COMPUTER BOOT PROCESS.

Trademarks
Altiris, RapiDeploy, LabExpert, ImageBlaster Agent, ImageBlaster, ImageBlaster Pro, BootWorks, SIDgen, Bo
Disk Wizard, Image Explorer and RapiDeploy AutoImager are trademarks or registered trademarks of Altiris,
the USA and other countries. 

KeyLabs is a trademark of KeyLabs, Inc.

Novell, NetWare and IntranetWare are trademarks or registered trademarks of Novell, Inc. 

Microsoft and Windows are trademarks or registered trademarks of Microsoft Corporation. 

Hi/fn is a trademark and LZS is a registered trademark of Hi/fn. 

Other brands and their products are trademarks or registered trademarks of their respective holders.

Altiris, Inc. 

387 South 520 West 

Lindon, UT 84042 

U.S.A. 

801-226-8500
 1998, 1999 Altiris, Inc. page 14 of 14
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