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LabExpert Quick Start Guide
Welcome to Altiris LabExpert! If you require more information beyond the scope of this Quick Start guide, see
details in the on-line manual. Once you have installed LabExpert, you can perform any of the following tasks 
instantly:

• Save and restore images at will, manually or unattended

• Reboot and control every networked computer from a single PC (your Control Console)

• Upload each client’s registry files individually

• Upload new registries anytime without creating entirely new images

• Download registries (separate from the entire image) one at a time or in groups whenever necessary

LabExpert Components
LabExpert includes the use of a Lab Control Server (LCS), 
a LabExpert Control Console (LCC), and client computers
(When using Windows 95/98/NT, the LCS and the LCC 
can be the same computer.) This Quick Start Guide illus-
trates the use of LabExpert using only two client computers 
plus a server and a Control Console. Each client should be 
designated as either:

• An image source computer (a computer already 
loaded with Windows, etc.) 

• An image recipient computer (any other computer)

Before You Proceed
These instructions assume the following:

• You have already downloaded the LabExpert Suite onto a network server (either a dedicated server or a
server device) but not installed the suite, or you are installing from a distribution CD-ROM.

• You have a computer already configured with an operating system, applications and files you want to ima

Note: If you don’t have a computer ready to image, see Create a Base Image Computer in the on-line m

Install LabExpert 
1. From the Windows 95/98/NT client that you want to become the LabExpert Control Console (LCC), login

administrator to the server to which LabExpert has been downloaded. 

2. From the LCC, run the LabExpert setup utility LE_SETUP.EXE.

Accept the recommended server directory name LABEXPRT (for example: F:\LABEXPRT where F:\ is th
drive mapping to the LabExpert server.

Note: Notice the missing “E” in the directory name.

3. Enter the License key information acquired from your reseller or from Altiris. The licensee and key are bo
case and space sensitive. 

Create a BootWorks User 
1. Use the appropriate network administration utility to create a user called “bootwork” with no password.

2. Grant “bootwork” sufficient rights to create, open, read and write to the \LABEXPRT directory. 

For a Windows server: 

a. Make the LABEXPRT folder a shared folder (a Share point).

For NetWare networks only:

a. Configure the “bootwork” user to automatically set a search path to the \LABEXPRT\BIN directory. 
b. Make \LABEXPRT\DATA the current working directory for the “bootwork” user. 
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Create BootWorks Diskettes
BootWorks lets you reboot all client computers from the LCC. You can also specify which commands each co
processes as it boots. You must first install BootWorks on each client PC with a BootWorks Install diskette.

Use the Boot Disk Wizard to create three diskettes: 

• Two “Install” diskettes

• One “Boot” diskette

Create the Install Diskettes
Two Install diskettes are required to install the BootWorks Partition on two client computers. The BootWorks P
tion (also called the Automation Partition) lets LabExpert remotely image and configure the client computers.

Note: You can use either IP or IPX protocol. If using IPX, one Install diskette works on multiple clients, so you
would only need to make one Install diskette.

To create the Install diskettes, 

1. Make sure the LCC client has Internet access to retrieve the necessary drivers.

2. Select Start > Programs > Altiris LabExpert > Boot Disk Wizard.

3. Select the appropriate DOS for the clients.

4. Select the server type.

5. Select the protocol.

6. Select and configure the appropriate NIC type.

7. Using the directions provided in the information frame of the Server Authentication window, set your network 
drive mapping.

8. Select the LabExpert Install application type. 

9. Accept the default partition size of 4 MB when building an Install  diskette.

10. Set the duplication count to two (2) and change computer name when prompted for the second diskette

Create the Boot Diskette
You need to create one Boot diskette to boot and connect a client to the server and map the required drives 
LabExpert directories. 

1. Repeat steps 1 through 8 above, substituting LabExpert Boot  for the application type in step 8. See the Boot
Disk Wizard documentation in the on-line manual for more information.

Create Batch Files 
Altiris provides the LabExpert Process Builder to automatically create a series of batch files simplifying the im
file configuration process. The following exercise uses two client computers: one as a Master computer, the o
Slave (it doesn’t matter which client is the Master or Slave). 

To create batch files,

1. Choose Start > Programs > Altiris LabExpert > LabExpert Control Console.

The “Getting Started” help system is displayed. You can follow these abbreviated steps anytime you nee
reminder of what to do and how to do it. For now, close the Getting Started window and continue with ste

2. Run the LabExpert Process Builder by opening Tools > LabExpert Process Builder.

3. Fill in all applicable fields by following the prompts in the right portion of the window. 

4. Make note of the category and image descriptor you specify to contain the batch files. These names def
directory structure and image file name used and displayed in the LCC. For example: 

A <category> of training  and an <image descriptor> of win95 results in the creation of two folders and an 
image filename. The actual structure created from the example above looks like this:

\LABEXPRT\DATA\TRAINING\WIN95\WIN95.IMG

5. Set the number of Slave computers to 1 (one).
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6. In the lower right corner, select Automation Partition  for this build.

7. After providing the required information, click Build . 

The Process Builder instantly creates the required batch files according to the selections you make.

8. Click Exit .

9. To verify creation of the batch files you just created, at the LabExpert Control Console, click the plus sign+) 
next to Batch Files, <Category>, and <Image Descriptor>. The batch files should appear.

10. Write down the names of the <Category> and <Image Descriptor> you created. These names are used again
step 13 of the Create the Image File section.

Create the Image File
Now you are ready to create an image file. The image must include LabExpert’s Remote Control agents. The
Install Wizard creates a diskette with the necessary files.

Warning: Before creating an image for a computer running Windows NT, modify your c:\boot.ini file so all 
references to Partition (1) are changed to Partition (2). See IBMIGRAT.EXE in the online documentation.

1. Obtain a blank, formatted diskette.

2. At the LCC computer, choose Start > Programs > Altiris Client Install > Make Client Diskette 

The diskette is created with the appropriate files.

3. Insert the new Client Diskette into the image source computer (it should currently be up and running Win
and run A:\SETUP.EXE. 

4. Select Remote Control for LabExpert and click Next, Next, Finish.

5. Boot the image source computer with the LabExpert Boot Diskette you created earlier in the Create Booorks 
Diskettes section. This establishes a temporary connection with the server. 

6. (Windows NT only) When asked to create a password file, press Enter, type Y and press Enter. Without typing 
anything more, press Enter again. The process stops at a NONE FOUND message. 

7. When prompted for the computer’s object name, enter a unique name used to identify this computer at t

8. The BootWorks (Automation) Partition must reside in the first partition on a hard drive. You are going to m
your current partition using the LabExpert utility IBMIGRAT.EXE.

9. At the F:\DATA prompt, run IBMIGRAT.EXE.

10. Type S to Slide the partition. Your existing partition is redefined to reside in Partition 2. IBMASTER.EXE s
automatically.

11. Select Upload to image file.

IBMaster displays the partition as if it were installed on partition 2.

12. Select Partition 2 by pressing the Space Bar and Enter.

13. Type an image file name to fit the following pattern:

.\<CATEGORY>\<IMAGE DESCRIPTOR>\<IMAGE DESCRIPTOR>.IMG

replacing the <category> and <image descriptor> with the same values recorded from step 10 in the Create 
Batch Files section. For example: .\TRAINING\WIN95\WIN95.IMG

14. Select Start.

An image is created of your Windows partition. The image is saved in the 

F:\LABEXPRT\DATA\<category>\<image descriptor> directory and is called <image descriptor.img>.

15. While your image is uploading, complete the Install BootWorks section for the image recipient computer. When 
you return to this PC after the upload is complete, choose L  to leave the partition in its shifted state.

Check Poin : When complete, the image file is stored on the server, ready to download to the client computer

Install BootWorks
While the base image computer (the first client) is uploading the image, install BootWorks on the second clien

1. Use one of the BootWorks install diskettes to boot the second client (the image recipient computer).
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2. If a partition is found on this computer, you are prompted for a decision. Since you are currently saving th
tition you want to use from the other client, and will download it to this client PC later, select E to erase this par-
tition and follow the on-screen instructions

3. When the Automation Partition installation is complete, the computer is left at the A:\ prompt. Remove th
kette and reboot the computer.

4. As the computer reboots: 

a. NetWare logs you in without additional steps
b. Windows NT requires you to press Enter to accept “bootwork” as the user login name and press En

again. When asked to create a password file, type Y and press Enter. Without entering anything more, 
press Enter again.

5. When prompted for the computer’s object name, enter a unique name used to identify this computer at LCC. 

6. Using the second install diskette, repeat steps 1 (erasing the existing partition) through 4 on the image s
computer, once it has completed its upload procedure. The second “install” diskette is used so this comp
receives a unique IP address and computer name (if using IP).

Step 5 is not repeated because this computer already has an object name (computer name) in the LCC 
so you are not prompted for the object name again.

Important : This computer stops at a BootOrg or non-system disk message. This is correct. Continue with th
Test the Installation section.

Test the Installation 
Test your installation by following these steps:

1. From the LCC, verify that the client computers are displayed in the console’s list view. Click the All Comput-
ers icon in the left half of the LabExpert console screen. 

You should see a computer icon for each computer configured with BootWorks. You can press F5 anytime to 
refresh the display.

2. Create a group at the console.

a. Right click the Groups icon.
b. Select New > Group and enter a name.
c. Click the Groups icon to see the Groups.
d. Click the All Computers icon to see the computers in the group.

3. Drag and drop the icons for the client computers to the new group.

4. Choose View > Options, check Boot to Automation Upon Batch Assignment, and click OK (you can remove 
this check mark whenever you want to force a normal reboot, even when a batch assignment exists.)

5. Assign your new group to the KEYTEST.BAT file: 

a. Click the (+) next to the Batch Files icon.
b. Click the (+) next to the Samples folder.
c. Drag the new group’s icon to KEYTEST.BAT. The batch file name is displayed next to each compute

to which it has been assigned.
6. Manually reboot both client computers.

7. Verify that the client computer screens display LabExpert Now Functional message. 

8. At the LCC, press F5 and verify the status field as Functional test complete. 

If the computer icons aren’t displayed in the right window, click the All Computers item in the top left win

Check Poin : LabExpert is installed, the image saved and the client computers are ready to receive the image

Multicast the Image File
During a multicast, one target computer is designated as a Master to first receive the image, decompress and
the image to all other target (slave) computers. This methodology reduces the load on the server and require
image to cross the wire only twice instead of once for each target, even if you are imaging 2000 computers.
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1. At the LCC, drag the group you created earlier to SLAVE.BAT (in the <image descriptor> directory specified 
earlier for the batch files creation). 

2. Drag one computer icon to MASTER.BAT (in the same directory) overriding the slave assignment made
1 (it doesn’t matter which computer you use as Master or Slave).

3. Right click the group and select Reboot. (If you selected IPX while creating the boot diskettes, open View >
Options > Remote Control and select IPX/SPX in the Communications Protocol box.) 

The two client computers reboot, come up in Automation Mode and receive the image. After automatica
rebooting again and, if the image is a Windows 95/98/NT image, the computers try to download registrie
Because the registries have not been uploaded yet, an error message is displayed stating the registries
found. Do NOT press Esc.

4. After receiving the error, mark the computers to boot to Production Mode through the LCC (right-click the 
group and select Boot to > Production).

5. Reboot both client computers.

The computers boot to Production Mode. If the image is using Windows 95/98/NT, an error message ap
because both computers received the same registry files.

6. Click OK. The normal process of trying to auto-detect hardware might delay boot completion. This mean
might need to wait a few minutes to ensure the computers have completed all necessary auto-detection
ware before continuing. 

Upload Registry Files
1. When auto-detection is complete, physically go to each computer and ensure that all Computer Names 

Addresses are set to unique values. Allow the computers to restart as prompted by Windows.

2. At the LCC, drag your group to REGUP.BAT in your batch file directory and reboot both client computers

When the computers reboot, they upload (back up) their registries, then reboot again to Production Mod

Check Point: The necessary Registries have been backed up. You now have the three required components:
image file, 2) the individual registries and 3) the batch files necessary to place this Image Configuration on on
more computers. 

Test the Complete Solution
1. At the LCC, drag one client computer icon to SLAVE.BAT. 

2. Drag the other client computer icon to MASTER.BAT. 

3. Reboot both client computers.

The computer screens display each client’s progress.

Check Point: The computers all receive the same image, then reboot and receive their own backed up registr
finally reboot again to production mode, each with their own Computer Name, IP address and any other setti
were stored in the registries. 

Important:  The REGUP.BAT and REGDOWN.BAT files are two very powerful tools that make the automatic r
ration of registries possible. Once the registries are established, you don’t need to visit each client every time
multicast an image. From then on, the correct registry files are automatically downloaded to the appropriate c
whenever they receive this image. You can even download just the registries anytime you want. Learn about
potential of these tools in the How Do I? section of the on-line manual.

By repeating the procedures above, you can set up any computer or group of computers for control by LabEx
Once you’ve taken a computer all the way through the Upload Registry Files process, you don’t need to phys
visit that computer again. You can reboot, re-image, and reconfigure a computer from the LCC. For informatio
about all Altiris products, see our Web pages at www.altiris.com.
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