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Adobe After Effects 3.1

Importing and exporting Cineon files

ou can use the Cineon plug-ins to 

import Cineon 4.5 or Digital Picture 

Exchange (DPX) format frames into an 

Adobe® After Effects® 3.1 project. They can be 

imported as individual images or as a sequence 

of numbered files. Once you have imported a 

Cineon file you can use it in a composition and 

then render the composition to a sequence of 

numbered Cineon files.

Cineon files are commonly used for trans-

ferring motion-picture film into digital format. 

To preserve the full dynamic range of motion-

picture film, Cineon files can be stored using 

up to 10 bits per channel. However, After 

Effects and QuickTime support 8 bits per 

channel. After you import a 10-bit Cineon file, 

you apply the Cineon Converter effect to 

precisely specify the most important 8 bits to 

use in After Effects. You can adjust the 10-bit to 

8-bit conversion at any time; the results appear 

immediately. If you are working with a film 

sequence where exposure conditions vary over 

time, you can vary the conversion over time by 

setting keyframes.

Installing the plug-ins
You can work with Cineon files by installing 

the two Cineon plug-in files, Cineon AE 

Format and Cineon Converter. You can use the 

plug-ins on Windows® 95, Windows NT, or 

Mac™ OS for Power PC. The plug-ins work 

with After Effects only; you cannot use them 

with Adobe Premiere or Adobe Photoshop.

The files do not use an installer. You simply 

copy the files to the After Effects plug-ins 

folder. Once installed, Cineon options appear 

in the following places:

• As an option in the File Type menu in the 

Import dialog box

• As a new Cineon Tools submenu on the 

Effects menu which contains one command, 

Cineon Converter

• As a format option in the Output Module 

Settings dialog box

To install the plug-in:
1 Quit After Effects.

2 Copy the two plug-in files, Cineon AE 
Format and Cineon Converter, to the Plug-Ins 
folder in the Adobe After Effects folder. You can 
store the files in any folder inside the Plug-Ins 
folder except the Optional (Windows) or 
Optional Plug-Ins (Mac OS) folder.

3 Restart After Effects. You do not need to 
restart your computer.

Importing Cineon files
You can import a single Cineon frame, or a 

sequence of numbered Cineon files. Importing 

works similarly to importing other sequence 

formats into After Effects. For more infor-

mation about importing, see “Importing 

Footage into a Project” in Chapter 3 of the 

Adobe After Effects 3.1 User Guide.
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To import a Cineon format file or sequence:
1 Choose File > Import > Footage File.

2 Do one of the following:

• Locate and select a Cineon file.

• Select Cineon Sequence, then locate and 

select the first file of a numbered sequence of 

Cineon files.

3 Click Open.

4 When the Interpret Footage dialog box 
appears, click Treat as Straight (Unmatted), 
and click OK.

The Cineon file or sequence appears in the 

Project window. When you select it, the 

thumbnail preview appears garbled. This is 

normal, because the Cineon file is still a 10-bit 

per channel image that After Effects cannot 

display in its current form. You’ll apply an 

effect that converts it to 8 bits per channel so 

that it displays properly.

Using the Cineon Converter
The Cineon Converter plug-in effect provides a 

high degree of control over 10-bit to 8-bit 

conversions of Cineon frames. The 10 bits of 

data available in each Cineon channel makes it 

easier to enhance an important range of tones 

while preserving overall tonal balance. By 

carefully specifying the 8-bit range to use in 

After Effects, you can create an 8-bit version of 

the image that faithfully resembles the original, 

or even improves upon it. This process of 

balancing the range of tones, or dynamic range, 

is similar to the techniques used when setting a 

proper exposure curve when scanning still 

images, or creating a chemical print of a film 

negative.

To convert a Cineon file:
1 Drag the Cineon file from the Project 
window to a composition. The image will 
appear garbled.

2 With the Cineon layer selected, choose 
Effect > Cineon Tools > Cineon Converter.

The Cineon Converter effect applies the default 

Kodak conversion parameters for editing 

motion-picture film on a digital system. You 

can refine these parameters using the Cineon 

Converter options in the Effect Controls 

window.

To control the tonal balance of a Cineon file:
1 Choose an option from the Conversion Type 
menu:

8-Bit Log to Linear Select when converting an 

8-bit logarithmic non-Cineon layer that you 

plan to render as a Cineon sequence.

8-Bit Linear to Log Select when converting a 

layer containing an 8-bit linear proxy of a 

Cineon file into an 8-bit logarithmic layer so 

that its display characteristics are consistent 

with the original Cineon file.

Auto Log to Linear Select to automatically 

detect an 8- or 10-bit logarithmic Cineon layer 

when you plan to convert it to an 8-bit linear 

layer for use in After Effects. This is the default 

setting.

Auto Log to Log Select to automatically detect 

an 8- or 10-bit logarithmic Cineon layer when 

you plan to render it as an 8-bit logarithmic 

proxy.

10-Bit Log to Linear Select when converting a 

10-bit logarithmic Cineon layer into an 8-bit 

linear layer for use in After Effects.
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10-Bit Log to Log Select for a 10-bit 

logarithmic Cineon layer that you will render 

as an 8-bit logarithmic proxy. This is the 

preferred setting for rendering a proxy as it 

maintains consistent color display when 

switching between the proxy and the original.

Note: Choosing a conversion type resets existing 

slider values to the default values for the conver-

sion type you selected.

2 Make sure the 8 Bit Black Point slider is at 0, 
and the 8 Bit White Point slider is at 255.

3 Do the following as necessary to adjust the 
black point:

• If a part of the image that should be black 

appears lighter than black, drag the 10 Bit Black 

Point slider to the right until that area is black. 

This value is equivalent to the minimum 

density, or Dmin, of a film negative.

• If too much of the image appears black, drag 

the 10 Bit Black Point slider to the left until all 

important non-black areas are visible.

4 Do the following as necessary to adjust the 
white point:

• If a part of the image that should be white 

appears gray, drag the 10 Bit White Point slider 

to the left until that area is white. This value is 

equivalent to the maximum density, or Dmax, 

of a film negative.

• If too much of the image appears white, drag 

the 10 Bit White Point slider to the right until 

all important non-white details are visible.

Adjust white point for the lightest details that 

should be visible. If resolving the brightest 

highlights results in darkening the rest of the 

image unacceptably, balance everything except 

the brightest highlights. You can address the 

brightest highlights specifically in step 7.

5 Drag the Gamma slider left to darken the 
midtones, or right to lighten the midtones. A 
Gamma value of 1.7 works well on many moni-
tors.

6 When all of the image is balanced, check the 
brightest highlights. If they appear as unsightly 
white blotches, drag the Highlight Rolloff 
slider to the right until details become visible. 
Higher-contrast images may require a higher 
rolloff value.

7 When the image is properly balanced, you 
may change the black and white points of the 8-
bit version while preserving the overall tonal 
improvements by doing either of the following:

• If you want the darkest tone to be lighter than 

black, drag the 8 Bit Black Point slider to the 

right. 

• If you want the lightest tone to be darker than 

white, drag the 8 Bit White Point slider to the 

left.

Note: Each computer monitor has unique display 

characteristics which affect your perception of 

color on screen. For best results when evaluating 

tonal balance, use the Info palette in After Effects 

to see the true color values of pixels as you move 

the pointer over them.

Varying tonal adjustments over time

You may be working with a Cineon sequence in 

which lighting characteristics vary over the 

duration of the sequence. To compensate, you 

can set keyframes with different tonal adjust-

ments for each instance where exposure condi-

tions shift. You can use keyframe interpolation 

and ease handles to precisely match even the 

most irregularly paced lighting changes. For 

more information about keyframes, see 

Chapter 8 in the Adobe After Effects 3.1 User 

Guide.
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Rendering an 8-bit proxy of 
a Cineon file
Cineon files are relatively large compared to 

other file formats, so you may want to edit 

using 8-bit proxies, which require less 

processing time and disk space than the 

original 10-bit Cineon files. You can render 8-

bit proxy versions of Cineon files from After 

Effects. When you’re ready to render a compo-

sition, you can replace proxies with the high-

quality, full-resolution versions. Changes you 

made to the proxies are then applied to the 

original Cineon files. For more information, 

see “Substituting a Proxy for Footage” in 

Chapter 3 of the Adobe After Effects 3.1 User 

Guide.

To render an 8-bit proxy of a Cineon file:
1 Import a Cineon file or sequence. For more 
information, see “Importing Cineon files” on 
page 1. 

2 Convert it to 8-bit color, making sure that 
Auto Log to Log or 10-bit Log to Log is chosen 
from the conversion Type menu in the Effect 
Controls window. When you choose Auto Log 
to Log or 10-bit Log, the Cineon Converter 
effect automatically sets the sliders to repro-
duce the dynamic range of the original Cineon 
image. For more information, see “Using the 
Cineon Converter” on page 2.

3 Do one of the following:

• Drag a Cineon composition into the Render 

Queue, click Output To, specify a location and 

filename, and click OK.

• Select a Cineon composition, choose 

Composition > Make Movie, specify a location 

and filename, and click OK.

4 In the Render Queue window, click Output 
Module and choose the video or still-sequence 
format you want to use from the Format menu, 
such as QuickTime.

5 Make sure Millions of Colors is chosen in the 
Depth menu, so that the resulting file will be 
24-bit color (8 bits per channel with no alpha 
channel).

6 If desired, you can click Format Options to 
customize settings such as compression. For 
proxies, picture quality only needs to be good 
enough to distinguish one frame from another 
or evaluate colors properly. Click OK when 
finished.

7 Click OK to close the Output Module 
Settings dialog box. If desired, you can click 
Render Settings to set other options appropri-
ately for proxies.

8 In the Render Queue window, confirm all 
settings for the composition and click Render. 
For more information about setting up 
rendering, see Chapter 10, “Rendering a 
Movie,” in the Adobe After Effects 3.1 User 
Guide.



 

5

 

IMPORTING AND EXPORTING CINEON FILES

 

User Guide

                          
Applying masks and effects 
to Cineon files
The Cineon Converter plug-in effect must be 

applied to a Cineon layer for it to display 

properly in After Effects, and the Cineon 

Converter must be the first effect applied to the 

Cineon layer. Also, you can’t apply a mask 

directly to a Cineon layer. This affects how you 

build compositions in the following ways:

• You can apply an effect directly to a Cineon 

layer. However, always make sure other effects 

are applied after the Cineon layer. To check 

this, select the Cineon layer, choose Layer > 

Open Effect Controls, and make sure Cineon 

Converter is the first effect listed in the Effect 

Controls window. If necessary, you can drag 

the Cineon Converter effect to the top of the 

window.

• You cannot apply the mask directly to a 

Cineon layer because a mask is applied to a 

layer before effects, such as the Cineon 

Converter. Instead, select the Cineon layer, 

choose Layer > Precompose, select Move All 

Attributes Into The New Composition, and 

click OK. This replaces the Cineon layer with a 

new composition containing the Cineon layer, 

isolating the Cineon layer by one level in the 

composition hierarchy. Now you can apply a 

mask to the new composition and it will be 

applied to the Cineon layer within.

• If masking is directly applied to the Cineon 

layer or an effect precedes the Cineon 

Converter effect, an error message will appear. 

To correct the error, remove any masking and 

verify the order of effects as described earlier.

For more information, see “Working with a 

Mask” in Chapter 6, “Precomposing” in 

Chapter 9, and “Working with Effects” in 

Chapter 7 of the Adobe After Effects 3.1 User 

Guide.

Rendering a Cineon file or 
sequence
You can render any composition to Cineon 

format, even compositions containing non-

Cineon layers. This converts the 8-bit-per-

channel color in After Effects to the 10-bit-per-

channel color in the Cineon format. Accord-

ingly, you can apply conversion parameters 

that reverse the values you applied when you 

used the Cineon Converter plug-in to convert a 

Cineon file.

To render a Cineon sequence:
1 Do one of the following:

• Drag a composition into the Render Queue, 

click Output To, specify a location and file-

name, and click OK.

• Select a composition, choose Composition > 

Make Movie, specify a location and filename, 

and click OK.

2 In the Render Queue window, click Output 
Module and choose Cineon Sequence from the 
Format menu.

3 Click Format Options.

4 In the File Type section, select Logarithmic 
or Linear depending on the requirements of 
the project that will receive the sequence you 
are rendering.

5 Specify the 8-bit to 10-bit conversion 
parameter values using any of the following 
sections in the Cineon Conversion Parameters 
dialog box:
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Predefined Conversions For general 

conversion scenarios, click one of the following 

buttons:

• Standard applies the standard Kodak conver-

sion parameters for processing film digitally.

• Video applies a narrower 8-bit input range 

than Standard, to compensate for digital video 

characteristics.

• Full Range applies a linear conversion of the 

entire 8-bit tonal range to the entire 10-bit 

tonal range, making no adjustments for digital 

processing or video display.

Conversion Parameters For conversion 

scenarios that are neither predefined nor saved 

as presets, type values for the following 

options:

• Black-Point (10 bit) is the darkest value you 

want the resulting file to use in 10-bit space.

• Black-Point (8 bit) is the darkest value that 

you want to convert from the 8-bit file. This 

will be converted to the Black-Point (10 Bit) 

value during rendering.

• White-Point (10 bit) is the lightest value you 

want the resulting file to use in 10-bit space.

• White-Point (8 bit) is the lightest value that 

you want to convert from the 8-bit file. This 

will be converted to the White-Point (10 Bit) 

value during rendering.

• Current Gamma is the Gamma setting of the 

current video display. Because the gamma of 

the current video display affects your percep-

tion of image adjustments, the inverse of this 

value will be applied during rendering to help 

equalize the image for display on other 

systems.

• Highlight Expansion specifies how much to 

expand the tonal range used for highlights in 

the resulting 10-bit file. A value of zero results 

in no adjustment; higher values increase the 

highlight expansion. If Highlight Rolloff (the 

opposite of Highlight Expansion) was applied 

to the composition, the Highlight Rolloff value 

is usually appropriate for Highlight Expansion.

Presets Load or save all settings in the 

Conversion Parameters dialog box using 

buttons in this section:

• To apply Conversion Parameters dialog box 

settings saved as a file, click Load, locate and 

select the file, and click OK.

• To save the current Conversion Parameters as 

a file, click Save, specify a location and file-

name, and click OK.

6 In the File Format section, select 
FIDO/Cineon 4.5 or DPX. In most cases Film 
In Digital Out (FIDO)/Cineon 4.5 is appro-
priate because it is used more widely than 
Digital Picture Exchange (DPX) format. DPX 
is provided because it is a Society of Motion 
Picture and Television Engineers (SMPTE) 
standard.

7 Click OK to close the Cineon Conversion 
Parameters dialog box. Then click OK to close 
the Output Module Settings dialog box.

8 In the Render Queue window, confirm all 
settings for the composition and click Render. 
For more information about setting up 
rendering, see Chapter 10, “Rendering a 
Movie,” in the Adobe After Effects 3.1 User 
Guide.
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Saving settings using an Output 
Module Template

The Save button in the Cineon Conversion 

Parameters dialog box saves only the settings in 

that dialog box. To simplify the creation of 

Cineon sequences, you can create one or more 

Output Module Templates containing a 

complete set of Output Module settings for 

each rendering scenario you anticipate. For 

more information, see “Using output module 

templates” in Chapter 10 of the Adobe After 

Effects 3.1 User Guide.
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