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CHAPTER 1 Welcome to Linkbot
This chapter summarizes Linkbot’s site management features, describes the instal-
lation requirements and tells you where to look for help on the software.

Program Overview
Linkbot is an award-winning site management tool. Linkbot is designed to help 
Webmasters maintain, test and organize their sites. As a Webmaster you will find 
that many of Linkbot’s features make it easier for you to manage one or more sites 
with both confidence and accuracy.

Locate Broken Links, Missing Images and Stale Content
The quality of a Web site naturally reflects on the company that creates it. Broken 
links, missing images and stale content project a negative impression about a com-
pany’s products and services. Linkbot helps you eliminate all three of these prob-
lems and provides a tool which lets you make the necessary repairs to the Hypertext 
Markup Language (HTML) code right from within the application.
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Identify Unused (Orphaned) Files
Is it safe to delete that old file from the Web server? Linkbot can answer this ques-
tion by scanning your Web server for files that are no longer being used. Linkbot 
can help Webmasters recover wasted disk space. 

Find Large Pages With Slow Download Times
About 70% of Internet users connect at speeds of 28.8 Kbs or less. Are you losing 
visitors because of slow download times? Linkbot can scan your site and identify 
bloated pages that could be reduced to improve download times.

Visualize the Structure and Organization of the Site
Explore the structure of your site in Linkbot’s intuitive “Explorer style” interface. 
With Linkbot you can view the links in and out of any page and get critical informa-
tion at a glance about every file on your site.

Isolate Subsections of the Site Using Customized Filters
As sites get bigger and more complex, they become harder to organize and main-
tain. Linkbot's filters, such as those that exclude images, text, Mailto, and other 
links, allow Webmasters to isolate and act upon certain kinds of files on the site. 
The filters can be combined and toggled on or off with the push of a toolbar button.

Schedule Web Site Analyses to Help Automate Routine Maintenance
Linkbot’s scheduling feature gives Webmasters the power to automate regular anal-
yses of the site.

How Linkbot Works
First you enter the starting Uniform Resource Locator (URL) for the site that you 
want to check (normally your home page). Linkbot then traverses through your site 
checking every kind of hyperlink/URL it encounters. Linkbot branches down every 
local hyperlink as deep into your site as you wish. Linkbot also checks hyperlinks 
to external sites. However, it does not check the hyperlinks on an external site. 
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The analysis continues until:

• the user terminates it,

• there are no more links to check, or

• the search depth stopping criterion have been met. Linkbot’s options allow you 
to set the depth of the search.

There are two ways to view the results of an analysis: 

1. Linkbot’s Explorer style interface, or 

2. a separate HTML report in a suitable Web browser.

Features and Specifications
Linkbot’s major features can be grouped into five categories: basic maintenance, 
mapping and organization, repair, HTML reports, and automation. Linkbot’s speci-
fications include:

• uses a high performance multi-tasking engine,

• supports Hypertext Transfer Protocol (HTTP), HTTPS (secure HTTP server) 
and file transfer protocol (FTP),

• works from a local disk or from a remote server, and

• supports password protected proxy servers and authenticated page requests.

Basic Maintenance
Linkbot’s basic maintenance features include:

• checks internal and external links (to and from a page),

• checks for unused (orphan) files,

• checks for stale content,

• checks for slow pages,

• checks for pages missing the <TITLE> tag,

• checks syntax of Mailto URLs,

• filters groups of URLs from the analysis, and

• re-checks specific subsets of URLs on a site.
User’s Guide to Linkbot 3
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Mapping and Organization
The mapping and organization features include:

• maps out the structure of a site in a Windows® Explorer style interface,

• shows links in and out of a selected URL,

• sorts the site’s URL list by one of the following categories: title, description, 
author, size, last modified date and type, and 

• provides advanced filters for viewing subsets of a site’s contents, such as all the 
FTP links, all the image links, etc.

Repair
The repair features include:

• provides built-in HTML editing, and

• exports results to a delimited file.

Hypertext Markup Language Report
Linkbot creates a comprehensive HTML report of its analysis with the following 
sections: site summary, warnings, broken URLs, broken pages, what’s new? what’s 
old? what’s slow? orphaned URLs, image catalog. Linkbot can also create an alpha-
betical HTML index of all your site’s links.

Automation
Linkbot’s scheduling features allow you to automate the routine maintenance of 
your site. Automation is integral to maintaining an error free site. The more auto-
mated a site management system is, the less chance there is for problems to creep in 
undetected.

Linkbot provides a very powerful, yet simple set of options for automating site 
maintenance. For example, you can tell Linkbot to analyze http://tetranetsoft-
ware.com/ every Sunday night at 12 a.m. On Monday morning an HTML site report 
will be waiting for you.
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Hardware/Software Requirements
In order to use Linkbot effectively you should have the following:

• 16 MB RAM (32 MB recommended),

• 2 MB hard disk space minimum, plus 5-10 MB for stored site reports,

• a 32-bit standard Winsock 1.1-compliant Internet connection, and

• a suitable Web browser for viewing HTML reports.

Installing Linkbot
Linkbot is installed using a Windows Setup program. The method is the same 
whether it is a Windows 95 or a Windows NT installation. The following method 
assumes you are installing from a diskette. If you have downloaded your installa-
tion from Tetranet’s Web site, begin with step two and change the path in step three 
to reflect where you saved the files.

To install Linkbot:

1. Insert the Linkbot program installation diskette into your floppy drive.

2. Go to the Windows File or Start menu and choose Run. The Run dialogue box 
appears.

3. Type a:\setup or the path to the setup file if you downloaded Linkbot.

4. Follow the instructions to complete the installation.

5. Launch the program by selecting the Linkbot icon from the Windows Start 
Menu.

Late-breaking Information

While this manual is as up-to-date as possible, check either the readme file or the 
electronic version of this manual included with the installation. They may describe 
changes or additions to the software that occurred after the manual went to press.
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Getting Help
There are many routes to choose from when you need help or when you want to 
learn more about the program. For instance, there is: 

• an on-line help facility,

• an HTML tutorial,

• a sample Linkbot file,

• a list of frequently asked questions (available on Tetranet’s Web site), and 

• a technical support e-mail address (support@tetranetsoftware.com).

On-line Help
Linkbot has a built-in help facility that describes all the menu commands and dia-
logue box options. The help facility is organized by topic but a complete keyword 
index is available for conducting searches.

To access Linkbot Help:

1. Go to the Help menu and choose a help topic. You can also access Tetranet’s 
Web site for the latest information on the program from the Help menu.

OR

1. Go to the Windows Start Menu and choose Linkbot from the Programs sub-
menu.

2. Select the Linkbot Help menu item. The help file for the program is launched.

HTML Tutorial
The HTML tutorial provides a general overview of the software, examples and 
complete instructions for analyzing a site, publishing site reports, and changing 
Linkbot’s options.

To open Linkbot’s HTML tutorial:

1. Go to the Windows Start Menu and choose Linkbot from the Programs sub-
menu.

2. Select the Tutorial menu item. Linkbot launches your Web browser and auto-
matically loads the tutorial.
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Select a URL in the 
left window pane and 
examine how the 
information in the right 
window pane changes

Try out Linkbot’s tool-
bar filters to see how 
they affect the sam-
ple analysis
Sample Linkbot File
Linkbot comes with a sample analysis that will help you become more familiar with 
the software. You don’t need to try and tackle your site immediately. You can open 
the sample analysis and try out Linkbot’s features on the sample first. 

Also included is a sample site report which shows the information available to you 
when you publish a report. A site report is a summary of Linkbot’s analysis and is 
published in HTML. The sample site report that comes with Linkbot shows an anal-
ysis of Tetranet’s Web site.

To open the sample analysis and sample site report:

1. Go to the Start Menu and choose Linkbot from the Programs submenu.

2. Select Linkbot. The application launches.

3. Go to the File menu and choose Open. The open dialogue box appears.

4. Find the Linkbot folder and open the file example.bot. The sample analysis 
appears in a new Linkbot project window.

5. Go to your Web browser and choose Open from the File menu.

6. Launch your Web browser and choose Open from the File menu.
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The sample site 
report contains a 
summary of Tetra-
net’s Web site. The 
information avail-
able here is indica-
tive of what will be 
available to you in 
your site report

Every site report is 
an HTML document 
with hyperlinks to its 
various parts
7. Find the Linkbot folder and open the file example.htm. The sample site report is 
loaded into your Web browser.

Frequently Asked Questions
A list of FAQs can be found on Tetranet’s Web site: http://www.tetranetsoft-
ware.com. 

To automatically jump to the FAQs:

1. Go to Linkbot’s Help menu.

2. Select Tetranet on the Web submenu and choose Support. The Tetranet FAQs 
Web page is loaded into your Web browser.
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Technical Support 
Before you report a problem to technical support, please check our on-line support 
site at: http://www.tetranetsoftware.com/support.htm. If the answer to your prob-
lem is not listed there, send your support question to: support@tetranetsoft-
ware.com. Make sure to include the following information:

• company or personal name,

• telephone number or e-mail address where you can be reached,

• detailed problem description and any error message(s),

• instructions on how we can replicate the problem,

• the version of Windows you are using, and

• the version of Linkbot you are using (under the Help menu choose About Link-
bot for the version number).
User’s Guide to Linkbot 9
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CHAPTER 2 Getting to Know 
Linkbot
This chapter begins with an introduction to the interface—the menus, toolbar, and 
windows—then continues with instructions for starting and stopping an analysis.

Overview of the Interface
Linkbot’s interface includes the menu bar, the toolbar, the Address field where Uni-
form Resource Locators (URLs) are entered, the project window, and the status bar.

Menu Bar
There are six menus on Linkbot’s menu bar, which are briefly described here:

• File: Open, save, and print. These commands apply to Linkbot project files. 

Note A project file is a complete site analysis that has been saved to your com-
puter. A Linkbot site analysis has the three-letter extension ‘.bot’ when 
saved as a file. Project files should not be confused with site reports, which 
have the extension ‘.htm’. Site reports can only be opened by an HTML 
aware application, such as a Web browser.
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The project window 
shows the results of 
the site analysis. It 
has two window 
panes

Linkbot has an inter-
face that is similar to 
your Web browser
• Edit: Copy, paste, and cut files in the project window. The files can be HTML, 
images, multimedia, etc. Many of these actions can be undone but always exer-
cise caution when deleting files.

• Tools: Publish site reports and indexes, change Linkbot’s options, and schedule 
runs.

• View: Toggle the left project window pane (see “Project Window” on page 15) 
between several possible views: Link URL, Link Description, Link Title, and 
Link File Path.

• Window: Toggle Linkbot between several open projects.

• Help: Access the on-line help facility, go to Tetranet’s Web site for information 
(a Web browser is launched with the correct URL entered), or register your copy 
of Linkbot.

Refer to Linkbot’s help for more information on the menus and their commands.
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Toolbar
Linkbot has an extensive toolbar for opening and saving files, filtering the project 
window, starting and stopping analyses, and launching external editors. The toolbar 
is located below the menus at the top of the Linkbot application window. Table 1 
describes each tool on the toolbar from left to right.

TABLE 1. Description of Linkbot Tools 

Toolbar Icon Description

Creates a new Linkbot project.

Opens a Linkbot project file (those saved with the extension 
‘.bot’).

Saves the current project.

Filters/shows Hypertext Transfer Protocol (HTTP) links in 
Children/Parents tab.

Filters/shows image links in Children/Parents tab.

Filters/shows Mailto links in Children/Parents tab.

Filters/shows FTP links in Children/Parents tab.

Filters/shows multimedia links in Children/Parents tab.

Filters/shows Applet links in Children/Parents tab.

Filters/shows good links in Children/Parents tab.

Filters/shows bad links in Children/Parents tab.

Filters/shows warning links in Children/Parents tab.

Filters/shows links with unknown types in Children/Parents tab.

Filters/shows internal links in Children/Parents tab.

Filters/shows external links in Children/Parents tab.
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Address Field
URLs are entered into the Address field just the same as you would enter them into 
a Web browser URL field. The URL entered into the Address field tells Linkbot 
where to start its analysis of your site. 

From this starting URL Linkbot traverses through the site checking the links 
between every URL it encounters. Linkbot branches down every local hyperlink as 
deep into your site as you wish. Linkbot also checks hyperlinks to external sites. 
However, it does not check the hyperlinks on an external site. 

Filters/shows password protected links in Children/Parents tab.

Filters/shows HTTPS (secure HTTP server) links in Children/
Parents tab.

Rotates the columns of information in the Children/Parents tab.

Launches your Web browser to view the URL selected.

Launches an external application to edit the URL/file selected.

Shows the link properties of the selected URL. Link properties 
include: status, type, size, download size, link description, doc-
ument title, last modified (date), and author.

Goes back to the previous Web page. The button only functions 
when the Browser tab is selected.

Goes forward to the next Web page. The button only functions 
when the Browser tab is selected.

Stops the analysis.

TABLE 1. Description of Linkbot Tools (Continued)

Toolbar Icon Description
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The analysis continues until:

• The stop button is pressed (on the toolbar).

• There are no more links to check.

• The search depth stopping criterion has been met (see Chapter 6 on page 41 for 
more information).

A drop down menu next to the Address field remembers the URLs that you recently 
entered.

Open Local URL Button
The open local URL button (an ellipses) is used to open a local HTML file on your 
computer which Linkbot can then check. As with URLs entered into the Address 
field, Linkbot’s analysis begins with the first file you open. 

The open local URL button is adjacent to the Address field.

Project Window

Linkbot has a project window with two panes to help you visualize Linkbot’s site 
analysis. The contents of the window panes can be changed to show different 
aspects of the analysis (see Table 2 and Table 3 for descriptions of each window 
pane).
User’s Guide to Linkbot 15
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The two project 
window panes can 
be toggled 
between different 
views
Table 4 describes some of the more useful combinations of the two windows. 

TABLE 2. Views on the Left Window Pane 

Menu Option Description

URL Tree Shows the site structure in a collapsible tree diagram which is 
useful for interactively exploring the site. The tree works in 
the same way as your Windows Explorer interface. The 
URLs can be collapsed and expanded instantly to show as 
much or as little of the site as you wish.

Broken Links Lists only the broken URLs on the site. 

Pages Containing 
Broken Links

Lists all pages that contain one or more bad links.

New Pages Lists pages that have been modified over a specified time 
interval (see Chapter 6 on page 41). 

Old Pages Lists pages that have not been modified over a specified time 
interval (see Chapter 6 on page 41).

Slow Pages Lists pages that may be slow for visitors to download due to 
their file size.

Orphaned Pages Lists unused files that are not referenced by a hyperlink any-
where on the Web server.
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Pages Missing Titles Lists pages that are missing an entry for the <TITLE> tag.

All Links Lists all the hyperlinks/URLs on the site.

TABLE 3. Right Project Window Pane Tabs 

Tab Name Description

Children Tab Displays the URLs that are inside the page selected in the left 
window pane. The Children tab has eight columns of statistics 
(see “URL Statistics” on page 18).

Parents Tab Displays the URLs that reference the object selected in the 
left window pane. The Parents tab has eight columns of statis-
tics (see “URL Statistics” on page 18).

HTML Text Tab Displays the HTML source code of the page selected in the 
left window pane. Use the HTML Text Tab for repairing bro-
ken links as well as other errors. Note that if your site has 
password protection, Linkbot prompts you for this informa-
tion before it can access the file.

Browser Tab Formats and displays the URL selected in the left win-
dow pane within Linkbot’s Web browser. You can check 
the changes /repairs to your files on the fly with the browser 
tab.

Properties Tab Summarizes the statistics of the URL selected in the 
left window pane. The statistics displayed include: sta-
tus, description, title, author, file size and last modified 
date (see “URL Statistics” on page 18).

TABLE 2. Views on the Left Window Pane (Continued)

Menu Option Description
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The statistics of 
each URL in your site 
can be found on the 
Children and Par-
ents tabs
 .

URL Statistics
Linkbot can gather up to eight different statistics about each URL. Each of these 
statistics is given its own column in both the Children and Parents tabs. Note that 
not all statistics are available for each URL. Some statistics do not apply to specific 
kinds of links, and some Web servers do not supply them. If a column is empty, the 
statistic was unavailable.

The URL link statistics include: 

• Link URL: The URL of the link being verified. Each type of URL is identified 
with a different icon.

• Link Status: Describes the status of the link—OK, error message returned by 
the server, unknown, or a warning. OK means the link is working. Error means 
the link is broken. A warning can be generated for a variety of reasons. For more 
information on link status messages, see Chapter 3 on page 25.

• Link Description: The actual text which has been tagged as the hyperlink (nor-
mally underlined).

TABLE 4. Useful Report Views

Left Window Pane Right Window Pane Action

Select the All Links icon on 
the tree diagram.

Children tab Use filters to view a subset 
of the site's objects.

Select Broken Links from 
the drop-down menu.

Parents tab Select an object. You can 
see all pages that reference 
the bad link.

Select Pages Referencing 
Broken Links from the 
drop-down menu.

Children tab Select an object. You can 
see all the bad links within 
that URL.
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• Link Document Title: The title of the page which is contained in the <TITLE> 
tag. Note that Linkbot does not gather document titles for external links. 

• Author: The name of the author that created the HTML document. Not all 
HTML authors include this information so it may not be available.

• Last modified: The date the document was last modified, if available. Not all 
HTML authors include this information so it may not be available.

• Type: The link type (HTTP, FILE, Mailto, News, FTP, etc.).

• Link Size: The size, in bytes, of the HTML document or image. 

Status Bar
The status bar tells you what site is currently being checked. Its information 
changes as the analysis progresses. The Status bar is located at the bottom of the 
Linkbot application window.

The status bar contains information such as: 

• the time that Linkbot took to complete its analysis of your site, 

• the number of links found, 

• the number of links checked, 

• the number of bad links found, 

• the number of connections, 

• the speed of the analysis in terms of the number of links checked 
per minute, and

• the status of the orphan analysis.
User’s Guide to Linkbot 19
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The URL may be 
entered with or with-
out the HTTP proto-
col. If you leave out 
the protocol, Linkbot 
assumes it to be 
HTTP
Using Linkbot for the First Time
In this section you will learn the basics of using Linkbot: how to start and stop an 
analysis and how to filter analysis information.

Starting Linkbot
To start Linkbot:

1. Go to the Windows® Start Menu and select the Programs submenu.

2. Choose the Linkbot menu item. The Linkbot application is launched.

Starting the Site Analysis
To begin the analysis of your site:

1.  Enter a URL into the Address field.

Notes Linkbot can check the following kinds of links, even if they are remote and 
password protected: HTTP, HTTPS, and FTP. Linkbot can also check the 
syntax of Mailto references, but it cannot determine if the mail address is 
valid.

2. Optional. Open a local file on your computer by pressing the ellipses button to 
the right of the Address field.

3. Press the Return key. Linkbot starts checking the links on your site. The status 
of the analysis—that is, the number of connections checked, and the number of 
bad links found—is reported on the status bar.

4. Press the stop button to end the analysis at any time.
User’s Guide to Linkbot



 Using Linkbot for the First Time

If you press the yes 
button, Linkbot 
launches your 
Web browser and 
loads the site 
report into it

Linkbot displays this 
message when you 
stop an analysis 
before it’s complete

Filters only affect the 
Children and Parents tab 
listings. They do not 
affect any of the other 
project window views
When the analysis is complete, Linkbot asks you if you want to publish a site 
report:

The site report is an HTML file that summarizes the analysis results.

Stopping the Site Analysis
To stop Linkbot’s analysis:

Go to the toolbar and press the stop button. Linkbot can be stopped at any time dur-
ing the analysis.

Using Filters
Use the filter buttons on the toolbar to isolate and act upon certain types of URLs 
shown in the Children and Parents tabs (e.g., graphics, FTP, bad links, good links, 
etc.). Filters can be used individually or in combination, but in either case filters 
only affect the right window pane.
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Filters are useful for several reasons:

• They make it easier to find or display information.

• They allow you to select a subset of URLs to re-check, print, or export (to 
HTML or to a text file). For example, you could choose to show only the broken 
hyperlinks/URLs that point to an external site, and filter out all other hyperlinks/
URLs.

To invoke a filter on the Children or Parents tab content:

1. Go to the toolbar and press one or more filter buttons. The content in the Chil-
dren or Parents tab changes depending on the filters depressed. When a filter is 
depressed, its background turns light grey.

2. Press a filter button again to deselect it. The background of the button returns to 
normal.

Creating Site Reports
When Linkbot has completed a site analysis it asks if you want to publish a site 
report. The site report is a comprehensive HTML report made up of ten sections 
that summarize the analysis. If you have chosen not to publish the report after an 
analysis you can always publish it at a later time as long as you save the project file 
(see “Saving Your Project File” on page 22).

To create a site report:

1. Go to the Tools menu and choose Publish Site Report. A Save dialogue box 
appears.

2. Choose the path of the new file and enter a filename for it. Linkbot saves the file 
and automatically loads it into your Web browser for viewing.

Saving Your Project File
You can save the results of Linkbot's analysis in a project file, which has the exten-
sion ‘bot’.

To save a project:

1. Go to the File menu and choose Save.

2. Choose the path and enter a filename for the project. Project files are automati-
cally given the extension ‘bot’.
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File Types and Extensions
Linkbot has the following file and extension types:

Extension File Type

.bot A project file, which is a complete site analysis. 
Linkbot comes with a sample project file called 
‘example.bot’.

.htm An HTML file. Linkbot uses HTML files to repre-
sent the following: tutorial files, sample site report 
(example.htm), published site report, or site index.

.ini An options file. The file ‘linkbot.ini’ is the default 
options file (see Chapter 7 on page 53 for more 
information).
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CHAPTER 3 Finding and 
Repairing Problems
This chapter describes how to view the various errors that Linkbot found in 
your Web site, interpret those errors, and make the necessary repairs.

Viewing the Errors Found

When Linkbot performs an analysis of your site it can produce a summary of the 
results. There are two places to view the summary of results:

• the project window, and

• a Web browser.

Interpreting Link Status Messages
The Children and Parents tabs both contain a column, the Link Status column, that 
describes the status of your site’s links. The Link status column can contain one of 
the following messages:

• OK: The hyperlink/URL is working properly.
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• Warning: The URL has been temporarily or permanently redirected or it con-
tains a syntax error (see “Warnings” on page 26 for more information).

• Error: The URL is broken (see “Errors” on page 26 for more information).

• Unknown: Linkbot does not support the URL’s protocol or the analysis was 
stopped prematurely and Linkbot could not test the link.

Warnings
Warnings can be generated for several reasons:

1. The message “Not checked” indicates that Linkbot cannot check this type of 
URL. Usually Linkbot cannot check a URL because it is unsupported or it was 
disabled in the Search options tab (see Chapter 6 on page 41 for more informa-
tion.)

2. The link has been re-directed to a new location but is still functioning, or

3. The link is a Mailto URL. Linkbot is warning you that it cannot determine 
whether or not the e-mail address is valid. Linkbot can only check whether the 
syntax of the Mailto link is correct. It cannot confirm whether or not the e-mail 
address is valid.

Errors
Error messages are generated by the server for several reasons:

1. Not Found. The file referenced by the URL cannot be found on the server. The 
file has either been deleted or moved.

2. Can't Connect. The base address of the URL may not be correct or the server is 
no longer functioning. 

3. Time-out. The server failed to respond to Linkbot’s request within a specified 
time limit. The time limit is specified in the Search options tab (see Chapter 6 on 
page 41 for more information).

4. Unauthorized. The page requires a user name and a password. This version of 
Linkbot does not support authentication of HTTP requests.

Note If Linkbot produces ‘can’t connect’ or ‘timeout’ errors for links that you 
know are working, try reducing the number of connections (see “Connec-
tion Options Tab” on page 45 for more information). Your server may not 
be capable of handling the current load.
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Displaying Broken Links
There are three ways to display the broken links on your site:

Repairing Broken Links
To repair the broken links you can:

1. Use Linkbot's HTML Text tab. You can view and edit the HTML code for any 
URL or page that has been selected in the left window pane.

2. Edit the HTML code using an external editor. Linkbot can be customized to 
launch an external HTML editor of your choice. 

Note Linkbot can launch other applications for you. If you have a favourite or 
preferred HTML authoring tool you can tell Linkbot to launch it using the 
Apps options tab (see “Apps Options Tab” on page 52 for more informa-
tion). The same holds true for image editing. If you want to work on 
graphics with a certain tool, just tell Linkbot to launch it. Use the Edit 
toolbar button to launch your authoring tool. Consult the on-line help for 
more information on changing these options.

No. Steps

1. a. Go to the project window drop-down menu and choose Bro-
ken Links.

b. Select the Parents tab. Each of the URLs listed on the Parents 
tab must be edited to repair the offending link.

2. a. Go to the project window drop-down menu and choose Pages 
Containing Broken Links.

b. Select the Children tab. Edit each page shown in the left win-
dow pane to repair the problem.

3. a. Go to the Tools menu and choose Publish site report. Linkbot 
creates a report and launches your Web browser.

b. Select the bad links page of the site report.
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Locating Out-dated Pages
Linkbot's What’s Old? analysis lists files that have not been modified within a user-
defined time period. These pages may be out of date and should be checked for old 
information. Use the Reporting options tab to define what constitutes an old page 
(see Chapter 6 on page 41 for more information).

To view the old pages on your site:

Go to the project window drop-down menu and choose Old Pages. Linkbot displays 
a list of all the old pages.

OR

Go to the HTML site report and click What’s Old? To create a Site Report from 
Linkbot, go to the Tools menu and choose Publish Site Report.

Locating Slow Pages
Linkbot's What’s Slow? analysis lists files that may be too slow for your users to 
download. When Linkbot makes the What’s Slow calculation it adds all the URLs 
and the text together on the page as follows:

HTML text + images + other URL objects that may slow the download

If the result exceeds a user defined threshold specified in the Reporting options tab, 
Linkbot flags the page as slow (see “Reporting Options Tab” on page 49 for more 
information).

To view the slow pages on your site:

Go to the project window drop-down menu and choose Slow Pages. Linkbot dis-
plays a list of all the slow pages.

OR

Go to the HTML site report and click on What’s Slow? To create a site report, go to 
the Tools menu and choose Publish Site Report.
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Locating Unused/Orphan Files
Linkbot’s orphan analysis scans your Web server for files that are not in use. An 
unused or orphaned file is a file on the Web server that is not referenced by any 
hyperlinks on the site. 

Linkbot can either scan a local drive or a remote server through FTP.

How Does the Orphan Analysis Work?
Linkbot compares the files found in the directories of your Web server to the hyper-
links/URLs referenced on the Web site. Linkbot takes a base URL that you provide, 
such as http://tetranetsoftware.com, and adds it to every file that it finds on your 
server. Linkbot can then compare your hyperlinks/URLs to the files that it finds on 
the server, which it now sees as having a base URL prefix. Any files that have no 
matching hyperlink are considered to be orphans because they are not referenced 
somewhere on the server. 

Of course Linkbot does not physically add anything during the analysis, because its 
comparison happens behind the scenes. Linkbot only reports what it has found.

Note Please use caution: the orphan analysis is not 100% accurate. For example, 
if your Web site contains references to files in Java Script code, Linkbot 
cannot find them in the URL tree because it does not support Java Script. 
Under these conditions, Linkbot may then presume that a file is not in use 
when it really is.

To view the orphaned files on your site:

Go to the project window drop-down menu and choose Orphaned Files. Linkbot 
displays a list of all unused files.

OR

Go to the HTML site report and click Orphaned URLs. To create a site report from 
Linkbot, go to the Tools menu and select Publish Site Report.
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Using Orphan Analysis With Linkbot’s Scheduler
If you wish to use Linkbot’s scheduling feature (see Chapter 5 on page 37 for more 
information) to check more than one site and check for orphans at each site, you 
will need to create a new options file for each site (see “Working with Multiple 
Option Files” on page 53). You would then associate an options file to a run using 
the command line parameters (see “Command Line Interface” on page 54).

Is My Orphan Analysis Working?
If the orphan analysis is working, a new entry appears on the status bar while Link-
bot is searching for orphans. Note that the orphan counter on the status bar may 
increase at the start of the run and then slowly decline. This behaviour is normal.

Troubleshooting the Orphan Analysis
Try one of the following methods to get the orphan analysis working for you:

• If no orphans are found, Linkbot may be having trouble accessing your Web 
server’s file system. Check both the login and the initial directory to ensure they 
are correct. If you are using a proxy server, ensure that the proxy options are 
correctly configured (for more information see “Proxy Options Tab” on 
page 47).

• If all files are listed as orphans, the Base URL setting may not be correct. If you 
start the run with http://tetranetsoftware.com/ then your base address should 
also be http://tetranetsoftware.com/. If your starting URL is file:///C|/linkbot3/
test.htm, then your base address should be file:///C|/linkbot3/.

• If some files are reported as orphans when you know they are not, your Web 
server is case insensitive. Go to the Search options tab and check the case insen-
sitive option.

• Still having problems? See Tetranet’s support site on the Web at: http://tetranet-
software.com/support.htm. Go to the Help menu to access the support site 
quickly.
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Re-checking a Site
Linkbot gives you the option of re-checking a site. Here are some situations where 
re-checking may be useful:

• You have fixed some of the errors with links and you want to re-check the bad 
links. 

• You want to re-check all your external links every night to ensure that they are 
still intact. 

• You want to re-check the entire site to check new content that was recently 
posted. 

When you re-check a site, you have two options:

1. Re-check Current Links, or

2. Check entire site.

It is important to note that when Linkbot re-checks it only verifies the existing list 
of URLs (those showing in the Children or Parents tab). It does not check to see if 
new URLs were added to a page.

When Linkbot checks the entire site it starts a new analysis from scratch. Linkbot 
also over-writes the existing site report. If new URLs have been introduced since 
the last run, Linkbot finds them and tests these as well. 

To re-check a subset of links:

1. Go to the project window pull-down menu and choose All Links.

2. Select the Children tab.

3. Select one or more filters from the toolbar (e.g., external links filter).

4. Go to the Tools menu and choose Re-Check Current Links.

To update all the URLs in a site:

Go to the Tools menu and choose Check Entire Site.
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CHAPTER 4 HTML Reports
This chapter describes the two types of HTML reports that Linkbot can produce:

• site report, and

• site index.

Overview

When Linkbot analyzes a site it creates a site report upon your request. The site 
report summarizes and consolidates the information presented in Linkbot’s project 
window. The site report offers an easy way to explore Linkbot’s results. 

The site report is saved in HTML so you can review it in a Web browser. It is orga-
nized into several pages linked together with a main contents.

Using the Site Report options tab you can change some of the parameters Linkbot 
uses when it produces a site report (see Chapter 6 on page 41 for more informa-
tion).

Do not confuse an HTML export with the export to text file option, which is dis-
cussed in Chapter 7.
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Site Report Categories
The site report describes the status of a Web site in ten categories:

Site Summary: Shows an overview of the site's major problem areas as 
well as some statistics about the site.

Warnings: Lists all non-critical problems, such as re-directed URLs 
and syntax errors.

Broken URLs: Shows each broken URL and all the pages that reference 
it.

Broken Pages: Shows all pages that contain broken URLs.

What's New? Lists all URLs that have been changed within a specified 
time interval. You can customize the time period covered 
by the What's New? page from the Site Report options tab.

What's Old? Lists all URLs that have not been changed within a speci-
fied time interval. You can customize the time period cov-
ered by the What's Old? page from the Site Report options 
tab.

Orphaned URLs: Shows the files that do not have a reference to them else-
where on the site. These files are taking up space on the 
server. You can customize certain aspects of the orphan 
analysis through the Orphans options tab.

What's Slow? Shows all pages that take too long for users to download. 
You can customize the definition of What's Slow? from the 
Site Report options tab.

Image Catalog: Lists all images on your site with a thumbnail representa-
tion of each image.

Site Map: Shows the hierarchy of your Web site. The hierarchy is 
identical to the one shown in Linkbot’s project window. 
By default, only three levels of the hierarchy are shown. 
You can change the default from the Report options tab 
(see “Edit Reports” on page 51 for more information).
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Each report has a 
different slant on 
the analysis of your 
site

The links shown in 
a site index are all 
hot. You can jump 
to any page listed 
in the index
A sample site report can be found in the directory where you installed Linkbot:

Site Indexes
You can also publish site indexes at any time. A site index, which is also an HTML 
file, provides an alphabetical listing of all your site’s links, with status information 
about each link.
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CHAPTER 5 Scheduling Runs
This chapter describes how to schedule runs using either Linkbot’s built-in sched-
uler or a third party scheduler.

Overview

Linkbot’s scheduling features allow you to automate the routine maintenance of 
your site. Automation is integral to maintaining an error free site. The more auto-
mated a site management system is, the less chance there is for problems to creep in 
undetected.

Linkbot provides a very powerful, yet simple set of options for automating site 
maintenance. For example, you can tell Linkbot to analyze http://tetranetsoft-
ware.com/ every Sunday night at 12 a.m. On Monday morning an HTML site report 
will be waiting for you. 

With Linkbot’s scheduling options you are not restricted to one site. If you manage 
several sites you can have Linkbot analyze them all. In fact, Linkbot can analyze an 
unlimited number of sites at once.
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Enter the name of the 
URL where Linkbot 
will start its run

Enter the HTML file 
name that Linkbot will 
create when the run 
has completed
How to Schedule Runs
There are two methods to schedule runs:

• use Linkbot's built-in scheduler, and

• use a third party scheduler like the one built into Windows NT or Internet 
Explorer 4.0.

If you use the built-in scheduler, Linkbot must already be running before the sched-
uler starts. A third-party scheduler, on the other hand, can launch Linkbot, have it 
analyze your site, and then shut itself down. Both methods for scheduling runs are 
described here.

To use Linkbot's built-in scheduler:

1. Go to the Tools menu and choose Schedule Runs. The Schedule Linkbot Runs 
dialogue box appears.

2. Select the Sites To Check tab.

3. Enter one or more sites in the Starting URL field.

4. Press the Add button. The URL is placed in the Scheduled Task List area. The 
starting URL tells Linkbot where the analysis will start. If you enter more than 
one starting URL, Linkbot checks the first site then checks the second and so on.

5. Enter a Site Report file name for each site you enter in the Starting URL field. 
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Enter a frequency 
and a time for the run 
to start

Select a report set-
tings option
6. Select the Run Schedule tab.

7. Enter the time when you want Linkbot to begin analyzing your site.

8. Select a frequency from the options. You can tell Linkbot to run just once or at 
regular intervals: hourly, daily or weekly.

9. Enter the time you want Linkbot to turn itself on in the Time to Start Run field.

10. Select one of the options in the Report Settings field.

11. Press the OK button. Your scheduling options are now configured. Ensure that 
you leave Linkbot running before the scheduled run time begins.

To use a third party scheduler:

1. Go to the Tools menu and choose Schedule Runs. The Schedule Linkbot Runs 
dialogue box appears.

2. Select the Sites To Check tab.

3. Enter one or more sites in the Starting URL field.
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4. Press the Add button. The URL is placed in the Scheduled Task List area. The 
starting URL tells Linkbot where the analysis will start. If you enter more than 
one starting URL, Linkbot checks the first site then checks the second.

5. Enter a Site Report file name for each site you enter in the Starting URL field.

6. Select the Run Schedule tab.

7. Go to the Frequency field and select the Run When Linkbot is started option.

8. Press the OK button.

9. Exit Linkbot.

10. Using your third party scheduler, specify a date and time when you want to 
launch Linkbot. The next time Linkbot is started, it analyzes the sites you speci-
fied. Linkbot will also turn itself off if you have checked the ‘Exit Linkbot when 
all scheduled tasks are finished’ option.

Dial Up Options for Scheduling
Linkbot can be tasked with automatically dialing your modem and establishing an 
Internet connection when the scheduled run is initiated. The Connection tab con-
tains the options related to this task. The options enable you to: enter a dialup entry 
from your networking folder, enter a username and a password (see “Connection 
Options Tab” on page 45 for more information).
User’s Guide to Linkbot



CHAPTER 6 ConÞguring Linkbot
This chapter describes the many options Linkbot has for tailoring it to suite your 
site and the configuration of your network. For example, there are options to:

• Limit the depth and speed of a search. The speed is the number of links checked 
simultaneously.

• Filter specific URLs and directories from a search.

• Configure proxy and password settings.

• Customize the What’s New? What’s Old? and What's Slow? reports.

• Specify external applications for HTML and image editing. 

There are eight option tabs in all: search, filters, connection, proxies, orphans, 
reporting, export, and apps (applications). If you need more information on using 
Linkbot’s options than is described in this chapter, refer to the on-line help facility.
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Specify how deep 
Linkbot should 
traverse into your 
site

Specify whether or 
not Linkbot checks 
external links
Search Options Tab
The Search tab is used to customize how Linkbot analyzes your site.

Note Set the options on the Search tab before you run an analysis.

Check All Links in Current Domain
When you select this option, Linkbot checks all links in documents that have the 
same base address as your starting URL. For example, if you start Linkbot by enter-
ing the URL www.tetranetsoftware.com, then all documents that have that same 
base address are checked. The analysis would also include external links if the 
Check External Links option is selected.

Check Current Domain to a Depth of x
Enter a number which limits the depth of Linkbot’s analysis. Unlike the previous 
option, which checks all URLs with the same base address, the ‘Check current 
domain to a depth of’ option limits Linkbot’s analysis. If you set the depth to one, 
Linkbot only checks the links in the first page of your site. If you set the depth to 
two, Linkbot checks the links on the first page and the links on the second page or 
pages (if there is more than one URL on the first page).
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Check External Links
Linkbot checks the links to external Web sites, i.e., outside of your site, when this 
option is selected. Linkbot does not traverse through the links on the external site.

Only Check Links in Starting Directory and Sub-directories
Linkbot is prevented from branching into directories outside the starting directory 
and sub-directories when this option is selected. For example, if your starting URL 
was http://www.netcom.com/~mysite/, then Linkbot would not branch into directo-
ries outside the /~mysite directory.

Look for Robot.txt Files
When you select this option Linkbot consults the instructions in the robots.txt file 
before checking your site. The robots.txt file tells visiting robots, like Linkbot, what 
directories they can and cannot look in when they search your site.

Note You can also use the Filters tab to prevent Linkbot from checking certain 
directories.

Accept Cookies
When you select this option Linkbot accepts cookies during its analysis.

Internal Links Are Not Case Sensitive
By default, Linkbot assumes that your Web server is case sensitive. If your server is 
not case sensitive, then check this option. If you run Linkbot in case sensitive mode 
when your server is not case sensitive, Linkbot may find duplicate URLs that are 
essentially the same but differ in their case. Besides cluttering the analysis with 
redundant URLs, the accuracy of the orphan analysis is also affected. Linkbot may 
flag a file as an orphan when it really is not because of a case mismatch between the 
URL and the actual file.

Default Index File Name for Local Checking
Enter the default file Linkbot should look for when it checks URLs that point to a 
directory on your local hard disk. By default, Linkbot assumes the default file is 
index.htm. 
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Enter as many URLs 
as you wish—the Fil-
ters tab keeps track of 
them for you

Use these buttons to 
manage the list of 
URLs to filter
Root Location for Local Checking
Enter a directory that Linkbot should consider as the base address for the URL (if 
you are running Linkbot on your local drive). All relative URLs will then reference 
this directory as the root.

Filter Options Tab
The Filters tab is used to prevent Linkbot from checking specific files and directo-
ries. Linkbot ignores all URLs that match or begin with the URL you entered. For 
example, if you entered “http://tetranetsoftware.com/download/”, Linkbot would 
filter (ignore) all URLs that start with this prefix.

Add
Adds a URL to the filter list.

Replace
Replaces the currently selected URL with a new one.

Enter a prefix 
without an 
address, such 
as ftp://, to 
ignore all URLs 
starting with 
that prefix

Use this button 
to include cer-
tain directories 
of a filtered 
URL
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Tip! 

Change the num-
ber of connections 
to suite your sys-
tem’s resources

Log on to an FTP 
server as anony-
mous, with your e-
mail address as the 
password
Delete
Removes the selected URL from the filters list.

Delete All
Deletes all URLs from the filters list.

Using the filter options you can prevent Linkbot from checking specific types of 
URLs. For example, to stop Linkbot from checking all FTP URLs, enter the filter 
“ftp://”.

But Include
Allows you to include certain directories from a URL path that has been filtered.

Connection Options Tab
The Connection tab is used to configure Linkbot’s network options.

Enter a username 
and password if 
your site has 
restricted access
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Tip! 
Number of Simultaneous Connections
Enter the number of URLs that Linkbot should check at the same time. The default 
value is 10. You may set this number between 1 and 20. Setting the number of 
simultaneous connections higher makes the run progress faster but it also consumes 
more of your PC’s resources and increases the load on your Web server.

With a dial-up connection it is unlikely that Linkbot will degrade your Web server’s 
performance significantly. However, with a direct Internet connection, a high per-
formance PC, and a slow Web server, your users may experience a decrease in 
response time from the Web server while Linkbot is running.

If Linkbot reports “can't connect” errors for URLs that you know are working, try 
reducing the number of simultaneous connections and start the analysis again.

Connection Time-out in x Seconds
Enter the connection time-out in seconds. The value should be between 1 and 60. 
By default, Linkbot times out after 1 minute of waiting for the server to respond. 
Setting the connection time-out to a low value speeds up your run times.

HTTP User Agent
Select a specific user agent from this list, if your site has been customized for one, 
or enter your own. The HTTP user agent enables Linkbot to pose as a specific 
browser when checking your site. This feature is useful if your site has been 
designed to show different content to different browsers.

Use the Following User Name and Password for Authenticated Pages
Enter a user name and password for your site, if it requires them. When Linkbot 
encounters a page that requires authentication, it automatically enters the user name 
and password you provide.

E-mail Address for Anonymous FTP Checking
Select this option to have Linkbot log onto an FTP server with the user name set to 
anonymous and the password set to your e-mail address. This is a standard protocol 
when checking anonymous FTP links.
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Specify whether or 
not your network 
has a proxy server
Proxy Options Tab
The Proxy tab is used to configure Linkbot to work through your proxy server if 
you have a firewall on your network.

Direct Connection
Disables the proxy server fields.

Connect Through a Proxy Server
Configures your proxy settings.

HTTP Proxy Requires Username and Password
Enter the username and password for your proxy server. Note that in many cases 
this is not required.

Enter the user-
name and pass-
word required by 
the proxy server
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Turn off the orphan 
analysis

Select an FTP site to 
check, then enter log-
in data
Orphan Options Tab
The Orphans tab is used to change the settings for the orphan analysis. Linkbot’s 
orphan analysis scans your Web server (either local or FTP) for files that are not in 
use. An unused or orphaned file is a file on the Web server that is not referenced by 
a hyperlink/URL anywhere on the site.

Do Not Check for Orphan Files
Disables the orphan analysis.

Check FTP Site for Orphan Files
Select this option to have Linkbot check for orphans via FTP on a remote Web 
server. Linkbot needs to access the directory where your Web site's files are located 
in order to complete an analysis.

Check Local Site for Orphan Files
Select this option to have Linkbot check for orphans on a local hard disk or network 
directory. Linkbot needs to access the directory where your Web site's files are 
located in order to complete an analysis.

Select a local 
site to check then 
enter the URL 
and path informa-
tion
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FTP Site

Base URL: The URL prefix that should be added to all files in order to 
check an entire Web site. For example, http://www.tetra-
netsoftware.com/ would be entered into the Base URL 
field in order to check Tetranet’s site.

FTP host: The host name of the FTP site where your files are 
located. In the previous example the address www.tetra-
net.com would be entered into the FTP host field.

Username: The user name required to log onto the FTP site.

Password: The password required to log onto the FTP site. 

Initial directory: The starting directory where your Web server files are 
located. Using the same Tetranet example, if the first 
directory to be checked is called ‘.public_html/’, that 
directory would be entered into the Initial directory field.

Local Site

Base URL: The URL prefix that should be added to all files in order to 
check an entire Web site. Leave this field blank if the base 
address is the same as the initial directory; Linkbot will fill 
it in for you when you add an Initial directory.

Initial directory: The starting directory where your Web server files are 
located.

Browse: Find the directory on your computer that will be added to 
the Initial directory field.

Reporting Options Tab
The Reporting tab is used to customize the What’s New? What’s Old? and What’s 
Slow? lists in the project window and in the HTML site report. The What’s New? 
page can be used to automatically generate a list of URLs that have been modified 
recently. 
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Enter the criteria that 
Linkbot will use to 
conduct its what’s new 
and what’s old analy-
sis

Enter the criteria that 
Linkbot will use to 
determine a page’s 
download speed
The What’s Old? page can be used to automatically generate a list of URLs that 
have not been modified recently. The What’s Slow? page lists files that may be slow 
for users to download due to the size of the file or the number of hyperlinks con-
tained on the page.

What’s New/Old?
Enter the time interval used to construct the What’s New? page in the site report. 
The default value is one month. This means that the What’s New? page lists all 
URLs that have been modified in the last month.

Enter the time interval used to construct the What’s Old? page in the site report. The 
default value is six months. This means that the What’s Old? page lists all URLs 
that have not been modified in the last six months.

What’s Slow?
Page Download Size

Greater Than: Enter the file size, in kB, that Linkbot should consider 
slow. Note that this is the combined page size (HTML + 
images + other objects).

Download Time: A read-only field that shows how long it would take to 
download a page of this size using the selected access 
speed.

Add/remove com-
ponents from the 
site report
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Access Speed: Change the access speed to test how long it would take to 
download the selected page. Note that a value of 64 Kbs 
(64 kilobits per second) is used to calculate ISDN access 
times.

Calculate Time 
button: Calculates the download time required and displays it in 

the download time field. The calculation is based on the 
page size entered and access speed selected.

Only Include HTML Files
Select this option when you only want HTML documents to appear in the What’s 
New? and What’s Old? pages. Images, multimedia, and other non-text files are 
ignored.

Exclude External Links
Select this option when you only want internal URLs to appear in the What’s New? 
and What’s Old? pages.

Edit Reports
Allows you to add or remove components from the published site report, such as 
the broken links summary. You can customize the site report output to only include 
those components that may be relevant to your needs.

Export Options Tab
The Export tab contains settings for the Export to HTML file command. With the 
Export tab you can specify what fields you would like to appear in the HTML file. 
By default, the file always contains the title of the URL. You can also include the 
following:

• Show Link: When you select this option, Linkbot includes the URL of the link 
in the HTML page.

• Show Last Modified Date: When you select this option, Linkbot includes the 
last modified date of the link from the HTML page.

• Show Parent Links: When you select this option, Linkbot includes the parent 
URL(s) of the link from the HTML page.
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Change the informa-
tion contained in the 
HTML export and 
index files

Enter the path to an 
HTML editor

Enter an image 
editor
• Show Image, Mailto, FTP, and Applet links: When you select this option, 
Linkbot includes all of these kinds of links in the exported file. 

Apps Options Tab
The Apps tab is used to specify external applications that should be launched when 
you select a URL and press the Edit button on the toolbar. Note that this function 
will not work on remote URLs.

External HTML Editor Command Line
Enter the path to your HTML editor.

External Image Editor Command Line
Enter the path to your image editor.

Find the application 
on your hard drive 
through a dialogue 
box
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CHAPTER 7 Advanced Features
This chapter describes how to work with multiple option files, use command line 
parameters, export analysis data, and make use of the Errors by Author report.

Working with Multiple Option Files 
Option files are useful if you have many different sites or subsections of a site. You 
can create a different configuration of Linkbot options for each site and then load 
them as needed. Option files can be called into use from the command line when 
starting the program or when starting a run.

Any changes made to the default options are saved in Linkbot’s option file—link-
bot.ini—which is stored in the default directory. The options are global, i.e., they 
are not associated with a project file. 

To create an option file:

1. Change the options for your site as desired using the Options command on the 
Tools menu.

2. Go to the File menu and choose Save/Load options.
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3. Enter a filename and press the Save button.

Note The file you have just created is now the global options file, even when 
Linkbot is closed and launched again. To return to another options file see 
“Command Line Interface” on page 54.

Command Line Interface
Linkbot allows you to use command line parameters when you are:

• starting the program, and

• starting a new project.

The command line parameters allow you to customize the options (ini) file that is 
used when starting the program or when starting a run. These parameters can also 
be used to start Linkbot with a specific URL.

A command line parameter can be entered from the Windows run dialogue box or 
from Linkbot’s Address field (where URLs are entered). 

Note You must first set up your site-specific options and save them before you 
can call up an options ini file in the following procedures.

To start Linkbot using a specific ini file:

Type linkbot.exe -i option_file_name.ini into the Address field. Substitute 
option_file_name with your file name.

To start Linkbot using a specific URL file:

Type linkbot.exe http://www.yoursite.com into the Windows run dialogue box. 
Substitute the Web address with the site to be checked.

To start a Linkbot run using a specific ini file:

Type http://www.yoursite.com -i option_file.ini into Linkbot’s Address field. Sub-
stitute the Web address with that of the site to be checked and the option_file with 
the name of your option file.
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 Exporting to a Text File
To associate a specific options file with a scheduled run:

1. Go to the Tools menu and choose Schedule Runs. The Schedule Runs dialogue 
box appears.

2. Type your address followed by the option ini file in the Starting URL field. For 
example, ‘http://www.yoursitename.com -i option_file.ini’, where yoursitename 
is the address of your site, and option_file is the name of your options file.

Exporting to a Text File
To export the contents of the Parents or Children tab to a delimited text file:

1. Select either the Parents or Children tab.

2. Go to the File menu and select Export to File.

Linkbot creates a text file with fields separated by commas. You can import this list 
into a spreadsheet or data base.

Note You can filter the contents of the Children and Parents tabs by pressing one 
or more of the filter buttons on the toolbar (see Chapter 2 on page  11 for 
more information). Only the URLs that are shown in the Parents/Children 
tab are exported.

Groupware Functions
If your site has many contributors or authors, you may find the Errors by Author 
report very useful. The Errors by Author report summarizes all the pages that con-
tain problems and groups them by originator. To use this feature you must add the 
standard author meta tag to your HTML documents. 
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To specify a page's author, enter the following hidden meta tag into the head tag of 
the HTML page:

<HEAD>
<META NAME="Author" content="John Smith"> 
</HEAD>

To view the errors grouped by author:

1.  Create an HTML site report.

2. Select the broken pages report from the menu. The broken pages report is dis-
played in the right-hand frame of the site report.
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