Strange Cargo
Beta Release 2
Build x057

Release Notes

This document includes information on all of the changes found in this latest release of Adobe Photoshop,
as well as a listing of some of the most significant known issues that may affect you as you test this
application. Please familiarize yourself with this information before beginning your testing.

This file will be updated for future beta releases of the application.

Known Issues

(2/6/98) Adobe is already aware of the following issues in Beta Release 2. Most of these issues will be fixed
before the next beta release is made available:

e [MacOSs 8.x only] Some elements of the interface are not properly displaying the “Platinum” look of
MacOS 8.x.

(1/17/98) Adobe is already aware of the following issues in Beta Release 1. Most of these issues will be fixed
before the next beta release is made available:

«  Working with a scratch disk that has more than 2GB of free space available may result in a crash.

e There have been reports of garbage characters appearing in some of the controls in the Layer Effects
dialog. This is a display issue only, and will be fixed in a future beta release.

»  Certain areas in the application may become unstable under low memory conditions, particularly when
using Paths and Type Layers. For example, using the Free Transform command on a Type Layer or on a
path may result in a crash when memory is low. Also, working with files that include many paths may
cause problems.

e The Export Transparent Image Wizard currently saves transparency in PNG files only if the file already
contains an alpha channel. Creating a selection prior to using the Wizard does not currently work
properly. Also, only the newest releases (v4.0) of Microsoft Internet Explorer and Netscape Navigator
currently support PNG files without the use of plug-ins.

e There may be a memory leak when opening PDF files. This can result in a low memory condition. If you
should see any low memory messages after opening a PDF file, exit Photoshop and then restart the
application.

e The Magnetic Pen tool may cause a crash when used on high resolution images.
*  When using the Multi-page PDF to PSD command in the File>Automate menu to convert a PDF file
stored on a CD, make sure that the destination for the PSD files is not also set to the CD. Using a CD-

ROM as your destination drive will result in a program error.

« Inthe Grids and Guides dialog, setting the spacing for gridlines too small (e.g. gridline every 1 percent)
can cause the application to hang.
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The Opacity slider in the Layers palette should not be available in images that contain only a
background layer. In some cases, however, the slider may still appear to be available. Changing the
opacity slider on an image with only a background layer will result in a program error and/or the
application crashing.

Certain effects may cause display problems when used in combination with adjustment layers.
Specifically, applying a layer effect to an adjustment layer in an image with no background may cause
the display to become corupted. Also--on Windows systems only--using one of the built-in filters, such
as Gaussian Blur and Unsharp Mask, on an adjustment layer may result in a corrupted dialog box.

[Windows only] When using the Measure tool on a zoomed-in view of a document, auto-scrolling by
dragging the Measure line endpoints off the edges of the document may cause artifacts in the on-screen
display of the image and the rulers.

[Windows only] The new Gamma utility (found inside your Photoshop folder in
\calibrat\NewGammaLoadWin.exe) will not run properly on systems set to display 32-bit color.

[Windows Only] Installing UMAX Vistascan v1.04 after installing Photoshop will disable Photoshop.
The workaround is to reinstall Photoshop after installing the Vistascan software.

[Macintosh Only] Using Magnetic Pen, Lasso, and Magnetic Lasso tools in sequence may result in a
crash.

What's New

Following is a listing of virtually all of the new features, both major and minor, in Strange Cargo as
compared to Photoshop 4.0:

Major New Features

Color Management

All Color Settings dialogs have been changed and improved.

RGB and CMYK spaces can be specified using ICC profiles.

Images can be saved with ICC tags, and tags will be read when opening images.

Dot Gain Curves can now be defined in CMYK setup (if not using ICC)

Support for non-monitor RGB means that the RGB space used for editing images can be different than
the RGB displayed by your monitor. Compensation between the two can be enabled in the RGB Setup
dialog.

New Gamma Control Panel can be used to calibrate your monitor and export an ICC profile for use
with ColorSync or ICM 2.0. (Currently, the Gamma control panel is installed in the Calibration folder.)
Custom Inks setup in CMYK Setup dialog can allow Lab coordinates, and includes two additional color
swatches for white point and black point.

Image>Mode>Profile-to-profile command can be used to do converstions between different color
space profiles on the fly.

History Palette (Photoshop’s answer to multiple undo)

As you edit, the History palette displays a listing of the most recent changes you've made to your
document.

Click on any editing step to revert to that stage of your editing session, or simply drag the slider bar at
the left of the palette.

Click on the Create Snapshot button to hold any image state as a snapshot at the top of the palette.
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Click in the left-hand column of the palette to set the source for the History Brush. (see New Tools
section, below)

History is now substituted wherever the Snapshot option was available in Photoshop 4.0.

History Palette options allow you to control the maximum number of states stored in the palette as well
as to use “non-linear history.” Non-linear history allows items to stay available in the palette longer, but
may be more confusing for the average person to use.

NOTE: All contents of the History Palette are limited to the current editing session. When you close and
then re-open the file, the palette will be blank except for the initial snapshot.

16-bit Channel Support

Support for 64-bit CMYK images

Hue/Saturation, Brightness/Contrast, Color Balance, Equalize, Invert, and Channel Mixer can all be
applied to images with 16-bit channels.

Crop, Rubber Stamp, and History Brush tools can now be used on images with 16-bit channels.
Image Size and Rotate->Arbitrary now work with images with 16-bit channels.

Layer Effects (found in Layer>Effects menu)
Dynamic effects can be added to any layer and update on-the-fly as the layer is edited:

Drop Shadow

Inner Shadow

Outer Glow

Inner Glow

Bevel and Emboss (includes Outer Bevel, Inner Bevel, Emboss, and Pillow Emboss)

New Tools

Color Sampler tool allows placement of up to four samplers in the image to give persistent before/after
color readouts in the Info palette for multiple locations.

Magnetic Lasso and Magnetic Pen tools intelligently snap to the edges in images as you drag to define
new selections or paths

Freeform Pen tool allows you to create a path by dragging just as you would with the Lasso tool.
Measure tool can be used to measure distances and angles in the document. After dragging a Measure
line, hold down the Alt/Option key on an endpoint of the line and drag to define an angle.

Vertical Type tool

Vertical Type Mask tool

Pattern Stamp tool is a replacement for the Rubber Stamp tool's "from pattern” setting.

History Brush tool paints from the current source in the History palette. (To set the source, click in the
left-hand column of the palette.) This tool replaces the Paint from Undo option.

Gradient tool now has pop-up with existing gradient types plus three new ones: Angular, Diamond, and
Reflected. Gradients also now have less banding. Reverse button has been added to the Gradient
Options dialog to reverse the direction of the gradient colors.

Type Layers

Horizontal and Vertical Type tools create re-editable type layers. (Change contents at any time by
double-clicking on the layer.)

Kerning or auto kern option

Tracking

Leading

Baseline shift

Multiple fonts per layer

Multiple styles per character

Full support for single- and double-byte characters

Live preview, with ability to reposition text in image when dialog is open
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Resizable and zoomable dialog.

Rotate option for vertical type.

Orientation of the text can be toggled in the Type submenu in Layer Menu, between Horizontal and
Vertical.

Type layers can be Free Transform-ed and can include layer effects. Further editing of the layer requires
use of the Layer>Type>Rasterize command to turn the type layer into a regular layer.

For CJK text using double byte characters, "Yakumono shori" or a subset of Japanese line composition
rules automatically apply.

New Adjustments/Adjustment Layers

Improved Hue/Saturation dialog allows adjustment of any selected color. Color can be selected using
color bar interface or by clicking in the image window.

Channel Mixer allows the color channels in an image to be redefined using a custom mix of the existing
channels. (e.g. Redefine the Red channel as being 80% of the original Red channel plus 30% of the
original Green channel.)

Spot Color Support

Spot color channels can now be added to any image using the New Spot Channel command in the
Channels palette.

Merge Spot Channel command in Channels palette will merge the contents of the spot channel into the
existing CMYK or RGB channels.

Duotones converted to Multichannel mode are converted as spot channels.

Improved Scriptability

The following commands, tools, and functions can now be recorded using the Actions palette, in
addition to those already supported by Photoshop 4.0:

= Paths palette

= Layers palette

= History palette

= Gradient Tool

=  Marquee Tool

= Crop Tool
=  Polygon and Lasso Tool
= Line Tool

=  Move Tool

=  Magic Wand Tool

= Paint Bucket tool

=  Type tool

= Lighting Effects

= Calculations

= Apply Image

= File Info

= Switching and Selecting documents

=  Free Transform

More menus "Insert Menu Item" savvy

The units recorded when using tools are now based on the current ruler units. Choose the new
"Percent" option for ruler units to record relative positions.

3D Transform

Filter>Render>3D Transform command can select portions of images (such as a photograph of a box)
and manipulate them as if they were 3D objects.

File Format Additions
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Flashpix Import/Export

Import/Rasterization of any PDF file

When saving PDF files have control over JPEG and ZIP compression.

Import of multi-page PDF files using File>Automate>Multi-page PDF to PSD command

DCS 2.0 support saves separations in a single file and includes alpha/spot channels. (DCS 1.0 and 2.0
are available as separate file formats in the Save dialogs.)

Tranformation Improvements

Free Transform now has a centerpoint for rotation. Center point can be absolute or relative.

New Repeat command in Edit>Transform submenu repeats the last transform settings.

Selections can be transformed with the Selection>Transform command.

When a path or part of a path is selected, the Edit>Transform commands become Edit>Transform Path
commands.

With the exception of the Selection>Transform command, all transformation commands are now in
the Edit menu instead of the Layer menu.

Other New Features

View>Preview submenu now includes separate preview modes for individual CMYK plates as well as for
CMYK composite preview.

Improved quality in 8-bit RGB-to-CMYK conversions.

Layer>Align Linked and Layer>Distribute Linked submenus make it easy to align or distribute multiple
linked layers along their edges or centers. Layers are aligned to or distributed around a selection if one is
present.

Select>Reselect command will bring back the last selection used.

Improved Indexed Color conversion dialog (from Image>Mode>Indexed Color...)

= Much better adaptive palette quality for indexed color conversion

= 'Best Quality' option for indexed color conversion (dithering/conversion is just a little less accurate
without this option, but much faster)

= 'Preserve Exact Colors' option for indexed color dithering. This means that colors in the image that
are also in the palette will not be dithered, preserving fine lines and text for web images

= Indexed color mode change dialog now previews.

Postscript 3 support: DeviceN color support for Duotones

Actions Plug-ins. New plug-in type that allows for plug-ins that control the existing functionality of

Photoshop to make complicated tasks easier and/or to automate workflows. All Actions plug-ins will be

found in the Help menu or the File>Automate menu. Plug-ins included with this release are:

= Resize Image Wizard to make it easier to target the proper size for an image based on the desired
output.

= Export Image with Transparency Wizard to export an image in EPS, PNG, or GIF format with the
proper clipping path, alpha channel, or transparency color.

= Automate>Batch command replaces the batch command that was included with Photoshop 4.0
and allows for further options including logging of program errors.

=  Automate>Conditional Mode Change to change an image to another color mode based on the
mode it is in already. (This item is useful as the first step of any Action that depends on having an
image in a specific mode.)
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= Automate>Contact Sheet to create a contact sheet with thumbnails of all of the imagesin a
selected folder.
= Automate>Fit Image for resizing an image to fit into a given space without changing its aspect
ratio.
= Automate>Multi-page PDF to PSD for converting a multi-page PDF file into multiple Photoshop
documents.
«  Option to save files with lowercase file extension by default
e Edition manager no longer used in Mac Photoshop
»  Faster saving large files when saving thumbnails
e Can now save Mac and Windows thumbnails independently

»  Pressure-sensitive tablet support no longer requires plugins

« New options in Save Copy As dialog make it easier to exclude unwanted information from files so as to
achieve the smallest possible file size.

e Brush Size cursors can now go up to 32000x32000 pixels on the Macintosh

Miscellaneous U.l. Improvements and Changes

*  New Status item for Current Tool

e More complete Windows help strings for tools

*  Tools show Cancel sign when they can’t be used, single click will beep, double-click tells why

«  All dragging-based selection tools (lasso, poly lasso, mag lasso, mag pen, free pen) get space-bar hand
scrolling mode and -/+ key zoom in/out behavior.

e Option key version of Apply Image dialog deleted.

e Target for Calculations now restricted to: New Document, New Channel, Selection
*  New: Edit> Purge> History command

¢ New: Edit> Purge> All command

e File>Adobe Online... command provides new interface to Adobe on the Web, and replaces the HTML
page that was included with Photoshop 4.0.

e The clipping path controls are no longer available in the EPS format options dialog. Use the paths
palette command to set the clipping path. (For action addicts, this is a good thing.)

»  Clone tool now clones from the original, pre-cloned state of the document rather than from the
"current” state of the document. This change avoids the "hall of mirrors" effect in which you can
accidentally clone the same section repeatedly.
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Small calculations dialog gone

Save selection dialog allows naming the new channel

New and Changed Key Shortcuts

Shortcut mouse/key combination to link all layers with visible data under cursor
PgUp and PgDn: move up and down by screenful (old)

Shift PgUp and PgDn: move up and down by nudge distance (old)

Cmd/Ctrl PgUp and PgDn: move left and right by screenful (new)

Shift Cmd/Ctrl PgUp and PgDn: move left and right by nudge distance (new)
Repeat last transform: Cmd-Shift-T

Previous history entry: Cmd-Shift-Z
Next history entry: Cmd-Opt/Alt-Z

Reselect: Cmd-Opt/Alt-D

Pen tool shortcut keys now the same as Illustrator
Option key now duplicates paths when using the arrow keys

Shift-+ and Shift-- scroll forwards and backwards through the blend modes for the current tool

=’ ("+’ without Shift) selects the Pen Add Knot Tool and -’ selects the Pen Delete Knot Tool

Airbrush tool shortcut is now (J) (used to be (A))

Path Select Tool shortcurt is now (A)

Tool shortcut keys no longer cycle through tool slots. You must hit Shift-<key> to cycle. Shortcut keys
now simply ensure you are using the tool slot - if you already have that slot selected, the key does

nothing.

Shortcut mouse/key combination to link all layers with visible data under cursor.
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