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Preface
The Lightscape Visualization 

System manuals are comprehensive 

documents that contain all the 

information you need to learn and 

use Lightscape efficiently and 

effectively.
ix



There are three Lightscape Visualization System manuals:

■ The Lightscape Visualization System Getting Started guide 
describes the basic concepts of the Lightscape technology 
and process, how to install and authorize the software, and 
the fundamentals of the user interface. 

■ The Lightscape Visualization System User’s Guide provides in-
depth explanations of the techniques and concepts required 
to set up, process, and render a Lightscape solution. 

■ The Lightscape Visualization System Tutorials provide step-by-
step examples of the procedures discussed in the User’s 
Guide.

The following information is available online in the Lightscape 
On-line Help:

■ The Task List provides step by step “How to” instructions 
for performing the procedures discussed in the User’s 
Guide.

■ The Reference Guide provides detailed explanations of 
each menu in the Lightscape interface.

Conventions Used 
in This Book

Before you start using your Lightscape application, you 
should be familiar with the typographical conventions used 
in this manual.
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Table 1.  Lightscape Typographical Conventions 

Convention Type of Information

Boldface Used for program commands, such as lid2cibse or lid2ies.

Italic Used for emphasis and when a new term is introduced.

Monospace Used for what you see on your screen such as field syntax and 
macro listings, and unspecified information, such as suggested 
syntax and macro samples that you need to provide. This typeface 
is shown in Courier. For example, if the manual says your batch file 
should read: lsray -aa 4 -vf view1.vw -x 1280 -y 
1024 solution1.ls image1.tif , you would see that text 
in your batch file.

Bold monospace  Used for specific text you enter. This typeface is shown in 
Courier bold. For example, if the instruction says “type cd 
projects ,” you would type the letters cd  followed by a space and 
then type projects. This typeface is also used for keys that you press 
on the keyboard, either singly (for example, Enter , Return , 
Esc ) or in combination (for example Ctrl+C ).

Bol d Italic monospace Used for place holders for items or filenames you must provide. 
This typeface is shown in Courier bold italic. As in the previous 
example, if the instruction says “type cd directory_name ,” 
you would replace directory_name  with the name of the 
directory. For a directory called “projects”, you would type cd 
projects . 

News Gothic typeface Used for things that you click, such as buttons and icons, or that you 
choose from pulldown menus and their rollover menus. For 
example, click Accept; choose New from the File menu.

> The > symbol indicates that you are to choose an item from a 
pulldown menu or rollover menu. For example, File > Parameters > 
Load means that you are to choose Load from the Parameters rollover 
menu of the File menu.
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Introduction
The tutorials in this book provide a 

map of the Lightscape process. After 

completing the tutorials, you will 

understand the basic concepts of the 

Lightscape Visualization System and 

will have the skills you need to use 

the software effectively.
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This book contains the following tutorials:

■ Tutorial 1, Getting Started - A Typical Workflow

Introduces you to the main concepts of the Lightscape 
Visualization System.

■ Tutorial 2, Fundamentals - Importing DXF Files

Introduces you to importing geometry from a CAD or 
modeling application. Using a DXF file, you will go 
through the steps you would take when working with a 
model in this format, including defining realistic materials 
and lights.

■ Tutorial 3, Exterior Models - Importing 3D Studio

Teaches you how to import a 3D Studio model and what 
steps to follow for preparing files from 3D Studio. Using 
the exterior model, you will set parameters and process it 
in a slightly different way. At the end of the tutorial, you 
will preview the animation imported with the 3DS file. 

■ Tutorial 4, Importing, Setting Up, and Rendering

Teaches you advanced DXF import techniques and 
specialized preparation tasks such as orienting surfaces and 
placing and aligning textures. You will also create an 
animation and produce frames of the first segment of the 
animation.

■ Tutorial 5, Advanced Lightscape Topics

Teaches you how to join the model files, which you created 
in the preceding tutorials, to create a single solution file. 
You will also optimize one of the models by converting 
selected radiosity mesh elements into texture maps and 
exporting the data to VRML format. 
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These tutorials include procedures that range from basic to 
advanced. They are constructed around the task of rendering a 
model. To complete the model, you must complete the tasks in 
each lesson.

In these tutorials, a procedure that you perform is indicated by 
a triangle symbol ( ), followed by a functional description of 
that procedure.

Before undertaking these tutorials, you should read through the 
Lightscape User’s Guide. This guide contains comprehensive 
information on all of the program features.
xv



How the Tutorials 
Are Organized

Tutorial 1, Getting Started - A Typical Workflow contains the 
following sections, each of which contains one or more lessons:

■ “How Tutorial 1 is Organized”
■ “Lightscape Project Overview”
■ “Importing Data”
■ “Understanding the Lightscape Interface”
■ “Preparing Data”
■ “Creating the Solution”
■ “Fine Tuning the Solution”
■ “Outputting the Results”
■ “Going Further”

Tutorial 2, Fundamentals - Importing DXF Files contains the 
following sections, each of which contains one or more lessons:

■ “How Tutorial 2 is Organized”
■ “Getting Data”
■ “Importing DXF Files”
■ “Preparing Data”
■ “Organizing Data”
■ “Lighting Basics”
■ “Material Basics”
■ “Creating the Solution”
■ “Refining the Solution”
■ “Outputting the Results”
■ “Lighting Analysis”
■ “Going Further”

Tutorial 3, Exterior Models - Importing 3D Studio contains the 
following sections, each of which contains one or more lessons:

■ “How Tutorial 3 is Organized”
■ “Getting Data”
■ “Preparing Data”
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■ “Creating the Solution”
■ “Outputting the Results”
■ “Going Further”

Tutorial 4, Importing, Setting Up, and Rendering contains the 
following sections, each of which contains one or more lessons:

■ “How Tutorial 4 is Organized”
■ “Getting Data”
■ “Preparing Data”
■ “Creating a Solution”
■ “Fine Tuning the Solution”
■ “Outputting the Results”
■ “Going Further”

Tutorial 5, Advanced Lightscape Topics contains the following 
sections, each of which contains one or more lessons:

■ “How Tutorial 5 is Organized”
■ “Getting Data”
■ “Preparing Data”
■ “Outputting the Results”

The following shows a typical tutorial lesson page.

Stage Name Lesson Name

Next procedure you will execute...
A functional description of this procedure. 
1. The first step of the procedure.
2. The next step of the procedure, and so on.

(For example,
(For example, Working with Blocks)

Preparation Stage) 
How the Tutorials Are Organized xvii
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 Tutorial 1 Getting Started -
A Typical Workflow
In this tutorial, you will be 

introduced to main concepts of the 

Lightscape Visualization System by 

completing a short project from 

start to finish. 
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The goal of this tutorial is to render the model used to create 
the image shown in Figure 1-1.

Figure 1-1. Sample of Rendered Image for Tutorial 1
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How Tutorial 1
is Organized

This tutorial contains the following sections and lessons:

■ “Lightscape Project Overview” on page 5
“Importing Data”
“Preparing Data”
“Creating the Radiosity Solution”
“Fine Tuning the Solution”
“Outputting the Results”

■ “Importing Data” on page 9
“Starting Lightscape”
“Opening a File”

■ “Understanding the Lightscape Interface” on 
page 11
“Screen Layout”
“Graphic Window”
“Using the Mouse”
“Materials Table”
“Layers Table”
“Blocks Table”
“Luminaires Table”

■ “Preparing Data” on page 16
“Viewing and Displaying the Model”
“Defining Materials”
“Using Material Libraries”
“Displaying Textures”
“Orienting Luminaires”
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■ “Creating the Solution” on page 29
“Initiating the Preparation Model”
“Setting Process Parameters”
“Checking the Solution”
“Processing the Solution”

■ “Fine Tuning the Solution” on page 36
“Changing a Material”
“Changing a Light Source”

■ “Outputting the Results” on page 41
“Creating a Radiosity Image”
“Creating a Ray Traced Image”
“Saving and Exiting”
“Viewing Image Files with LVu”

■ “Going Further” on page 48
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Lightscape Project 
Overview

Although Lightscape projects vary in complexity and focus, you 
will generally perform the following tasks:

■ “Importing Data”
■ “Preparing Data”
■ “Creating the Radiosity Solution”
■ “Fine Tuning the Solution”
■ “Outputting the Results”

Importing Data
Lightscape imports 3D models which are then rendered using 
the software. These models are generally created in specialized 
CAD or 3D modeling systems.

Lightscape for Windows NT and Windows 95 provides import 
filters for DXF, 3D Studio, and SOFTIMAGE formats. As 
additional filters become available, these filters will plug 
seamlessly into the existing Lightscape interface.

Preparing Data
During the Preparation stage, you perform a number of specific 
tasks to prepare geometric data for radiosity processing. These 
tasks include:

■ Defining the materials that comprise the surfaces.

Because Lightscape is based upon the physics of Lighting, 
accurately representing the material properties of the 
surfaces in your model is important for achieving 
meaningful results.

■ Ensuring that the surfaces of the model are properly 
oriented. 
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■ Setting special processing parameters for the surfaces in the 
model.

These special properties can effect the final appearance of 
the model and the speed and accuracy of the radiosity 
process.

■ Defining the photometric properties (lighting distribution, 
intensity, and color) of the luminaires (lighting fixtures) 
used in the model.

Lightscape uses physically based lighting values to define 
the artificial light sources and natural light.

■ Adding, deleting, and moving entities and luminaires as 
desired.

The model structure used during this stage is called the 
Lightscape Preparation Model and it is saved to a Lightscape 
Preparation (.lp ) file.

Creating the Radiosity Solution
Once you have defined the material and lighting characteristics 
of the model, you can then start calculating the direct and 
indirect diffuse lighting of the model using the radiosity process. 
(For a good introduction to the concepts of radiosity and 
lighting, refer to Chapter 1, The Basics in the Lightscape Getting 
Started manual.)

During this part of the process you will:

■ Initiate the geometry.

This optimizes the model for the radiosity process.
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■ Define the processing parameters.

Using the processing parameters, you can control the speed 
and quality of the resulting radiosity solution. Finer settings 
produce more accurate solutions and better quality images, 
but require more time and memory. Lightscape provides a 
wizard that lets you set the process parameters quickly and 
easily.

■ Process the radiosity solution.

The model structure used during this stage is called the 
Lightscape Solution Model and it is saved to a Lightscape 
Solution (.ls ) file.

Fine Tuning the Solution
In Lightscape, you can interrupt the radiosity process at any 
time to alter or fine tune the model's appearance. You cannot 
change the physical shape of the model, but you can change the 
characteristics of a material and the photometric properties of a 
luminaire.

Outputting the Results
You can output results from a radiosity solution in many ways:

■ Create single images.

You can add specular (shiny) reflections and enhanced 
lighting effects using the post-process ray-tracer.
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■ Create frames for use in animation.

You can create camera animation paths in Lightscape or 
import them from other programs. Individual frames can 
quickly be rendered with OpenGL using the radiosity 
solution alone or rendered with ray tracing to add specular 
lighting effects.

■ Export the radiosity solution as a VRML model for use in 
other applications.
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Importing Data In this exercise, you will perform the following tasks:

■ “Starting Lightscape”
■ “Opening a File”

Starting Lightscape
Start Lightscape.

Note: If you launched this tutorial from the installation 
program, you can skip ahead to “Understanding the Lightscape 
Interface” on page 11.

1. In the Lightscape Visualization System window group, 
double-click the Lightscape icon.

If you are running Windows NT 4.0 or Windows 95, you 
can also start Lightscape by choosing it from the Start menu.

The Lightscape graphical user interface displays on the 
screen.

Opening a File
Load a Preparation file.

The Preparation file for this tutorial has already been set up for 
you.

1. Choose File > Open.

The Open dialog box appears. Note that the Files of Type 
should be set to Preparation Files (*.lp).
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2. Double-click the file tutorial1.lp .

If tutorial1.lp  does not show up on the list, you should 
confirm that your current directory is:

c:\Program Files\lvs\projects\tutorial1

This path assumes that you performed a typical installation. 
You will have to adjust the path if you installed the 
application to a different location.

Lightscape displays a small gallery with a number of light 
sources and picture frames on the walls.
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Understanding the 
Lightscape Interface

This section introduces you to the Lightscape interface by 
discussing:

■ “Screen Layout”
■ “Graphic Window”
■ “Using the Mouse”
■ “Preparing Data”
■ “Layers Table”
■ “Materials Table”
■ “Blocks Table”
■ “Luminaires Table”

Screen Layout
The Lightscape interface, illustrated in Figure 1-2, consists of 
views into the five major components that make up the 
Lightscape model.
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Figure 1-2. The Lightscape Interface

The largest is the Graphic Window. This is located, by default, 
on the left side of the window and occupies the majority of the 
screen. The four other components, the Layers, Materials, 
Blocks, and Luminaires Tables, are grouped together in a 
vertical bar of list windows on the right side of the screen. You 
can reposition and resize all of these windows as required. 

Layers Table

Materials
Table

Blocks Table

Luminaires
Table

Menu Bar

Status Bar Typical Dialog Box

ToolbarGraphic
Window
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You can find editing commands in a variety of locations—by 
using the pulldown menus on the Lightscape menu bar, by 
clicking the appropriate icon in a toolbar, or by bringing up a 
context menu with the right mouse button. 

As you choose editing commands, additional dialog boxes pop 
up as appropriate. 

Graphic Window
The Graphic Window is used to display and edit the geometry 
of the current model.

Using the Mouse
Lightscape is designed for a two-button mouse. The left button 
is the action button. The right button is used to bring up a 
context menu based on the current selection.

Using the Left Mouse Button
When you move the mouse and press the left button in the 
Graphic Window, Lightscape performs one of several actions, 
depending on the currently selected mouse mode. There are 
four general mouse modes:

■ Query Mode - Clicking an entity in the Graphic Window 
displays information about that entity in the status bar.

■ Select Mode - Use the mouse to select entities in the model. 

■ Dynamic View Modes - When you select a dynamic view 
mode such as orbit or rotate, dragging the mouse in the 
Graphic Window dynamically changes the display of the 
model in the window. 
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■ Special Selection Modes - Certain functions in Lightscape will 
require you to perform specialized operations using the 
mouse. These include operations such as dragging an object 
to reposition it or selecting a point on a surface to indicate 
where you would like to aim a luminaire. The special 
mouse modes are typically set from the dialog box related 
to the functions being performed.

Using the Right Mouse Button
Clicking with the right mouse button in any window brings up 
a context menu; a popup menu that contains commands 
appropriate to the current window or to the entities selected in 
it. For example, clicking the right mouse button in the Graphic 
Window when a surface is selected brings up a context menu 
that contains commands that can only be performed on surfaces.

Layers Table
Each entity in Lightscape is associated to a layer and the Layers 
Table displays the names of these layers. A check mark to the 
left of the layer name indicates that the layer is on and that the 
entities associated to it are currently being displayed in the 
Graphic Window. Double-clicking a layer name toggles its state 
on/off. For more detailed information, refer to Chapter 1 in the 
Lightscape User’s Guide.

Materials Table
The Materials Table contains all of the materials currently 
available for use in the model. Double-clicking a material name 
activates the Material Properties dialog box which contains tools 
for editing the characteristics of the material. For more detailed 
information, refer to Chapter 1 in the Lightscape User’s Guide.
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Blocks Table
The Blocks Table contains all of the blocks available for use in 
the model. A block in Lightscape is a group of entities that is 
given a common name and an insertion point. Double-clicking 
a block name isolates the block for display and editing in the 
Graphic Window. You can also enter and end isolate mode 
using the context menu. For more detailed information, refer 
to Chapter 1 in the Lightscape User’s Guide.

Luminaires Table
The Luminaires Table contains all of the luminaires available for 
use in the model. A luminaire is a special type of block used to 
represent light fixtures in Lightscape. A luminaire includes the 
photometric characteristics that control how light energy is 
emitted from the luminaire. Double-clicking any luminaire 
name isolates the luminaire editing in the Graphic Window and 
activates a dialog box for editing the luminaire's photometric 
characteristics. For more detailed information, refer to
Chapter 1 in the Lightscape User’s Guide.
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Preparing Data In this exercise, you will perform the following preparation 
tasks:

■ “Viewing and Displaying the Model”
■ “Defining Materials”
■ “Using Material Libraries”
■ “Displaying Textures”

Viewing and Displaying the Model
Turn on all Toolbars.

This tutorial makes extensive use of the toolbars to quickly and 
easily execute operations.

1. Choose Tools > Toolbars.

The Toolbars dialog box displays.

2. Double-click any item that does not have a check mark in 
front of it to turn on that toolbar.

3. Click Close when you are done.

View the full extents of the model.

Often, you want to see everything on the screen at once. 
Choosing View > Extents adjusts the view to fit the entire model 
in the Graphic Window. In Perspective mode, View > Extents 
orients the model so you view it from the front. In the 
orthogonal views, View > Extents zooms the model to fit in the 
Graphic Window. You should be in Perspective mode when you 
start the tutorial.

1. Choose View > Extents or click the View Extents button on the 
toolbar.
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Adjust the view interactively.

One of the many features of Lightscape is a set of camera 
controls which make it easy for you to interactively change your 
point of view.

1. Choose View > Interactive > Orbit or click the Orbit button on 
the toolbar.

2. Place the cursor anywhere in the Graphic Window, press 
the left mouse button, and drag first horizontally and then 
vertically.

Notice the change of view in the model. This is orbiting.

Set the display mode.

Lightscape gives you a variety of modes with which to display 
your model. The mode at which you are looking is called 
wireframe. A wireframe representation provides the fastest 
display speed but can often become confusing with more 
complex models. Other modes provide better feedback but can 
be slower to display.

1. Choose Display>Solid or click the Solid button on the toolbar.

2. Continue to Orbit the model.

Notice that this is somewhat slower but you can more easily 
understand the model. 

3. To see the model more clearly, choose Display>Outlined or 
click the Outline button on the toolbar.

You can further enhance both Solid mode and Outlined 
mode by adding some simple shading. This will create an 
effect as if you had a headlight mounted on the camera as 
you move around.
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4. Choose Display > Solid or click the Solid button on the 
toolbar.

5. Choose Display > Enhanced or click the Enhanced button on the 
toolbar.

6. Notice that as you orbit the model, some of the surfaces 
such as the walls and ceiling disappear as you turn.

This is a display technique called backface culling. With this 
display mode activated, surfaces that are oriented away 
from your viewing position are removed (culled) from the 
display. 

7. Choose Display > Culling or click the Culling button on the 
toolbar to turn off backface culling.

Notice the change in the display as you orbit.

8. Choose Display > Culling or click the Culling button to turn it 
back on.

Open the original view of the model.

It is easy to restore the view displayed when you first opened 
the model. The view you had when you last saved the model 
becomes the original view the next time you open it.

1. Choose View > Original.

Try other interactive viewing controls.

In addition to orbiting, there are a number or other camera 
modes you can set to interactively set your viewpoint.

1. Choose View > Interactive > Pan or click the Pan button on the 
toolbar.
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2. Place the cursor anywhere in the Graphic Window, press 
the left mouse button, and drag first horizontally and then 
vertically.

Notice the change of view in the model. This is panning.

You will often have to use a combination of viewing modes 
to navigate your model. The most convenient way to do 
this is to simply hold down the hotkey to set a view mode 
as you move the mouse in the Graphic Window. You can 
try this now. Hold down the following hotkeys as you drag 
the mouse:

o for Orbit
p for Pan
z for Zoom
r  for Rotate
d for Dolly
s for Scroll
t  for Tilt

3. When you are through experimenting, choose View>Original 
to reset you view.

4. Choose Edit > Selection > Select or click the Select button on 
the toolbar.

This sets the function of the left mouse button to Single 
Selection mode, your normal operating mode.

Defining Materials
Because Lightscape is based upon the physics of lighting, 
defining materials properly is important for obtaining 
meaningful results. In the following exercise, you will define a 
wood floor material that you will use later in this tutorial.
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1. Click the right mouse button anywhere in the Materials Table 
to open the context menu.

2. Choose Create from the context menu.

A new material, called “item17 ”, is added to the table and 
highlighted in blue. You can now enter the desired name for 
the material.

3. Type the following and press Enter :

FLOOR_WOOD

4. Using the left mouse button, double-click on FLOOR_WOOD.

The Material Properties dialog box displays.

On the Color tab, there are a number of parameters that can 
you can set to define the characteristics of a material. To 
assist you in selecting valid values for a specific type of 
material, you should start by selecting a template that most 
closely matches the type of material you are defining.

5. Select Wood Varnished  from the Templates combo box.

After you make your selection, the various parameter 
sliders are marked with red and green lines. The green 
portions of these lines represent the valid range of values 
that you should use when defining the desired material. 
Notice that the Hue (H) and Saturation (S) sliders of the 
reflective color have no lines. This means that you can use 
any values.

Value (V) is used to represent the amount of energy that is 
reflected from a surface. A material with a Value of .2  will 
reflect 20% of the energy and absorb 80% of the energy 
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that it receives. Assigning a reasonable Value for a material is 
particularly important in obtaining a valid lighting 
simulation.

Many materials contain patterns or textures. A wood floor 
is a good example of such a material. To define these 
materials you can use image bit maps (called texture maps) to 
modify the color of a material across a surface.

6. Click on the Texture tab.

7. Click Browse.

8. Double click on woodfloor.jpg  in the File Name list to 
load this texture map.

The image of the wood floor is previewed on the texture 
page. Texture maps such as these are readily available from 
a number of suppliers (some samples are provided with the 
Lightscape system). When using these textures, make sure 
that the average Value of the texture is also within a valid 
range for the type of material it represents. This range is 
indicated in the Value slider that can be used to scale the 
Value of the texture map being used.

9. Set the Value slider scale to .25  so that the average Value of 
the texture is .209  and the Maximum Value (Max.) is .246 .

10. Click the Fixed Tile Size check box and enter 3 (meters) in 
both the Width and Height input fields.

These numbers represent the real world dimensions of the 
texture being used.

11. Click on the Color tab.
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12. Click the Texture Average button to set the Reflective Color to 
the average of the texture map being used.

Note that if a material uses a texture map, the system 
normally uses the texture map as the source for 
determining the reflectivities during the radiosity solution 
(although you can also specify to use the Reflective Color 
instead). 

13. Set the Smoothness slider to 0.90 .

This value determines how shiny the floor appears when 
the image is ray traced.

14. Click OK to set the new material.

Using Material Libraries
Save material definitions to a material library.

Now that you have defined this material, you may want to save 
it to a Material Library so that you can easily access it later to 
use in another project.

1. Select FLOOR_WOOD in the Materials Table.

2. Using the right mouse button, click anywhere in the 
Materials Table to open the context menu.

3. Select Save from the context menu.

4. Type floors.atr  in File Name and click OK.

If you are running Windows 95 or Windows NT 4.0, you 
may click Save.

5. If necessary, change directory to:

c:\Program Files\lvs\projects\tutorial1
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6. Click Yes to confirm the creation of a new library file.

You can add additional materials to this library at any time 
if you wish.

Load material definitions from a material library.

You can also load materials from a material library to use in 
your project. If the name of the material you are loading already 
exists in your Materials Table, then that material is overridden 
with the new definition. This is a convenient way of storing 
alternate material palettes for a project.

1. Using the right mouse button, click anywhere in the 
Materials Table to open the context menu.

2. Select Load from the context menu.

3. Select tutorial1.atr  in the File Name list.

4. If necessary, change directory to:

c:\Program Files\lvs\projects\tutorial1

5. Click OK to open the library file.

If you are running Windows 95 or Windows NT 4.0, you 
may click Open.

A material list browser displays.

6. Click Select All to select all materials.

7. Click OK to load the material definitions.

8. In the next dialog, confirm the overwriting of all textures 
by clicking Yes.

The appearance of the materials making up the ceilings, 
walls, and floor changes.
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Displaying Textures
Turn on textures.

In this model, there are texture maps applied to areas inside the 
picture frames.

1. Choose Display > Textures or click the Textures button on the 
toolbar.

Allow some time for the textures to load into memory. 
Check the status of texture loading using the status bar.

To improve interactivity, you should turn off textures while 
doing the remaining exercises in this tutorial.

2. Choose Display >Textures or click the Textures button on the 
toolbar to turn texture display off.

Orienting Luminaires
What is a luminaire?

Orient the downlights so that they point to the picture 
frames.

Although Lightscape is not a modeling program, a number of 
tools are provided to let you easily add and position objects and 
luminaires in your models.

Lightscape creates a special class of blocks called luminaires, which 
represent light fixtures in the model. You create a luminaire by 
associating photometric data with an existing block. As with 
materials and regular blocks, you can store luminaires in libraries 
and use them repeatedly in different models. In this tutorial, the 
luminaires have been set up for you.
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1. Choose Edit > Selection > Luminaire or click the Luminaire 
button on the toolbar.

This sets selectable entities to luminaires only.

2. Select a spotlight that you want to orient.

Notice that you can select a luminaire by picking near the 
desired luminaire. Lightscape highlights the selected 
spotlight.

3. Choose Edit > Transformation or, using the right mouse 
button, click anywhere in the Graphic Window and choose 
Transformation from the context menu.

The Transformation dialog box displays.

4. Click the Orientation tab.

5. Click in the Pick check box to turn on this feature.

6. Pick a point roughly in the center of the picture frame 
under the selected luminaire.

Lightscape orients the selected luminaire to the point you 
pick.

7. Click in the Pick check box to deactivate this special mouse 
mode.

8. Select another luminaire to orient.

9. Click in the Pick check box to reactivate this special mouse 
mode.

10. Pick a point roughly in the center of the picture frame 
under the luminaire selected.

Note that you can greatly reduce the number of mouse 
movements you have to do by using hotkeys (this is 
generally true for most of the operations in Lightscape.)
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11. Hold down the 1 key to temporarily activate Select Mode.

12. While holding down the 1 key, select another luminaire. 

13. Release the 1 key and then select the point on the picture 
where you want the luminaire to aim. 

14. Press the 1 key again to select the next luminaire.

15. Repeat steps 11 through 14 until all the spotlights are 
pointing toward their respective paintings.

During this process, you can also easily adjust your view to 
make it easier to pick points by holding down the desired 
camera mode hotkey. 

16. Click Cancel when you are done orienting luminaires.

17. Choose Edit > Selection > Surface or click the Surface button on 
the toolbar.

This sets selectable entities to surfaces only.

18. Choose View > Original.

19. Click the Deselect All button on the toolbar.

Figure 1-3 shows the model prior to radiosity processing.
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Figure 1-3. Model Prior to Radiosity Processing

Save the file.

Save the work you have done so far so that you can return to 
this point later if you want to make geometry modifications or 
add lights.

Lightscape’s Undo function is limited to restoring the most recently 
deleted entity, if the model database has not changed in the interim. 
In general, use the Save and Save As functions to give yourself a point 
to return to when necessary.
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1. Choose File > Save As.

The Save As dialog box displays.

2. In the File Name input field, type the following:

temp.lp

3. Click OK.

If you are running Windows 95 or Windows NT 4.0, you 
may click Save.
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Creating the Solution In this exercise, you will perform the following tasks:

■ “Initiating the Preparation Model”
■ “Setting Process Parameters”
■ “Checking the Solution”
■ “Processing the Solution”

Initiating the Preparation Model
Initiate the Solution stage.

You have now completed the Preparation stage and can proceed 
into the Solution stage to perform the radiosity processing. This 
transition takes place by initiating the Preparation Model.

1. Choose Display > Solid or click the Solid button on the toolbar.

2. Choose Process > Initiate or click the Initiate button on the 
toolbar.

3. If necessary, click No to proceed without saving changes.

This prompt does not display if you have not made any 
changes to your model since you last saved.

After initiation, the model appears dark because the 
processing has not yet started and no energy has been 
distributed from the light sources. This is referred to as the 
Zero Energy State (0 iterations).

Notice that in the title bar of the Graphic Window the 
filename has an .ls  suffix, indicating that this model can 
now be saved to a Solution file.
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Setting Process Parameters
Set the process parameters.

1. Choose Process > Parameters.

The Process Parameters dialog box displays.

Observe the numerical values in the various boxes of the 
dialog. These control the quality and speed of the 
Lightscape radiosity process. Although these can be set by 
hand, you will use a wizard in this tutorial to set them 
automatically.

2. Click the Wizard button to active the Process Parameters 
Wizard.

3. Select the radio button labeled 2 to select a moderate 
quality level for the model.

4. Click Next to access the next page of the wizard.

5. Select No to not consider daylighting in this model.

6. Click Next to access the next page of the wizard.

7. Click Finish to update the process parameters based on the 
selections made in the wizard.

Observe the change in the numerical values in the various 
boxes of the dialog.

The most important part of this stage is choosing process 
parameters which will give you the results you desire. Process 
parameters control how accurately the light effects are calculated. 
These settings, more than anything else, determine the size of the 
final model (measured in polygonal elements), its quality, the 
accuracy of the light distribution, and the time it takes to process 
the model. For more information, refer to Chapter 8, Solution in 
the Lightscape User’s Guide.
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8. Click OK to close the Process Parameters dialog.

Checking the Solution
Turn on ambient to check overall light level.

Ambient light distributes all the undistributed light energy 
evenly to all surfaces. If the model appears overly dark or overly 
light when Ambient is turned on before processing, this 
indicates that either the luminaires are incorrectly defined or 
that the model has been scaled incorrectly.

1. Choose Display > Ambient or click the Ambient button in the 
toolbar.

Observe that the model's overall light level is acceptable.

2. To better see how the process works, choose View > Open 
and double-click on rm2.vw  in the File Name list.

This shows you the entire extents of the room.

3. Turn off Ambient by choosing Display > Ambient or by clicking 
the Ambient button in the toolbar.

Processing the Solution
Start radiosity processing.

In this step, Lightscape calculates the light distribution in the 
given environment. 

1. Choose Process > Go or click the Go button on the toolbar.
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What is progressive refinement radiosity?

Lightscape computes the simulation in successive iterations. At each 
iteration, the system selects the brightest light source and computes 
its contribution to all the surfaces in the scene. Once it accounts for 
all the primary light sources, the system starts computing the 
interreflections of light between surfaces. 

At each iteration, the system selects the brightest reflecting surface 
and computes its contribution to the rest of the environment.

At each iteration, the radiosity solution is refined—that is, it is a 
progressively better approximation of the final result.

In principle, this refinement process continues until the system 
accounts for all the multiple interreflections of light. In practice, 
however, the simulation converges very rapidly toward the final 
result, so that visual differences between successive iterations 
become unnoticeable after only a fraction of the surfaces (but the 
most important of them) have reflected their light contribution back 
into the environment.
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Stop the process after about 30 iterations.

It can take anywhere from several seconds to several hours to 
completely process the light energy distribution in a model. 
Processing time depends on such factors as model size, number 
of light sources, meshing parameters, and hardware resources.

In the current model, let the process run for about 30 
iterations, which should process approximately 75% of the 
available energy (leaving 25% unprocessed). The number of 
iterations processed displays in the status bar.

1. Choose Process > Stop or click the Stop button on the toolbar.

The process stops after the current iteration is complete. It 
may take a few seconds for the processing to stop. The 
message “Preparing to stop processing ” displays in 
the status bar. When processing completely stops, the 
message “Processing stopped ” displays.

Note In this tutorial, we are redisplaying the scene between each 
iteration so that you can better understand the process of 
progressive refinement radiosity. Each redraw takes time that 
slows down the overall processing. With a larger project, you 
would typically set up the model and then run the radiosity 
processing using the batch lsrad  program for the fastest 
results. This is described in Tutorial 5.

Observe the model.

Note the color bleeding effects obtained as the system 
distributes the strong reflected light energy from the floor. Also 
note how the brightness of the room evens out as the energy is 
distributed among the surfaces.
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Adjust your view using level of detail control.

One of the most important features of Lightscape is the ability 
to interactively move around in a fully rendered model.

1. Choose View > Interactive > Orbit or click the Orbit button on 
the toolbar.

Note that one method of increasing the interactive display 
speed of a radiosity solution is to use Level of Detail control.

2. Choose Edit > Properties.

3. Click on the Display Interactivity tab.

4. Set the Level of Detail slider to approximately 25.

5. Click Apply.

6. Continue orbiting the model.

7. Set the Level of Detail slider to 1.

8. Click Apply and orbit the model again.

9. When you are finished moving around in the model reset 
the Level of Detail slider to 100 .

10. Click OK.

11. Choose View > Original.

Observe the underlying radiosity mesh.

The reason that you are able to redisplay different views of this 
model so quickly is that Lightscape stores the diffuse lighting 
distribution it calculates as an integral part of the 3D surfaces in 
the model. This information is stored in the form of a 3D 
radiosity mesh structure. Once calculated, the system can then 
quickly display the radiosity mesh from any point of view by 
interpolating the colors that are stored at the vertices of each 
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mesh element. This simple and fast display technique (often 
referred to as Gouraud shading) is supported by OpenGL and can 
be further accelerated through the use of an OpenGL 
compatible 3D graphic acceleration board.

1. Choose Display > Outlined or click the Outlined button on the 
toolbar.

Notice that the mesh elements are smaller and more dense 
around areas where there are light beams or shadows.

What is adaptive subdivision?

Redisplay solid mode.

1. Choose Display > Solid or click the Solid button on the toolbar.

Adaptive subdivision ensures that the sample points (the vertices 
of each mesh element), used for determining the energy 
transfer received at a surface, are created only where required. 
This results in the smaller, more dense mesh elements you 
observed.

In areas where there is not a high contrast in lighting intensity, 
the samples can remain sparse (mesh element size is larger), 
whereas in areas where there are significant changes in 
intensity, such as along shadow boundaries and light beams, the 
sampling becomes more dense. 

The key to controlling a radiosity solution lies in the process 
parameters that you set. These parameters determine the 
meshing density and the resulting accuracy of the solution.
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Fine Tuning the Solution In this exercise, you will perform the following tasks:

■ “Changing a Material”
■ “Changing a Light Source”

Changing a Material
Change the carpeted floor to a wood floor.

An important feature of Lightscape is the ability to make 
changes to the surface materials even after starting a radiosity 
solution. This allows you to rapidly test various design 
alternatives and make adjustments to the materials and lighting 
to set the precise look you want.

1. Choose Edit > Selection or click the Select button on the 
toolbar.

2. Choose Edit > Selection > Surface or click the Surface button on 
the toolbar.

3. Pick a point anywhere on the floor.

Notice that the floor is now selected.

4. Using the right mouse button, click anywhere in the 
Graphic Window to open the context menu.

5. Choose Assign Material from the context menu.

The Assign Material dialog box displays.

6. Select FLOOR_WOOD from the list.

7. Click OK.

You have now set the material assigned to the floor surface 
to be a wood floor.
1-36 Tutorial 1, Getting Started - A Typical Workflow



8. To see the texture map on the surface, choose
Display >Texture or click the Texture button on the toolbar.

Notice that the color of the floor changes as soon as you 
redefine the material, but the color of the interreflection 
from the floor to the ceiling and walls does not change. To 
update the interreflections you need to run the radiosity 
processing further.

9. Click the Deselect All button on the toolbar.

Continue processing a few more iterations.

1. Click the Go button on the toolbar.

2. After a few iterations, click the Stop button on the toolbar 
to interrupt the processing.

Observe the change in coloration in the room.

After only a few iterations, you can observe the effects of this 
material change on adjacent surfaces. The color of the walls and 
ceiling has changed significantly. This demonstrates an impor-
tant effect that various materials and lights can have on the 
overall aesthetics of a room, known as color bleeding. The ability 
of Lightscape to simulate this effect is one of the key advantages 
that the software offers over conventional rendering technolo-
gies. Another advantage is the fact that because luminaires can 
be specified using real-world photometric values (including 
specifications from manufacturers), you can perform a meaning-
ful lighting analysis of your solution.
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Perform a lighting analysis.

1. Choose Light > Analysis.

The Lighting Analysis dialog box displays.

2. Click on the Statistics tab.
You can now use your mouse as a “virtual light meter” in 
your model.

3. Using the left mouse button, pick a point in the middle of 
one of the pictures.
Note the information about the illumination level of the 
picture displayed in the dialog box. Is this too bright (most 
galleries would not want to see more than 20 footcandles 
on a picture)? In the next section, you will see how you can 
easily modify a luminaire to test a different intensity lamp.

4. Click on the Display tab.

5. Select Color  from the Display combo box.

6. Enter 75 in the Max input field.

7. Click Apply.

Note that your model is now displayed in a pseudo-color 
mode that lets you easily characterize the lighting 
conditions of this space. Do you see any hot-spots?

8. Select Normal  from the Display combo box.

9. Click Apply and then Cancel.
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Changing a Light Source
Change the properties of one of the luminaires.

Just as you were able to change a material, you can also change 
the properties of a luminaire. Note, however, that you cannot 
reposition or reorient a luminaire in the solution model. You 
will have to return to the preparation model if you want to 
modify the geometry of the model.

1. Click the Select button on the toolbar.

2. Click the Luminaire button on the toolbar.

3. Pick a point on one of the spotlights oriented toward a 
picture.

The system highlights the selected luminaire.

4. Using the right mouse button, click anywhere in the 
Graphic Window to display the context menu.

5. Choose Photometrics from the context menu.

The Luminaire Properties (instance of lt_sp2) dialog box displays. 
You can now adjust the photometric properties for the 
luminaire you have selected.

6. Set H (Hue) to 0 .

7. Set S (Saturation) to 0.5 .

8. Set V (Value) to 1.00 .
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9. In the Intensity group box, set the Field Angle to 120  and the 
Beam Angle to 40.

It is important to set the field angle before setting the beam 
angle because the field angle acts as a maximum constraint 
for the beam angle.

This changes the shape of the spotlight’s distribution.

10. Click OK and confirm the overwrite.

11. Click the Deselect All button on the toolbar.

Continue the process for a few more iterations.

Having redefined the selected luminaire, you must run the 
simulation for a few more iterations to allow Lightscape to 
process the new properties of the modified luminaire. The 
system first subtracts the original light energy from the 
environment and then adds the redefined light energy back into 
the environment.

1. Click the Go button on the toolbar.

2. After a few iterations, click the Stop button on the toolbar 
to interrupt the processing.
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Outputting the Results In this exercise, you will perform the following tasks:

■ “Creating a Radiosity Image”
■ “Creating a Ray Traced Image”
■ “Saving and Exiting”
■ “Viewing Image Files with LVu”

Creating a Radiosity Image
Create an image showing the diffuse lighting of the 
gallery only.

Once you are satisfied with the radiosity solution and 
everything else looks the way you want, you can rapidly save 
images of the model using OpenGL display techniques.

OpenGL is what is typically used to display your radiosity on 
your screen. Using OpenGL, you can only render the diffuse 
lighting effects calculated during the radiosity solution. You 
cannot render shiny specular reflections and true transparency 
effects, nor can you render the effects of procedural bump or 
intensity maps that may be part of a material definition.

If you are satisfied with the quality of the radiosity solution you 
see, then OpenGL offers the fastest method for creating 
images. This can be particularly important if you are rendering 
many images (for example, animation frames).

1. Choose View > Original.

2. If necessary, click the Textures button on the toolbar to turn 
on textures.

3. Choose File > Render.

The Rendering dialog box displays.
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4. In the Output File group box, select Targa (TGA) from the Format 
combo box.

5. Type radiosity.tga  in the Name input field.

6. Click OK.

Lightscape takes a snapshot of the current view and saves 
the image to disk.

Note You can further improve the quality of any image you create 
with Lightscape by using antialiasing to remove jagged edges. 
The higher the level of antialiasing specified, the longer it takes 
to create the image.

Creating a Ray Traced Image
If you are interested in the highest quality image, then you can 
use the ray tracer to add specular reflections and enhanced 
lighting effects. Typically, the ray tracing process used in 
Lightscape proceeds much faster than traditional ray tracing 
because the ray tracer does not have to calculate the direct 
lighting; this is already calculated with the radiosity process. 
For some light sources (such as sharp spotlights and sunlight), 
you may want to ray trace the direct light to obtain a better 
quality shadow.

Set a luminaire to be ray traced.

1. Click the Luminaire button on the toolbar.

2. Select on one of the spotlights oriented toward a picture.

The selected luminaire highlights.

3. Click the right mouse button in the Graphic Window to 
open the context menu for the selected luminaire.
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4. Select Luminaire Processing from the context menu.

The Luminaire Processing dialog box displays.

5. Click the Ray Trace Direct Illumination check box.

6. Click OK.

Create an image using ray tracing.

1. Choose File > Render.

The Rendering dialog box displays.

2. In the Ray Tracing group box, click in the Ray Tracing check 
box to turn on ray tracing.

3. In the Ray Tracing group box, click the Ray Trace Direct Illumina-
tion check box.

This indicates that you want to ray trace any luminaires that 
have been set for ray tracing.

4. In the Output File group box, type raytrace.tga  in the 
Name input field.

If you leave the Name input field blank, the system renders 
the image and displays it to the screen but does not save it 
to disk.

5. Select Targa (TGA) from the Format combo box.

6. Click OK.
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7. Confirm that it is OK to do some additional processing 
before starting the ray tracing.

Lightscape will do an iteration for each light source set for 
ray tracing (in this case, only one) to remove the direct 
contribution to the surfaces in the model. When that is 
complete, the ray tracing begins.

Soon, you see the specular reflections from the floor 
surface that were not visible in the diffuse radiosity model 
or in the OpenGL rendered image. You will also see the 
results of the procedural intensity map that gives an “aged 
plaster” effect to the red wall in the niche.

You may notice that some of the surfaces appear brighter 
than they did when rendered using OpenGL. This is 
particularly true of texture mapped surfaces and surfaces 
that have a self-emitted illuminance. This difference occurs 
because the Lightscape ray tracer handles the interaction of 
light with these surfaces in a different (and more accurate) 
way than OpenGL does.

You can easily adjust the brightness of any material before 
ray tracing by adjusting the Value scale slider on the Texture 
tab of the material in question. To quickly test the materials 
in your model before committing to a long, high resolution 
ray trace rendering or animation, you can use the ray trace 
preview feature to ray trace only a selected region on your 
screen.

Saving and Exiting
Sign off.

1. Choose File > Save As to save this file.

The Save As dialog box displays.
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2. In the File Name input field, type tutorial1.ls  and click 
OK.

If you are running Windows 95 or Windows NT 4.0, you 
may click Save.

3. Choose File > Exit and confirm that you want to exit.

Viewing Image Files with LVu
1. Double-click the LVu icon in the Lightscape Visualization 

System folder.

If you are running Windows NT 4.0 or Windows 95, you 
can also start the LVu application by choosing it from the 
Start menu.

2. Choose File > Open.

3. Change directory to the following:

c:\Program Files\lvs\projects\tutorial1

If you installed Lightscape in a directory other than the 
default installation setup, then change directory to the 
appropriate location.

4. Click OK to open the images in the directory.

If you are running Windows 95 or Windows NT 4.0, you 
may click Open.

Three thumbnails of image files display.
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5. Double-click the radiosity.tga  thumbnail.

A full-sized image displays in the window. The 
radiosity.tga  file is the image of the gallery you 
produced using only radiosity. Notice how natural the 
diffuse surfaces appear, although the floor and the glass 
(which are specular surfaces), are less realistic. 

6. Double-click the image to return to the three thumbnail 
images.

7. Double-click the rayonly.tga  thumbnail.

A full-sized image displays in the window. The 
rayonly.tga  file is an image of the gallery we produced 
using only ray tracing. This is typical of the quality you can 
obtain using conventional scanline rendering and ray tracing 
programs. Notice that the floor and glass, which are 
specular surfaces, look compelling but also notice how flat 
non-specular surfaces, such as the walls and ceiling, appear.

8. Double-click the image to return to the three thumbnail 
images.

9. Double-click the raytrace.tga  thumbnail.

A full-sized image displays in the window. The 
raytrace.tga  file uses both the radiosity and ray tracing 
algorithms. It is the most accurate, and therefore, the most 
compelling of the three images.

10. Choose File > Exit to exit the LVu image viewing application.

Congratulations! You have reached the end of Tutorial 1. At this 
point you should:

■ Feel comfortable with the Lightscape interface.

■ Have a basic understanding of the interaction between light 
and materials and how Lightscape simulates this.
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■ Understand the major steps in the Lightscape process, their 
sequence and interrelation.
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Going Further To learn more about the Lightscape Visualization System, you 
can do the following:

Open the sample solution files.

The Lightscape Installation media contains a number of sample 
solution files which you can use for experimenting. To install 
these files:

1. Perform a Custom installation.

2. Select only the Sample Files from the list items in the File 
list.

3. Observe the way the mesh was created, the way materials 
were defined, the way luminaires were defined, and so on.

This gives you a feel for the performance of larger models.

4. Try resetting the solution and experimenting with different 
process parameters.

Read the manuals.

The Lightscape Getting Started manual and Lightscape User’s Guide 
contain excellent information that describes in detail the 
underlying concepts of the technology used in Lightscape, as 
well as the basics of lighting and materials. The more you 
understand about these underlying concepts, the faster you will 
be able to master working with Lightscape.

Do the remaining tutorials for more experience 
working with Lightscape.
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 Tutorial 2 Fundamentals - 
Importing DXF Files
In this tutorial, you will be 

introduced to importing geometry 

from a CAD or modeling 

application. Using a DXF file, you 

will go through the steps you would 

take when working with a model in 

this format, including defining 

realistic materials and lights.
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The goal of this tutorial is to render the model used to create 
the image in Figure 2-1.

Figure 2-1. Sample of Rendered Image from Tutorial 2
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How Tutorial 2
is Organized

This tutorial contains the following sections and lessons:

■ “Getting Data” on page 5
“Entities Supported by Lightscape”
“Import Units and Scale Factor”
“Importing Geometry”
“Checking the Scale of the Geometry”

■ “Preparing Data” on page 10
“Viewing the Model”
“Setting an Explicit View”
“Working with Display Controls”
“Working with Layers”
“Selecting Surfaces”
“Working with Blocks”
“Understanding Luminaires”
“Photometric Properties of a Luminaire”
“Setting up Photometric Properties”
“Setting Specular Reflection”
“Setting Diffuse Reflection”
“Changing and Refining Materials”

■ “Creating the Solution” on page 51
“Understanding Process Parameters”
“Setting the Process Parameters”
“Initiating the Preparation Model”
“Checking the Solution”
“Processing the Solution”
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■ “Refining the Solution” on page 60
“Using Natural Lighting”
“Setting Up a Window”
“Turning Off Lights”

■ “Outputting the Results” on page 65
“Understanding Rendering”
“Creating a Single High Quality Image”
“Performing Lighting Analysis”
“Saving and Exiting”

■ “Going Further” on page 70
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Getting Data In this exercise, you will start Lightscape and turn on all of the 
toolbars.

Starting Lightscape
Start Lightscape.

1. In the Lightscape Visualization System program group, 
double-click the Lightscape icon.

The Lightscape graphical user interface displays on the 
screen.

Turn on all toolbars.

This tutorial makes extensive use of the toolbars to make 
executing operations easier.

1. Choose Tools > Toolbars.

The Toolbars dialog box displays.

2. Double-click any item that does not have a check-mark in 
front of it to turn on that toolbar.

3. Click Close when you are done.
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Importing DXF Files The DXF file format was initially described by Autodesk and is 
now the AEC industry standard for the exchange of geometric 
data; most commercial CAD and modeling applications can 
export DXF files.

Entities Supported by Lightscape
Lightscape currently imports most of the DXF entities that can 
be converted to polygons in 3D. These entities include:

■ 2D Polyline (with width or height) 
■ 3D Polyline
■ 3D Face 
■ 3D Polygon Mesh 
■ 3D Polyface Mesh 
■ Arc (with height)
■ Circle (with height)
■ Line (with height)
■ Solid Trace

Lightscape does not import ACIS solids—these must be 
converted to 3D faces or 3D meshes before being imported. 
This is done using the 3dsout command within AutoCAD to 
create the faces, which can be imported back into AutoCAD 
using 3dsin or imported directly into Lightscape. 

Import Units and Scale Factor
Many of the problems encountered by Lightscape users stem 
from not setting the units correctly when importing a file. 
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Because Lightscape is a physically based lighting renderer, 
correct physical measurements are vital to using the product 
effectively—the seat of a chair should be 16 inches from the 
floor, not 16 feet; and a wall should be 8 feet high, not 8 inches 
or 8 meters high.

■ You can choose millimeters, centimeters, meters, 
kilometers, inches, feet, or miles as the units in which the 
model was created.

■ You can apply a scale factor by entering a number in the 
Scale field, if required.

It is a good idea to confirm the scale of the model before you 
start to work on it. You will learn to do this in an exercise that 
follows.

Importing Geometry
Load the DXF file called tutorial2.dxf.

A DXF file is one of several types of geometry files you 
can import into Lightscape. Lightscape is not a modeling 
program, so you must import the geometry from an external 
modeling program.

1. Choose File > Import > DXF.

The Import DXF dialog box displays.

2. In the Name area, click Browse.

The Open dialog box displays.

3. Change directory to:

c:\Program Files\lvs\projects\tutorial2

4. Double-click tutorial2.dxf .
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5. In the File Units area, choose Feet from the combo box.

This model was created with one unit in the CAD program 
set to equal one foot in the real world.

6. Click OK.

Note that the message box reports that the model is 
30.0622 x 17.15 x 9.50054  feet. 

7. Click Yes to open and display the file.

Checking the Scale of the Geometry
Check the scale of the geometry.

1. If necessary, choose View > Extents or click the Extents button 
on the toolbar.

The model was probably imported with the View set to 
Extents.

2. Choose Edit > Properties.

The Document Properties dialog box displays.

3. Click the Units tab.

Note that the length units in the Length combo box are in 
feet (this information is displayed in the status bar).

4. Click OK to close the Document Properties dialog.

5. Choose Edit > Selection > Select or click the Select button on 
the toolbar.

6. Choose Edit > Selection > Surface or click the Surface button on 
the toolbar.
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7. Choose Tools > Measure Distance.

The Measure Distance dialog displays.

8. If necessary, click the Snap to Nearest Vertex check box to turn 
on this feature.

9. Click near the lower left corner of any wall.

Notice that Lightscape fills in the coordinates for this point 
in the first set of X, Y, and Z fields of the dialog.

10. Click in the upper left corner of the same wall.

Notice that Lightscape fills in the next set of X, Y, and Z 
fields and the Distance between the points is about 8.5 feet. 
This indicates that the room is 8.5 feet high, a reasonable 
size.

11. Click Close to dismiss the Measure Distance dialog.
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Preparing Data In this exercise, you will perform the following tasks:

■ “Viewing the Model”
■ “Setting an Explicit View”
■ “Working with Display Controls”

Viewing the Model
View projections.

Lightscape allows you to view the model in perspective or in 
one of several orthogonal projections.

1. Choose Display > Outlined or click the Outlined button on the 
toolbar.

2. Choose View > Projection > Top or click the Top button on the 
toolbar. 

Notice that the model changes to plan or top view.

3. Choose View > Projection > Perspective or click the Perspective 
button on the toolbar. 

Notice that the model changes back to the previous 
perspective view.

4. Choose View > Projection > Left or click the Left button on the 
toolbar. 

Notice that the model changes to left view.

5. Experiment with the other projection modes which are 
Bottom, Right, Front, and Back.
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View the full extents of the model.

You can adjust the view to fit the entire model in the Graphic 
Window. In Perspective mode, the model is oriented so you 
view it from the front. In the orthogonal views, the model is 
sized to fit in the Graphic Window. The extents are set based 
on the current entities displayed in the Graphic Window.

1. Choose View > Projection > Perspective.

2. Choose View > Extents or click the View Extents button on the 
toolbar.

View hotkeys.

One of the many features of Lightscape is a set of viewing 
controls that make it easy to interactively change your view. 

1. Choose Display > Wireframe or click the Wireframe button on 
the toolbar.

2. Choose Edit > Selection > Select or click the Select button on 
the toolbar.

3. With the cursor in the Graphic Window, press the letter “o” 
on the keyboard and simultaneously click the left mouse 
button while dragging.

This temporarily sets the left mouse button to this 
interactive view mode and is the shortcut for choosing View 
> Interactive > Orbit. There are a number of other shortcut 
keys, or hotkeys available; refer to the Reference Card for a 
complete list.

As you drag, notice the change of view in the model. This 
is known as Orbiting.
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4. With the cursor in the Graphic Window, press the p key 
and the left mouse button simultaneously while dragging.

Notice the change of view in the model. This is known as 
Panning.

5. Experiment with using R for Rotate, Z for Zoom, D for Dolly, T 
for Tilt, and S for Scroll operations.

A mouse mode refers to the mode in which the left mouse button of 
the mouse is engaged. There are two basic mouse mode states:

(1) Viewing operations (pan, zoom, etc.)

(2) Model manipulation operations (select surface, luminaire, etc.)

You can select a viewing mouse mode operation by using the 
hotkeys, pull-down menus, or toolbar icons. You can select a model 
manipulation operation using the pull-down menus or the toolbar 
icons.

When you select a viewing operation using a hotkey, that mode is in 
effect until the hotkey is released. 

If you select a viewing mouse mode using the hot key, it is in effect 
until you release the key. The viewing mouse mode then returns 
back to the mode it was before using the hotkey. However, if you 
select a viewing mouse modes using the Shift key with a hotkey, it is 
the same as selecting the appropriate toolbar icon.

When you select the viewing mouse mode using the pull-down 
menus or toolbar icons, the mouse mode remains in effect until you 
explicitly select another mode.
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Setting an Explicit View
The Lightscape perspective model uses a viewer position, a focus 
point, and a picture plane to create perspective views. Both the 
view setup and the dynamic view controls are built around these 
conventions.

When you select View > Setup, Lightscape displays the model in plan 
view with a red triangle. This triangle is known as the view frustum. 
It describes, in two dimensions, the currently active perspective 
view.

The bottom vertex of the triangle represents the viewer position, or 
the point where the viewer is standing. (This point is called the 
camera position in some programs). 

The opposite end point of the line protruding out from the viewer 
position is the focus point, or the point where the viewer is looking.

The side of the triangle opposite the viewer position is the far 
clipping plane. The near clipping plane is the line parallel to the far 
clipping plane between the viewer position and the far clipping 
plane. Only the portions of the model that fall within the trapezoid 
formed by the frustum and the near and far clipping planes will be 
visible.
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Set up an explicit view.

In this procedure, you set up a specific view that you want to 
return to in the future.

1. Choose View > Setup or click the View Setup button on the 
toolbar.

The View Setup dialog box displays and the view of the model 
switches to the top projection. You can move the dialog 
box out of the way if necessary.

2. Make the Graphic Window active by clicking on the Title 
Bar of the Graphic Window.

3. With your cursor at the top of the Graphic Window, hold 
down the z key, press the left mouse button, and drag 
downward.

This is the hotkey for choosing View>Interactive>Zoom. For a 
list of available hotkeys, refer to the Reference Card.

4. Keep zooming out until the red triangle is fully visible.

5. Click the Select button on the toolbar.

6. In the dialog box, click the Viewer Position radio button.

7. Pick a point on the screen where you want to place your 
viewer position.

8. Click the Focus Point radio button.

9. Pick a point on the screen where you want to place your 
focus point.

10. Move the Near Clip Plane slider all the way to the left.

11. Click OK.

Notice the new view of the model.
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12. If you are satisfied with this view, go to the next procedure. 
If not, keep experimenting.

If you want to change the height of the viewer position or the 
focus point, enter the explicit values in the Z input field. 
Remember, you can use the other view controls to help set 
up a view you like.

Save this view.

You need to save the view so that you can return to it. A saved 
view is a file containing only the information described earlier, 
such as viewer position and focus point. It does not contain any 
information about the geometry seen in the view when you 
saved it.

1. Choose View > Save As.

The Save As dialog box displays.

2. If necessary, change directory to:

c:\Program Files\lvs\projects\tutorial2

3. In the File Name input field, type view1.vw .

You do not need to type the .vw  file extension; the 
program provides it for you if you leave it off.

4. Click OK and confirm the overwrite if necessary.

If you are running Windows NT 4.0 or Windows 95, you 
may click Save instead of OK.
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Open the view you just saved.

Open the view file you just saved. This does not change 
anything contained in the model you are currently using.

1. Choose View to display the View menu.

Notice that view1.vw appears at the bottom of the 
pulldown menu in the Most Recently Used List. When a view is 
saved to disk, a copy of that view is also added to the active 
view list. This view list is erased when you exit Lightscape. 
Selecting view1.vw  from the View List Functions is the same 
as selecting it from the disk.

Notice also that the view list contains Original . This 
represents the viewing parameters for the model when it 
was initially imported into Lightscape. You can always 
return to this by selecting Original  from the View pull-
down menu.

Change your view.

2. Choose View > Open.

The Open dialog box displays.

3. Double-click view1.vw .

The view you saved earlier redisplays on the screen.
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Working with Display Controls 
There are five different modes for viewing the model:

Wireframe Mode displays the model with only the edges of 
surfaces displayed.

Colored Wireframe Mode displays the surface edges in their 
appropriate material color.

Hidden Line Mode displays only those edges not blocked by 
other surfaces closer to the viewer. 

When the Antialiasing option is on (Display>Antialiasing), lines 
displayed in the above modes (and Outlined Mode described below) 
are displayed antialiased and should appear smoother. 

Solid Mode displays the surfaces of your model in their material 
color. 

Outlined Mode displays the model in solid mode with the 
addition of the surface edges being outlined. 

When Enhanced is turned on (Display>Enhanced), the Preparation 
model is displayed using  simulated lighting.

When Double Buffer is on (Display>Double Buffer), double buffering is 
used to eliminate screen refresh artifacts when interactively viewing 
a model.

When Culling is on (Display>Culling) the surfaces that are oriented 
away from the viewer position are not displayed.

When Blending is on (Display>Blending), transparent surfaces appear 
transparent using OpenGL transparency.
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Display the model in Outlined mode.

You can view an outlined, flat-shaded version of the model. 
This is often more useful than viewing the model in Wireframe 
mode.

1. Choose Display > Outlined or click the Outlined button on the 
toolbar.

Display the model in the other modes.

You will find that these different modes have various strengths 
and weaknesses. Try experimenting with them all.

Display the model in Outlined mode, then turn on 
Enhanced Mode and adjust the view.

1. Choose Display > Outlined or click the Outlined button on the 
toolbar.

2. Choose Display > Enhanced or click the Enhanced button on the 
toolbar.

With enhanced mode, the Preparation model is displayed 
using simulated lighting. This provides a more desirable 
display of the Preparation model but is comparatively slow. 

Display the model in the other modes.

Experiment with the other Display Mode controls such as 
culling, antialiasing, and double buffering. It would not help to 
experiment with blending at this time since there are not any 
transparent surfaces in the model. Blending is a display 
mechanism that allows surfaces to appear transparent.
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Change the brightness and contrast settings.

Because all monitors are not created equal, Lightscape allows 
you to adjust brightness and contrast. These settings help to 
fine tune the way you perceive the solution. These changes will 
not be perceptible in preparation mode.

1. Choose Edit > Properties.

2. Click the Display tab.

3. Set Brightness to 65.

4. Set Contrast to 50.

Change the background color.

With Lightscape, you can alter colors of items such as the 
background color, wireframe color, and mesh outline color.

1. Click the Colors tab.

2. Set H (Hue) to 180 .

3. Set S (Saturation) to 0.40 .

4. Set V (Value) to 0.70 .

5. Click the left arrow button that corresponds with 
Background to assign the HSV values to the background color.

6. Click OK.
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Organizing Data Layers and blocks are the two of the most powerful tools for 
organizing data in Lightscape. You can isolate layers or blocks, 
allowing you to work on only part of the model at any given 
time. This can reduce the complexity and confusion when 
working on large and complex models.

In this exercise, you will perform the following tasks:

■ “Working with Layers”
■ “Selecting Surfaces”
■ “Working with Blocks”

Working with Layers

Display the model in Outlined mode and view the full 
extents of the model.

This helps you view the model correctly for the next few 
procedures.

1. Click the Outlined button on the toolbar.

2. Click the View Extents button on the toolbar.

Each entity in Lightscape is associated to a layer. You can use layers 
to manage the large amounts of data that may make up your model. 
For example, you can associate all the surfaces that define the walls 
of a model to a layer named “walls.” 

All the layers that exist in a Lightscape model are listed in the 
Layers Table.

In Lightscape, a layer can be either on or off. Only entities 
associated to layers that are on are displayed in the Graphic Window. 
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Turn off all layers except the layers named 
ROOM3_WALLS.

1. Using the right mouse button, click anywhere in the Layers 
Table to open the context menu.

If the Layers Table is not already displayed, choose 
Edit>Tables>Layers to display it.

2. Choose All Off from the context menu.

3. Select ROOM3_WALLS from the Layers Table. 

4. Using the right mouse button, click anywhere in the Layers 
Table.

5. Choose On from the context menu. 

All layers are now turned off except the ROOM3_WALLS 
layer.

6. Adjust your view so that you are looking down at the 
model.

Notice that only the walls are visible, and that some walls 
seem to appear and disappear when you orbit around the 
model. This is because Lightscape displays only the front 
side of a surface (when culling is set to on), a technique 
known as backface culling.

Turn all layers back on.

1. Using the right mouse button, click anywhere in the Layers 
Table to open the context menu.

2. Choose All On from the context menu.
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Turn off the layer named ROOM3_WALLS.

1. Select ROOM3_WALLS from the Layers Table. 

2. Using the right mouse button, click anywhere in the Layers 
Table to open the context menu.

3. Choose Toggle from the context menu. 

The ROOM3_WALLS layer is now turned off (the walls 
disappear).

4. Using the right mouse button, click anywhere in the Layers 
Table.

5. Choose Toggle from the context menu. 

The ROOM3_WALLS layer is now turned back on (the walls 
reappear).

Set Layer GLASSWARE to be the current layer and turn 
off all other layers.

Setting a layer to be the current layer makes it the layer to 
which all new geometry is associated. For example, if you 
create a new surface in the model, it is associated to, and 
displayed on, the current layer.

1. Select GLASSWARE from the Layers Table. 

2. With the right mouse button, click anywhere in the Layers 
Table to open the context menu.

3. Choose Make Current from the context menu. 

A colored C appears adjacent to the GLASSWARE layer 
indicating it is the current layer.

4. Using the right mouse button, click anywhere in the Layers 
Table.
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5. Choose All Off from the context menu.

6. Double-click GLASSWARE in the Layers Table to turn on this 
layer.

The check mark reappears beside the layer name.

7. Click the Extents button on the toolbar. 

A single vase or urn is now the only entity in the Graphic 
Window.

Selecting Surfaces
Select a single surface.

1. Choose Edit > Selection > Select or click the Select button on 
the toolbar.

2. Choose Edit > Selection > Surface or click the Surface button on 
the toolbar.

This sets the selection filter to select only surfaces (as 
opposed to blocks and luminaires).

3. Click a surface on the vase.

A red highlight displays indicating it is selected.
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Add other surfaces to the selection.

1. If not already selected (there is no check mark next to the 
menu item), choose Edit > Selection > Accumulate Pick or click 
the Accumulate Pick button on the toolbar. 

When on, this allows you to add entities to the current 
selection set.

2. Click another surface on the vase.

A red highlight displays indicating it is also selected.

Remove surfaces from the selection set.

1. Click one of the selected surfaces on the vase.
The red highlight disappears indicating it has been removed 
from the selection set.

2. Choose Edit > Selection > Deselect All or click the Deselect All 
button on the toolbar.

This clears the current selection set.

Select groups of surfaces.

1. Choose Edit > Selection > Select Area All or click the Area All 
button on the toolbar.

2. Drag a window to enclose all the surfaces of the vase.

All of the surfaces are now highlighted in red indicating 
they are selected.
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Working with Blocks

Create a block from the selected surfaces.

In order to insert several copies of the vase into the model, you 
will first turn the individual surfaces into a block. 

1. Make sure that all surfaces of the vase are still selected.

1. Using the right mouse button, click anywhere in the 
Graphic Window to open the context menu.

2. Choose Create Block from the context menu.

The Create Block dialog box displays.

3. Type VASE in the name field and click OK to create the 
block. 

Notice that a new block called VASE is added to the Blocks 
table. The existing geometry in the Graphic Window has 
been collected together to form a new single block entity 
(see Figure 2-2).

A block is a collection of entities (surfaces and/or other blocks) that 
are grouped together to form a single entity. Each block has a 
unique name. Once defined, a block can be inserted or instanced as 
many times as you desire in the Lightscape Model. If you change the 
definition of the block, every instance of the block in the model inherits that 
change. 
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Figure 2-2. Creating the VASE Block

Reposition the VASE block to sit in one of the niches in 
the model.

1. Turn on all of the layers in the model.

2. Click the Extents button on the toolbar.
The entire model is visible. Orbit to look down on the 
model.
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3. Choose Edit > Selection > Deselect All or click the Deselect All 
button on the toolbar.

This clears the current selection set.

4. Choose Edit > Selection > Select or click the Select button on 
the toolbar.

5. Choose Edit > Selection > Block or click the Block button on the 
toolbar.

This sets the selection filter to select only blocks.

6. Click a surface on the vase.

The entire vase highlights in red indicating the block is 
selected.

7. Choose Edit > Transformation, or using the right mouse 
button, click anywhere in the Graphic Window and choose 
Transformation from the context menu.

The Transformation dialog box displays.

8. Click the Position tab.

9. Choose Pick from the Values combo box.

10. Click in the center of the shelf within one of the four niches 
in the model (you may need to modify your view).

The vase moves to this location. (You may pick again to 
move to another location.)
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Duplicate the VASE block and move it to sit in another 
niche.

1. Using the right mouse button, click in the Graphic 
Window to open the context menu.

2. Choose Duplicate from the context menu.

This creates a second copy of the vase in exactly the same 
location as the first vase. You can now reposition the copy.

3. On the Position tab of the Transformation dialog, choose Drag 
from the Values combo box.

As it is only possible to drag in an orthographic view, the 
model is displayed in plan or top view.

4. Using the left mouse button, drag the vase to the center of 
one of the other niches.

Add a copy of the VASE block by dragging and 
dropping from the Block table.

1. Click VASE in the Blocks Table and hold the left mouse 
button down.

2. Drag the mouse into the Graphic Window and move the 
cursor until it is over one of the empty niches.

3. Release the mouse button.

A copy of the vase block is added at that location.

4. Repeat steps 1, 2, and 3 to place a copy of the block in the 
remaining niche.

If necessary, use the Transformation dialog to position each of 
these new vases more precisely.
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Scale and rotate blocks.

1. Choose Edit > Selection > Deselect All or click the Deselect All 
button on the toolbar.

This clears the current selection set.

2. Select one of the VASE blocks.

3. Click the Scale tab in the Transformation dialog box.

4. Change the x value to 1.5  and click Apply.

The vase is now oval in shape. However, it is not turned to 
face into the room.

5. Click the Rotation tab in the Transformation dialog box.

6. In the Values combo box, choose Absolute.

7. In the Z input field, type 135 . (Depending on the vase you 
selected, it might be 45.)

8. Click Apply to rotate the display.

9. Click the Deselect All button on the toolbar.

10. Repeat steps 4 through 9 until you have varied the size and 
shape of the vases in a pleasing manner. Experiment with 
changing the x, y, and z scale values.

Note Remember, each time you click Apply, objects are scaled relative 
to their last edit; not relative to their original form. Rotations, 
on the other hand, are relative to their original form.

11. Click OK to close the Transformation dialog box.

12. Click the Perspective button on the toolbar. 
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13. Click the Extents button on the toolbar.

Figure 2-3 shows the view that is displayed.

Figure 2-3. Model After the Insertion and Scaling of the Blocks

Lightscape - tutorial2.lp
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Save your work up to this point.

1. Choose File > Save As.

2. If necessary, change directory to:

c:\Program Files\lvs\projects\tutorial2

3. Type temp.lp in the File Name input field.

4. Click OK.

If you are running Windows NT 4.0 or Windows 95, you 
may click Save instead of OK.

5. If necessary, click Yes to confirm the overwrite.
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Lighting Basics In this section, you will learn about the following:

■ “Understanding Luminaires”
■ “Photometric Properties of a Luminaire”

You will perform the following task:

■ “Setting up Photometric Properties”

Understanding Luminaires
A luminaire in Lightscape is a special type of block that has 
photometric attributes associated with it. When you create a 
luminaire, the block is removed from the Blocks Table and 
placed in the Luminaires Table. All instances of the block are 
changed into luminaires.

■ A luminaire is the basic lighting primitive in Lightscape.

■ It represents both the physical appearance and the 
photometric characteristics of a lighting fixture—that is, it 
includes the geometry of the fixture, the color intensity, 
and directional distribution of the light energy emitted 
from the fixture.

■ A luminaire is made by associating photometric data with 
an existing block definition.
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Photometric Properties of a Luminaire
You can set the following photometric properties of a luminaire:

■ “Light Source Type”
■ “Lamp Type”
■ “Intensity Magnitude”
■ “Intensity Distribution”
■ “Photometric Web”

Light Source Type
The light source type sets the most general lighting 
characteristics of a luminaire. You can select a source type using 
the Source Type combo box, which offers the following choices:

■ Point Light - A point light is a light source that distributes 
energy from a single point. The filament in an incandescent 
bulb is a good example of such a source.

■ Linear Light - A linear light source distributes energy from a 
straight line segment. A fluorescent tube is a good example 
of a linear light source. 

■ Area Light - An area light source distributes energy from a 
triangular or convex quadrilateral surface. A typical area 
light is a fluorescent fixture that emits light fairly evenly 
over the entire surface of its diffuser panel. 

Lamp Type
Lightscape provides the following common lamp colors which 
you can select using the Lamp Color Specification combo box:

■ D65White
■ Fluorescent
■ Deluxe warm white
■ Deluxe cool white
■ Warm white
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■ Cool white
■ White fluorescent
■ Daylight fluorescent
■ Incandescent
■ Xenon
■ Halogen
■ Metal halide
■ Mercury
■ Phosphor mercury
■ High-pressure sodium
■ Low-pressure sodium

Intensity Magnitude
You can enter a value in the Intensity Magnitude field to set the 
strength or brightness of the light source. Three methods are 
available: 

■ Luminous Intensity - The maximum luminous intensity of the 
luminaire usually along the direction of aim. This value is 
measured in candelas (cd).

■ Luminous Flux - The overall output power of the luminaire. 
This value is measured in lumens (lm).

■ Illuminance at a Distance - The luminous flux density 
incident on a differential area (a point) at a given distance 
along the aim direction of the luminaire.

Intensity Distribution
You can set how light is distributed from the light source (that 
is, how much light is being distributed in any given direction). 
Four methods are available:

■  Isotropic - Light is distributed equally in all directions (valid 
for point lights only).
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■ Spot - A spotlight distribution is defined by a beam angle 
and a field angle. The beam angle is defined as the angle at 
which the intensity of the light is 50% of the maximum 
intensity at the center of the beam (valid for point lights 
only).

■ Diffuse - Light is distributed from a surface with the 
intensity greatest at right angles to that surface and falling 
off at increasingly oblique angles. This distribution can be 
used with linear and area lights only.

■ Photometric Web - Light is distributed using a photometric 
web or IES distribution, which is a complex 3D 
representation of the luminous intensity distribution of a 
light source. This distribution can be used with point, 
linear, and area lights only.

Photometric Web
The distribution from most light sources in the real world is 
more complex than the simple spot, isotropic, and diffuse light 
models. The shape of the reflector, the nature of the lens, and 
the type of lamp combine to make the distribution from a 
source quite interesting and unique.

This kind of data is often depicted using goniometric diagrams. 
These diagrams provide a 2D visual representation of how the 
luminous intensity of a source varies. A photometric web or 
IES distribution is a 3D representation of how the intensity of a 
source changes. Many lighting manufacturers can supply IES 
files for their fixtures. Figure 2-4 shows a sample photometric 
web.
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Figure 2-4. Sample Photometric Web File

Setting up Photometric Properties
Define the block called LITE_NARROW1 as a luminaire 
and set up its photometric properties.

In this procedure you convert the block LITE_NARROW1 into a 
luminaire. This causes the block to be removed from the Blocks 
Table and added to the Luminaires Table. This luminaire is set up as 
a spotlight, a type of point light that is directional.

The LITE_NARROW1 will contain a R-40 150 Watt wide beam 
bulb with the manufacturer-specified parameters shown in 
Table 2-1.
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Table 2-1.  LITE_NARROW1 Photometric Properties 

1. Select LITE_NARROW1 from the Blocks Table.

2. Using the right mouse button, click anywhere in the Blocks 
Table to open the context menu.

3. Choose Define as Luminaire from the context menu and 
confirm that you wish to continue.

The Luminaire Properties for LITE_NARROW1 dialog box displays. 
You are now looking at the isolated luminaire.

4. In the Source Type combo box, choose Point.

5. Define the luminaire using Table 2-1.

Set the Intensity Distribution settings before the Intensity 
Magnitude settings.

6. Click OK and confirm the overwrite.

The complete model displays in the Graphic Window. 
LITE_NARROW1 is removed from the Blocks Table and added 
to the Luminaires Table. All of the instances of 
LITE_NARROW1 are now defined as luminaires.

Source 
Type

Lamp
Color
Spec.

Color 
Filter

(H Value)

Color 
Filter

(S Value)

Color 
Filter

(V Value)

Intensity 
Mag’tude
(Lum. Int.)

Intensity 
Dist.

Beam
Angle

Field
Angle

Point Halogen 0 0.00 1.00 5400 cd Spot 22 50
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Define the block called LITE_UPLITE1 as a luminaire.

The block LITE_UPLITE1  represents the four wall sconces. A 
manufacturer’s IES file will be used to describe the distribution 
of this fixture.

The LITE_UPLITE1  will have the parameters shown in Table 
2-2.

Table 2-2.  AREAUPLIGHT Photometric Properties

1. Select LITE_UPLITE1  from the Blocks Table.

2. Using the right mouse button, click anywhere in the Blocks 
Table.

3. Choose Define as Luminaire from the context menu and 
confirm that you wish to continue.

The Luminaire Properties for LITE_UPLITE1 dialog box displays. 
You are now looking at the isolated luminaire.

4. In the Source Type combo box, choose Point to define this 
luminaire as a point light.

5. In the Distribution combo box, select Photometric Web.

6. In the Name area, click Browse.

The Open dialog box displays.

7. If necessary, change directory to:

c:\Program Files\lvs\projects\tutorial2

Source
Type

Lamp
Color
Spec.

Color
Filter

(H Value)

Color
Filter

(S Value)

Color
Filter

(V Value)

Intensity 
Magnitude 
(Lum. Int.)

Intensity
Distribution

Point Incand. 0 0.00 1.0 3550 cd Photo. Web
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8. Double-click Phillips-103a.ies .

This selects the photometric web distribution for this 
particular manufacturer’s fixture.

9. Define the remaining properties as shown in Table 2-2.

10. Click OK and confirm the overwrite.

Figure 2-5. Creating the LITE_UPLITE1 Luminaire

The complete model displays in the Graphic Window. 
LITE_UPLITE1  is removed from the Blocks Table and added 
to the Luminaires Table.

Incandescent

C:\programfiles\lvs\

Lightscape - tutorial2.lp
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Save your work up to this point.

1. Choose File > Save As.

2. Change directory to:

c:\Program Files\lvs\projects\tutorial2

3. Type temp.lp in the File Name input field and confirm the 
overwrite.

4. Click OK.
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Material Basics A material defines the appearance of a surface. Defining a 
material in Lightscape requires that you set both the diffuse and 
specular behavior of the material. 

■ The diffuse behavior is set by manipulating the reflective 
color for the material.

■ The specular behavior is set by manipulating the Refractive 
Index, Smoothness, and Transparency sliders.

In this section, you will learn about the following:

■ “Setting Specular Reflection”
■ “Setting Diffuse Reflection”

You will perform the following task:

■ “Changing and Refining Materials”

Setting Specular Reflection
■ The amount of light reflected from a material is set by the 

Refractive Index slider. Typical values range between 1.0  (no 
specular reflection) and 2.5  (the Refractive Index for 
diamond)—the more light is reflected, the larger the 
refractive index.

■ The character, how shiny or dull the reflection, is set by the 
Smoothness slider. If the surface is perfectly smooth, 
reflected images appear as they would in a mirror. A less 
smooth surface scatters the light in many directions and 
reflected images are more indistinct and appear as 
highlights.
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■ The Transparency slider controls how much of the incident 
energy, that is not reflected from the surface, passes 
through the body of the material. As it passes through the 
material, the energy is modulated by the reflective color of 
the material.

Setting Diffuse Reflection
The amount and character of the absorption and diffuse 
reflection of a material is set by the reflective color. Generally 
these should be set using HSV values which have the following 
effects:

■ Hue controls the color of the absorbed and reflected light. 
For example, a blue material reflects more energy in the 
blue wavelengths and thus appears blue in color, while a red 
material reflects more energy in the red wavelengths and 
appears red in color.

■ Saturation controls the degree of colorization of the 
reflected and absorbed light. Increasing the saturation 
deepens the color of the material and increases the amount 
that reflected light is colored by the surface.

■ Value controls the amount of light reflected versus the 
amount of light absorbed. A value of 0.7  indicates that 
70% of the incident energy is being reflected and 30% is 
being absorbed. Increasing the value increases the amount 
of light reflected by the material and should almost never 
be greater than 0.8 .
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Changing and Refining Materials
Display the model in Outlined mode.

1. Adjust your view so that you are “standing” inside the room.

2. Click the Outlined button on the toolbar.

Rename the material assigned to the walls to a new 
name, PAINT_FLAT_DARKGREEN.

In this procedure, you will rename the materials from 
AutoCAD color index numbers to names. In general, you 
should give your materials names that are meaningful to you.

1. Click the Query Select button on the toolbar.

2. Choose Edit > Selection > Surface or click the Surface button on 
the toolbar.

3. Pick a point on a wall.

The wall highlights in green and material 115 is highlighted 
in the Materials Table.

4. Using the right mouse button, click anywhere in the 
Materials Table to open the context menu.

5. Choose Rename from the context menu.

A blinking cursor displays at the end of the item 115.

6. Type PAINT_FLAT_DARKGREEN and press Enter.

Material 115 is renamed to PAINT_FLAT_DARKGREEN.
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Edit the properties of this material.

1. Double-click PAINT_FLAT_DARKGREEN in the Materials 
Table.

The Material Properties for PAINT_FLAT_DARKGREEN dialog box 
displays. 

2. Click the Color tab.

Notice the current values in the fields. Note especially that 
Saturation is set to 0.95  indicating that light reflected from 
the surface will be extremely green, changing the color of 
the rest of the room. Also note that Value is set to 0.45  
indicating that 55 percent of the incident energy will be 
absorbed and 45 percent reflected. You will change both 
the saturation and the value.

3. Set S (Saturation) to 0.60 .

4. Set V (Value) to 0.40 .

5. Click OK.

Notice the slight change of color on all the walls of the 
model.

Rename the material assigned to the trim to a new 
name, PAINT_OIL_WHITE.

1. Pick a point on the trim.

The trim is highlighted in green and material 7 is 
highlighted in the Materials Table.

2. Using the right mouse button, click anywhere in the 
Materials Table to open the context menu.
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3. Choose Rename from the context menu.

A blinking cursor displays at the end of the item 7.

4. Type PAINT_OIL_WHITE  and press Enter.

Edit the properties of this material.

1. Double-click PAINT_OIL_WHITE  in the Materials Table.

The Material Properties for PAINT_OIL_WHITE dialog box displays. 

2. Click the Color tab.

Observe the current values in the fields. Note especially 
that Value is set to 0.85  indicating that only 15 percent of 
the incident energy will be absorbed and 85 percent 
reflected. You will change only the Value as the other 
numbers are acceptable.

3. Set V (Value) to 0.75 .

4. Set the Refractive Index slider to 1.2  and the Smoothness slider 
to 0.5 .

This makes the material a little specular (shiny) and makes 
the bounced light display as highlights rather than 
reflections.

5. Click OK.

Rename the material assigned to the floor to a new 
name, WOOD_WHITEASH.

1. Pick a point on the floor.

The surface highlights in green and material 43 highlights in 
the Materials Table.

2. Using the right mouse button, click anywhere in the 
Materials Table.
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3. Choose Rename from the context menu.

A blinking cursor displays at the end of the item 43.

4. Type WOOD_WHITEASH and then press Enter.

Edit the properties of this material.

1. Double-click WOOD_WHITEASH in the Materials Table.

The Material Properties for WOOD_WHITEASH dialog box displays.

2. Click the Color tab.

Observe the current values in the fields. Note especially 
that Saturation is set to 0.95  indicating that light reflected 
from the surface will be extremely yellow, changing the 
color of the rest of the room.

3. Set S (Saturation) to 0.25 .

4. Set the Refractive Index slider to 1.2  and the Smoothness slider 
to 0.7 .

This makes the material a little specular (shiny) and makes 
the bounced light appear as highlights with some reflective 
effect.

5. Click OK.

Rename the material assigned to the ceiling to a new 
name, PAINT_FLAT_WHITE.

1. Pick a point on a ceiling.

You may need to change your view to do this. 

The surface highlights in green and material 253  highlights 
in the Materials Table.
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2. Using the right mouse button, click anywhere in the 
Materials Table to open the context menu.

3. Choose Rename from the context menu.

A blinking cursor displays at the end of the item 253 .

4. Type PAINT_FLAT_WHITE and then press Enter. 

Edit the properties of this material.

1. Double-click PAINT_FLAT_WHITE in the Materials Table.

The Material Properties for PAINT_FLAT_WHITE dialog box 
displays. 

2. Click the Color tab.

3. Set V (Value) to 0.70 .

4. Click OK.

Rename the material assigned to the vases and 
windows to a new name, GLASS_BLUE.

1. Pick a point on one of the vases.

The surface highlights in green and material 140  highlights 
in the Materials Table.

2. Using the right mouse button, click anywhere in the 
Materials Table to open the context menu.

3. Choose Rename from the context menu.

A blinking cursor displays at the end of the item 140 .

4. Type GLASS_BLUE and then press Enter.
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Edit the properties of this material.

1. Double-click GLASS_BLUE in the Materials Table.

The Material Properties for GLASS_BLUE dialog box displays. 

2. Click the Color tab.

Observe the current values in the fields. Note especially 
that Saturation and Value are both set to extremely high values.

3. Select the Glass  template in the Templates combo box. 

The template sets the specular sliders to appropriate values 
for a particular class of materials—here, making the 
material quite specular (shiny) and the bounced light appear 
as reflections rather than highlights.

4. Set S (Value) to 0.30 .

5. Set V (Value) to 0.8 .

For transparent materials like glass, Value controls what is 
generally called the transmissivity of the material, or the 
amount of energy absorbed as the light passes through the 
body of the material. 

6. Click OK.

Rename the material assigned to the light fixtures to a 
new name, PAINT_METAL_WHITE.

1. Pick a point on one of the light fixtures.

The fixture highlights in green and material 9 highlights in 
the Materials Table.

2. Using the right mouse button, click anywhere in the 
Materials Table to open the context menu.
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3. Choose Rename from the context menu.

A blinking cursor displays at the end of the item 9.

4. Type PAINT_METAL_WHITE and then press Enter.

Edit the properties of this material.

1. Double-click PAINT_METAL_WHITE in the Materials Table.

The Material Properties for PAINT_METAL_WHITE dialog box 
displays. 

2. Click the Color tab.

Observe the current values in the fields. Note especially 
that Value is set to 0.85  indicating that only 15 percent of 
the incident energy is absorbed and 85 percent reflected. 

3. Select the Metal template in the Templates combo box.

This deselects the Refractive Index and Transparency sliders. The 
Refractive Index of metals is approximated using the 
reflective color of the material and metals cannot be 
transparent.

4. Set the Smoothness slider to 0.5 .

This makes the bounced light display as weak highlights 
rather than reflections.

As metals tend to be more highly reflective than other 
classes of material, leave the Value unchanged.

5. Click OK.
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Save your work up to this point.

You have concluded the Preparation stage and are about to 
enter the Solution stage. The model you are currently working 
on is going to be radically transformed during the initiation 
process. It is a good idea to save your work at this time.

1. Choose File > Save As.

2. Change directory to: 

c:\Program Files\lvs\projects\tutorial2

3. Type temp.lp in the File Name input field and confirm the 
overwrite.

4. Click OK.
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Creating the Solution In this section, you will learn about the following:

■ “Understanding Process Parameters”

You will perform the following tasks:

■ “Setting the Process Parameters”
■ “Initiating the Preparation Model”
■ “Checking the Solution”
■ “Processing the Solution”

Understanding Process Parameters
During the radiosity process, the surfaces of your model are 
subdivided into a mesh of energy sample points. The number of 
mesh elements required to capture the illumination of a surface 
depends upon the complexity of the illumination on that 
surface. The greater the lighting detail, the greater the number 
of mesh elements that are needed to capture it accurately.

This section discusses the following process parameters:

■ “Adaptive Subdivision”
■ “Initiation”
■ “Processing”

Adaptive Subdivision
In order to represent variations of illumination across a surface, 
the surface is automatically broken down into smaller pieces 
(elements). The radiosity process then computes the 
illumination from a light source to each of the corners 
(vertices) of each element. To maintain as efficient a solution as 
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possible, the system starts with a coarse mesh. It automatically 
refines the mesh locally where large differences in light level are 
detected (see Figure 2-6).

Figure 2-6. Adaptive Subdivision

Initiation
Initiation is the process that simplifies the geometry, materials, 
and lights, and produces a model that the radiosity calculations 
can work their magic on.

Processing
After initiation, your model is ready for the radiosity lighting 
simulation which is started by choosing Process > Go. The 
simulation is computed in successive iterations. 

At each iteration, the system selects the brightest light source 
and computes its contribution to all the surfaces in the scene. 
Once all the primary light sources are accounted for, the 
system starts computing the interreflections of light between 
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surfaces. At each iteration the system selects the brightest 
reflecting surface and computes its contribution to the rest of 
the environment.

This process is called progressive refinement because, at each 
iteration, the radiosity solution is refined—that is, it is a better 
approximation of the final result.

Setting the Process Parameters
Set the process parameters.

1. Choose Process > Parameters.

The Process Parameters dialog box displays.

Observe the numerical values in the various boxes of the 
dialog. These values control the quality and speed of the 
Lightscape radiosity process. Although these can be set 
individually, you will use a wizard to set these automatically.

2. Click the Wizard button to activate the wizard.

3. Select the second radio button (labeled 2) to select a lower 
than average quality for the model.

4. Click Next to access the next page of the wizard.

5. Select No to not consider daylighting in this model.

6. Click Finish to update the process parameter based on the 
answer given to the wizard.

Observe the change in the numerical values in the various 
boxes of the dialog.

7. Click OK to close the Process Parameters dialog.
Creating the Solution 2-53



Initiating the Preparation Model
Initiate the Solution stage.

1. Choose Display > Solid or click the Solid button on the toolbar.

2. Choose Process > Initiate or click the Initiate button on the 
toolbar.

3. Click Yes to save changes.

This updates the temp.lp  model with the latest changes 
and causes the program to create the solution model. 
Notice that the filename changes to temp.ls  when the 
initiation process completes. The model is dark because no 
light has been distributed to the scene.

Checking the Solution
Turn on ambient to check overall light level.

Ambient light distributes all the undistributed light energy 
evenly to all surfaces. If the model appears overly dark or overly 
light when Ambient is turned on before processing the model, 
this indicates that either the luminaires are incorrectly defined 
or that the model is incorrectly scaled.

1. Choose Display > Ambient.

Observe that the model’s overall light level is acceptable.

2. Turn off Ambient by choosing Display > Ambient.
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Processing the Solution
Start the radiosity processing.

In this step, Lightscape calculates the light distribution in the 
given environment.

1. Choose Process > Go or click the Go button on the toolbar.

Observe the statistics as the processing continues.

Among the statistics that display at the bottom of the Graphic 
Window at this time are:

■ Number of iterations
■ Percentage of the total energy distributed

Observe the green highlight on the screen. This lets you know 
which light source is being distributed at the current time.

Stop processing when the percentage of energy 
distributed exceeds 75%.

1. When the percentage of energy shot exceeds 75%, choose 
Process > Stop or click the Stop button on the toolbar.

The processing stops after the current iteration finishes. This 
may take awhile (depending on the speed of your computer).

Display the model in Mesh mode and observe the way 
the mesh was formed.

Lightscape gives you complete control over the quality of a 
solution. A quick design study does not require the same 
degree of quality as a final production graphic. The next several 
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exercises compare the various process parameter settings to 
demonstrate the differences in processing speed and image 
quality.

1. Click the Outlined button on the toolbar.

Display the model in Solid mode and move it around.

Get a feel for the interactive display speed by adjusting your 
view.

1. Click the Solid button on the toolbar.

2. Adjust your view.

Document the statistics and take a mental snapshot of 
the picture.

You should, using these parameters, have approximately 14,000 
mesh elements.

1. Choose Process > Statistics.

Notice the number of mesh elements in your model as 
indicated in the status bar.

Reset the solution, increase the meshing parameters, 
and start processing again.

1. Choose Process > Reset or click the Reset button on the 
toolbar.

2. Choose Process > Parameters.
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3. In the Receiver group box, set Mesh Spacing Min. to 0.13 .

This will half the size of the smallest mesh element, 
increasing the quality of the solution, but also increasing 
the amount of meshing. 

4. Click OK.

5. Click the Go button on the toolbar.

Observe the difference in the length of time it takes to 
process the solution.

The time it takes to process increases proportionally to the 
increase in mesh density.

Again, stop processing when the percentage of energy 
distributed exceeds 75%.

How much longer did it take? How much better does it look? 
Chances are it took a lot longer and looks only a little better. 
You will notice that the boundaries between the lighter and 
darker areas look better. This is because more mesh elements 
were used to represent a smoother transition.

1. Click the Stop button on the toolbar.

Display the model in Mesh mode and observe the way 
the mesh was formed.

Observe where the geometry was meshed more finely.

1. Click the Outlined button on the toolbar.

2. Choose Process > Statistics.

Note the number of mesh elements in the model.
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Turn on the ambient approximation, and continue the 
solution.

Ambient approximation takes the remaining unshot energy and 
distributes this evenly over all of the surfaces of the model. The 
model should lighten when this feature is turned on and the 
remaining 25% of the energy is distributed to the remaining 
surfaces.

1. Choose Display > Ambient or click the Ambient button on the 
toolbar.

2. Click the Go button on the toolbar.

3. Click the Stop button on the toolbar when the percentage of 
energy distributed exceeds 85%.

4. Choose Display > Ambient or click the Ambient button on the 
toolbar to turn off the ambient feature.

Optimize the display speed of the solution.

As the radiosity process adds considerable additional geometry 
to the solution, moving the model around interactively in 
solution mode may be slow and cumbersome. Setting the 
display interactivity features allows you to increase the speed 
and smoothness of redraws when you are moving through the 
model. There are two primary ways to control the display 
speed:

■ Draw every nth polygon - This only displays a certain 
percentage of the polygons in the model. Setting this to 2 
will draw every 2nd polygon effectively doubling the 
display speed.
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■ Level of Detail - This only displays part of the mesh 
information for each original polygon. Where surfaces are 
distant from you in the model, only the top level lighting 
data is displayed. This makes these surfaces appear more 
crude but they will redisplay faster. 

These settings only effect the display during interactive 
movement; the screen will redraw in full display mode once the 
left mouse button is released 

1. Select a view of the model where you are looking through 
the door from outside the model.

2. Choose Edit > Properties.

3. Click the Display Interactivity tab.

4. Set the Draw Every Nth Face slider to 2.

5. Click the Preview check box and note that only every second 
polygon is displayed.

6. Click Apply and then Orbit the model. 

Note the increased smoothness and speed of the display.

7. Return to the view selected above.

8. Set the Level of Detail slider to 50.

9. Click the Preview check box.

Note that the nice lighting detail from the up lights is now 
displayed much more crudely.

10. Click Apply and then Orbit the model. 

Note the increased smoothness and speed of the display.

11. Reset the sliders to their default values and click OK to close 
the dialog.
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Refining the Solution In this section, you will learn about the following:

■ “Using Natural Lighting”

You will perform the following tasks:

■ “Setting Up a Window”
■ “Turning Off Lights”

Using Natural Lighting
Lightscape uses two daylight algorithms: Interior Daylight and 
Exterior Daylight. Each method provides the fastest and most 
efficient algorithms for the appropriate situation. When you are 
using the Interior Daylight algorithm, daylight and sunlight are 
only calculated through surfaces that are specified as a window 
or an opening. 

■ A window is defined such that the properties of the 
material assigned to a window (i.e. the material should be 
transparent) affect the amount and color of the light that 
enters the space.

■ An opening is treated as if there is no surface there at all.

You can modify the following sun and daylight parameters by 
choosing Light > Daylight:

■ Direction of north
■ A city location
■ Latitude and longitude
■ Time zone
■ Day of the year
■ Time of day
■ Daylight saving time on/off
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■ Sun color
■ Sky color
■ Sky conditions

Setting Up a Window
Select the surface that will be turned into windows.

1. Choose View > Extents or click the Extents button on the 
toolbar.

2. Choose Edit > Selection > Select or click the Select button on 
the toolbar.

3. Choose Edit > Selection > Surface or click the Surface button on 
the toolbar. 

This sets the selection filter to select only surfaces.

4. Select the surfaces that are window panes.

There are 16 of these. A red highlight displays as you select 
each one.

5. Using the right mouse button, click in the Graphic 
Window to open the context menu.

6. Select Process Control in the context menu. 

This is where you can control specific processing 
parameters for individual surfaces.

7. Click the Window check box to turn on this feature and click 
OK. 
The surfaces are now defined as windows.

8. Click the Deselect All button to clear the selection set.
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Turn on Interior Daylight and then set up the Daylight 
parameters.

1. Choose Process > Parameters.

The Process Parameters dialog box displays.

2. In the Process group box, click the Daylight (sunlight + skylight) 
check box to turn on daylight.

3. Click the Daylight through Windows and Openings only check box 
to turn on this feature.

4. Set the Skylight Accuracy slider to 0.30 .

5. Click OK.

6. Choose Light > Daylight.

The Daylight Setup dialog box displays.

7. Using the appropriate tabs and fields in the Daylight Setup 
dialog box, enter the information shown in Table 2-3.

Table 2-3.  Interior Daylight Parameters 

8. Click OK.

Direction 
of North

City 
Location

Latitude/
Longitude

Time 
Zone

Day of 
the Year

Time of 
Day

Daylight 
Saving 
Time

Sun/Sky 
Colors

Sky 
Condition

90 New York 41/74 GMT-5 6/21 5:00pm On Defaults 0.3 
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9. Click the Go button on the toolbar.

As the processing continues, the direct energy from the sun 
will be distributed first. Next, the diffuse skylight 
component will be calculated for each of the window panes.

10. Click the Stop button on the toolbar after about 25 more 
iterations.

Turning Off Lights
Turn off the LITE_UPLITE1 fixtures.

Although lights cannot be added or moved in the solution stage, 
they can be changed or deleted. With the sunlight added to the 
scene, the four uplites can be turned off. Once turned off, the 
solution must run for several iterations to remove the light 
energy that was emitted from the modified light sources.

1. Click the Extents button on the toolbar.

2. Select LITE_UPLITE1  from the Luminaires Table.

3. Using the right mouse button, click anywhere in the 
Luminaires Table to open the context menu.

4. Choose Photometrics from the context menu.

The Luminaire Properties for LITE_UPLITE1 dialog box displays.

5. In the Magnitude area, change the intensity from 3550  to 
0 cd and click OK.

6. Confirm the overwrite of the existing luminaires.
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7. Click the Go button on the toolbar.

As the processing continues, the energy from the four lights 
is subtracted creating a dark patch on the walls and ceiling.

8. Click the Stop button on the toolbar after several iterations.
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Outputting the Results In this section, you will learn about the following:

■ “Understanding Rendering”

You will perform the following tasks:

■ “Creating a Single High Quality Image”

Understanding Rendering
Rendering is the process of taking the three-dimensional 
radiosity solution and converting it into a two-dimensional 
image. With Lightscape, you can perform this operation in two 
ways:

■ Rendering the radiosity solution as it stands.
■ Adding specular and reflection lighting effects using ray 

tracing.

A rendering is created by selecting File > Render and setting the 
appropriate rendering options. The resulting images can be of 
any resolution. They can also be antialiased to produce higher-
quality output.

Rendering Options
Lightscape can produce images of any resolution that can be 
output in a variety of standard file formats. The following 
options control the rendering process:

■ Format Type - The Format Type selects the file format of the 
image. Most standard formats are supported.
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■ Resolution (size) - The Resolution (size) of the image can be 
set by selecting a standard image size from the Resolution 
combo box or by entering values in the Width and Height 
input fields.

■ Antialiasing - The level of antialiasing is used to eliminate 
image artifacts such as the “stepping” or “jaggies” of 
polygon edges.

■ Ray tracing - Ray tracing is used in Lightscape to add 
specular lighting effects to the radiosity solution. This more 
accurately shows transparency effects and refines the 
primary shadows from light sources.

■ Ray Trace Direct Shadows - The Ray Trace Direct Shadows option 
recomputes the direct energy contribution of the sun and 
selected light sources using the ray tracer. This eliminates 
image artifacts such as the “jaggies”.

■ Ray Bounces - The Ray Bounces input field sets the number of 
ray bounces used when ray tracing an image. 

Creating a Single High Quality Image
Create a single high quality image using the ray tracer.

1. Select a desirable view of the model.
Be sure to include at least one of the vases in the view.

2. Choose Edit > Selection > Select or click the Select button on 
the toolbar.

3. Choose Edit > Selection > Luminaire or click the Luminaire 
button on the toolbar.

4. Select a luminaire that is positioned directly over a vase in 
one of the niches.
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5. Using the right mouse button, click in the Graphic 
Window to open the context menu.

6. Select Luminaire Processing from the context menu.

7. Click the Ray Trace Direct Illumination check box to turn on ray 
tracing for these luminaires and click OK.

8. Choose File > Render.

The Rendering dialog box displays.

9. Choose the Targa (TGA) format from the Format combo box.

10. Type ray  in the Name input field in the Output File group box.

11. Select Two in the Antialiasing combo box.

Antialiasing over- samples pixels to remove “jaggies” along 
the edges of objects.

12. In the Resolution combo box, choose Full Window.

13. Click the Ray tracing check box to turn on ray tracing.

14. Click the Ray Trace Direct Illumination check box to turn on this 
feature.

This will create better direct shadows by ray tracing the sun 
and the luminaires selected above.

15. Type 10 in the Ray Bounces field.

16. Click OK and confirm the additional processing.

Lightscape now ray traces the model. Soon you will see the 
specular reflections from the vases that were not visible in 
the diffuse radiosity model. In addition to displaying the ray 
traced results in the Graphics Window, they are saved to 
the ray.tga filename above. You can use the LVu utility 
to view the ray.tga  file.
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Lighting Analysis The radiosity solution contains all the information necessary for 
performing lighting analysis:

■ You can visualize the distribution of light over the surfaces 
in the environment by using pseudo-coloring techniques.

■ A grid of illumination values can be superimposed over 
selected surfaces.

■ Statistical data such as averages, minima and maxima, and 
criterion ratings are presented interactively for any surface 
in the scene on the Statistics tab in the Lighting Analysis dialog.

In this section, you will perform the following tasks:

■ “Performing Lighting Analysis”
■ “Saving and Exiting”

Performing Lighting Analysis
Check the lighting analysis of the solution.

1. Choose View > Extents.

2. Choose Light > Analysis.

3. Click the Display tab.

4. Select Color from the Display combo box.

5. Set Scale Max to 2000  lx.

Lux is an international unit for specifying luminance. To 
display in foot candles, choose Edit > Properties, click the 
Units tab, and choose American in the Lighting combo box. 

6. Click Apply.

7. Click the Statistics tab.
2-68 Tutorial 2, Fundamentals - Importing DXF Files



8. Pick a point on a wall.

Notice the values that appear on the Statistics page.

9. Click the Grid tab.

10. Click the Grid check box to turn on this feature.

11. For X, Y, and Z, set the spacing to 3.

12. Set Grid Labels Precision to 4 digits.

13. Click Apply.

14. Choose View > Projection > Top.

15. Pick a point on the floor.

Notice the grid of illuminance values that displays on the 
floor.

16. Click Cancel.

17. Click the Perspective button on the toolbar.

Saving and Exiting
Congratulations! You have completed Tutorial 2. 

1. Choose File > Save As to save this file.

The Save As dialog box appears.

2. In the File Name input field, type a name for the new file and 
click OK.

3. Choose File > Exit and confirm.
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Going Further You have reached the end of Tutorial 2. At this point you should 
understand:

■ How to import DXF files
■ Basics of setting materials
■ How to create luminaires
■ Adaptive meshing and how to control the quality of a 

radiosity solution
■ How to set up interior daylighting options
■ How to perform an analysis of the lighting data in the model

To learn more about the Lightscape Visualization System, do 
the following:

Open the sample solution files.

The Lightscape Installation media contains a number of sample 
solution files which you can use for experimenting. To install 
these files:

1. Perform a Custom installation.

2. Select only the Sample Files from the list items to install.

3. Once installed, open one of these sample files in Lightscape.

4. Observe the way the mesh was created, the way materials 
were defined, the way luminaires were defined, and so on.

This gives you a feel for the performance of different 
models.

5. Try resetting the solution and experimenting with different 
process parameters.

Do the remaining tutorials for more examples of 
working with Lightscape.
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 Tutorial 3 Exterior Models - 
Importing 3D Studio
In this tutorial, you will import a 

3D Studio model and follow the 

typical steps for preparing files from 

3D Studio. Additionally, as this is an 

exterior model, you will set 

parameters and process it in a 

slightly different way. At the end 

of the tutorial, you will preview 

the animation imported with the 

3DS file. 
3-1



The goal of this tutorial is to render the model used to create 
the image in Figure 3-1.

Figure 3-1. Sample of Rendered Image from Tutorial 3
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How Tutorial 3 is 
Organized

This tutorial contains the following sections and lessons:

■ “Getting Data” on page 4
“Starting Lightscape”
“Using Good Modeling Practices”
“Importing 3D Studio Files”
“Importing Geometry”

■ “Preparing Data” on page 10
“Assigning Procedural Textures”
“Loading and Placing Light Fixtures From a Library”
“Setting the Local Process Parameters”
“Setting the Global Process Parameters”

■ “Creating the Solution” on page 25
“Initiating the Preparation Model”
“Creating a Night Solution for the Courtyard”
“Processing the Solution”
“Creating a Daytime Solution for the Full Model”

■ “Outputting the Results” on page 33
“Ray Tracing a Region”
“Previewing an Existing Animation”
“Saving and Exiting”

■ “Going Further” on page 36
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Getting Data In this exercise, you will perform the following tasks:

■ “Starting Lightscape”
■ “Importing 3D Studio Files”
■ “Importing Geometry”

This section also includes “Using Good Modeling Practices” on 
page 5. This discussion provides information about modeling 
practices to keep in mind when you use Lightscape.

Starting Lightscape
Start Lightscape.

1. In the Lightscape Applications window group, double-click 
the Lightscape icon.

If you are running Windows NT 4.0 or Windows 95, you 
can also start Lightscape by choosing it from the Start menu.

The Lightscape graphical user interface displays on the 
screen.

Turn on all toolbars.

This tutorial makes extensive use of the toolbars to execute 
commands more easily.

1. Choose Tools > Toolbars.

The Toolbars dialog box displays.

2. Double-click any item that does not have a check mark in 
front of it to turn on that toolbar.

3. Click Close when you are done.
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Using Good Modeling Practices
There are several modeling habits to get into when creating 
models for import into Lightscape. Because Lightscape 
calculates the relationship between light and surfaces, it is 
important to:

■ Model only those surfaces that are physically apparent.

During each iteration, Lightscape looks at each and every 
surface to calculate the effect of the current light source on 
it. Extraneous surfaces (such as the inside surfaces of walls 
which never receive light) will increase processing time.

■ Create large contiguous surfaces rather than many small 
discrete surfaces.

Figure 3-2. Surface on the Right Processes More Efficiently

Where more than one surface is used to represent a plane, 
each of the surfaces must be considered separately when 
reflecting energy into the environment, increasing 
processing time.
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■ Surfaces that are occluded by other surfaces should be 
modeled as two or more separate surfaces.

Figure 3-3. Floor on the Right Reduces Occlusion Artifacts

For example, where a wall intersects a floor plane, the 
floor surface should be made of two surfaces, not one. 

■ Model surfaces in the most efficient way possible.

Figure 3-4. Complex Geometry Processes Faster When Modeled 
Efficiently, As Shown on the Right

When creating a revolved surface, set the tessellation 
complexity of the object to a coarse value, and use 
smoothing within Lightscape to get the volumetric effect.
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■ Where possible, surfaces should be modeled as regular 
polygons.

Figure 3-5. Surfaces with Openings Are Best Modeled As Shown On 
the Right

Many shadow artifacts are the product of meshing strangely 
shaped surfaces (such as adjacent, long, thin, triangular 
surfaces). Rectangular polygons and equilateral triangles 
produce the best effects.

Importing 3D Studio Files
Lightscape imports 3D Studio scenes, creating a polygonal 
mesh based on the objects stored in the 3D Studio file.

Blocks and Layers
Setting how 3D Studio mesh objects are organized in the block 
and layer structure of Lightscape is important for organizing 
data efficiently. By default, each mesh object is associated to its 
own separate layer. This breaks the model into discrete parts, 
which can then be easily edited. Blocks can be created from 
each mesh object as an alternate organizing strategy. 
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Maximum Light Intensity Scale
When 3D Studio lights are imported into Lightscape, their 
luminous intensity is scaled by the value indicated in the input 
field. For example, a 3D Studio light with an intensity of 128 
(half-way across the slider) is set to 1250 candela if the default 
value of 2500 candela is selected. 

Materials
When 3D Studio materials are imported into Lightscape, they 
are mapped into Lightscape materials of the same name. If a 
diffuse color has been assigned in 3D Studio, this will be used 
to create the Reflective color for the material. Shininess and 
shininess strength are used to set the Refractive Index and 
Smoothness values. Where it exists, Texture 1 is assigned as the 
single texture map in Lightscape.

Camera Paths
3D Studio camera paths are imported into Lightscape, creating 
.la  files (Lightscape animation files) whose name is a 
combination of the 3DS file name and the camera number in 
3D Studio. 

Importing Geometry
Load the 3D Studio file called tutorial3.3ds .

1. Choose File > Import > 3D Studio.

The Import 3D Studio dialog box displays.

2. In the Name area, click Browse.

The Open dialog box displays.
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3. Change directory to:

c:\Program Files\lvs\projects\tutorial3

4. Double-click tutorial3.3ds .

5. In the File Units area, choose Feet in the combo box.

This is the unit of measurement with which the model was 
created.

6. Change the Maximum Light Intensity Scale to 100000 .

This is an exterior model with a single light source 
representing the sun. If you want to render the scene using 
the artificial sun source, it is important that you scale the 
light source accordingly. Later in this tutorial, we will 
remove this source and use Lightscape’s implementation of 
natural daylight instead.

7. Click OK.

Notice that the message box reports that the model is 
165 x 137 x 60.9249 feet . 

8. Click Yes to open and display the file.
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Preparing Data In this exercise, you will perform the following tasks:

■ “Assigning Procedural Textures”
■ “Loading and Placing Light Fixtures From a Library”
■ “Setting the Local Process Parameters”
■ “Setting the Global Process Parameters”

Assigning Procedural Textures
A procedural texture modulates the color of a surface, making 
it appear visually more interesting. While Lightscape reads 
much of the material data when importing 3D Studio files, it 
does not read procedural textures. You will need to re-create 
these in Lightscape.

There are two methods for generating procedural texture maps 
in Lightscape: 

■ “Intensity Mapping”
■ “Bump Mapping”

Intensity Mapping
Intensity mapping varies the reflectance of the material, 
resulting in smooth variations in intensity over the surface. 
These variations can have the effect of making a surface look 
dirty or slightly wavy.

■ The Width (specified in real units) controls the size of each 
intensity patch.

■ The Amount controls the variation in intensity.
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■ The Layers controls the number of intensity layers of slightly 
different period to be added together. When several layers 
are added together, the intensity has fractal-like properties, 
sometimes called turbulence.

Bump Mapping
Bump mapping creates the appearance of bumps or dimples on 
the surface.

■ The Width (specified in real units) sets the distance between 
bumps on the surface.

■ The Height sets the height of the bumps relative to their 
width. A negative value turns every bump into a depression.

■ The Clamp sets the amount of the surface that will have the 
bump map applied to it. The smaller the value, the less of 
the surface that will have bump mapping applied to it.

Assign a wavy procedural texture to the water.

1. Choose Display>Textures or click the Textures button on the 
toolbar to turn off textures, if necessary.

This avoids redraws as the materials are updated.

2. Double-click WATER from the Materials Table.

The Material Properties dialog box displays with the WATER 
properties.

3. Click the Procedural Texture tab in the Material Properties dialog.

4. Turn on Bump Mapping.

5. Enter 0.25  in the Width input field.

6. Adjust the Height slider to 1.0 .
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7. Adjust the Clamp slider to 1.0 .

8. Click OK to update the material and close the dialog.

The procedural texture is only apparent when an image is 
ray traced. The water will have a wavy appearance.

Assign a noise procedural texture to the ground.

1. Double-click GROUND from the Materials Table.

The Material Properties dialog box appears with the GROUND 
properties.

2. Click the Procedural Texture tab in the Material Properties dialog.

3. Turn on Intensity Mapping.

4. Enter 3.0  in the Width input field.

5. Adjust the Amount slider to 0.3 .

6. Adjust the Layers slider to 3.

7. Click OK to update the material and close the dialog.

The procedural texture is only apparent when an image is 
ray traced. The grass will have a color variation over its 
surface.

Assign stucco procedural textures to the walls.

1. Select WALLS, WALL_RED, and WALL_ORANGE from the 
Materials Table.

You can select more than one object from a table by holding 
down the Ctrl  key while selecting objects.
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2. Using the right mouse button, click in the Materials Table and 
select Edit Properties from the context menu.

The Material Properties for Multiple Selections dialog box shows 
those properties which are common to the three materials. 
Notice on the Color tab there are no numeric settings for the 
diffuse color, for example, but the Refractive Index slider is set 
to 1.0 , which is how all three materials are currently set.

3. Click the Procedural Texture tab in the Material Properties dialog.

4. Turn on Bump Mapping.

5. Enter 0.05  in the Width input field.

6. Adjust the Height slider to 0.5 .

7. Adjust the Clamp slider to 1.0 .

8. Click OK to update the three materials and close the dialog 
(see Figure 3-6).

The procedural texture is only apparent when an image is 
ray traced. The walls will have a stucco-like finish.
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Figure 3-6. Setting Bump Mapping for Multiple Materials

Loading and Placing Light Fixtures From a 
Library
Lightscape can store blocks and luminaires from any model in a 
block library. The library contains the complete definition of 
the entity—its geometry, material, surface properties, and, in 
the case of luminaires, the photometric definition of the source. 
Once stored in a library, blocks and luminaires can be accessed 
in any Lightscape model. Where an instance of the block 
already exists, the new definition of the block overwrites the 
definition in the file. This is a powerful feature that allows you 

Lightscape - tutorial3.lp
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to change from one version of a block to another—from a 
simple to a complex representation of the same object, for 
example. 

Load two luminaires from the Block Library 
tutorial3.blk.

1. Click the Wireframe button on the toolbar.

2. Using the right mouse button, click anywhere in the 
Luminaires Table to open the context menu.

3. Choose Load from the context menu.

The Open dialog box displays.

4. Change directory to:

c:\Program Files\lvs\projects\tutorial3

5. Double-click tutorial3.blk .

The Available Luminaires dialog box displays.

6. Select LITE_EXTERIOR1 and LITE_EXTERIOR2 from the 
Available Luminaires dialog box.

7. Click OK.

 The two luminaires are added to the Luminaires Table.

Add an instance of the LITE_EXTERIOR1 luminaire at 
the front entrance.

1. Turn off all layers except DOOR1 and make this the current 
layer.

2. Ensure that you are in perspective view.

3. Choose View > Extents or click the Extents button on the 
toolbar.
Preparing Data 3-15



4. Select LITE_EXTERIOR1 from the Luminaires Table.

5. Using the right mouse button, click anywhere in the 
Luminaires Table to open the context menu.

6. Choose Create Single Instance from the context menu.

An instance of the light is added and highlighted.

7. Choose Edit > Transformation, or using the right mouse 
button, click anywhere in the Graphic Window and choose 
Transformation from the context menu.

The Transformation dialog box displays.

8. Click the Position tab.

9. Choose Pick from the Values combo box.

Ensure that the Snap to Nearest Vertex option is turned off.

10. Using the left mouse button, pick a point in the ceiling of 
the alcove centered above the door.

This places the luminaire on the frame pointing down 
towards the ground.

11. Click Cancel to close the Transformation dialog box.

12. Click the Deselect All button on the toolbar.

Replace the surfaces on the LITE layers with the block 
LITE_EXTERIOR2.

When a modeling program supports a block structure, the 
most efficient way to create luminaires is to create blocks, 
which can later be turned into luminaires. In modeling 
packages that do not support a block structure, the best 
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technique is to create a single surface as a placeholder for each 
luminaire. That surface is then replaced by a luminaire within 
Lightscape.

1. Using the right mouse button, click anywhere in the Layers 
Table to open the context menu.

2. Choose All Off from the context menu.

3. Using the right mouse button, click in the Layers Table and 
choose Select Pattern from the context menu.

4. Type LITE*  in the select field and click Select.

This selects all layers beginning with the string “LITE ”.

5. Using the right mouse button, click anywhere in the Layers 
Table to open the context menu.

6. Choose On from the context menu. 

7. Choose View > Extents or click the Extents button on the 
toolbar. 

There are now 13 triangular surfaces on the screen. You 
may wish to orbit and look at the model from above to 
confirm this.

8. If you orbited, then choose Edit > Selection > Select, otherwise 
go to step 9.

9. Choose Edit > Selection > Surfaces or click the Surface button 
on the toolbar.

10. Click the Select All button on the toolbar. 

The surfaces on the layers are highlighted.

11. Using the right mouse button, click in the Graphic 
Window to open the context menu.
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12. Choose Replace With Block/Luminaire.

13. Select LITE_EXTERIOR2 from the block/luminaire list.

14. Click OK.

The selected surfaces are replaced with the luminaire.

15. Turn all layers back on.

Delete the 3D Studio Sun.

Because Lightscape uses a “real” sun, you can now delete the 
Light01  light (representing the sun) that was created in 3D 
Studio.

1. Choose View > Extents or click the Extents button on the 
toolbar.

The view of the model gets quite small on the screen. This 
is because the Light01  object was placed a large distance 
from the model.

2. Select Light01  in the Luminaires Table.

3. Using the right mouse button, click anywhere in the 
Luminaires Table to open the context menu.

4. Choose Query Instances from the context menu. 

A small green light icon displays in the upper right corner 
of the screen identifying the luminaire.

5. Using the right mouse button, click in the Luminaires Table 
and select Delete.

The 3D sun source is deleted from the model and the 
Luminaires Table.
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6. Choose View > Extents or click the Extents button on the 
toolbar.

The model now occupies a more reasonable portion of the 
screen.

Setting the Local Process Parameters
Local process parameters alter the global settings for selected 
surfaces. This allows you to make the meshing more accurate in 
areas of interest or need, and less accurate in other areas of the 
model. This is especially important in the exterior model, 
which has some very large surfaces. Where these contribute 
negligibly to the scene (the roof which reflects light up to the 
sky but doesn’t reflect light on any surface in the model), you 
can set them to be largely ignored in the solution. The 
parameters that you can control locally are: 

■ Mesh Resolution - this parameter scales the minimum and 
maximum mesh spacing for the selected surfaces and is 
used to improve the quality of a radiosity mesh on 
individual surfaces or economize the number of mesh 
elements on other surfaces where they are needed less. A 
value of 2 will decrease the size of the Receiver Mesh 
Spacing Min and Max values for this surface by half thereby 
potentially quadrupling the number of mesh elements on 
this surface. A value of 0.5 will increase the size of the 
Receiver Mesh Spacing Min and Max values for this surface 
by two thereby potentially decreasing the number of mesh 
elements on this surface by 75%.

■ No Mesh - the surface is not meshed at all. Only the original 
vertices will be used in the radiosity calculation.

■ Occluding - controls whether a surface casts a shadow or 
light goes straight through it unaffected.
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■ Receiving - when receiving is off, the surface is not 
calculated in the radiosity solution. You can turn this 
parameter off to save computation time on a surface that is 
self-emitting (for example, an area light source).

■ Reflecting - when reflecting is off, a surface will not reflect 
the light incident on it back into the environment. 

Remove meshing for all surfaces on the TREE (TREE01, 
TREE02…) layers.

This prevents any adaptive subdivision meshing from taking 
place on these surfaces. It is a way of economizing on the 
number of total mesh elements in the model.

1. Using the right mouse button, click anywhere in the Layers 
Table to open the context menu.

2. Choose All Off from the context menu.

3. Using the right mouse button, click in the Layers Table and 
choose Select Pattern from the context menu.

4. Type TREE* in the Select field and click Select.

This selects all layers beginning with the string “TREE”.

5. Using the right mouse button, click anywhere in the Layers 
Table to open the context menu.

6. Choose On from the context menu. 

Only the trees in the model are displayed.

7. Choose View > Extents or click the Extents button on the 
toolbar.

8. Choose Edit > Selection > Surface or click the Surface button on 
the toolbar. 
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9. Click the Select All button on the toolbar.

10. Using the right mouse button, click anywhere in the 
Graphic Window to open the context menu.

11. Choose Process Control from the context menu.

12. Click the No Mesh check box to turn on this feature.

13. Click OK.

14. Click the Deselect All button on the toolbar.

Turn on the ROOF layers and set all of the visible 
surfaces to nonreflecting.

This prevents Lightscape from computing the light energy that 
is reflected from these surfaces. The actual amount of light that 
would be reflected from these surfaces is insignificant in 
proportion to the rest of the model, so you can save some 
computational time.

1. Select EXTROOF1 and EXTROOF2 in the Layers Table.

2. Using the right mouse button, click anywhere in the Layers 
Table to open the context menu.

3. Choose On from the context menu.

4. Click the Select All button on the toolbar. 

The roof and the trees are now selected.

5. Using the right mouse button, click anywhere in the 
Graphic Window to open the context menu.

6. Choose Process Control from the context menu.

7. Turn off Reflecting.
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8. Click OK.

9. Click the Deselect All button on the toolbar.

Minimize the amount of meshing on the ROOF layer.

Assuming that you will normally view the building from eye 
level, the roof does not need to be meshed to the same level of 
detail as the rest of the building.

1. Turn off all layers except EXTROOF1 and EXTROOF2.

2. Click the Select All button on the toolbar.

3. Using the right mouse button, click anywhere in the 
Graphic Window to open the context menu.

4. Choose Process Control from the context menu.

5. Slide the Meshing slider to the left until you reach 0.2  or 
enter .2  in the entry field.

6. Click OK.

7. Click the Deselect All button on the toolbar.

Make the surfaces on the GROUND layers non-
occluding.

This prevents Lightscape from computing whether these surface 
create shadows on other surfaces. Since there are no surfaces 
below the ground onto which to cast shadows, there will be no 
shadows, so again you can save some computational time.

1. Turn off all layers.

2. Double-click GROUND in the Layers Table to turn on the layer.

3. Click the Select All button on the toolbar.
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4. Using the right mouse button, click anywhere in the 
Graphic Window to open the context menu.

5. Choose Process Control from the context menu.

6. Turn off Occluding.

7. Click OK.

8. Click the Deselect All button on the toolbar.

9. Turn all of the layers back on and return to the original view 
of the model.

Setting the Global Process Parameters
Set the process parameters.

1. Choose Process > Parameters.

The Process Parameters dialog box displays.

Observe the numerical values in the various input fields of 
the dialog. These values control the quality and speed of the 
Lightscape radiosity process. Although you can set these 
manually, you will use a wizard to set them automatically. 
You may refine one or more parameters at any time.

2. Click the Wizard button to activate the wizard.

3. Select the first radio button (labeled 1) to select the lowest 
quality for the model.

4. Click Next to access the next page of the wizard.

5. Select No, do not consider daylighting in this model.

You are creating a night solution first, so you do not 
consider daylighting.

6. Click Next to access the next page of the wizard.
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7. Click Finish to update the process parameters based on the 
answers given to the wizard.

Observe the change in the numerical values in the various 
boxes of the dialog.

8. In the Receiver group box, set the Mesh Spacing Min to 0.25 . 

This will allow for finer meshing.

9. In the Tolerances group box, set the Initialization Minimum Area 
to 12.

This helps to improve the proportions of the geometry 
during initiation.

10. Click OK to close the Process Parameters dialog.

Save your work up to this point.

1. Choose File > Save As.

2. Change directory to:

c:\Program Files\lvs\projects\tutorial3

3. Type temp.lp  in the File Name input field.

4. Click OK to save the file.

If you are running Windows NT 4.0 or Windows 95, you 
may click Save.
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Creating the Solution In this exercise, you will perform the following tasks:

■ “Initiating the Preparation Model”
■ “Creating a Night Solution for the Courtyard”
■ “Processing the Solution”
■ “Creating a Daytime Solution for the Full Model”

Initiating the Preparation Model
Initiate the Solution stage.

1. Choose Display > Wireframe or click the Wireframe button on 
the toolbar.

2. Choose Process > Initiate or click the Initiate button on the 
toolbar.

Creating a Night Solution for the Courtyard
Turn off some layers.

It is possible to consider only part of the model when creating a 
solution. This can be used to create multiple solution options or 
to quickly test illumination levels with only rudimentary parts 
of the model displayed. Since the only illumination at night in 
this model is in the courtyard, you will turn off all the layers 
that cannot be seen from the courtyard; the trees, ground 
plane, and the windows.

1. Select a view inside of the courtyard.

2. Double-click GROUND in the Layers Table to turn off this layer.

3. Using the right mouse button, click in the Layers Table and 
choose Select Pattern from the context menu.
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4. Type TREE* in the Select field and click Select.

This selects all layers beginning with the string “TREE”.

5. Using the right mouse button, click anywhere in the Layers 
Table to open the context menu.

6. Choose Off from the context menu.

This turns the tree layers off.

7. Using the right mouse button, click in the Layers Table and 
choose Select Pattern from the context menu.

8. Type WIND* in the select field and click Select.

This selects all layers beginning with the string “WIND”.

9. With the right mouse button, click anywhere in the Layers 
Table to open the context menu.

10. Choose Off from the context menu.

This turns off the window layers. 

Save a Layer State.

When you are working with many layers that are being 
switched on and off, it is beneficial to save the state of these 
layers in a separate file for use at a later time. This file is known 
as a Layer State file and has the file extension .lay . It records 
all of the layer names and their current state—whether off or 
on—and also whether the layer is the Current layer.

1. Using the right mouse button, click in the Layers Table and 
choose Save State from the context menu.

2. Change directory to:

c:\Program Files\lvs\projects\tutorial3

3. Type noland.lay  in the File Name input field.
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4. Click OK to save the file.

This will allow you to easily return to this state by choosing 
Load State from the Layer Table context menu. This layer 
state file will also appear in the Most Recently Used list at 
the bottom of this context menu.

Adjust the brightness.

Brightness adjusts the color range of the displayed image for 
your monitor. It does not affect the actual lighting levels in the 
model. Some scenes, such as exterior models, contain extreme 
differences between the brightest and dimmest regions of the 
environment. You can use brightness and contrast to achieve a 
more appealing balance of light levels in such cases.

Brightness and contrast affect the display of solution files only.

1. Choose Edit > Properties.

2. Click the Display tab.

3. Set Brightness to 75.

4. Set Contrast to 50.

5. Click OK.

Processing the Solution
Start the radiosity processing.

1. Choose Display > Solid or click the Solid button on the toolbar.

2. Choose Process > Go or click the Go button on the toolbar.

3. Continue processing for about 35 iterations and stop the 
process.
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Figure 3-7. A Night Time View of the Courtyard

Save the night solution.

1. Choose File > Save As.

2. Change directory to:

c:\Program Files\lvs\projects\tutorial3

3. Type night.ls  in the File Name input field.

4. Click OK to save the file.

If you are running Windows NT 4.0 or Windows 95, you 
may click Save.
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Reset the solution and turn on all of the layers.

1. Choose Process > Reset or click the Reset button on the 
toolbar.
The model displays black.

2. Choose Display > Wireframe or click the Wireframe button on 
the toolbar.

3. Using the right mouse button, click in the Layers Table to 
open the context menu.

4. Choose All On to turn all of the layers back on.

5. Choose View > Extents or click the Extents button on the 
toolbar.

Creating a Daytime Solution for the Full 
Model
Lightscape uses two daylight algorithms: Interior Daylight and 
Exterior Daylight. For an exterior model, you need to indicate 
the sun position and set the exterior daylight options on the 
Process Parameters dialog. Although you can set the sun location 
by specifying latitude, longitude, and time of day, you can also 
set the sun location directly. Lightscape calculates both the 
direct sunlight and diffuse skylight contributions. The diffuse 
skylight contribution looks at the entire sky when performing 
this calculation - the light on south facing surfaces being 
different than that on north facing surfaces. This calculation can 
be expensive in exterior models so controlling its accuracy is 
important.
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It is also possible to set the system so that daylight can be 
recalculated by the ray tracer when rendering. This can be 
important with exterior models which tend to have large 
ground planes, which if they were meshed extremely finely (to 
capture shadow boundaries) would create a prohibitive number 
of mesh elements. A cruder mesh (sufficient for calculating the 
interreflection of light) can be set instead and the fine shadow 
detail later created in the ray tracer.

Set the Daylight parameters.

1. Choose Process > Parameters.

The Process Parameters dialog box displays.

2. Click the Wizard button to activate the wizard.

3. Select the first radio button (labeled 1) to select the lowest 
quality for the model.

4. Click Next to access the next page of the wizard.

5. Select Yes, to consider daylighting in this model.

6. Click in the radio button next to the item 
The model is an exterior of a building or object.

7. Click Next to access the next page of the wizard.

8. Click Finish to update the process parameters based on the 
answers given to the wizard.

Observe the change in the numerical values in the various 
boxes of the dialog.

9. Click OK to close the Process Parameters dialog.

10. Choose Light > Daylight.

The Daylight Setup dialog box displays.
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11. Click the Direct Control check box to turn on this feature. 

The Direct Control tab replaces the Time and Place tabs in the 
dialog.

12. Click the Direct Control tab in the Daylight Setup dialog.

13. Set the Rotation of the sun to 315 degrees .

14. Set the Elevation of the sun to 45 degrees .

15. Set the Sun Illuminance to about 131835 lux  or full 
brightness.

16. Click the Processing tab in the Daylight Setup dialog.

17. Ensure that all the check boxes, except the Ray Trace Direct 
Illumination in the Sky Light area, are turned on. 

This sets up the model so that sunlight and skylight are both 
calculated and displayed in the radiosity solution, and only 
the direct sunlight ray traced during image processing.

18. Click OK to update the sun parameters and close the dialog.

Save your work up to this point.

1. Choose File > Save As.

2. Change directory to:

c:\Program Files\lvs\projects\tutorial3

3. Type day.ls  in the File Name input field.

4. Click OK to save the file.
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Process the solution.

1. Choose Display > Solid or click the Solid button on the toolbar.

2. Choose Process > Go or click the Go button on the toolbar.

The first iteration which calculates the direct sunlight 
should be fairly quick. The next iteration calculating the 
skylight contribution may take some time.

3. Let the process run for several iterations.

Because the direct contribution from the sun is extremely 
large compared to the bounced light from the surfaces in 
the model, there will be little visible change as the process 
continues to run.

Stop the processing and save your work.

1. Choose Process > Stop or click the Stop button on the toolbar.

2. Choose File > Save.
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Outputting the Results In this exercise, you will perform the following tasks:

■ “Ray Tracing a Region”
■ “Previewing an Existing Animation”
■ “Saving and Exiting”

Ray Tracing a Region
Ray trace a part of the screen to partially preview the 
final image. 

It is possible in Lightscape to preview the effects of ray tracing 
for only part of the image displayed on the screen. This is useful 
when only part of an image contains interesting ray trace effects 
and you wish to ensure that these are going to be displayed 
correctly. 

1. Choose a view of the model where surfaces (the walls of 
the buildings and the water) that have procedural textures 
applied to them are visible.

To best see these effects the view should be relatively close 
to the building. 

2. Choose Display > Ray Trace Area Options.

The Ray Trace Area Options dialog displays.

3. Ensure that Antialiasing Samples is set to One and Ray Bounces is 
set to 10 and that all the other options are turned off.

4. Click OK to close the Ray Trace Area Options dialog.

5. Choose Display > Textures or click the Texture button on the 
toolbar to turn this feature on. 

6. Choose Display > Ray Trace Area or click the Ray Trace Area 
button on the toolbar. 
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7. Drag a window over part of the model in the Graphic 
Window.

The area in question now ray traces displaying the bump 
and intensity effects from the ray tracer.

8. Choose Display > Ray Trace Area Options.

The Ray Trace Area Options dialog displays. 

9. Click the Ray Trace Direct Illumination check box to turn this 
option on.

This more accurately displays the shadows from the sun 
when the area is ray traced.

10. Click OK to close the Ray Trace Area Options dialog.

11. Drag a window over part of the model in the Graphic 
Window. 

12. Click OK to accept the additional processing.

The area in question now ray traces displaying the bump 
and intensity effects as well as ray traced sun shadows.

Previewing an Existing Animation
Load an animation and preview it.

A Lightscape animation file named tutorial3.la  was created 
when the 3D Studio file was imported into Lightscape. This 
animation file contains an animation path based on CAMERA01 
motion in 3D Studio.

1. Choose Animation > Open.

The Open dialog box displays.
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2. Change directory to:

c:\Program Files\lvs\projects\tutorial3

3. Double-click tutorial3.la . 

This loads the animation file into memory.

4. Choose Display > Wireframe or click the Wireframe button on 
the toolbar.

5. Choose Animation > Edit.

6. Click the Preview tab.

7. Move the Animation dialog box out of the way.

8. Click the Play button.

9. Choose Display > Solid or click the Solid button on the toolbar.

10. Click the Rewind button.

11. Click the Play button.

Note that the animation was smoother in wireframe mode. 
This is because more frames per second can be displayed in 
non-solid modes.

12. Click Close when you are done viewing the animation.

Saving and Exiting
Congratulations! You have just completed Tutorial 3.

1. Choose File > Save to save this file.

2. Choose File > Exit.
Outputting the Results 3-35



Going Further You have reached the end of Tutorial 3. At this point you should 
be able to:

■ Import 3D Studio files.
■ Assign procedural textures to materials.
■ Create radiosity solutions of selected portions of a model.
■ Set up for lighting an exterior model.
■ Set local process parameters to speed up and control the 

quality of the radiosity solution.

To learn more about the Lightscape Visualization System, do 
the following:

Open the sample solution files.

The Lightscape Installation media contains a number of sample 
solution files which you can use for experimenting. To install 
these files:

1. Perform a Custom installation.

2. Select only the Sample Files from the list items.

3. Observe the way the mesh was created, the way materials 
were defined, the way luminaires were defined, and so on.

This gives you a feel for the performance of larger models.

4. Try resetting the solution and experimenting with different 
process parameters.

Do the remaining tutorials for more experience 
working with Lightscape.
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 Tutorial 4 Importing, Setting 
Up, and Rendering
In this tutorial, you will begin by 

working through advanced DXF 

import techniques. Next, you will 

undertake some specialized 

preparation tasks such as orienting 

surfaces and placing and aligning 

textures. Finally, you will create an 

animation and produce frames of the 

first segment of the animation. 
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The goal of this tutorial is to render the model used to create 
the image in Figure 4-1.

Figure 4-1. Sample of Rendered Image from Tutorial 4
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How Tutorial 4
is Organized

This tutorial contains the following sections and lessons:

■ “Getting Data” on page 4
“Starting Lightscape”
“Understanding the Advanced DXF Import”
“Importing Geometry”

■ “Preparing Data” on page 16
“Orienting Surfaces”
“Smoothing Surfaces”
“Understanding Texture Alignment”
“Displaying and Aligning Textures”

■ “Creating a Solution” on page 29
“Understanding the Global Process Parameters”
“Rules of Thumb”
“Testing Primary Lights”
“Testing Overall Light Levels”
“Refining Global Meshing Parameters”
“Setting Process Parameters”
“Processing the Solution”

■ “Fine Tuning the Solution” on page 38

■ “Outputting the Results” on page 38
“Understanding Lightscape Animation”
“Creating an Animation”
“Creating Animation Images”
“Saving and Exiting”

■ “Going Further” on page 50
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Getting Data In this exercise, you will learn:

■ “Understanding the Advanced DXF Import”

You will perform the following tasks:

■ “Starting Lightscape”
■ “Importing Geometry”

Starting Lightscape
Start Lightscape.

1. In the Lightscape Applications program group, double-click 
the Lightscape icon.

The Lightscape graphical user interface displays on the 
screen.

Turn on all toolbars.

This tutorial makes extensive use of the toolbars to make 
executing operations easier.

1. Choose Tools > Toolbars.

The Toolbars dialog box displays.

2. Double-click any item that does not have a check-mark in 
front of it to turn on that toolbar.

3. Click Close when you are done.
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Understanding the Advanced DXF Import
Lightscape contains a number of tools to optimize a model that 
you import using the DXF translator. In part, this is because the 
DXF file format is missing support for material definitions, but 
you may also need to import revised versions of the model into 
Lightscape. This would minimize the preparation tasks that you 
might have to repeat.

Material Maps
By default, Lightscape assigns a material to a surface whose 
name and color match the color number in the DXF file. Not 
only are the names of these materials nondescript (usually 0 
through 255), but the colors are generally not suitable for 
producing acceptable Lightscape results. 

With the material map technique you can:

■ Associate Lightscape materials to the color numbers used in 
the DXF file.

■ Load a material map in conjunction with a DXF file. This 
substitutes all the colors defined in the DXF file with the 
associated Lightscape material. For example, you can map a 
material called “wood” onto every surface that is drawn 
with color 1.

Block Libraries
By default, Lightscape creates a new block definition for each 
block when importing a DXF file. If you have pre-existing 
Lightscape blocks defined, you can use these block definitions 
instead. This saves considerable time and effort in the 
Preparation stage.  
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During DXF import:

■ Pre-existing Lightscape block and luminaire definitions can 
be mapped onto incoming DXF blocks of the same name. 

■ The system searches through all the loaded block libraries 
and replaces each block encountered in the DXF file with a 
block of the same name stored in the libraries. 

Overwrite/Append to the Current Model
When importing geometry, you can choose either to append to 
or overwrite the current model:

■ Overwriting creates a new model from the imported 
surfaces. If you choose to overwrite, the existing model 
displayed in the Graphic Window is replaced by the model 
you import. 

■ Appending adds the imported surfaces to the current 
model displayed in the Graphic Window.

Importing Geometry
Load  and examine the DXF file called tutorial4.dxf.

Although we will eventually be using advanced tools for loading 
this DXF file, import it now using basic settings and familiarize 
yourself with it.

1. Choose File > Import > DXF.

The Import DXF dialog box displays.

2. In the Name area, click Browse.

The Open dialog box displays.
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3. Change directory to:

c:\Program Files\lvs\projects\tutorial4

4. Double-click tutorial4.dxf .

5. In the File Units area, choose Feet from the combo box.

This model was created with one unit in the CAD program 
set to equal one foot in the real world.

6. Click OK and confirm that the model is 26 x 29 x 25 feet in 
extent.

If you turn on solid display (Display>Solid), you will notice 
the material colors which are taken from the default 
AutoCAD color scheme (see Figure 4-2). You will also 
notice that many of the surfaces of the piano are missing 
(actually oriented incorrectly).
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Figure 4-2. Basic Imported DXF File

7. Select CHAIR in the Blocks Table.

8. Using the right mouse button, click in the Blocks Table to 
open the context menu.

9. Select Isolate from the context menu.

Notice that this is a simple cube, a rather unlikely shape for 
a chair.

Lightscape - tutorial4.lp
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10. Using the right mouse button, click in the Blocks Table and 
select Return to Full Model to end the block isolate mode.

Notice that the two light fixture blocks, LITE_FIRE1  and 
LITE_SPOT1, are just blocks and not luminaires.

11. Choose File >  New to open a new, empty Lightscape file.

12. Click No to not save changes.

Load materials from an existing material library.

Lightscape materials can be stored in libraries that can be 
accessed from within any Lightscape model. 

1. Using the right mouse button, click in the Materials Table to 
open the context menu.

2. Choose Load to load materials from a library.

The Open dialog box displays.

3. Change directory to:

c:\Program Files\lvs\projects\tutorial4

4. Double-click tutorial4.atr . 

A material browser displays several materials.

5. Choose Select All to select all of the materials and click OK to 
load them. 

They now display in the material browser.
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Assign the newly loaded materials to a Material Map 
and save as tutorial4.mm.

1. Choose Tools > Material Map.

The Material Map dialog box displays.

2. In the Materials list of the dialog, click 
WOOD_PINE_VARNISH.

3. In the Color Indices list, click Index:  001 .

4. Click Assign.

Index:  001  now has the material WOOD_PINE_VARNISH 
assigned to it.

5. Repeat steps 2 through 4 until all materials listed in Table 
4-1 have been assigned to their respective indices. 

Table 4-1.  Material Mapping Assignments

Color Index Material

001 WOOD_PINE_VARNISH

002 STUCCO_WHITE

003 BRICK_ROMAN_TAN

004 PAINT_FLAT_WHITE

005 PAINT_METAL_TAN

006 GLASS

007 CARPET_AREARUG

009 VINYL_GREEN

010 WOOD_CHERRY_BURLED
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6. When you are done assigning materials, click in the Show 
Only Assigned Colors check box to turn on this feature. 

You can easily use this feature to check the assignments that 
you have made against Table 4-1.

7. Click Save.

The Save As dialog box displays.

8. Change directory to:

c:\Program Files\lvs\projects\tutorial4

9. If necessary, type the following in the File Name input field:

tutorial4.mm

10. Click OK to close the Save As dialog box.

11. Click Close to close the Material Map dialog box.

Open the block library and examine the predefined 
Lightscape blocks.

1. Using the right mouse button, click in the Blocks Table to 
open the context menu.

2. Choose Load to load blocks from a library.

The Open dialog box displays.

3. Change directory to:

c:\Program Files\lvs\projects\tutorial4

4. Double-click tutorial4.blk . 

A list browser displays several block names.

5. Choose Select All to select all of the blocks and click OK to 
load them.

They now display in the block list.
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6.  Using the right mouse button, click in the Luminaires Table 
to open the context menu.

7. Choose Load in the context menu to load luminaires from a 
library.

The Open dialog box displays.

8. Change directory to:

c:\Program Files\lvs\projects\tutorial4

9. Double-click tutorial4.blk .

A list browser displays several luminaire names.

10. Choose Select All to select all of the luminaires and click OK 
to load them. 

They display in the luminaires list. Note that the two 
luminaire blocks, LITE_FIRE1  and LITE_SPOT1, have 
been converted to luminaires.

11. Select CHAIR in the Blocks Table.

12. Using the right mouse button, click in the Blocks Table to 
open the context menu.

13. Select Isolate from the context menu.

Notice that now a properly defined Breuer chair appears in 
the Graphic Window.

14. Using the right mouse button, click in the Blocks Table to 
open the context menu.

15. Select Return to Full Model from the context menu to end the 
block isolate mode.

16. Choose File > New to open a new, empty Lightscape file.

17. Click No to not save changes.
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Reimport the file tutorial4.dxf and use the Material 
Map and Block library.

1. Choose File > Import > DXF.

The Import DXF dialog box displays.

2. In the Name area, click Browse.

The Open dialog box displays.

3. Change directory to:

c:\Program Files\lvs\projects\tutorial4

4. Double-click tutorial4.dxf .

5. In the Material Map area, click Browse.

The Open dialog box displays.

6. Double-click tutorial4.mm .

7. In the Block and Luminaire Library area, click Add.

The Open dialog box displays.

8. Double-click tutorial4.blk .

9. In the File Units area, choose Feet from the combo box.

10. Click OK and confirm that the model is 26 x 29 x 25 feet in 
extent.

The reimported version of the DXF file is now properly 
scaled and has the correct material names and definitions 
set up. Many of the blocks are now correctly defined (see 
Figure 4-3).
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Figure 4-3. Advanced DXF Import

Append the file tutorial4a.dxf.

The file you are going to append contains some additional up 
lights located in the four corners of the room. Rather than re-
importing the entire model during a design revision, you can 
merely import the changes into Lightscape.

1. Choose File > Import > DXF.

The Import DXF dialog box displays.

Lightscape - tutorial4.lp
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2. In the Name area, click Browse.

The Open dialog box displays.

3. Change directory to:

c:\Program Files\lvs\projects\tutorial4

4. Double-click tutorial4a.dxf .

5. Adjacent to the Name area, select Append from the Overwrite 
combo box. 

This sets the import options so the new geometry is added 
to the existing geometry in the model.

6. In the Material Map area, click Browse.

The Open dialog box displays.

7. Double-click tutorial4.mm .

8. In the Block and Luminaire Library area, click Add.

The Open dialog box displays.

9. Double-click tutorial4.blk .

10. In the File Units area, choose Feet from the combo box.

11. Click OK, answer No, you do not want to save changes.

12. Confirm that the appended model is of a reasonable size.

The additional lights appear in the four corners of the room.

13. Adjust your view so that you are inside of the room.
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Preparing Data In this exercise, you will learn:

■ “Understanding Texture Alignment”

You will perform the following tasks:

■ “Orienting Surfaces”
■ “Smoothing Surfaces”
■ “Displaying and Aligning Textures”

Orienting Surfaces
Geometry in Lightscape, as in many modelers, is represented 
by infinitely thin surfaces. Like a piece of paper, these surfaces 
clearly have two sides. Generally, however, only one of these 
sides is visible; for example a surface representing a wall has 
one face which looks into the room and a second face which 
faces outwards. It is extremely useful to tell the program which 
side of the surface is the visible one, so that it looks only at one 
side of the surface; effectively halving the number of objects to 
be considered in each iteration. This is done by setting the 
orientation of the surface.

If surface orientation is not set or preserved then when 
importing files, Lightscape attempts to orient the surfaces, 
occasionally getting the orientation wrong. This is apparent 
when you are in solid mode with backface culling on because 
surfaces that should be visible, disappear. They are there but are 
facing the wrong direction. When you activate the Orientation 
dialog box, the display of the model in the Graphic Window 
changes so that backfacing surfaces are no longer culled and are 
displayed in bright green. This helps you to identify those 
surfaces whose orientation is incorrect.
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The Orientation tool offers four methods for changing a 
surface’s orientation:

■ Automatically orienting all surfaces visible to the current 
viewer position to face that direction using the Auto-Orient 
tool.

■ Reversing a surface’s orientation.

■ Orienting a surface toward or away from a specific (focus) 
point in the model.

■ Making surfaces double-sided. This option should be used 
sparingly; it is computationally expensive and, for a 
material such as glass, modeling both sides of the plate of 
glass with correct thickness between them is important in 
rendering accurate refraction effects.

Select surface orientation mode.

This mode turns off culling and displays, in green, the backfaces 
of all of the surfaces. This color helps you determine which 
surfaces are oriented correctly and which ones are not.

1. Choose Display > Outlined or click the Outlined button on the 
toolbar.

2. Choose Edit > Selection > Select or click the Select button on 
the toolbar.

3. Choose Edit > Selection > Surface or click the Surface button on 
the toolbar.

4. Pick a point on a wall in the Graphic Window.

5. Using the right mouse button, click anywhere in the 
Graphic Window to open the context menu.
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6. Choose Orientation from the context menu.

The Surface Orientation dialog box displays and surface 
backfaces are displayed in green.

7. Click the Deselect All button on the toolbar.

Adjust the view and spin the model around 360 degrees 
to observe which surfaces are green and which ones 
are the correct color.

Make mental notes about which surfaces should have their 
orientations reversed. The correct orientation of a wall is tan 
on the inside, green on the outside.

1. Click the Orbit button on the toolbar.

Orbit around the model to view the orientation of all of the 
surfaces.

2. When you are through orbiting, click the Select button on the 
toolbar.

Select any surface that is not tan colored on the inside 
of the building and reverse the orientation.

Since all of the tan surfaces are on the ROOM1_WALLS layer, you 
can start by turning off all other layers.

1. Using the right mouse button, click anywhere in the Layers 
Table to open the context menu.

2. Choose All Off from the context menu.

3. Select 0 and ROOM1_WALLS from the Layers Table. 

4. Using the right mouse button, click anywhere in the Layers 
Table.
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5. Choose On from the context menu. 

All layers are now turned off except for the ROOM1_WALLS 
layer and layer 0.

6. If you see a surface that is not oriented correctly, select it.

7. Make sure that Accumulate Pick is turned on.

8. Click Reverse in the Surface Orientation dialog box to reverse 
the orientation of the selected surfaces.

The selection set remains active so that you can reverse the 
operation you just performed or perform another 
operation on the same set of surfaces.

9. Click the Deselect All button on the toolbar.

Use auto-orient to orient the other surfaces on the 
layer.

1. Choose View > Setup.

2. Select a view where the observer position is in the lower 
right corner of the room and the focus point is in the center.

3. Set the Field of View to 80 (to see as much of the model as 
possible) and click OK to set the view.

4. Observe which surfaces are colored green in the model.

These will be reversed by the Auto-Orient tool, so you may 
wish to select a better view.
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5. In the Surface Orientation dialog box, click Auto Orient.

The green surfaces are reversed.

Repeat steps 2 through 4, selecting other views, and 
orienting the rest of the surfaces on the ROOM1_WALLS 
layer.

Turn off the ROOM1_WALLS layer, turn on the 
ROOM1_FIREPLACE layer, and orient the surfaces of 
isolated blocks.

In this procedure, you orient the surfaces of the fireplace 
elements and add one more step. All of the surfaces are part of 
blocks so they can be isolated and worked on individually.

1. Select ROOM1_WALLS in the Layers Table. 

Press the Ctrl  key to select the ROOM1_FIREPLACE layer 
as well.

2. Using the right mouse button, click anywhere in the Layers 
Table to open the context menu.

3. Choose Toggle from the context menu.

The ROOM1_WALLS layer turns off and the 
ROOM1_FIREPLACE layer turns on (layer 0 should still be 
on).

4. Select TREAD1 in the Blocks Table.

5. Using the right mouse button, click anywhere in the Blocks 
Table to open the context menu.

6. Choose Isolate from the context menu.

At this point, the block TREAD1 is isolated as if this were 
your entire model. Some of what you just did to the model 
is now going to be performed on a single block.
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7. Click the Orbit button on the toolbar and orbit around the 
tread.

Observe that there are four surfaces on this block and that 
only one of them is oriented incorrectly. Reverse its 
orientation.

8. Using the right mouse button, click in the Blocks Table and 
choose Return to Full Model. 

Notice that the stair treads are all correctly oriented.

You should also orient the rest of the surfaces that make up 
the fireplace. You may need to do this by reversing their 
orientation and not by using the auto-orient tool.

Repeat the previous procedures until all surfaces on all 
layers have been oriented.

Be sure to check the layer ROOM1_CEILING which still has 
some incorrectly orientated surfaces. Close the Orientation dialog 
when you are finished.

Smoothing Surfaces
Turn on the ROOM1_FIREPLACE layer and smooth the 
surfaces of the chimney.

In this procedure, you will smooth the surfaces of the fireplace 
chimney. It currently is made of 12 facets. However, since this 
is a round tube you would like it to display as smooth volume 
not as separate surfaces. 

1. Turn off all of the layers.

2. Select ROOM1_FIREPLACE in the Layers Table and turn this 
layer on.
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3. Select the surfaces that make up the fireplace chimney. 

This can be done quickly using the Area Any Vertex picking 
option and dragging a box across the top end of the 
chimney.

4. Using the right mouse button, click in the Graphic 
Window to open the context menu.

5. Choose Smoothing from the context menu.

6. Set the Smoothing Angle to 60 and click Make Smooth.

7. Click Close to close the Smoothing dialog box. 

The surfaces of the chimney now appear smoothed. You 
can turn on Enhanced display mode to confirm this.

8. Turn on all of the layers.

9. Click the Deselect All button on the toolbar.

Understanding Texture Alignment
The texture assigned to a material can be positioned, rotated, 
and stretched during the alignment process. This alignment 
defines how this texture will be applied to a particular surface. 

There are five different ways of projecting a texture onto a 
surface:

■ Orthographic - projects the texture as on a flat surface.

■ Cylindrical - wraps the texture around a cylinder.

■ Spherical - wraps the texture around a sphere.

■ UV - uses coordinates that were imported with the model.

■ Reflection - simulates reflection on objects.
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Aligning an Orthographic Texture
Most, if not all textures in a typical model will be applied to flat 
surfaces and aligned using orthographic projection. An 
orthographic texture is aligned by choosing points for the lower 
left corner, the lower right corner, and the upper left corner 
(see Figure 4-4). This information is used to create a plane. 
This plane is then projected onto the selected surfaces, applying 
the first copy of the texture map. Additional copies will be in a 
grid on the surface based on the selected mapping mode. 

Figure 4-4. Aligning an Orthographic Texture

Lower Right

Lower Left

Upper Left
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Mapping Modes
Mapping Modes determine where additional copies of the 
texture should be placed. Each mapping mode can be applied 
separately in the horizontal and vertical directions. For 
example, it is possible to tile horizontally and clip vertically to 
create a single row of tiles along the base of a wall. The modes 
are displayed in Figure 4-5.

Figure 4-5. Texture Mapping Modes

Tile Flip

ExpandClip
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Displaying and Aligning Textures
Associate a texture with a material and then align it.

To view textures that are associated with materials, you need to 
turn texture display on. Currently, none of the materials in the 
model have textures associated with them (that’s why there is 
no visible change in the model). In the next task, you will be 
associating a texture with a material and then aligning it.

1. Choose Display > Textures or click the Textures button on the 
toolbar.

2. Select BRICK_ROMAN_TAN from the Materials Table.

3. Using the right mouse button, click anywhere in the 
Materials Table to open the context menu.

4. Choose Edit Properties from the context menu.

The Material Properties dialog box displays.

5. Click the Texture tab.

6. In the Name area, click Browse.

The Open dialog box displays.

7. Change directory to:

c:\Program Files\lvs\projects\tutorial4

8. Double-click BRICK_TAN.TGA.

9. In the Filter Method area, select Point MM from the Minimize 
combo box.

This increases the quality of the sampling of the texture (in 
this case making the block edges more clearly defined).
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10. In the Tile Size area, click Fixed Size to turn on this feature 
and set the Width to 3 and set the Height to 1.5 .

The concrete texture repeats every 3 feet in the horizontal 
direction and every 1.5 feet in the vertical direction. When 
you know the area represented by the image file, this 
option allows you to accurately size the texture, creating 
maps of a believable scale. 

11. Click OK.

12. Using the right mouse button, click anywhere in the Layers 
Table to open the context menu.

13. Choose All Off from the context menu.

14. Select ROOM1_WALLS from the Layers Table.

15. Using the right mouse button, click anywhere in the Layers 
Table.

16. Choose On from the context menu.

17. Choose Edit > Selection > Select or click the Select button on 
the toolbar.

18. Choose Edit > Selection > Surface or click the Surface button on 
the toolbar.

19. Select all of the brick surfaces that make up one of the sides 
of the room. 

Notice that although correctly aligned, the texture is not 
continuous but begins from the lower left corner of each 
surface.

20. Using the right mouse button, click anywhere in the 
Graphic Window to open the context menu.
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21. Choose Texture Alignment from the context menu.

The Texture Alignment dialog box displays.

22. Choose Pick Points in the Mouse Select Mode area and turn on 
Snap To Nearest Vertex.

23. Pick a point in the vicinity of the lower left corner of the 
wall selected.

You do not have to be precise; Lightscape looks for the 
nearest vertex (if you selected Snap To Nearest Vertex).

Notice that Lightscape uses icons to represent the lower 
left, lower right, and upper left points. These icons aid in 
understanding how a texture has been aligned.

24. Pick another point in the lower right corner.

25. Pick one more point in the upper left corner.

26. In the Lower Right combo box, choose Tile.

27. In the Upper Left combo box, choose Tile.

28. Click Apply. 

The brick texture now appears to be continuous.

29. Click Close.

30. Click the Deselect All button on the toolbar.
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Repeat this procedure for all the walls.

All the walls have a brick texture applied to them that you will 
need to align as well.

1. To align the brick textures, repeat steps 18 through 29 in 
the above task, “Associate a texture with a material and 
then align it.”

Note You need to turn off Pick Points in the Texture Alignment dialog box 
to select other surfaces.

2. When you are finished aligning textures, close the Texture 
Alignment dialog box.

3. Turn on all of the layers.

Save your work up to this point.

You have concluded the Preparation stage and are about to 
enter the Solution stage. The model you are currently working 
on is going to be changed during the Initiation process. It is a 
good idea to save your work at this time.

1. Choose File > Save As.

2. Change directory to:

c:\Program Files\lvs\projects\tutorial4

3. Type temp.lp  in the File Name input field.

4. Click OK.

If you are running Windows NT 4.0 or Windows 95, you 
may click Save instead of OK.
4-28 Tutorial 4, Importing, Setting Up, and Rendering



Creating a Solution In this exercise, you will learn about the following:

■ “Understanding the Global Process Parameters”
■ “Rules of Thumb”
■ “Testing Primary Lights”
■ “Testing Overall Light Levels”

You will perform the following tasks:

■ “Refining Global Meshing Parameters”
■ “Setting Process Parameters”
■ “Processing the Solution”

Understanding the Global Process 
Parameters
The adaptive meshing process is controlled by the following 
parameters:

■ “Receiver Group”
■ “Source Group”

You can set these parameters by choosing Process>Parameters.

Receiver Group
The parameters in the Receiver Group area determine how 
surfaces are subdivided when they receive light, based on the 
following settings:

■ Mesh Spacing Maximum - Sets the initial (coarse) size of 
the receiver mesh. A value of 36 inches creates an initial 
mesh where the longest side of each mesh element is less 
than or equal to 36 inches.
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■ Mesh Spacing Minimum - Sets the smallest size into which 
the mesh can be subdivided. A value of 4 inches means that 
the longest side of the smallest mesh element is greater 
than or equal to 4 inches.

■ Subdivision Contrast Threshold - Sets the contrast level 
where subdivision occurs. The greater this value, the less 
likely that subdivision will take place. Subdivision continues 
until the contrast is no longer great enough, or the Mesh 
Spacing Minimum value is reached. 

Source Group
Just as surfaces are subdivided (sampled) when they receive 
light, they are also sampled when they reflect or emit light. 
When a surface is a light source, it is subdivided based on the 
Direct Source controls. When a surface is reflecting light it is 
subdivided based on Indirect Source controls. 

■ Source Subdivision Accuracy Parameters - Controls how 
many emitter points are used when shooting light energy 
from a source.

■ Direct Source Minimum Value - Sets the minimum size that 
an area or linear source can be subdivided. 

■ Indirect Source Minimum - Sets the minimum size that a 
reflecting surface can be subdivided.

Rules of Thumb
Generally, when starting to run a radiosity solution, you will 
want to run several tests to find what the optimum meshing 
parameters should be. To test the radiosity mesh, you should 
start with fairly coarse settings (which  gives quick results but 
often produces a large number of mesh artifacts), then refine 
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the solution by selecting less coarse global parameters and 
setting the local mesh parameters for selected individual 
surfaces.

Finding the right mesh parameters for a particular model may 
require several tests, a little practice and a degree of patience.  
You should set these initial test parameters using one or all of 
the guidelines that are outlined in the next sections.

Receiver Group Guidelines
To determine the Mesh Spacing Maximum and Minimum:

Model size ratio 1-10-100 - Estimate or determine the average 
of the length, width, and height of the model. For example, a 
room 30 feet long x 15 feet wide x 10 feet high would have an 
average of  [30 + 15 + 10]/3 = 18 1/3 feet. 

■ The Mesh Spacing Maximum should be 1/10 of this value (1.8 
feet in the example above).

■ The Mesh Spacing Minimum should be 1/100 of this value (.18 
feet in the example above).

■ The Subdivision Contrast Threshold should be set to 0.8.

Source Group Guidelines
To determine Source Group parameters:

■ Direct Source Min - Set to the Receiver Mesh Spacing 
Minimum value.

■ Direct and Indirect Source Subdivision Accuracy - Set to 0.4.

■ Indirect Min - Use the same values that you set for the 
Receiver Mesh Spacing Minimum.

■ Shadow Grid Size - Set to Two.
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Testing Primary Lights
To test the primary lights:

■ Once the values have been set based on these rules, run the 
solution.

■ Stop the processing after all of the primary lights have shot.

Examine the model to see if the lights are positioned and 
pointed as desired, and check that their photometric 
properties are more or less correct. They can be changed at 
this point.

■ Display the model in Outline mode and note the mesh 
spacing.

In general, you are unlikely to adjust the mesh parameters 
during these early tests, but if the mesh spacing is so coarse 
that lighting effects are not appearing at all, you should 
decrease the Mesh Spacing values.

Testing Overall Light Levels
To test the overall light level:

■ Continue to run the solution allowing the secondary light 
sources to shoot.

The percentage of energy distributed is displayed in the 
status bar. If this is less than 65-75%, you should continue 
to run the solution and stop it only when that threshold has 
been reached. 
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■ Turn on Ambient (to distribute the remaining light energy 
evenly over all surfaces) and examine the model to see 
whether the overall light level is acceptable.

If the light level is not acceptable, adjust the luminaire and 
material properties.

■ After making the appropriate changes, reset and rerun the 
solution.

You may find that you will need to repeat this process 
several times.

Refining Global Meshing Parameters
Now that the general lighting and material characteristics are 
set as desired, it is time to try to refine the solution to remove 
general mesh artifacts. A general mesh artifact is one which is 
endemic to the model as a whole; for example, where the 
shadow boundaries from many lights in the environment appear 
to be “jagged”. You can remove these general artifacts by 
gradually changing the global process parameters.

Set the pre-mesh value.

Lightscape uses this value to determine if surfaces should be 
subdivided into smaller, more regular polygons before the 
actual radiosity calculations. Generally this can be set to ½ the 
mesh space maximum number.

1. Choose Process > Parameters.

The Process Parameters dialog box displays.

2. In the Tolerances group box, set Initialization Min Area to 1.3 .

3. Click OK.
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Save your work up to this point.

1. Choose File > Save As.

2. If necessary, change directory to:

c:\Program Files\lvs\projects\tutorial4

3. Type temp.lp in the File Name input field.

4. Click OK.

If you are running Windows NT 4.0 or Windows 95, you 
may click Save instead of OK.

5. If necessary, click Yes to confirm the overwrite.

Begin the Solution stage by initiating the geometric 
data.

1. Choose Display > Solid or click the Solid button on the toolbar.

2. Choose Process > Initiate or click the Initiate button on the 
toolbar.

3. Choose Display > Wireframe or click the Wireframe button on 
the toolbar. 

Note the effects of pre-meshing on the surfaces of the 
model.
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Setting Process Parameters
Set up the receiver meshing controls in the process 
parameters.

When this model was imported its size was indicated as 
26 x 29 x 25 feet. This gives an average length of a side of 
26 2/3 feet. This would indicate a mesh maximum space of 
2.6 feet and a minimum of 0.26 feet

1. Choose Process > Parameters.

The Process Parameters dialog box displays.

2. In the Receiver group box, set Mesh Spacing Min. to 0.26 .

3. In the Receiver group box, set Mesh Spacing Max. to 2.6 .

In the Receiver group box, set Subdivision Contrast Threshold to 
0.8 .

Set up the source meshing controls in the global 
process parameters.

1. In the Source group box, set Direct Source Min. to 0.26 .

2. In the Source group box, set Indirect Source Min. to 0.26 .

Set up the Source Subdivision Accuracy in the global 
process parameters.

1. In the Source group box, set Direct Source Subdivision Accuracy to 
0.4 .

2. In the Source group box, set Indirect Source Subdivision Accuracy 
to 0.4 .

3. In the Source group box, set Shadow Grid Size to Two.
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Set up Lightscape to use textures to filter the color of 
reflected light.

1. In the Process group box, click in the Textures check box to 
turn on this feature.

2. Click OK.

Save your work up to this point.

1. Choose File > Save As.

2. If necessary, change directory to:

c:\Program Files\lvs\projects\tutorial4

3. Type temp.ls in the File Name input field.

4. Click OK.

If you are running Windows NT 4.0 or Windows 95, you 
may click Save instead of OK.

5. If necessary, click Yes to confirm the overwrite.
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Processing the Solution
Start processing the solution and stop to test the 
primary lights.

1. Choose Display > Solid or click the Solid button on the toolbar.

2. Choose Process > Direct Only.

Let the solution run 14 iterations as there are 14 lights in 
the model. It will stop after it has distributed the direct 
sources.

3. View the model to ensure that the lights are pointing 
predictable places and that the mesh is acceptable.

Continue processing the solution and stop to test the 
overall light level.

1. Choose Process > Go or click the Go button on the toolbar.

Let the solution run roughly 35 further iterations or until at 
least 65% of the energy has been distributed.

2. Choose Display > Ambient to distribute the remaining energy. 

3. View the model to ensure that the general light level and  
the mesh are acceptable.

4. Continue processing if desired.
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Fine Tuning the Solution Sometimes, the lighting and material characteristics that you 
have selected for the model will produce exactly the desired 
effect when a solution is created. You can interrupt the 
processing of the radiosity solution at any time to alter or fine 
tune the model’s appearance. You will not fine tune this model.

Outputting the Results In this exercise, you will learn about the following:

■ “Understanding Lightscape Animation”

You will perform the following tasks:

■ “Creating an Animation”
■ “Creating Animation Images”
■ “Saving and Exiting”

Understanding Lightscape Animation
Lightscape provides a robust set of tools for defining and 
generating walk-through animations. Depending on the 
complexity of the model and the display hardware you use, it 
may be possible to show a real-time animation. In other 
situations, it may be more appropriate to save individual frames 
and display them using a movie-playing utility.

Generating a walk-through animation in Lightscape involves the 
following steps:

■ Defining a 3-D camera path by setting a sequence of 
keyframes.

■ Defining the speed of the camera as it travels along this 
path.
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■ Previewing the animation and adjusting the path and speed 
if necessary.

■ Generating the individual frames and storing them on disk.

■ Transferring the frames to a movie file format on disk or 
exporting the images to video or film.

It is easier and quicker to use Wireframe display mode rather 
than Solid display mode when setting up the animation. Also, 
because the Preparation file (.lp  extension) is more compact, 
it is faster to create the animation using the Preparation model. 

Animation Path
When creating the animation path, the Graphic Window is split 
into the following:

■ Four windows
■ Three orthographic views
■ One perspective view that defaults to a view called the 

Director’s view:
You can toggle between the Director’s view that shows the 
current model view and a Keyframe view that shows a view of 
the model as seen from the currently selected keyframe (see 
Figure 4-6).
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Figure 4-6. Creating an Animation Path

You create a camera path by:

■ Adding keyframe points to a path by choosing the Add After 
or the Add Before mode on the Path tab in the Animation dialog 
and picking a point in any of the orthogonal view windows. 

■ Using the Edit option to move the keyframes and adjust the 
camera path. To select a keyframe, click on it in the 
Graphic Window and drag it to the desired position.

Lightscape - tutorial4.ls
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■ Changing the shape of the camera path curve by adjusting 
the handles of a keyframe. The handles are dumbbell-
shaped objects that are displayed tangent to the camera path 
at the keyframe location. To move a handle, select a single 
keyframe in Edit mode and then drag the handle.

Animation Motion
When setting the speed that the camera moves along the path, 
the display shows three views (see Figure 4-7):

■ The lower Distance Graph view displays a graph of camera 
speed that you can edit. The vertical axis of the graph 
represents the distance along the camera path, and the 
horizontal axis represents time. 

■ The top left camera view shows the camera’s view at the 
current time in the animation, indicated by a vertical green 
line on the camera speed graph. You can change the current 
time by clicking in the time legend of the graph.

■ The top right view shows the Director’s view of the model.

■ By setting the Grid mode to on, you can display a light blue 
grid on the graph where the horizontal grid lines represent 
the location of keyframes.
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Figure 4-7. Creating Animation Motion

You define the camera speed by adding control points on the 
camera speed curve. You can do this by selecting Insert and 
clicking locations in the Distance Graph view (see Figure 4-7).

■ You use the Edit option to move the control points and 
adjust the motion path. 

■ You can change the shape of the motion path curve by 
adjusting the handles of a keyframe. Changing the 
curvature changes the acceleration, where the slope is 

Lightscape - tutorial4.ls
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steep, the camera moves quickly and where flat, the camera 
moves slowly. If the curve dips from left to right, the 
camera motion moves backward.

Creating an Animation
You will create an animation which starts near the piano in the 
bottom left of the model and moves around the edge of the 
room to the top right. Then, you will set the speed such that 
the animation slows down during the middle portion of the 
animation. 

Create animation path.

1. Choose Display > Wireframe or click the Wireframe button on 
the toolbar.

2. Choose Animation > New.

3. Choose Animation > Edit.

The Animation dialog box displays.

4. Click the Path tab in the Animation dialog box.

5. Select Add After in the Mode combo box.

6. Choose Edit > Selection > Select or click the Select button on 
the toolbar.

7. In the top view sub-window in the Graphic Window, click a 
point in the lower left corner to add a Keyframe to the 
animation path.

8. Enter 5 in the Z input field and click Apply. 

This sets the height of this and all subsequent points to 
5 feet above the floor.
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9. In the top view sub-window, click a point near the lower 
right corner to add a Keyframe to the animation path.

10. In the top view sub-window, click a point in the upper right 
corner to add a Keyframe to the animation path.

11. Select Edit in the Mode combo box.

12. Click on the middle keyframe in the top view sub-window. 

13. Drag the handles associated to the keyframe to a 45 degree 
position to begin to form a “C” curve.

14. Click on the first keyframe in the top view sub-window. 

15. Drag the handles associated to the keyframe to a horizontal 
position to continue to form a “C” curve.

16. Click on the last keyframe in the top view sub-window. 

17. Drag the handles associated to the keyframe downward to 
finish forming a “C” curve.

Identify the Lookat path.

Not only do you need to specify where the camera is at any 
time during its motion but also the direction that the camera is 
looking. In this case, you will set the camera to look at the same 
point (on one of the chairs) through the length of this 
animation.

1. Choose All in the Select area.

This selects all three keyframe points.

2. Select At Point in the Look combo box. 

Three green Look At icons are added to each keyframe. By 
default, these look to the origin of the model, so you will 
need to move them. 
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3. Turn on the Pick check box adjacent to the combo box.

4. Select a point on the arm of one of the chairs.

The green look at lines now point to the selected location.

5. Turn off the Pick check box to end the pick sub mode. 

Create a motion path.

1. Click the Motion tab in the Animation dialog box.

2. Select On in the Grid combo box.

3. Select View > Interactive > Zoom and zoom the Camera Speed 
graph to show all keyframe points. 

The three keyframes are represented by three horizontal 
blue lines on the graph. One of these blue lines usually 
overlaps the 0 distance axis along the bottom of the graph.

4. Select Insert on the Mode combo box.

5. Choose Edit > Selection > Select or click the Select button on 
the toolbar.

6. In the Camera Speed graph, click in the middle of the line to 
add a Control Point.

7. Select Edit in the Mode combo box.

8. Click on the middle Control Point and drag the handles, 
associated to the keyframe, to a horizontal position to form 
an “S” curve.

The animation starts, comes to a stop in the middle of the 
room (horizontal position), and then restarts moving the 
rest of the way across the room.
Outputting the Results 4-45



Preview your animation.

1. Click the Preview tab in the Animation dialog box.

2. Click the Rewind button to rewind to the beginning of the 
animation.

3. Enter -1  in the End Time input field. 

This sets the end time to the last frame of the animation.

4. Click the Play button to preview the animation. 

You may also wish to view the animation in solid mode.

5. Click Close to end the animation editing session.

Save your animation.

1. Choose Animation > Save As.

2. Change directory to:

c:\Program Files\lvs\projects\tutorial4

3. Type tutorial4.la  in the File Name input field.

4. Click OK to save the file.

Creating Animation Images
You will save animation images of the model using OpenGL. 
OpenGL represents a set of operations performed in hardware 
to display a rendered image. It is not as accurate or as full-
featured as the Lightscape ray tracer but it makes the image’s 
appearance more consistent with a non-ray traced image.
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Save animation images of the model using OpenGL.

1. Click the Solid button on the toolbar.

2. Choose Display > Textures or click the Textures button on the 
toolbar.

3. Choose File > Render.

The Rendering dialog box displays.

4. Make sure that Windows Bitmap (BMP)  is selected in the 
Format Type combo box.

5. Type rad  in the Name input field in the Output File group box.

 The animation files are saved with the names 
rad0001.bmp , rad0002.bmp , etc.

6. In the Resolution combo box, choose Test (300 x 300).

7. Make sure that Ray Tracing is not selected.

8. In the Frame Generation area, choose Animation File in the Source 
combo box.

9. Enter 0 in the From input field to set the first frame to be 
rendered.

10. Enter 14 in the To input field to set the last frame to be 
rendered.

11. Click OK.

15 images (½ second of animation) now process and the 
files are saved to the current working directory.
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Save animation images of the model using the ray 
tracer.

In this procedure, you render the same view but turn on ray 
tracing to add the specular floor component and the procedural 
textures.

1. Choose File > Render.

The Rendering dialog box displays.

2. Make sure that Windows Bitmap (BMP)  is selected in the 
Format Type combo box.

3. Type ray  in the Name input field in the Output File group box.

4. In the Resolution combo box, choose Test (300 x 300) .

5. Choose Animation File from the Source combo box in the Frame 
Generation dialog area.

6. Enter 15 in the From input field to set the first frame to be 
rendered.

7. Enter 29 in the To input field to set the last frame to be 
rendered.

8. Click the Ray Tracing check box to turn on ray tracing.

9. Enter 1 in the Ray Bounces field.

10. Click OK.

Lightscape is now ray tracing the model. Soon you will see 
the specular reflections and procedural textures that were 
not visible in the diffuse radiosity model or in the OpenGL 
rendered image.
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Saving and Exiting
Congratulations! You have completed Tutorial 4.

1. Choose File > Save As to save this file.

The Save As dialog box displays.

2. In the File Name input field, type a name for the new file and 
click OK.

3. Choose File > Exit and confirm.
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Going Further You have reached the end of Tutorial 4. At this point you should 
be able to:

■ Load DXF files using libraries
■ Append DXF Files
■ Orient and smooth surfaces
■ Display and align textures
■ Set global processing parameters by hand
■ Create an animation
■ Create animation images

To learn more about the Lightscape Visualization System, do 
the following:

Open the sample solution files.

The Lightscape Installation media contains a number of sample 
solution files which you can use for experimenting. To install 
these files:

1. Perform a Custom installation.

2. Select only the Sample Files from the list items to install.

3. Open one of these sample files in Lightscape.

4. Observe the way the mesh was created, the way materials 
were defined, the way luminaires were defined, and so on.

This gives you a feel for the performance of larger models.

5. Try resetting the solution and experimenting with different 
process parameters.

Do the remaining tutorials for more examples of 
working with Lightscape.
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 Tutorial 5 Advanced 
Lightscape Topics
In this tutorial, you will join the 

model files, which you created in 

the preceding tutorials, to create a 

single solution file. You will also 

optimize one of the models by 

converting selected radiosity mesh 

elements into texture maps and 

exporting the data to VRML format. 
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The goal of this tutorial is to render the model used to create 
the image in Figure 5-1.

Figure 5-1. Sample of Rendered Image from Tutorial 5
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How Tutorial 5
is Organized

This tutorial contains the following sections and lessons:

■ “Getting Data” on page 4
“Starting Lightscape”
“Opening a File”
“Appending Files”

■ “Preparing Data” on page 9
“Opening a File”
“Converting Surfaces to Texture Maps”

■ “Outputting the Results” on page 30
“Opening a File”
“Using Command Line Batch Utilities”
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Getting Data In this exercise, you will perform the following tasks:

■ “Starting Lightscape”
■ “Opening a File”
■ “Appending Files”

Starting Lightscape
Start Lightscape.

1. In the Lightscape Applications window group, double-click 
the Lightscape icon.

If you are running Windows NT 4.0 or Windows 95, you 
can also start Lightscape by choosing it from the Start 
menu.

The Lightscape graphical user interface displays on the 
screen.

Turn on all toolbars.

This tutorial makes extensive use of the toolbars to execute 
commands easier.

1. Choose Tools > Toolbars.

The Toolbars dialog box displays.

2. Double-click any list item that is not checked.

3. Click Close when you are done.
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Opening a File
Load a Solution file.

You will perform this tutorial with a file that has already been 
created in Lightscape.

1. Choose File > Open.

The Open dialog box displays. List Files of Type should be set to 
Preparation Files (*.ls).

2. Change directory to:

c:\Program Files\lvs\projects\tutorial5

3. Double-click the file tutorial1.ls .

This is a similar solution file to the one you created during 
Tutorial 1.

4. Choose Display>Solid or click the Solid button on the toolbar.

The model now displays in Solid mode.

5. Choose File > Save As, type tutorial5  in the input field, 
and click OK to save the file.

Appending Files
Append the file tutorial2.ls.

The second file you will add to the model is a file similar to the 
one you created in Tutorial 2.

1. Choose File > Open.

The Open dialog box displays.

2. Change directory to:

c:\Program Files\lvs\projects\tutorial5
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3. In the lower left corner of the dialog, click Append to turn 
on this option. 

This sets the loading options so the new geometry is added 
to the existing geometry in the model.

4. Double-click the file tutorial2.ls .

5. Choose View > Extents or click the Extents button. 

The two models now both display on the screen.

Append the file tutorial4.ls.

The third file you will add to the model is a file similar to the 
one you created in Tutorial 4.

1. Choose File > Open.

The Open dialog box displays.

2. Change directory to:

c:\Program Files\lvs\projects\tutorial5

3. Choose the file tutorial4.ls .

4. Below to the Name area, click Append to turn on this option. 

This sets the loading options so the new geometry is added 
to the existing geometry in the model.

5. Click OK and click Yes to confirm saving the file 
tutorial5.ls .

The third room now displays between the first two rooms.

6. Adjust your view so that you are inside of the building.
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Append the file tutorial3.ls.

The last file you will add to the model is the exterior view of 
the model.

1. Choose File > Open.

The Open dialog box displays.

2. Change directory to:

c:\Program Files\lvs\projects\tutorial5

3. Below to the Name area, click Append to turn on this option. 

This sets the loading options so the new geometry is added 
to the existing geometry in the model.

4. Choose the file tutorial3.ls .

5. Click OK and click Yes to confirm saving the file, 
tutorial5.ls .

6. Choose View > Extents or click the Extents button. 

The exterior model now displays on the screen. It appears 
extremely bright, because the display settings are currently 
optimized for an interior model.

7. Choose Edit > Properties and click the Display tab.

8. Change the Brightness to 15 and click Apply. 

This displays the exterior more appropriately. The interior 
portions of the model are displayed darker than usual. 
Setting the Brightness back to 55 corrects this.
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Save your work up to this point.

1. Choose File > Save As.

2. Change directory to:

c:\Program Files\lvs\projects\tutorial5

3. Type tutorial5.ls  in the File Name input field.

4. Click OK and confirm the overwrite.

On Windows NT 4.0 or Windows 95, click Save and 
confirm the overwrite.

5. Close the Document Properties dialog.
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Preparing Data In this exercise, you will perform the following tasks:

■ “Opening a File”
■ “Converting Surfaces to Texture Maps”

Opening a File
Load a Solution file.

You will perform this tutorial with a file that has already been 
created in Lightscape.

1. Choose File > Open.

The Open dialog box displays. List Files of Type should be set to 
Preparation Files (*.ls).

2. Change directory to:

c:\Program Files\lvs\projects\tutorial5

3. Double-click the file tutorial1.ls  and click Yes to 
confirm saving the file tutorial5.ls .

Converting Surfaces to Texture Maps
In order to optimize the display of Lightscape models, it is 
important to keep the number of polygons in a given model to 
as few as possible. For example, if your CPU can display 
100,000 rendered polygons a second, and you wish to show a 
smooth animation (at 15 frames per second, for example), the 
model should contain no more than 6666 polygons 
(100,000 / 15).
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By carefully setting global and local process parameters, you 
can achieve this in some models. A second method, converting 
polygonal meshes to texture maps, is also available in 
Lightscape.

In this procedure, an image is created of a surface that contains 
many mesh elements and saved to a file. The image is then 
applied as a texture map to the surface and the underlying mesh 
is removed from the model.

These texture maps can also be exported to display radiosity 
lighting data in modeling programs and rendering engines that 
cannot display vertex-colored mesh data.

There are three methods available for converting selected 
geometry to textures:

■ Creating a separate texture for each selected surface 
(Texture per Surface).

■ Taking existing texture maps and remaking them with the 
radiosity lighting data included as part of the texture 
(Relight Textures).

■ Creating a single texture from a group of selected surfaces 
(Project all Textures).

With the last option you may wish to delete some of the 
geometry from the model. For example, a wall surface may 
have several pictures hanging on it and windows through it. In 
this case, a single surface (the wall) may be all the geometry you 
wish to display - with the pictures and windows appearing as 
decals on the wall surface. 
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When you use the mesh to texture utility you create two 
selection sets:

■ The first selection set is generally empty. It contains 
geometry that you will be projecting onto another surface 
and that you wish to delete from the model once it has been 
projected.

■ The second selection set contains the geometry where you 
will be placing the textures. It generally contains all the 
geometry you wish to map into the texture, less the 
geometry in the first selection set, if any. 

Note the number of polygonal mesh elements in the 
model.

1. Choose Display > Outlined or click the Outlined button on the 
toolbar.

The mesh on each of the surfaces displays. Notice how 
simple surfaces, such as the wall in the alcove, have been 
subdivided to capture the lighting in the model.

2. Choose Process > Statistics. 

Notice the number of mesh elements in the model.Write 
down this number for future reference.

3. Choose Display > Textures or click the Textures button on the 
toolbar.

Create a single texture map to replace the floor.

1. Choose Display > Solid or click the Solid button on the toolbar.

2. Choose Tools > Mesh to Texture. 

The Mesh To Texture wizard displays.
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3. Select the Convert each surface to a single texture per surface radio 
button. 

This makes a single texture for each individual surface that 
is selected.

4. Click Next to advance to the Select Projected Geometry page of 
the wizard. 

This is the page where you select the geometry for the first 
selection set. This is the geometry that you intend to delete 
from the model. In this case, leave the selection blank.

5. If necessary, choose Edit > Selection > Deselect All or click the 
Deselect All button on the toolbar to ensure that the selection 
set is empty.

If the selection set is empty, then both the menu item and 
the toolbar button are grayed out.

6. Click Next to advance to the Select Target Geometry page of the 
wizard. 

This is the page where you select the geometry for the 
second selection set. This is the geometry that you intend 
to apply the texture to and keep in the model.

7. Choose Edit > Selection > Select or click the Select button on 
the toolbar.

8. Choose Edit > Selection > Surface or click the Surface button on 
the toolbar.

9. Pick a point on the floor to select this surface and click Next 
to advance to the Use Existing Texture Filenames page of the 
dialog.
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10. Ensure that the Use Existing Texture Filenames button is turned 
off and click Next to advance to the Texture Output page of the 
wizard. 

Use existing file names when the floor already has a texture 
map applied to it.

11. Choose JPEG (JPG) from the Format combo box.

12. Type floor  in the New Texture Base Name input field. 

This creates a texture called floor000.jpg  when you 
create the texture.

13. Ensure that the Manual Size radio button is selected and type 
256  in the Width input field and 128  in the Height input field.

The floor is about twice as wide as it is long. 

14. Click Next to advance to the Rendering Options page of the 
wizard.

15. Type 0 in the Ray Bounces input field. 

Although it is possible to create texture maps that have 
specular lighting, generally these will look odd from most 
views as the reflections will be calculated from only a single 
point of view.

16. Click Next to advance to the Replace/Delete page of the wizard.

17. Select the Replace Textures on target geometry option. 

This places the texture map on the floor surface.

18. Select the Reset Mesh on Target geometry option.

This removes the radiosity mesh from the floor.
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19. Click Finish to create the texture map.

A new material with the name M2T FLOOR-> floor000.  
is created and added to the material list. The floor surface is 
now replaced with a texture map.

View the texture and note the change number of 
polygonal mesh elements in the model.

1. Double-click M2T FLOOR-> floor000.  in the Materials 
Table.

The Material properties for M2T FLOOR-> floor000. dialog box 
displays. 

2. Click the Texture tab.

Observe the display of the texture file.

3. Choose Display > Outlined or click the Outlined button on the 
toolbar. 

The mesh on the each of the surfaces now displays. Notice 
how the floor surface is no longer meshed.

4. Choose Process > Statistics. 

Notice the number of mesh elements, as compared to the 
number you wrote down earlier. It should be much less.

Create a single texture map for each surface in a group 
of surfaces.

1. Choose Display > Solid or click the Solid button on the toolbar.

2. Turn off all layers except ROOM2_WALLS.

3. Choose View > Original to return to the original view of the 
model.
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4. Choose Tools > Mesh to Texture. 

The mesh to texture wizard displays.

5. Select the Convert each surface to a single texture per surface radio 
button. 

This makes a single texture for each individual surface that 
is selected.

6. Click Next to advance to the Select Projected Geometry page of 
the wizard. 

This is the page where you select the geometry for the first 
selection set. This is the geometry you intend to delete 
from the model. In this case, leave the selection blank.

7. Choose Edit > Selection > Deselect All or click the Deselect All 
button on the toolbar to ensure the selection set is empty.

8. Click Next to advance to the Select Target Geometry page of the 
wizard. 

This is the page where you select the geometry for the 
second selection set. This is the geometry you intend to 
apply the texture to and keep in the model.

9. Choose Edit > Selection > Select Area Any or click the Area Any 
Vertex button on the toolbar.

10. Select all the surfaces that make up the end wall facing 
towards you in the model.

You can do this by dragging a window across the upper part 
of the alcove (see Figure 5-2).
Preparing Data 5-15



Figure 5-2. Selecting the End Wall Surfaces

11. Click Next to advance to the Use Existing Texture Filenames page 
of the wizard.

12. Ensure the Use existing texture filenames button is turned off 
and click Next to advance to the Texture Output page of the 
wizard. 

13. Choose JPEG (JPG) from the Format combo box.

14. Type east  in the New Texture Base Name input field.

This creates several textures called east000.jpg , 
east001.jpg , and so on, when you create the textures.

15. Ensure the Manual Size radio button is selected and type 128  
in the Width input fields and 128  in the Height input field. 

This creates square texture maps.
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16. Click Next to advance to the Rendering Options page of the 
wizard.

17. Type 0 in the Ray Bounces field. 

Although it is possible to create texture maps that have 
specular lighting, generally these will look odd from most 
views as the reflections will be calculated from a single 
point of view.

18. Click Next to advance to the Replace/Delete page of the wizard.

19. Select the Replace Textures on target geometry option. 

This places the texture map on the wall surface.

20. Select the Reset Mesh on Target geometry option. 

This removes the radiosity mesh from the walls.

21. Click Finish to create the texture map. 

Seven new materials with the names M2T WALLS-> 

east000. , M2T WALLS-> east001. , and so on, are 
created and added to the material list. The wall surfaces are 
now replaced with texture maps.

View the textures and note the change in the number 
of polygonal mesh elements in the model.

1. Double-click M2T WALLS-> east001.  in the Materials 
Table.

The Material properties for M2T WALLS-> east001. dialog box 
displays.

Note The numbers at the end of the material names (000, 001, etc.) 
are determined by the order in which you select the surfaces.
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2. Click the Texture tab. 

Observe the display of the texture file.

3. Turn on all of the layers.

4. Choose Display > Outlined or click the Outlined button on the 
toolbar. 

The mesh on the each of the surfaces now displays. Notice 
how the wall surface is no longer meshed.

5. Choose Process > Statistics. 

Notice that the number of mesh elements in the model has 
decreased again.

Map many surfaces into a single texture map and apply 
the single texture back onto the surfaces. Delete some 
of the geometry.

1. Choose Display > Solid or click the Solid button on the toolbar.

2. Turn off all layers except ROOM2_WALLS and 

ROOM2_PICTURES.

3. Orbit the view so that you can see all of the surface making 
up the south wall of the room (right hand side of the 
screen).

4. Choose Tools > Mesh to Texture. 

The Mesh to Texture wizard displays.

5. Select the Project all selected geometry into one texture radio 
button. 

This makes a single texture from all the surfaces you select.
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6. Click Next to advance to the Select Projected Geometry page of 
the wizard. 

This is the page where you select the geometry for the first 
selection set. This is the geometry you intend to delete 
from the model. In this case, you will select the pictures 
and picture frames. These surfaces will be deleted from the 
model and an image of them pasted onto the wall surface.

7. Click the Deselect All button then select the surfaces of the 
pictures and the picture frames (see Figure 5-3).

Figure 5-3. Selecting Surfaces of Pictures and Picture Frames

8. Click Next to advance to the Select Target Geometry page of the 
wizard. 

This is the page where you select the geometry for the 
second selection set. This is the geometry you intend to 
apply the texture to and keep in the model.

9. Choose Edit>Selection>Deselect All or click the Deselect All 
button on the toolbar to ensure that the selection set is 
empty.
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10. Select the wall surface behind the pictures.

11. Click Next to advance to the Select Projection Method page of the 
wizard.

12. Choose Orthographic in the Projection combo box and choose 
Snap to Nearest Vertex to turn on this feature.

13. Ensure the Lower Left Radio button is selected and pick a point 
in the vicinity of the lower left corner of the wall.

You do not have to be precise; Lightscape looks for the 
nearest vertex (if Snap To Nearest Vertex is selected).

14. Pick another point in the lower right corner of the wall.

15. Pick a third point in the upper left corner of the wall.

16. Click Next to advance to the Texture Output Information page of 
the wizard. 

17. Type south  in the New Texture Base Name input field. 

This creates a texture called south000.jpg when you 
create the textures.

18. Ensure the Manual Size radio button is selected and type 512  
in the Width input fields and 256  in the Height input field. 

19. Click Next to advance to the Rendering Options page of the 
wizard.

20. Type 0 in the Ray Bounces field. 

21. Click Next to advance to the Replace/Delete page of the wizard.

22. Select the Replace Textures on the Target Geometry option. 

This places the texture map on the wall surface.

23. Select the Reset Mesh on Target Geometry option. 

This removes the radiosity mesh from the walls.
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24. Select the Delete the Projected Geometry From the Model option. 

This removes the pictures and their frames from the model 
once the texture has been created.

25. Click Finish to create the texture map. 

A new material with the name M2T WALLS-> south000.  
is created and added to the material list. The texture map 
replaced the pictures and was applied to the wall surface.

View the textures and note the change number of 
polygonal mesh elements in the model.

1. Double-click M2T WALLS-> south000.  in the Materials 
Table.

The Material Properties for M2T WALLS-> south000. dialog box 
displays. 

2. Click the Texture tab and observe the display of the texture 
file.

3. Choose Display > Outlined. 

The mesh on the each of the surfaces now displays. Note 
how the wall is no longer meshed and the geometry of the 
picture frames is gone.

4. Choose Process > Statistics. 

Notice the number of mesh elements in the model. Again, 
there should be a significant reduction.
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Map many surfaces into a single texture map and apply 
the single texture back onto the surfaces.

1. Choose Display > Solid. 

2. Turn off all layers except ROOM2_WALLS and 
ROOM2_PICTURES.

3. Orbit the view so that you can see all of the surface making 
up the north wall of the room.

4. Choose View>Extents.

5. Choose Tools > Mesh to Texture. 

The mesh to texture wizard displays.

6. Select the Project all selected geometry into one texture radio 
button. 

This makes a single texture from all the surfaces that you 
select.

7. Click Next to advance to the Select Projected Geometry page of 
the wizard. 

This is the page where you select the geometry for the first 
selection set. This is the geometry you intend to delete 
from the model. In this case, leave the selection blank.

8. Choose Edit > Selection > Deselect All or click the Deselect All 
button on the toolbar to ensure that the selection set is 
empty.

9. Click Next to advance to the Select Target Geometry page of the 
wizard.

This is the page where you select the geometry for the 
second selection set. This is the geometry you intend to 
apply the texture to and keep in model.
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10. Choose Edit > Selection > Select or click the Select button on 
the toolbar.

11. Select both the wall surface and the surfaces of the pictures 
(including the frames).

12. Click Next to advance to the Select Projection Method page of the 
dialog.

13. Choose Orthographic in the Projection combo box and choose 
Snap to Nearest Vertex to turn on this feature.

14. Ensure the Lower Left radio button is selected and pick a 
point in the vicinity of the lower left corner of the wall.

You do not have to be precise; Lightscape looks for the 
nearest vertex (if Snap To Nearest Vertex is selected).

15. Pick another point in the lower right corner of the wall.

16. Pick a third point in the upper left corner of the wall

17. Click Next to advance to the Texture Output Information page of 
the wizard.

18. Choose JPEG (JPG) from the Format combo box.

19. Type north  in the New Texture Base Name input field. 

This creates a texture called north000.jpg  when you 
create the textures.

20. Ensure the Manual Size radio button is selected and type 512  
in the Width input fields and 256  in the Height input field. 

21. Click Next to advance to the Rendering Options page of the 
wizard.

22. Type 0 in the Ray Bounces field. 

23. Click Next to advance to the Replace/Delete page of the wizard.
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24. Select the Replace Textures on target geometry option. 

This places the texture map on the wall surface.

25. Select the Reset Mesh on Target geometry option. 

This removes the radiosity mesh from the walls.

26. Make sure that the Delete the projected geometry from the model 
option is turned off.

27. Click Finish to create the texture map. 

A new material with the name M2T WALLS-> north000.  
is created and added to the material list. The texture map is 
wrapped around the pictures and applied to the wall 
surface.

View the textures and note the change number of 
polygonal mesh elements in the model.

1. Double-click M2T WALLS-> north000.jpg  in the 
Materials Table.

The Material Properties for M2T WALLS-> north000. dialog box 
displays. 

2. Click the Texture tab and observe the display of the texture 
file.

3. Choose Display > Outlined. 

The mesh on the each of the surfaces now displays. Notice 
how the wall and picture surfaces are no longer meshed.

4. Choose Process > Statistics. 

Notice the number of mesh elements in the model. 
Compare this to the original number of mesh elements 
without any texture conversions.
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Save your work up to this point.

1. Choose File > Save As.

The Save As dialog box displays.

2. Change directory to:

c:\Program Files\lvs\projects\tutorial5

3. In the File Name input field, type the following:

M2T.ls

4. Click OK.

Opening a File
Load a Solution file.

You will perform this part of the tutorial with a file which has 
already been created in Lightscape.

1. Choose File > Open.

The Open dialog box displays. Note that List Files of Type 
should be set to Preparation Files (*.ls).

2. Change directory to:

c:\Program Files\lvs\projects\tutorial5

3. Double-click the file tutorial2.ls .
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Make a cylindrical texture map of the entire room.

A cylindrical or spherical image map can be used with a 
number of display engines that wrap a single texture map to 
represent all of the geometry in a space. You can make such a 
map in the following manner.

1. Choose Display > Solid. 

2. Turn on all layers.

3. Choose Tools > Mesh to Texture. 

The mesh to texture wizard displays.

4. Select the Project all selected geometry into one texture radio 
button. 

This makes a single texture from all the surfaces that you 
select.

5. Click Next to advance to the Select Projected Geometry page of 
the wizard. 

This is the page where you select the geometry for the first 
selection set. This is the geometry you intend to delete 
from the model. In this case, leave the selection blank

6. Choose Edit > Selection > Deselect All or click the Deselect All 
button on the toolbar to ensure that the selection set is 
empty.

7. Click Next to advance to the Select Target Geometry page of the 
wizard. 

This is the page where we select the geometry for the 
second selection set - geometry we intend to apply the 
texture to and keep in model. 

8. Choose Edit > Selection > Surfaces or click the Surfaces button 
on the toolbar.
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9. Choose Edit > Selection > Select All or click the Select All button 
on the toolbar. 

This selects all of the surfaces in the model.

10. Click Next to advance to the Select Projection Method page of the 
dialog.

11. Choose Cylindrical in the Projection combo box.

12. Ensure the Lower Center radio button is selected and type the 
following:

-21.5  in the x field

-4  in the y field

0 in the z field 

These are the coordinates for the exact center of the floor.

13. Ensure the Upper Center radio button is selected and type the 
following:

-21.5  in the x field

-4  in the y field

9.5  in the z field 

These are the coordinates for the exact center of the ceiling.

14. Ensure the Seam Direction radio button is selected and type 
the following:

-13.5  in the x field

-4  in the y field

0 in the z field 

These are the coordinates for a point on the wall.
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15. Ensure the Project Inward button is turned off.

This sets the projection so that the surfaces are understood 
to be looking towards the center of the mapping system.

16. Click Next to advance to the Texture Output Information page of 
the dialog box.

17. Type round  in the New Texture Base Name input field. 

This creates a texture called round000.jpg  when you 
create the textures.

18. Ensure the Manual Size radio button is selected and type 512  
in the Width input fields and 128  in the Height input field. 

As the texture wraps around the room it is considerably 
wider than it is high.

19. Click Next to advance to the Rendering Options page of the 
wizard.

20. Type 10 in the Ray Bounces field. 

As this is a cylindrical texture seen from a single point of 
view, you can display specular lighting effects (the 
reflections from the vases).

21. Click Next to advance to the Replace/Delete page of the wizard.

22. Deselect the Replace Textures on target geometry option.

You will not place this texture in the model.

23. Deselect the Delete the projected geometry from the model option.

24. Click Finish to create the texture map. 

A new image with the name round000.jpg  is created. 
You can view this texture using the LVu utility and choosing 
the c:\Program Files\lvs\projects\tutorial5  
directory.
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Exit without saving.

1. Choose File > Exit.

2. Click No and do not save changes.
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Outputting the Results In this exercise, you will perform the following task:

■ Using Command Line Utilities

Using Command Line Batch Utilities
In addition to the main Lightscape GUI program, the 
Lightscape Visualization System supports a number of utilities 
that can be run at the command line or in batch files. Using 
batch files, you can set up a series of procedures and have them 
run sequentially over an extended period of time. The 
command line utilities are generally run from a DOS window 
and take the form: 

COMMAND [options] Lightscape_file

The most common command line utilities are:

■ lsray  - Creates a ray traced image of a Lightscape file.
■ lsrad  - Runs the radiosity process.
■ lsrender  - Creates a non ray-traced image of a Lightscape 

file.
■ ls2vrml  - Creates a VRML file from a Lightscape model.

Create a VRML file from a Lightscape solution file.

VRML is a 3D file format designed to view 3D models over the 
World Wide Web (WWW). There are a number of browsers 
available for viewing files of this type.

1. In the Main window group within the Program Manager, 
double-click the MS-DOS icon.

If you are using Windows 95 or Window NT 4.0, choose 
Start > Programs> MS-DOS Prompt.
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2. Change directory to the following:

C:\Program Files\lvs\projects\tutorial5

The quotation marks are required. If you have installed 
Lightscape in a place other than the default location, you 
will need to alter the path accordingly.

3. Type the following:

..\..\bin\ls2vrml -o tutorial1.wrl 
tutorial1.ls

A file called tutorial1.wrl  will be created in the 
current directory. This is the non-optimized version of the 
model.

4. Type the following:

..\..\bin\ls2vrml -o M2T.wrl M2T.ls

A file called M2T.wrl will be created in the current 
directory. This is the optimized version of the model, using 
texture maps in the place of the radiosity mesh.

5. If you have access to a VRML viewer, open the files. (You 
will need to turn the headlight off in most VRML viewers).

Run a batch file that creates both a radiosity and ray-
traced image of a Lightscape model.

Batch files are special files in DOS that contain a sequence of 
instructions to be performed one after another. The batch file 
next will first call lsrad  - the radiosity process command line 
utility and run several iterations of the radiosity process. It will 
then render and display a view of the model using the radiosity 
data only. Finally, it will do a ray-trace rendering of the model.

1. In the Main window group within the Program Manager, 
double-click the File Manager icon. 
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2. Change directory to:

C:\program files\lvs\projects\tutorial5

If you installed Lightscape in other than the default 
location, you will need to alter the path accordingly.

3. Double-click makeimage.bat .

This executes a batch file called makeimage.bat . It should 
open a DOS window and execute four commands in 
sequence. 

That file contains the following lines:

..\..\lsrad -term 10  -v tutorial1.ls

..\..\lsrender -aa 2 -x 645 -y 486 -v 
tutorial1.ls radiosity.tga

..\..\lsray -aa 2 -x 645 -y 486 -w -v 
tutorial1.ls raytraced.tga

..\..\bin\lvu ..\tutorial5

The first line calls the radiosity program (lsrad ), runs ten 
iterations (-term 10 ) using the file tutorial1.ls .

The second line calls the radiosity renderer (lsrender ), 
sets the antialiasing to 2 (-aa 2 ), creates an image of 
645x486 pixels (-x 645 -y 486 ), uses the same 
tutorial2.ls  file and creates an image called 
radiosity.tga .

The third line calls the ray-trace renderer (lsray ), sets the 
antialiasing to 2 (-aa 2 ), creates an image of 645x486 
pixels (-x 645 -y 486 ), uses the same tutorial1.ls  
file, and creates an image called raytraced.tga . The -w  
option paints the results to the screen.
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The last line opens the LVu utility and automatically loads 
the images created by makeimage.bat .

You may wish to look at the contents of the batch file using 
a simple text editor.

Congratulations! You have reached the end of Tutorial 5. At this 
point you should be able to:

■ Combine models

■ Simplify models using the mesh to texture utility

■ Create and use batch files
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