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Introduction

 

elcome to the Adobe PageMill

 

™

 

 program—page-authoring software for the World 
Wide Web. With Adobe PageMill you can build and preview text, images, anima-
tions, sounds, frames, tables, and links on a Web page. You can drag and drop 

images, objects, and links directly onto a Web page, and apply standard HTML formats and 
styles to text without typing any HTML code.

Before using Adobe PageMill, you should have a working knowledge of your computer and 
its operating conventions. You should know how to use the mouse and standard menus and 
commands. You should also know how to open, save, and close files. If you need to review these 
techniques, see the documentation that comes with your computer.

 

About this guide

 

The 

 

Adobe PageMill User Guide

 

 provides detailed information about Adobe PageMill tools and 
commands. It is designed to be a reference tool in your everyday work with Adobe PageMill. 
This guide also includes a hands-on tutorial to give you familiarity with the features in 
Adobe PageMill.

The 

 

Adobe PageMill User Guide

 

 is organized according to the tasks you most commonly 
perform when creating and managing a Web site:

Chapter 1 is a tutorial that includes step-by-step instructions for creating Web pages. Before 
you begin the tutorial, you might want to read Chapter 2, “Basic Concepts,” to familiarize 
yourself with Adobe PageMill concepts and terminology.

Chapter 2 presents fundamental concepts you’ll use in your work with Adobe PageMill, 
and provides an orientation to the primary parts of the user interface.

Chapter 3 explains how to add text to a Web page. This chapter includes information on 
applying formats and styles, changing font size and color, and finding and replacing text.

Chapter 4 includes information on how to import and work with images, animations, movies, 
and sounds.

Chapter 5 describes how to create links to other pages or Web resources. This chapter explains 
finding and replacing links, creating anchors, and storing frequently used links.

Chapter 6 describes how to use images as image maps. It contains information on both
client-side and server-side image maps.

W
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Chapter 7 describes how to create tables, enter data in tables, format tables, and import tables 
into your Web page. 

Chapter 8 explains how to create a form on a Web page. This chapter includes information 
about form controls and text-entry fields, and Submit and Reset buttons.

Chapter 9 explains how to create and use frames in your Web pages. 

Chapter 10 includes information on uploading your site to a Web server.

Appendix A is a troubleshooting section that helps you solve problems you may encounter 
when working with Adobe PageMill.

Appendix B is a guide to working in HTML from inside PageMill.

 

System requirements (Macintosh)

 

Adobe PageMill (Macintosh) requires the following hardware and software:

 

•

 

An Apple Macintosh

 

®

 

 computer with a 68020 or later processor (68040 recommended) or a 
Power Macintosh

 

®

 

•

 

Apple system software version 7.1 or higher for the Macintosh or System 7.1.2 or higher for 
the Power Macintosh. Dragging and dropping between Adobe PageMill and other applications 
requires System 7 Pro or later. (7.5 or later recommended)

 

•

 

4 megabytes (MB) of RAM available to Adobe PageMill or 5.5 MB available for a Power 
Macintosh (6 MB recommended)

 

•

 

10 MB of available hard disk space

 

•

 

4-bit grayscale monitor or 8-bit color monitor

 

•

 

QuickTime 2.1 and the QuickTime PowerPlug (for Power Macintosh only)

 

System requirements (Windows)

 

•

 

Adobe PageMill (Windows) requires the following hardware and software:

 

•

 

A Windows-compatible computer with a n 80486

 

™

 

, Pentium

 

®

 

, or Pentium Pro

 

®

 

 processor 
(Pentium processor recommended)
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•

 

Microsoft Windows 95, or Windows NT

 

®

 

 4.0 or later software

 

•

 

8 megabytes (MB) of RAM for Windows 95 or 16 MB for Windows NT (16 MB recom-
mended for Windows 95 and 24 MB recommended for Windows NT)

 

•

 

20 MB of available hard disk space

 

•

 

VGA (or better) color monitor

 

•

 

QuickTime 2.0 (or later) 

 

Registration

 

We are confident you will find that Adobe PageMill greatly increases your productivity. 
So that we can continue to provide you with the highest-quality software, offer technical 
support, and keep you informed about new Adobe PageMill developments, please register 
your product. 

 

About Adobe products and services

 

More information about Adobe products and services is available through the following services:

 

•

 

The Adobe Home Page on the World Wide Web. To open the Adobe Home Page, use the 
URL 

 

http://www.adobe.com

 

.

 

•

 

The Technical Support database. To search the database, use the URL 

 

http://www.adobe.com/
supportservice/custsupport/tssearchdb.html

 

 (or click the red question mark on the Adobe 
Home Page).

 

•

 

Forums on CompuServe

 

®

 

 and America Online

 

SM

 

. Forums and availability may vary 
by country. 

 

•

 

FaxYI, a free fax-based service that provides the latest technical information about Adobe 
products. To use FaxYI, call 206-628-5737. This service is available 24 hours a day, 7 days a 
week. Request document 260099 to receive a copy of the index of all technical faxes containing 
information about Adobe PageMill and Adobe SiteMill

 

®

 

.

 

•

 

To speak with an Adobe customer service representative, call 800-411-8657.

 

•

 

When you register your retail product purchase, you automatically receive one free 
call to technical support. To contact Adobe PageMill technical support, call 206-628-5731 
(Macintosh) or 206-628-4517 (Windows). For more information on the Adobe technical 
support policy see 

 

http://www.adobe.com/supportservice/custsupport/cfcomp.html

 

.
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•

 

Using electronic mail, you can order technical and customer service information about 
Adobe products on Macintosh, Windows, and UNIX

 

®

 

 platforms.The information is created 
by Adobe Technical Support and can help you with troubleshooting a problem or help 
you learn new ways to use your Adobe product. To get started, send an e-mail message to 
“techdocs@adobe.com” with “help” in the Subject field. E-mail from Adobe “techdocs” is 
available 24 hours a day, 7 days a week.

 

Adobe PageMill package contents

 

The Adobe PageMill package includes:

 

•

 

the Adobe PageMill CD-ROM including the Adobe PageMill application software, 
third-party software, clipart, template, online documentation, and technical documents from 
Adobe Customer Support

 

•

 

the 

 

Adobe PageMill User Guide

 

•

 

a registration card (new purchases only)

 

Installing Adobe PageMill on the Macintosh

 

To use Adobe PageMill you must first install it on your hard disk.

 

Note:

 

 If Adobe PageMill 1.0 or Adobe SiteMill 1.0 is installed on your machine, Adobe PageMill 2.0 
will read the preferences file for the previously installed version and use these same settings for the 
Adobe PageMill 2.0 preferences file. If you want to set different preferences, open the Preferences 
folder in your System folder and drag the existing PageMill Preferences file to the trash.

 

To install Adobe PageMill:

 

1

 

Turn off or remove any virus-protection or screen-saver software, then restart your 
Macintosh with the extensions off. 

 

2

 

Insert the PageMill Application CD-ROM disc into your CD-ROM drive. 

 

3

 

Double-click the Install Adobe PageMill 2.0 icon to install the application onto your hard 
drive. The Adobe PageMill installer banner appears.

 

4

 

Click Continue.

 

5

 

When the licence agreement screen appears, click Accept.



 

5

 

6

 

From the Install Adobe PageMill dialog box, set up how you want to install the Adobe 
PageMill program:

 

•

 

Choose Easy Install to install the appropriate version of Adobe PageMill for your 
particular machine.

 

•

 

Choose Custom Install to install the version of the program corresponding to your system or 
to install individual items.

 

7

 

If you chose Custom Install in step 6, select the items you want to install including one of the 
following program versions:

 

•

 

Adobe PageMill 2.0 68K if your computer is a 68000-series Macintosh

 

•

 

Adobe PageMill 2.0 Power Macintosh if your computer is a Power Macintosh

 

•

 

Adobe PageMill 2.0 Universal if your computer is a 68K Macintosh with a Power Macintosh 
upgrade card installed, or if you plan to transport the application between dissimilar 
types of systems

For more information about an item to install, click the I icon to its right.

 

8

 

Select a location for the installation by selecting a hard disk from the menu. To install in a 
particular folder, choose Select Folder from the menu, click the folder name in the directory 
box, and then click Select.

 

9

 

Click Install. 

 

10

 

A dialog box appears asking you to personalize your copy of the program. Type your name 
and company name.

 

11

 

Type the serial number of your Adobe PageMill program exactly as it appears on the regis-
tration card or on the inside front cover of this guide (including the hyphen). If you’re 
upgrading form an earlier version of PageMill, the serial number is located on the first page of 
your original user guide.

 

12

 

Click OK. The Installer copies the files to your hard disk.

 

13

 

After the files have been copied, the electronic registration screen appears. Follow the 
on-screen instructions to register your copy of Adobe PageMill 2.0.

 

14

 

Click Quit to exit the installer.

 

15

 

Turn on or replace any virus-protection and screen-saver software that you turned 
off in step 1.

 

16

 

Restart your computer.
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Installing Adobe PageMill in Windows

 

To use Adobe PageMill you must first install it on your hard disk.

 

To install Adobe PageMill:

 

1

 

Start Windows, if necessary.

 

2

 

Insert the PageMill Application CD-ROM disc into your CD-ROM drive. 

 

3

 

Choose Start > Run.

 

4

 

Type d:\install.exe (where d: is the CD-ROM indicator) and click OK.

 

5

 

Click Next.

 

6

 

When the licence agreement screen appears, click Yes.

 

7

 

From the Install Adobe PageMill dialog box, set up how you want to install the Adobe 
PageMill program:

 

•

 

Choose Typical to install the most common options.

 

•

 

Choose Compact to install the minimum required options.

 

•

 

Choose Custom to choose the options you want to install. The installer display the amount 
of disk space required to install each set of program files, the total amount of disk space 
required for the selected files, and the amount of available disk space. Select the desired files 
and click Next.
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In the User Information dialog box, enter the requested information. Type the serial number 
of your Adobe PageMill program exactly as it appears on the registration card or on the inside 
front cover of this guide (including the hyphen). 
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Click Next. Confirm your user information and click Yes.
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Click Next to confirm your selections and to begin the installation, following the on-screen 
instructions.When installation is complete, a message appears indicating that the installation 
was successful. Click OK.
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If you installed the Electronic Registration module and want to register the application 
online, follow the on-screen instructions to register. 
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Using the PageMill logo in your site

 

The PageMill software includes a product signature graphic logo, which you can use on your 
site (the logo tells the user the page was created using PageMill). Before you include the logo, 
be sure to read the special license agreement concerning logo use. The graphic and the license 
agreement are installed in the Logos folder, which was installed when you installed PageMill.

 

Starting Adobe PageMill

 

Follow these steps to start the program.

 

To start Adobe PageMill on the Macintosh:

 

1

 

Open the Adobe PageMill 2.0 folder, and double-click the PageMill program icon. 

 

2

 

The Adobe PageMill window appears. You can now start creating or editing your pages.

 

To start Adobe PageMill in Windows:

 

1

 

Choose Start > Adobe > PageMill 2.0. (If you installed the program in a folder other than 
Adobe, choose that folder from the Start > Programs menu.)

 

2

 

The Adobe PageMill window appears. You can now start creating or editing your pages.

Making installation floppy disks from the CD-ROM 
installer files
If you need floppy disks as backup or for installing the Adobe PageMill program on a computer 
that doesn’t have a CD-ROM drive, follow this procedure to make a set of installation floppy 
disks. This procedure assumes that you have access to another computer with a CD-ROM drive 
for copying the files.

To make a set of installation floppy disks:

1 Insert the PageMill Application CD-ROM disc into your CD-ROM drive.

2 Choose from the following options:

• On the Macintosh, open the Adobe PageMill 2.0 folder and the Disk Images folder.

• In Windows, open the PageMill folder and the Diskimag folder.
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3 Insert a formatted, high-density floppy disk into your floppy disk drive. Select and copy the 
contents of the Disk 1 folder onto the floppy disk and label each disk as follows:

• On the Macintosh, name the floppy disk exactly the same as the folder containing the files 
you just copied (i.e., Disk 1).

• In Windows, label each disk with the proper number. During installation, you will be 
prompted for the disks by number.

4 Eject the disk. Repeat step 3 for the remaining disk folders on the CD-ROM disc.

5 To install PageMill from the floppy disks, insert Disk 1 into your floppy disk drive and follow 
the instructions in “Installing Adobe PageMill on the Macintosh” on page 4 or “Installing 
Adobe PageMill in Windows” on page 6.

What’s new in Adobe PageMill 2.0? (Macintosh only)
PageMill 2.0 offers the easiest to use and most reliable capabilities available in any 
web-authoring program on the market today. Here are some of the features that have 
been added to PageMill for version 2.0:

• Full support for tables including importing tables from Microsoft Excel. PageMill tables 
are easy to create and allow you to format cell contents, nest tables, add images, sounds, and 
movies to table, specify table dimensions, and add captions.

• Easy creation and manipulation of frames. PageMill frames are simple to create and easy to 
link. PageMill frames can be nested, resized, formatted with new margins, named, and printed. 
You can resize, name, format, and display frames with a few clicks. 

• Client-side image maps that speed link display and simplify file organization and maintenance.

• Advanced text handling that allows you to change the base font size, select relative font sizes, 
change text color, and flow text around images. 

• Complete search capabilities for all page elements including text, links, images, tables, 
movies, and sounds. You can drag and drop elements into the Find dialog, specify the scope of 
the search, and limit the search to case sensitivity for text and size sensitivity for images. 

• A full-featured spell checker that includes customizable dictionaries.

• Support for Netscape™ plug-ins including PDF Viewer, QuickTime movies, and 
Shockwave animations.
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• Ability to toggle between the PageMill page and the HTML source code. This enables you to 
easily edit the source code. Now you can drag from WYSIWYG view or the Pasteboard directly 
in the source code. You can even specify code you don’t want edited by PageMill.

• The ability to add hidden fields to forms and hidden comments to pages.

• A new Color Panel that lets you drag and drop colors onto the page and even change the 
background color instantly.

• An improved Inspector that provides even more options for formatting your Web 
page elements. 

• The ability to open linked pages in the same window and quickly move between pages in 
the Preview mode.
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Chapter 1: Tutorial

his first chapter leads you through basic Adobe PageMill authoring techniques. 
Complete this tutorial before starting to create your own Web page. A small Web site is 
included with PageMill so that you have files to work with throughout this tutorial; the 

site is stored in a folder called Tutorial within your PageMill folder. 

Open a page and explore links
In Adobe PageMill you can create new pages from scratch, or you can open an existing page 
generated from any application that saves or exports files in the HTML format. You’ll begin by 
opening a page that’s been started for you.

1 Start Adobe PageMill and choose File > Open. Locate and open the EWHome.html file 
in the Tutorial folder in your PageMill folder. This folder was installed when you installed 
Adobe PageMill. 

2 Choose File > Save Page As, rename the file Home.html, and save the file in the Tutorial 
folder. Saving the file with a different name prevents you from modifying the original 
tutorial file.

The file appears the way it looks when viewed in a Web browser. Existing documents open in 
Preview mode. Preview mode lets you follow links within your site—that is, view other pages 
by clicking on links.

T
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A. Link Location bar

3 Move the pointer over the underlined text “Order Form” near the top of the page. 
The underline indicates that the text is linked.

4 Notice that as you pass the pointer over a link in the PageMill window, the pointer changes 
to a pointing hand, and the address of the link, otherwise known as a URL (Uniform Resource 
Locator), appears in the Link Location bar at the bottom of the page.

A
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5 Click the linked text. The destination page—EWOrder.html—appears in the same window, 
replacing the previous page. (Destination pages open in the same window unless you choose 
Edit > Preferences and change the Local link option in the General panel of the Preferences 
dialog box.) 

6 In the EWOrder.html window, click the Back button at the top of the window to return 
to the Home.html file.

7 Position the pointer on the Title bar and press to display a history of the files you’ve viewed. 
You can use this history to trace your steps through a Web site, and you can select any previ-
ously viewed page to display it.

8 Click the globe icon in the upper right corner of the page to change to Edit mode. 
PageMill has two modes:

• Preview mode, indicated by the globe icon (A), simulates how the page looks and behaves 
when viewed in a Web browser. (Existing pages open in Preview mode unless you choose 
Edit > Preferences and change the Open pages option in the General panel of the Preferences 
dialog box.) 

• Edit mode, represented by the pen-and-paper icon (s), lets you create or modify the content 
and design of the page—enter and edit text, manipulate images, create links, and so on. 
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Edit and format text
Working with text in Adobe PageMill is similar to using a word processor. Now you’ll make 
basic text edits and formatting changes.

1 Near the top of the Home.html window, drag to select the sentence, “Welcome to our 
online catalog.”

2 At the top of the PageMill window there are two rows of buttons. Clicking the buttons in this 
toolbar lets you perform formatting and design tasks quickly. Move the pointer over the Italic 
button (ˆ) and notice that the text “Italic” appears in the far right under the first row of buttons 
(Macintosh) or in a pop-up window (Windows). PageMill always provides a description of the 
button the pointer is over.

3 Click the Italic button to format the selected text. Deselect the text by clicking the page 
anywhere off of the text to see the formatting. 

4 Double-click to select the word “Accessories,” and then type More.

5 Triple-click the linked text “Order Form” to select the entire link. Triple-clicking linked text 
selects the underlined (linked) characters. (Triple-clicking unlinked text selects the entire line.)
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6 Press Option (Macintosh) or Ctrl (Windows) and drag the text toward the end of the first 
paragraph, until an insertion point appears immediately to the left of the closing bracket. When 
you’re in Edit mode, you can quickly duplicate selected text, graphics, and other objects on the 
same page by pressing Option/Ctrl as you drag. (To copy an item from one page to another, 
drag without pressing Option/Ctrl.)

7 Choose Window > Show Pasteboard (Macintosh) or View > Show Pasteboard (Windows). 
The PageMill Pasteboard has five pages on which you can store multiple elements, unlinked or 
linked, without having to keep the source of the link open. (This lets you reuse a linked element 
throughout a Web site without having to relink the item each time.) 

8 Now you’ll move the line of text you just edited to the Pasteboard so you can use it as a 
standard element on other pages. Triple-click any unlinked text (text which is not underlined) 
in the “[Plants | Tools | More | Order Form]” paragraph to select the entire line of text.

9 If necessary, resize the Pasteboard by dragging its lower right corner so that it is wider than 
it is long, and you can view the text you’re about to store there.
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10 Drag the selected text from the Home.html window onto the center of the Pasteboard. 
The text appears in the Pasteboard, ready to be inserted onto another page. Notice that the 
linked text remains linked.

11 Close the Pasteboard.

Add images
Working with images is as easy as working with text. You can insert, move, and resize images 
in PageMill, and even change some aspects of how they display on the screen.

1 Click at the left side of the window just above “[Plants | Tools | More | Order Form]” to
position the insertion point.

2 Choose File > Place. Locate the EWLogo.gif file in the Tutorial folder, and click Place.

3 Click the Center Align Text button (Y) on the toolbar. The image moves to the center 
of the page.
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4 Click the image to select it, hold down Shift, and drag the handle in the lower right corner 
up to make the image proportionately smaller. 

5 Now you’ll make the image blend into the page by giving it a transparent background. 
Hold down Command (Macintosh) or Ctrl (Windows) and double-click the image to open 
the Image window. 

6 Click the transparency tool (D), and then click the white section of the image. The image’s 
background turns gray to indicate transparency.

Original background Transparency applied

7 In order to preserve the original image, Choose File > Save A Copy As (Macintosh) or 
File > Save As (Windows). Rename the file Logo.gif and click Save.

8 Close the Image window. At the prompt, click Don’t Save.
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9 Make sure the image is still selected, then choose File > Place to replace the logo with the 
transparent version. Locate the Logo.gif file in the Tutorial folder, and click Place. You will need 
to resize the new image. 

Change the text color and page background 
The Inspector palette lets you specify settings associated with an entire page, selected text, or a 
selected object (such as an image or a table).

1 You’ll start by inserting the image you’ll use for the page background into the page. Scroll 
if necessary, and press Return (Macintosh) or Enter (Windows) to position the insertion point 
to the right of the word “More.” Click the Place Object button (v) on the toolbar (this button 
provides a quick way to place a file). Locate the EWFloral.gif file in the Tutorial folder, 
and double-click.

2 Click to select the image that you just inserted. 
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3 If necessary, choose Window > Show Inspector (Macintosh) or View > Show Inspector 
(Windows) to display the Inspector.

A. Page tab B. Background image well

4 Click the Page tab to select the Page panel. Drag the EWFloral.gif image onto the Background 
Image well in the Inspector palette. The image repeats, or tiles, to become the page background. 
(HTML doesn’t let you control the size of the tiles.)

A

B
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5 With the image still selected, press Delete (Macintosh) or Backspace (Windows). The image 
disappears and the new background remains on the page. 

6 Now you’ll set the color for the body text on the page. In the Inspector palette, choose 
Custom from the Body Text menu. In the Color box, click a dark color (for legibility). Press OK. 

7 Close the Inspector palette by clicking its close box or choosing Window > Hide Inspector 
(Macintosh) or View > Hide Inspector (Windows).

8 Choose File > Save Page. 

Create links
A link takes you from one page (the source) to another (the destination). The destination can 
be on the same page in your Web site, another page in your Web site, or somewhere else on the 
Web. Now you’ll create links between selected text and another page in the Web site. 

1 If necessary, scroll to the top of the Home.html page. Select “Plants” in the first line of text. 

2 One way to create a link is by dragging the page icon from the destination page onto a 
selection on the source page. Choose File > Open, then locate and open the EWPlants.html file 
in the Tutorial folder. Choose File > Save Page As, rename the file Plants.html, and click Save.

3 (Windows only) If necessary, click the Restore button in the Plants.html window so that all 
open windows are visible.

4 Position the Home.html and Plants.html windows side by side, so that the selected text 
on the source page (Home.html) and the page icon of the destination page (Plants.html)
are visible. 

5 Drag the page icon from the Plants.html window onto the selected text in the Home.html 
window. The selected text becomes underlined, indicating that it is linked. 
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6 Another way to create a link is by copying a link to another page or to another place on 
the same page. Click the globe icon in the Plants.html window to switch to Edit mode.

7 Choose Window > Show Pasteboard (Macintosh) or View > Show Pasteboard (Windows). 
You’ll paste the link you copied to the Pasteboard earlier. When you paste linked text from the 
Pasteboard, both the text and the link are copied. You don’t need to respecify the link and you 
can even modify the text without breaking the link.

8 Press Option (Macintosh) or Ctrl (Windows), and drag the text from the Pasteboard to 
the Plants.html window, immediately above the circular Earth&Ware logo (an insertion 
point appears). 

9 Close the Pasteboard.

10 A third way to create a link is to type the link’s address or Uniform Resource Locator (URL) 
into the page. In the Plants.html window, select the text “Plants” in the paragraph you just 
inserted from the Pasteboard, and type Home.

11 Double-click the word “Home” to select it. 
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12 Click in the Link Location bar at the bottom of the window, and type Home.html 
(the address of the page you want to link to). Linking by typing the URL is most useful when 
you’re linking to a page at an external Web site or when linking to other Web resources (such 
as e-mail). Typing the URL is the only way to create a link when all you have is its address.

A. URL in location bar

13 Press Return (Macintosh) or Enter (Windows). The selected text becomes a link. 

A
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Test links
You can quickly double-check your work by switching to Preview mode and following the 
links you created.

1 In the Plants.html window, click the pen-and-paper icon (s) to switch to Preview mode.

2 Click the text “Home” above the logo. At the prompt to save changes, click Save (Macintosh) 
or Yes (Windows). The Plants.html page closes and is replaced by the Home.html page.

3 In the Home.html window, click the pen-and-paper icon to switch to Preview mode.

4 Click the linked text “Plants” near the top of the page. At the prompt to save changes, click 
Save/Yes. The Plants.html window replaces the Home window and becomes active.

5 Close the Home.html and Plants.html pages. 

Add a rule and format text
You’ll add a new section to the order form by inserting a horizontal line, or rule. 

1 Choose File > Open, and open the EWOrder.html file. Choose File > Save Page As, rename 
the file Order.html, and click Save. Click the globe icon (A) to switch to Edit mode.

2 Click to the right of the closing bracket in the first paragraph near the top of the page, 
and press Return (Macintosh) or Enter (Windows).

3 Click the Insert Horizontal Rule button (w). A horizontal line appears. You can adjust the 
length or width of rules, but for now the default settings are fine. Horizontal rules are useful 
in many kinds of page designs, not just in forms.
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4 Press Return (Macintosh) or Enter (Windows). It’s important to press Return/Enter 
before and after inserting a rule to ensure that the browser aligns the rule properly. 

5 Click the Left Align Text button (X) on the toolbar. The insertion point moves to the left edge 
of the window.

6 Click the Indent Right button (]) on the toolbar. Now each line you type will retain the 
indent and alignment settings you just specified.

Create a form
Creating an interactive form for the Web involves two tasks: laying out the form elements 
and linking to a script to collect the information in the form. For more information about 
preparing a script, see Chapter 8, “Creating Forms.”

Add text fields

You’ll start by creating a new section of the form where customers can type basic mailing information. 

1 With the insertion point between the two horizontal rules and right indented, type the eight 
labels shown here, pressing Shift-Return (Macintosh) or Shift-Enter (Windows) to add a single 
space between lines, and Return/Enter to add double spaces between lines. 

2 Click immediately after “Name” and then click the Insert Text Field button (l) on the 
toolbar. This adds a one-line fill-in text field. 

3 Click to select the text field, press Option (Macintosh) or Ctrl (Windows), and drag the field 
to the right of the Address label.

4 Repeat step 3 for the remaining labels you typed earlier, but do not add a text field to the 
Method of Payment label. (You can also use the Edit > Copy and Edit > Paste commands to 
copy and paste the text fields.)



25

5 Resize each field as needed by clicking to select it and dragging the handle to the right to 
increase its size or to the left to reduce its size.

6 Now you’ll add explanatory text to one of the fields. Double-click the Credit Card # text field. 
Make sure that a thick bar surrounds the field. The thick bar indicates that you can type in 
the text field. 

7 Type Enter unless paying by check. 

Add a radio button group

You can use a radio button individually or as part of a group. Use grouped radio buttons to 
offer a set of mutually exclusive choices: selecting one radio button automatically deselects the 
other options in the group. 

1 Click to the right of the “Method of Payment” text, and then click the Insert Radio Button 
button (j) on the toolbar. 

2 Select the radio button, press Option (Macintosh) or Ctrl (Windows), and drag the button 
to the right. Copying a radio button by dragging (instead of creating new buttons) keeps 
the buttons grouped. 

3 Repeat the previous step to add a third button to the same line.
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4 Click between the first and second buttons, and at the insertion point type EW Credit Card.

5 Click between the second and third buttons, and type Standard Credit Card.

6 Click to the right of the third button, and type Check.

7 Click the pen-and-paper icon (s) to switch to Preview mode, and try typing in the text fields 
and selecting radio buttons. Notice that you can type beyond the width of the field, and that 
selecting one radio button automatically deselects the previously selected one. 

Note: Although you can’t use Tab to move from field to field in PageMill, the user will be able to tab 
through fields when using the form in their browser.

Add a checkbox and a pop-up menu

To complete the form, you’ll add form elements to the Vegetables section and edit them.

1 Click the globe icon to switch to Edit mode.

2 Click at the end of the line that lists vegetable seeds (after the word “chicory”) and press 
Return (Macintosh) or Enter (Windows) to create a new line where you’ll recreate the arrange-
ment of form elements used for the Fruit and Herbs sections immediately below.
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3 Click the Insert Checkbox button (e). Customers will check this box to include an order 
of vegetable seeds. 

4 Click the Insert Text Field button (l). Customers will type the kind of seed here.

5 Click the Insert Pop-up button (n). Customers will choose a quantity here.

6 Double-click the pop-up menu to edit it. Choose Edit > Select All. Type the following, 
pressing Return (Macintosh) or Enter (Windows) to start each new line: 

7 Set the default option by dragging the triangle next to the list beside any of the quantity/price 
figures. Click outside the pop-up menu to see the new default.

8 Now you’ll duplicate this section of the form. Drag across all the elements to select them. 

9 Press Option (Macintosh) or Ctrl (Windows) and drag the selected form elements down to 
the next line until an insertion point appears.

10 Press Return (Macintosh) or Enter (Windows) to move the insertion point down.

11 Click the Insert Submit button (o) to place a Submit button on the form. All forms must 
contain a Submit button.

12 Test the form by switching to Preview mode and checking how the new fields work. 
Then choose File > Close. When prompted to save changes, click Save (Macintosh) or 
Yes (Windows). 
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Create a table
Tables effectively summarize information so that readers can quickly scan your Web page. 
PageMill makes creating a table as simple as adding any other element to a page. 

1 You’ll work on an existing page that contains a graphic, and add a table. Choose File > Open, 
and open the EWHerbs.html file in the Tutorial folder. Choose File > Save Page As, rename the 
file Herbs.html, and click Save.

2 Click the globe icon to switch to Edit mode, then click to place the insertion point after the 
graphic. Press Return (Macintosh) or Enter (Windows) a few times to add some space. 

3 Position the pointer over the Insert Table button (m) on the toolbar and drag until you 
have 5 rows and 4 columns, then release the mouse button. The table appears.

4 Next you’ll add the column headings to the table. Click the upper left cell. A thick bar appears 
around the table indicating that it’s ready for you to enter data. An insertion point appears in 
the cell. Type Herb. 

5 Press Tab to move to the cell to the right and type Soil. Fill the remaining two cells in the top 
row by typing Location and Height. 
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6 You can add text, images, movies, and even other tables to a table cell. Press Tab to move to 
the second cell in the first column. Click the Place Object button (v) in the toolbar and then 
double-click the EWAnise.gif file in the Tutorial folder. The image appears in the cell.

Note: Each empty cell in a table contains a non-breaking space. If the image is inserted after the 
space, an empty line will appear above the image. To remove the space, select it and press Delete 
(Macintosh) or Backspace (Windows).

7 Click the third cell in the first column and click the Place Object button (v). Place the 
EWBasil.gif file in this cell.

8 Continue filling in the first column with the remaining two images, EWChervil.gif and 
EWThyme.gif. 

9 Click the second cell in the second row of the second column and type Moist. Continue 
filling in the table until all the columns and rows are complete.
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10 Now you will format the cells by applying a heading style to the text in the top row. 
Click the upper left cell and choose Large Heading from the Format menu on the toolbar. 

11 In a PageMill table, the text in each cell must be formatted individually. Repeat the previous 
step for each cell entry in the top row. When you’ve filled the cells, click outside to deselect 
the table.

12 Choose File > Save Page to keep the work you’ve done so far.
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Add a border and a caption
Now you’ll customize the table border to help the table stand out from the page background 
and from the other objects on the Web page. 

1 A table must be selected before you can change its appearance. If necessary, click any cell to 
display the thick bar around the table. Click along the edge of the thick bar to select the table. 
(The thick bar is replaced by a thin line and handles for resizing the table.)

2 Choose Window > Show Inspector (Macintosh) or View > Show Inspector (Windows) to 
display the Inspector palette. Because the table is selected, the Inspector automatically opens to 
the Object panel and displays the table attributes. 

3 Enter a value of 5 in the Border box and press Return (Macintosh) or Enter (Windows). The 
border appears around the table. 
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4 As a final step, you’ll add a caption to the table. Click the Caption option in the Inspector. 
PageMill automatically places the caption area above the table unless you click the radio button 
below the table in the Inspector to position the caption under the table.

5 Triple-click the word “caption” to select it, and type Herb Requirements.

6 Close and save the Herbs.html page. Click the Close box to close the Inspector.
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Create frames
Frames visually divide a window into different areas, with each frame displaying information 
independently of the other areas. Each frame contains a separate page, and all the frames taken 
together make up a frameset. Frames are useful when you want to update only part of a page, 
for example, when you want to have a reader click a link in the table of contents to display 
information that describes that topic in an adjoining frame. 

1 To complete the tutorial, you’ll create a new page with frames that serve as an entry point 
into the Earth&Ware catalog. Choose File > New Page to create a new page.

2 Press Option (Macintosh) or Ctrl (Windows), and move the pointer over the area at the top 
edge of the window. As you pass over the thin line just inside the window edge, the pointer 
turns into a down arrow.

3 Drag about a third of the way down the page.
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4 Press Option (Macintosh) or Ctrl (Windows) again, and move the pointer over the left edge 
of the window. When the pointer turns into a right arrow, drag right about 2 inches. Now you 
have three frames, the portion of the original page and the two frames you just created. (Don’t 
worry about the exact size of the frame right now.)

Fill the frames

Now you’ll fill the frames with graphics and pages. The top frame will contain a banner, the left 
frame will contain a table of contents, and the right frame will contain product information. 

1 Click to place the insertion point in the top frame and click the Place Object button (v). 
Locate the EWMore.gif file in the Tutorial folder, and click Place.

2 Click the Center Align button (Y) on the toolbar to move the banner to the center 
of the page.
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3 Next you will add a table of contents. Click to place the insertion point in the left frame, 
choose File > Insert Page (Macintosh) or File > Frameset > Insert Page (Windows), and select 
the EWTOC.html file in the Tutorial folder. Click Open.

4 If necessary, resize your frame so that the text displays correctly. To resize a frame, move the 
pointer over the thin line that surrounds each frame. When you see the double-headed arrow, 
drag to change the size.

Create and target a link

The third frame will display different pages depending on what link the reader clicks in the 
table of contents frame. You are going to create a link from the text “Chairs” in the left frame to 
the EWChairs.html page, and then target the link to display that page in the right frame. 

1 Select the word “Chairs” in the left frame.

2 Choose File > Open, locate the EWChairs.html file in the Tutorial folder, and click Open. 
Rearrange the windows so that you can see the selected text in the untitled window and the 
page icon in the EWChairs.html window. 
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3 Drag the page icon from the EWChairs.html window over the selected text to create the link. 
Close the EWChairs.html window. 

4 Make sure the link is still selected. Now you will target the link you just created so that the 
page it links to appears in the right frame of this page. 

5 Move the pointer over the target icon to the right of the Link Location bar, and press the 
mouse button. A miniature of the page with its frames appears.

6 Drag over the frames until the right frame is highlighted. This tells PageMill to display the 
linked page in that frame. Release the mouse to target the highlighted frame.
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7 Choose File > Save Frameset (Macintosh) or File > Frameset > Save Frameset (Windows) 
and name the file Frames.html. Click Save.

8 Click the paper-and-pen icon to go to Preview mode and click the link. The linked page 
appears in the right frame.

This completes the tutorial. You’re ready to create your own Web pages. For more information, 
see the remaining chapters in this manual.

If you want to do the tutorial again, remove the files you’ve created from the Tutorial file 
(Frames.html, Herbs.html, Home.html, Logo.html, Order.html, and Plants.html) and you’re 
ready to start over.
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Chapter 2: Basic Concepts

he World Wide Web (the Web) is an increasingly popular medium for electronically 
distributing and viewing information in the form of pages of text, graphics, movies, and 
other media. This chapter introduces the concepts, terms, and procedures you use to 

create a Web page with Adobe PageMill.

About the World Wide Web
The Web is a collection of electronically linked documents (called pages) that are stored on the 
Internet. Established in the 1960s, the Internet was developed so that government agencies and 
universities could link research centers. The Internet is a network of networks that communi-
cate with each other using a common computer language, called a protocol. Many services 
comprise the Internet, such as e-mail and mailing lists, Usenet newsgroups, FTP file transfer-
ring, Telnet for logging in to remote services, and Gopher for menu-based Internet searches. 
Probably the best known and fastest growing of these services is the Web. 

Understanding these common terms will help you as you create Web pages with 
Adobe PageMill: 

• A document and a page in the Web world both refer to a single file. (In printed materials, a 
document is a single body of work that contains individual pages.) You move through and 
between these pages using hypertext links—similar to clicking a topic in an online help system. 

• A Web server is a computer on any platform, such as Macintosh, UNIX, or Windows, that 
stores and manages Web documents. The server accepts requests from other computers and 
then delivers the documents back to the requester. 

• A browser (sometimes called a Web client) lets you look at documents sent by a server. Many 
browsers are available, including Netscape Navigator™, Microsoft Internet Explorer, National 
Center for Supercomputing Applications (NCSA) Mosaic™, and so on. 

T
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• An Internet Service Provider (ISP) maintains the server where you send requests as well as 
makes space available for you to store your own Web pages. (If you work in a company or 
educational institution, your organization probably provides the services you use to get to the 
Web server.) Most ISPs include a browser in their software or tell you where to go on the Web 
to download a browser.

Note: Your own computer can be a Web server if it has the proper software and a direct connection 
to the Internet, but running a Web server involves extensive technical and administrative overhead. 
Most people and small companies avoid this labor-intensive option and have someone else provide 
them with Web access. 

• A site is a group of related pages on a Web server. You usually enter a Web site via a home page.

• A home page is the Web page that loads when you start a browser. Each browser application 
has its own home page, which is typically the page of the company that created the browser. 
The home page also is the entry point to your Web site when you publish information on 
the Web. A home page usually displays general information about the Web site, and links to 
the Web pages in this site and to pages in other sites. The home page usually is named 
www.sitename.com/index.html. Your ISP can provide the name you should use for your 
own Web site. 

• Your document is published when you upload a copy of your site to a Web server where the 
rest of the world can access it. Most ISPs offer customers a few megabytes of space on their 
servers to store their site documents.

Your machine with
browser software and
connection software

Your Web page is
stored on server

Server provided by your
ISP broadcasts Web pages

on the Internet

Users who access
your Web pages
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Using Web addresses
To go somewhere on the Web, you enter an Internet address called a Uniform Resource Locator 
(URL) in your browser. The URL is the pathname to the page or object you’re looking for. 

A URL is made up of several parts, for example: 

where 

• PROTOCOL is the set of rules that describes how you want the information transferred. 
The system used by the Web to transfer data is called HyperText Transfer Protocol (HTTP). 
Most browsers now also support file transfers, gophering (browsing for resources using menus 
and the appropriate application such as telnet or ftp), sending mail, and so on. For more infor-
mation, see “About URLs” on page 104.

• DOMAIN describes the host name and namespace on the Internet.

• DIRECTORYPATH is the location within the machine’s file structure of the Web site.

• PAGENAME is the filename of the page you’re requesting.

Using PageMill to create Web pages
With PageMill, you can prepare pages for your Web site in one of two ways:

• You can prepare a site on a computer away from the Web server (such as on your home 
computer or on a laptop), as a group of Web pages inside a folder on your hard disk; the site 
folder can contain images and subfolders containing more folders, images, and Web pages. 
Once you’re finished editing, you upload, or send a copy of, the site to the Web server where it 
is stored electronically and becomes available to anyone who uses the Web.

• You can work on a site directly on the Web server if the Web server is available via a local area 
network connection. That is, if you are able to log into your Web server using the Chooser 
(Macintosh) or Network Neighborhood (Windows) and access the Web directly, you can use 
PageMill to work directly on the site. Typically, such access is available to corporate or educa-
tion users over their local area network. For more information about network file system 
options for Web servers, see your computer documentation or IS manager.

PROTOCOL / DOMAIN / DIRECTORYPATH / PAGENAME

http://www.company.com/department/sales/western.html
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About Web page design 

Pages on the World Wide Web are described using the Hypertext Markup Language (HTML). 
HTML is a text-only markup language that was designed to allow text to be tagged (or marked 
up) to designate the content—not the appearance—of the text. Hence, your options for design-
ing a Web page differ greatly from those for the printed page. As you design Web pages, remem-
ber that you don’t have complete control over how the reader sets the page size, the width of 
the text column, the fonts, or the size of the text. 

Adobe PageMill lets you create pages without typing any codes—unlike many other applications 
for designing Web pages that require you to learn the HTML codes (called tags) that format the 
text, graphics, and objects on a page. With PageMill, you can format text by clicking buttons 
in the button bar, and you can import, resize, and reposition graphics on the page simply by 
dragging them. To add a feature or special effect not directly supported by this version of 
PageMill, such as blinking text, meta tags, and Java scripts, you can enter custom HTML code 
into PageMill. (For more information about entering custom HTML code, see Appendix B, 
“Viewing and Editing HTML Code.”)

Even though you don’t have to enter HTML tags to create your Web page in PageMill, you need 
to know a few things about the capabilities of HTML and how they control what you can 
present on your page. For more information on the HTML tags Adobe PageMill supports, you 
can search the Adobe online technical database for related technical documents at 
http://www.adobe.com/supportservice/custsupport/tssearchdb.html. Also see the resources in 
“Before you call technical support” on page 195.

The following sections give an overview of the differences between designing for a Web page 
and for a printed page.

Layout considerations

HTML is primarily a set of tags for a sequence of text, graphics, and other media with hypertext 
links. An HTML page is one column of continuous text with graphics that flow along with the 
text, as if they were text characters themselves. This text-stream model limits control over page 
layout; for example, it does not let you control layouts that use multiple columns, layered text 
and graphics, or rotated text.
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The text-stream model means that page proportions and line breaks will vary depending on the 
size of the monitor or window in which the page is viewed, the preferences set in PageMill, and 
the preferences set in the Web browser. However, as a rough guideline, you might design for the 
line length produced by a Web browser using a default font on a 640-by-480-pixel screen.

Resizing a browser window changes line endings.

You cannot specify a precise horizontal and vertical position for a graphic. For example, if you 
position a graphic at the bottom right of a page as it appears on your monitor and a reader 
decides to make the window narrower, the graphic probably will move to the next line down 
and may end up on the left side of the page.

Typographical considerations

You cannot control the typographical appearance of your Web page using HTML, because the 
Web browser’s window size and font settings determine line breaks, letter spacing, and word 
spacing. In addition, you cannot specify the following type characteristics from PageMill 
because the Web browser either completely controls them or does not support them:

• Font and leading

• Font width

• Tracking and kerning
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• Outline, shadow, and reverse type styles

• Tab positions

• Spacing before or after a paragraph

To preserve the typography in a short passage of text, such as a company logo, create the text in 
an image-processing program and import it as an image. For more information, see “Adding 
Images, Movies, Sounds, and Plug-in Objects” on page 77.

Graphics considerations

When you’re considering what images to include in a Web page, keep in mind that images take 
longer to download than text. Some browsers don’t display graphics at all, and some readers 
turn off graphics to speed up their browsing. Here are additional considerations for working 
with images that you’ll display on the Web:

Keep the file size as small as possible by reducing the image size and the number 
of colors (the color palette) used in the images.

Because you want a home page to load very quickly, no graphic should be larger than about 
10K. The entire home page (all the graphics on the page plus the text) should not be larger than 
50K (which takes about 20 seconds to download using a standard modem connection). To 
transfer a megabyte of data (1024K), a 14.4 bbs modem takes 10 minutes, and a 28.8 bbs 
modem takes 5 minutes. For more information about image size and download speed, see 
“Determining the download time of pages and objects” on page 86.

Limit the image width to 480 pixels or less. 

This width lets most readers view the image easily since 480 pixels is the default width of a 
Netscape window (when displayed on a 13-inch monitor). When you must use larger images, 
consider placing a thumbnail (a small version of the image) on the main page and linking it to 
the larger or higher resolution image. Then readers can decide if they want to spend the time 
downloading the bigger file.
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Resample or reduce the image resolution in an image-editing application such 
as Adobe Photoshop.

Scaling an image in PageMill does not change its file size and won’t speed downloading. 
You can use an image-editing application such as Adobe Photoshop™ to resize or resample 
high-resolution images. A resolution of 72 pixels-per-inch (ppi) (for the Macintosh) or 96 ppi 
(for Windows) is high enough for most images because it is the resolution of most readers’ 
monitors. See your graphics program documentation for more information on reducing image 
dimensions and image resolution.

Save the file in GIF or JPEG format.

To decrease the file size of an image without dramatically changing how it looks, save the image 
in the Graphics Interchange Format (GIF). GIF uses an indexed color palette with no more 
than 256 (8-bit) colors and is useful for most graphics, line art, and text. GIF files can contain 
transparent areas and can be interlaced for faster downloading. When an image requires more 
color information or precise color fidelity (for example, when the image is a photograph or 
contains a gradient), save the file in JPEG format. JPEG compresses the file to save space while 
still providing millions (24-bit) of colors. For more information, see “Adding Images, Movies, 
Sounds, and Plug-in Objects” on page 77.

Use a dither-free Web palette in your image-editing application.

Work in RGB color mode rather than in CMYK mode when preparing images in an 
image-editing application to help prevent the undesired pointillist look of dithered—mixed—
colors. RGB files are smaller, and use the same color model as that used by most monitors. 
Monitors can show only one palette per screen. If multiple images will appear on the 
same page, use your image-editing program to find the best adaptive color palette for all the 
images on a page. (An adaptive palette creates a color table by sampling colors from the more 
commonly used areas of the color spectrum that appear in the image.) To avoid dithering 
colors in flat color or limited color images, use a color palette with the lowest common denom-
inator (limited color palettes don’t work well with photographs). The Windows and Mac 
browser palettes differ slightly and share only 216 of 256 possible colors. Nondithering, 
216-color palettes are available on the Web. (For example, Lynda Weinman, author of 
Designing Web Graphics, has posted a nondithering palette for the Mac and Windows at 
http://www.lynda.com/hex.html.)
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Create the image using anti-aliasing. 

Low-resolution images often appear with jagged edges where colors change. In an 
image-editing application such as Adobe Photoshop or using Adobe ScreenReady™ for 
the Macintosh, you can apply anti-aliasing to blur slightly the edges where colors change 
and create a smoother transition between adjacent colors. (Don’t anti-alias a graphic if you’re 
making the rectangular background around the image transparent or you’ll get a halo or 
fringe around the edges.)

Use the same image in different places in your site.

Typically, a browser has to download an image only once when it’s repeated in a site. This lets 
duplicated elements, such as navigation bars and logos, appear very quickly. 

Keep your target audience in mind.

If you want modem users to access your page, the total graphics content of a single page should 
not exceed 50K. You can use PageMill’s download statistics to check on downloading time 
for images and graphics before you put your site on a server. For more information, see 
“Determining the download time of pages and objects” on page 86.

Using HTML formats

The constraints of HTML may seem like limitations from a printed-page designer’s point of 
view, but they are advantages for online delivery. Tagging text by content, not appearance, 
makes Web pages readable on a wide variety of computer systems and monitor sizes.

HTML structures information using named formats. You apply formats based on the function 
of a particular piece of text, such as a heading, a regular paragraph, or a list. HTML formats 
resemble the named styles in many word-processing programs in that you change the appear-
ance of text by applying different formats. However, the appearance of a format can also be 
changed within the browser by the person reading a Web page—something a reader of a 
printed page cannot do. The formats in HTML preserve the functional organization of a page 
even if a reader changes a format’s appearance. For more information, see “Applying paragraph 
formats” on page 62.
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Preserving a page layout 

If preserving the graphic identity or page layout is important, consider creating some of your 
Web pages as Adobe Acrobat® Portable Document Format (PDF) files. PDF files preserve the 
layout and typographical characteristics that HTML does not, and can include hypertext links 
between pages and to the World Wide Web. You can import PDF files from any version of 
Adobe Acrobat. To be read, you must have the PDFViewer plug-in installed in the Browser 
Plug-ins folder in the PageMill Plug-ins folder. (See “About file formats and plug-ins” on 
page 77.) When you place a PDF file, only the first page of the imported PDF file appears 
in PageMill. You can then link the image of the first page to the actual PDF file to view the 
entire document. 

If you include PDF files, also include a link to the free Adobe Acrobat® Reader application, 
which is required to view PDF files. You can configure Acrobat Reader as a helper application 
for browsers, to interpret the PDF format for browsers that don’t support it using plug-ins. 
Acrobat Reader runs on Macintosh, Windows, MS-DOS®, OS/2® and some UNIX systems, such 
as LINUX. For more information about PDF files and Adobe Acrobat, see the Adobe Web site 
at http://www.adobe.com.

Using Web links

The most significant difference between a printed page and a Web page is a link, which lets you 
arrange pages in a Web site nonsequentially. When you click a link, the Web browser jumps you 
to the page set as the link’s destination. Links appear as specially marked text or images on a 
page. Each page can have several links, with each link leading directly to another page within 
your site or to pages on any other Web server in the world. 

Your Web site Other Web site

Links
Home page

Link

Pages on
your server

Page on
another server
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In Adobe PageMill, creating a link can be as simple as dragging the icon of a page onto selected 
text or an image. For more information, see “Creating a link” on page 105.

Building a Web site
As with any publishing project, planning is important and can save you much time and trouble 
later. A Web site is structured very differently from printed books and periodicals, and its 
existence depends on both local and network hardware and software. Here are the suggested 
steps to follow in creating a Web site:

• Determine the requirements of your server

• Make a rough sketch of the site organization

• Organize the Web site files and folders on your computer

• Create the pages

• Add links

• Test the links

• Upload the pages to the server

Step 1: Determine the server requirements

In order to design and upload your site, you need to obtain specific information from your ISP, 
including who will be responsible for uploading the site. Before designing your pages, you 
must know:

• The URL of your Web site

• How much disk space is available for your site

• How you will be expected to deliver your files for publishing (filename conventions, transfer 
protocols, via disk or modem, and so on)

• If you plan to use scripts, the CGIs that are available

• If you plan to include server-side image maps, what kind of map format your server uses 
(NCSA or CERN), what operating system it runs, and the type of server software

Your Web server’s administrator or your ISP can provide this information. 
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Step 2: Sketch the page layouts and site links

Before you begin creating Web pages, you should know who your audience will be and what 
information you want to present (called the content). Then you can decide how your pages 
should look and how they will link together. 

For each page:

• Sketch the layout of text and images 

• Consider adding tables, movies, or sounds to the pages.

• Decide where to place links and what elements you’ll use for navigating through the pages. 
Avoid using too many links on a page that might confuse readers and keep them from following 
the information flow.

For the entire site:

• Diagram the relationships between the pages, showing the home page, and how pages link 
to each other and to pages outside your site 

• Devise a naming scheme for the files that make up your site

Step 3: Structure your Web site

Setting up the proper directory structure for your Web site is crucial to avoiding problems later 
(such as broken links when files are moved) when you try to upload your pages to a Web server. 
To display properly over the Web, all of a site’s page files and images must be stored on the Web 
server. To make sure that all site files transfer together when you upload your site from your 
computer to the Web server, set up your preferences and the folders for pages and images before 
you create the site.

To set up the directory structure for your Web site:

1 Create a folder on your computer that will hold your entire Web site. This is known as the 
site’s local root folder. 

2 Within the local root folder, create a folder for images where PageMill stores imported PICT 
or BMP images that it converts to GIF files. For more information on how PageMill treats 
imported files, see “Maintaining links to imported files” on page 87.

3 Choose Edit > Preferences, and click Resources.
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4 Do one of the following:

• (Macintosh) Click the icon for the Resource Folder, select the images folder you created in 
Step 2, and click In Here.

• (Windows) Click the Browse button to locate the images folder, and click OK.

Note: If you do not create and assign the images to a folder, PageMill creates a default folder called 
PageMill_Resources. Converted files stored in the default folder are not part of your local Web site 
and are not included when you upload your pages.

5 If you’re using server-side image maps, you may have to set additional preferences; see 
“Setting format preferences for a server-side image map” on page 122.

6 Save the first home page in the local root folder.

7 Within this root folder, continue to create subdirectories and insert all the files (including 
linked files) for your Web site. 

Important: Do not save, link, or insert any Web files from outside this site folder.

Step 4: Create the pages

Create pages in Adobe PageMill’s Page window, following your layout sketches. For more infor-
mation, see Chapter 3, “Adding Text” and Chapter 4, “Adding Images, Movies, Sounds, and 
Plug-in Objects.”

Follow these conventions when naming files:

• On Web servers other than Macintosh computers, be sure to follow the file-naming conven-
tions of the server’s platform. For example, do not use spaces in your filenames, and use only 
the characters A to Z, a to z, 0 to 9, - (hyphen), and _ (underscore). (On MS-DOS-based 
platforms, filenames must not exceed eight characters, not including the three-character 
filename extension.)

• Name HTML pages with either the .html or .htm filename extension (use .htm when you’re 
uploading the files to a DOS server). Without the file extension, some browsers may display the 
file as a text file with all of its coding. You set this extension in the Page Preferences dialog box.

Step 5: Add links

Following your link layout plan, add links between pages. For more information, see
Chapter 5, “Creating Links.”
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Step 6: Test links within your Web site

Test the links to local pages in Preview mode to ensure that no links between pages are broken. 
To test remote links, use the Switch > To command to launch your Web browser. For more 
information, see “Testing a link” on page 110. 

Step 7: Upload your pages to the Web server

When you have completed and tested your Web pages, upload them to the Web server. How 
you upload them depends on the type of server you are using and your connection to it. For 
more information, see Chapter 10, “Uploading Your Web Site.” If everything works, your pages 
are now available to anyone in the world with a Web browser. 

Maintaining your Web site
Most Web sites need periodic maintenance. For example, you may need to restructure your site 
as it grows; correct information on the pages; or add, delete, or rename files. Use Adobe 
PageMill to update your pages. Remember that deleting, moving, or renaming files can 
break links. 

When you are finished updating your Web site, upload it to the Web server, replacing the old 
version of the site. 

Creating, saving, and opening pages
In Adobe PageMill, you work with individual Web pages. 

Creating a new page

Choose File > New Page to create a blank page that is ready for you to add text, images, movies, 
and sound. You can have any number of pages open at a time. 

To set the defaults for all new pages:

1 Choose Edit > Preferences, and click Page.
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2 Set the background color or pattern.

• For a color, use the Background Color menu in the Appearance section. Choose Default 
to use the default color or choose Custom and select a color, and then click OK. 

• To set a pattern, drag a graphics file from the Finder or Windows directory window to the 
Background Image well or click the image icon (Macintosh) or File button (Windows) under 
the Background Image well to locate a file. 

3 To set the text and link colors, using the appropriate menus, choose Default to use the default 
color or choose Custom and select a color, and then click OK.

4 Click OK to close the Preferences dialog box. The default settings go into effect the next time 
you create a page.

Saving a page

Choose File > Save Page to save a page. Remember to save your work often. To save an existing 
page with a new name or new location, choose File > Save Page As. For file-naming conven-
tions, see “Step 4: Create the pages” on page 50.

If you are uploading your files to a DOS or UNIX server, you might want to save your files with 
a specific line break format and filename suffix.

To change the default file saving formats:

1 Choose Edit > Preferences, and click Page.

2 Select a format from the Line Breaks menu. 

3 Select a suffix from the Suffix menu.

4 Click OK to close the Preferences dialog box. The default settings go into effect the next time 
you save a page.

Opening a page 

In addition to opening existing PageMill documents, you can also open and edit Web pages 
you’ve downloaded. When opening a non-PageMill Web page on your computer, PageMill 
interprets all HTML tags that it understands, and displays a question mark for any tags that it 
cannot interpret. For more information, see Appendix B , “Viewing and Editing HTML Code.”
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PageMill may work with some HTML tags differently than other authoring applications. If you 
open a page that was not created by PageMill, make a copy of the original file before you start 
editing. After proofing the edited document, you can delete the original file. 

To open a PageMill page:

Choose File > Open.

To open a page from the Web: 

1 Use a Web browser or a file-transfer utility to download the source HTML code to your 
computer (graphics and linked files are not downloaded). You cannot open a page directly 
over the Web. 

2 Choose File > Open, choose All Readable or HTML (Macintosh) or All Files or HTML Files 
(Windows) from the File Type menu, and click Open. 

Opening a page in another application

You can also open a PageMill page in another application using the Switch To command. This 
is useful when you want to edit an image using a feature that PageMill does not support, such 
as cropping. 

Note: The application must be installed on your computer in order to appear in the 
Switch To menu.

To set up the Switch To menu:

1 Choose Edit > Preferences and click Switch To.

2 To add an application to the menu:

• (Macintosh) Click an unnamed icon, locate the application, click Open, and then click OK.

• (Windows) Click the Add button, locate the application, click Open, and then click OK.

3 To remove an application from the Switch To menu:

• (Macintosh) Click the trash can next to the application name. 

• (Windows) Click the application, then click the Remove button. 
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To open a page in another application:

1 Make sure the application you want to switch to is running.

2 Choose Window > Switch to (Macintosh) or View > Switch to (Windows).

3 Choose the application from the menu.

Viewing a page
You can view a page in Preview mode or Edit mode, and switch between the two modes 
at any time.

• Preview mode—indicated by the PageMill globe icon in the upper right corner of the 
page—is the default view when you open an existing page. In Preview mode, you can see how 
the page will appear in a graphical Web browser, and you can test hypertext links to other 
pages stored on your computer. You cannot alter a Web page in Preview mode. 

Note: Because PageMill is not a full Web browser, you cannot preview links to pages that are not 
on your computer, and you cannot preview scripted interactions with servers.

Preview mode
A. Globe icon

• Edit mode—indicated by the pen-and-paper icon in the upper right corner of a page—is the 
default view when you create a new page. In Edit mode, you can create and edit Web pages. The 
button bar at the top of the window is active in Edit mode.

Edit mode
A. Pen-and-paper icon

To view pages in Edit mode by default:

1 Choose Edit > Preferences, and click General.

2 Using the Open Pages in menu, choose Edit mode, and click OK.

A

A
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To switch between Preview mode and Edit mode:

Click the icon in the upper right corner of the page.

To preview linked pages, do one of the following:

• Click the link to display the destination page.

• Position the pointer over the link and press (Macintosh) or right-click (Windows) to display 
a menu. Choose Same Window to display the destination page in the same window or choose 
New Window to display the destination page in a separate window.

To preview linked pages in a new window by default:

1 Choose Edit > Preferences, and click General.

2 Using the Local Links menu, choose New Window, and click OK.

To preview GIF animations:

Switch to Preview to start automatic playback.

To preview QuickTime movies:

In Preview mode, click to start the move.

To preview sounds:

1 Click the sound link. 

2 To stop previewing a sound, press Command-period (Macintosh) or click the Stop button 
in the playback bar (Windows).
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To move between the most recently visited pages in Preview mode, do one of the following:

• Click the Home, Back, or Forward buttons at the top of the page. 

• Choose the page from the Title pop-up menu.

A. Title menu

Note: Moving between recently viewed pages is possible only when you’ve chosen to preview pages 
in the same window. 

Controlling the window display (Macintosh)
In PageMill, you can stack, tile, or close all windows. To control the window display, choose the 
corresponding command from the Window menu.

To set tiling preferences:

1 Choose Edit > Preferences and click General.

2 Click an icon to choose horizontal or vertical tiling, and click OK.

To switch windows:

Choose the window you want to display from the list at the bottom of the Window menu.

Controlling the window display (Windows)
In PageMill, you can stack, tile, or close all windows. Choose the display you want from the 
Windows menu. 

A
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Using the Inspector palette
The Inspector palette is a floating palette, active only in Edit mode, that displays information 
about the current page or selected page elements. It has four panels with controls and options 
for various objects: 

• The Frame panel has controls for frames that you create to divide Web pages. 

• The Page panel has options for the current page. 

• The Forms panel has options for the script associated with the form. 

• The Object panel has options for selected images, tables, and other objects. 

For more information about using a panel, see the description of the PageMill feature. 

To display a panel:

Click the corresponding tab. (The Frame and Object panels are unavailable if no frame or 
object is selected.)

A. Frame tab B. Page tab C. Text tab D. Object tab

To display or hide the Inspector palette:

Choose Window > Show Inspector (Macintosh) or View > Show Inspector (Windows) to 
display the palette. Choose Window > Hide Inspector (Macintosh) or View > Hide Inspector 
(Windows) to hide the palette.

DCBA



CHAPTER 258
Basic Concepts



59

Chapter 3: Adding Text 

ext and images are the most basic features of a Web page, and form the foundation 
for the links you will add later. This chapter describes how to add text to a Web page 
using the Adobe PageMill tools.

Adding text to a page
You can enter and edit text the same way you would in a word processor. When the page is 
empty, you must begin typing from the top of the page. If text exists on the page, you must type 
within, or at the beginning or end of the existing text.

You can add text to a Web page in these ways:

• Type text directly on the page.

• Copy or cut the text from another application, and then paste it into the page in PageMill.

• Drag the text from another application, and then drop it into the page in PageMill.

Macintosh Note: Drag-and-drop operations between applications require System 7 Pro or later, 
and the other application must support Macintosh Drag Manager.

• Using the Open command, import text in any of the formats supported by the 
PageMill application. 

T
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You can import text into PageMill from the following applications:

Importing text from another application removes most character or paragraph formatting. 
HTML does not preserve some special characters. For more information, see “Using special 
characters” on page 70.

To type text directly on a page:

1 If the page is not in Edit mode, click the globe icon in the upper right corner of the page 
window to switch to the pen-and-paper icon.

A. Pen-and-paper icon

2 Click the page where you want to type text. If there is no text where you click, the insertion 
point appears at the end of the existing text.

3 Type the text.

Application or File Format Filename 
extension

Macintosh versions Windows versions

AMIPro/Professional Word Pro .sam — 1.1 and later

ClarisWorks™ — 3.0 and later 3.0 and later

HTML files .htm, .html — —

Lotus® 1-2-3® .wks — 1A to 5.0

MacWrite Pro — 1.0 —

Microsoft Excel .xls 3.0 to 5.0 2.1 to 5.0, 7.0

Microsoft® Word .doc 3.0 and later 1.0 to 2.0, 6.0 and later

Rich Text Format (RTF) .rtf — —

Text-only .txt — —

WordPerfect® .wp5, .wp6 1.0 to 3.5 5.0 and later

A
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4 Choose from the following methods to end a line:

• To start a new paragraph, press Return (Macintosh) or Enter (Windows). (This creates a 
<P> HTML tag and results in a double-space between the text entries.)

• To create a line break within a paragraph, press Shift+Return (Macintosh) or Shift+Enter 
(Windows). (This creates a <BR> HTML tag.)

To import text by copying and pasting:

1 In another application, select the text and choose Edit > Copy. 

2 Switch to a page in PageMill.

3 If the page is not in Edit mode, click the globe icon in the upper right corner of the 
page window.

4 Click on the page where you want to import the text.

5 Choose Edit > Paste. PageMill does not use import filters when you copy and paste text.

To import text by dragging and dropping:

1 Set up page windows in PageMill and in the second application that supports dragging and 
dropping so that both are visible.

2 In PageMill, if the page is not in Edit mode, click the globe icon in the upper right corner 
of the page window.

3 In the other application, select the text.

4 Drag the text from the other application into the PageMill page window, and then position 
the text on the page.

5 Release the mouse button.

The drag-and-drop feature isn’t just for importing. You can quickly move text around 
a page or between pages by selecting it and then dragging and dropping it.
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To import text or spreadsheet contents using the Open command:

1 Choose File > Open.

2 Choose All Readable from the File Type menu (Macintosh) or All Files or Convertible Files 
(Windows) from the File of type menu to display all formats supported by PageMill. To read 
other text formats, you must have the appropriate plug-ins installed in the Text Converters 
folder in the PageMill Plug-ins folder.

3 Locate and select a file, and click Open.

PageMill creates a temporary HTML file while it’s importing and converting the file. This file 
named Untitledx.html (where x is the next sequential number), can be edited, dragged and 
dropped, or copied and pasted just like any other PageMill document.

If the file contains images in TIFF, PICT, JPEG, or BMP formats, PageMill converts the files to 
GIF format and saves them in the PageMill_Resources folder. For more information on 
importing graphic files, “Importing an image, movie, or sound” on page 80.

4 To keep your changes, save the file in PageMill.

To delete text:

1 Select the text.

2 Choose Edit > Clear, or press the Delete (Macintosh) or Backspace (Windows) key.

Applying paragraph formats
Formats structure the HTML pages. You apply different formats to parts of a page that 
serve different functions, such as headings, paragraphs of body text, and lists. Applying a 
format changes an entire paragraph. To change the appearance of individual words or charac-
ters, apply character styles instead; see “Applying character styles” on page 67. For more infor-
mation about how the page structure and page appearance differ, see “About Web page design” 
on page 42.

With all formats but the Preformatted format, browsers collapse multiple spaces, tabs, and 
end-of-line characters into a single space. (To maintain the desired spacing, you can also use 
tables. For more information, see Chapter 7, “Adding Tables.”) 
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To apply a format:

1 Click in a paragraph.

2 Choose from the following Format options:

• Choose the desired format from the Format menu in the toolbar. For a description of the 
formats, see the “Selecting a paragraph format” on page 64.

• Click the Indent Right (]) or Indent Left ([) button in the toolbar to indent a paragraph.

• Choose the desired format from the Format menu. For the Heading format, also choose a size 
from the Heading submenu. For a list, also choose a list type from the List submenu; for more 
information, see “Creating lists” on page 66.
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Selecting a paragraph format

You can choose the following formats either from the toolbar or from the Format menu:

Paragraph format Is a plain format used for body text. Applying the Paragraph format removes 
other paragraph formatting. 

Preformatted format Applies a monospaced, or fixed-width, font to selected paragraphs, and 
retains all of the original spaces and line breaks. The Preformatted format preserves the original 
appearance of text when each character takes up the same space on a line (such as column 
alignment and line breaks), and is useful for tables from some spreadsheet applications, 
such as a financial report from an older mainframe computer. Browsers typically display 
the Preformatted format in a monospace font such as Courier. 

Paragraph format applied to Preformatted format applied to tabular material.
monospaced tabular material.

Address format Is useful for formatting the e-mail address, the postal address, or the telephone 
number of the Web page author. In PageMill, the address appears in italics. The actual appear-
ance depends on the browser. (Remember that you still must link the mail text to make the 
browser jump to the mail command.) For more information, see “Creating a link” on page 105.

Note: Although PageMill allows you to center and right-align preformatted and address-styled 
text, HTML always displays these two formats as left-aligned text. If you want to center or 
right-align the text, try changing the format for the Preformatted or Address text to Paragraph, and 
then apply the Teletype style to the text.
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Heading formats Organize text on a page. PageMill supports the six levels of headings available 
in HTML 2.0. Heading sizes are relative, because the actual display size depends on the browser 
used to view the page. In general, use the largest size for the main heading on the page and use 
the other sizes for subheadings. When you select a Heading format, PageMill shows the Bold 
button depressed (and bold appears checked in the Style menu) because most browsers display 
all Heading formats in a bold type style. You cannot remove the boldface. 

A. Largest heading B. Larger heading C. Smaller heading

List formats Create different kinds of lists. Some List formats number or bullet listed items 
automatically. The actual appearance of a list depends on the browser. For more information, 
see “Creating lists” on page 66.

Indent formats Either remove space from the margins on both sides of the text (Indent Left) or 
add space to the margins (Indent Right). The actual amount of the indent depends on the 
browser; some browsers don’t indent at all.

Bottom paragraph indented right.

A

B

C
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Creating lists

Creating a list is similar to applying a format. You can also create a list containing more than 
one level, such as an outline, by combining a list format with indents. PageMill automatically 
applies a different bullet or numbering style to each level of a nested list. You can choose from 
six list formats:

• Bullet List and Directory List convert selected paragraphs into an indented, bulleted list. The 
bullets are added automatically in front of paragraphs that end with a carriage return—not 
lines that end with Shift+Return (Macintosh) or Shift+Enter (Windows). Use the Directory 
List format when making a directory. 

• Menu List converts selected paragraphs into an indented list with bullets.

• Numbered List converts selected paragraphs into an indented, numbered list. PageMill inserts 
number signs next to each item in the list. The correct numbers appear when a browser 
displays the list. 

• Term and Definition List formats are designed to be used together to present glossary 
information. The Term format positions selected paragraphs flush with the left margin of 
the page. The Definition format indents the selected paragraphs.

Bulleted list Menu list Numbered list A. Term format B. Definition list format

To apply a Bullet, Directory, Menu, or Numbered list format:

1 Click in a paragraph.

2 Choose Format > List, and then choose Bullet, Directory, Menu, or Numbered.

To add a paragraph under a single numbered entry, press Shift+Return (Macintosh) or 
Shift +Enter (Windows) twice to begin a new paragraph separate from the numbered entry.

To apply Term and Definition list formats:

1 Make sure that terms and definitions alternate and are separated by carriage returns.

2 Click in a term.

3 Choose Format > List > Term.

A

B
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4 Click in the definition associated with the term you just formatted.

5 Choose Format > List > Definition.

To create a nested list:

1 In an existing list, click in the paragraph that you want to nest.

2 Choose Format > Indent Right.

Changing paragraph alignment

PageMill provides left, center, and right paragraph alignment. (Some browsers do not support 
center or right paragraph alignment.) You change paragraph alignment using the toolbar.

To change paragraph alignment:

1 Click in a paragraph.

2 Click the Left Align Text button (X), the Center Align Text button (Y), or the Right Align Text 
button (Z) in the toolbar.

A. Left Align Text B. Center Align Text C. Right Align Text

Applying character styles
Character styles distinguish individual characters or words on a page. Applying a character 
style changes only the selected characters. (To change the characteristics of entire paragraphs, 
apply paragraph formats instead; see “Applying paragraph formats” on page 62.)

Some character styles, such as Sample, Keyboard, Code, and Variable, may seem unusually 
technical—a reflection of the roots of the Internet and HTML language in distributing reports 
throughout the scientific and technical community. You can choose from physical or logical 
character styles.

A B C
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To apply a character style:

1 Select a range of text.

2 Do one of the following:

• Using the Style menu, choose a character style, as described in the following two sections. 

• To apply a physical style quickly, click the Bold (ı), Italic (ˆ), or Teletype (T) button 
in the toolbar. 

Applying physical character styles

A physical style changes the appearance of selected text in a specific way. For example, applying 
the physical style Italic makes the selected text appear in italics in most browsers. Apply a 
physical style to make character formatting consistent across browsers. You can choose from 
four physical character styles:

• Plain is a basic style useful for body text.

• Bold applies a boldface version of a font.

• Italic applies an italic version of a font.

• Teletype applies a monospaced font.

Applying logical character styles

A logical style labels the selected text, but the actual appearance of the text depends on how a 
particular browser interprets the label. For example, applying the logical style Emphasis lets a 
browser use its own definition of Emphasis, which could mean italics, underlining, or boldface. 
Apply a logical style when the function of the selected text is more important than its specific 
appearance, or when you want a reader to control the appearance of character styles.

Strong Is intended as a more intense emphasis, often displayed with boldface text.

Emphasis Calls attention to the selected text. Many browsers display emphasis with italics.
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Citation Is intended for titles of publications or media, such as a book or videotape.

Sample Is useful for representing computer status messages, and is displayed by most browsers 
with a monospaced font.

Keyboard Is useful for representing text to enter into a computer, and is displayed by most 
browsers with a monospaced font.

Code Can be used to represent lines of computer code, and is displayed by most browsers with 
a monospaced font.

Variable Is intended for text used as a variable within computer instructions. For example, you 
could apply the Variable style to the phrase “your name” if the reader must substitute his or her 
name in the instructions.
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Using special characters 
On the Macintosh, you can type special characters (also known as extended characters) the 
same way you would in any other application, by using the Option key in combination with 
other keys or by copying and pasting special characters from the Key Caps application that 
came with your Macintosh. In Windows, you can type special characters by pressing the Alt key 
and then entering the four-number combination of the special character using the numbers 
on the keypad (not the numbers on the keyboard). For more information on entering special 
characters, see your Macintosh or Windows documentation.

Adobe PageMill automatically converts special characters into the ISO Latin-1 encoding 
supported by HTML 2.0. Some special characters cannot be represented in the ISO Latin-1 
character set. If you try to enter a special character that HTML does not support, PageMill 
filters it out whether you type it directly on the page or paste or drag it in from another 
application. 

Changing the font size
Although you can’t set an absolute font size for text on a page, you can indicate how the text 
size should differ from the browser’s default size. You can enlarge or decrease the font size, or 
you can specify a size relative to the surrounding text. Because only Netscape-compatible 
browsers support font size changes (the size won’t change in most other browsers), it’s best to 
change the font size only for limited special effects. To ensure that all readers can distinguish 
larger text, use a paragraph heading format.

Changing the base font size changes the default font size by a relative amount, from 1 (smallest) 
to 7 (largest). For example, a base font of 7 will be larger in a browser using a 24-point default 
font than one using a 12-point default font. The most you can change the relative font sizes is 
seven. For example, if the base font is set to 4, you can increase the relative font size up to +3 
(for value of 7), and you can decrease the relative font size by no more than -3 (value of 1).

To change the base font setting:

1 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or
View > Show Inspector (Windows).

2 Click the Page tab.

3 Choose a value from the Base Font menu.
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To increase the relative font size:

1 Select the text.

2 Do one of the following:

• Choose Style > Increase Font Size or Decrease Font Size to enlarge or reduce the font size 
by one size.

• Click the relative font size buttons (UV Macintosh) or († ® Windows) in the toolbar. Each 
click changes the relative font size by one size.

• Click the current relative font size button (between the font size buttons) and choose a new 
size from the menu.

A. Decrease relative font size B. Current relative font size C. Increase relative font size

Changing the color of text, links, and the page background
By default, text entered on a page is black and links are blue (these defaults are used by Netscape 
when no color specifications are included in the HTML code). You can change the color of text 
and the color of links, active links, and links that have been clicked. (If the link is an image, the 
border color changes.) The colors you set are visible only in Netscape-compatible browsers; all 
other browsers display text and links in the default colors set in the browser preferences. 

To set your own specified default color for text, links, and background color, you use the 
Preferences command. To change the colors for a single page, you use the Inspector. To change 
the color of selected text, you use the Text Color button in the toolbar. All of these methods use 
the color picker to select a new color. 

You can also select new colors for text, links, and the background color using the PageMill color 
panel. The color panel is a floating palette that contains 16 color swatches. You can customize 
the color panel. 

CBA
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To change the default colors for text, the page background, or links:

1 Choose Edit > Preferences, and click Page. 

2 For Appearance, choose Custom from the menus as follows:

• Default Text Color specifies the color of the text.

• Background Color specifies the page background.

• Link Color specifies the color of a link that the reader has not yet seen.

• Active Link Color specifies the color of a link as the reader clicks it.

• Visited Link Color specifies the color of links that the reader has recently seen.

3 Select a color and click OK.

4 Click OK in the Preferences dialog box.

To change the color of text, page background, or links for a specific page:

1 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or 
View > Show Inspector (Windows).

2 Click the Page tab.

3 Choose Custom from the appropriate menu and select a new color; click OK. Any changes 
apply to the entire page.

To change the color of selected text:

1 Select the text.

2 Click the Text Color button (c) in the toolbar, choose Custom, and select a new color; 
click OK.

Note: You cannot change the color of linked text using the Text Color button. All linked text must 
be the same color and is set in the Inspector. 
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To change the color of selected text, links, or the background using the PageMill color panel:

1 Choose Window > Show Color Panel (Macintosh) or View > Show Color Panel (Windows).

2 To change a color, do one of the following:

• To change selected text, select the text and drag a color from the color panel over the 
selected text.

• To change the color of all the text or a category of links, make sure the Inspector palette is 
visible, then drag a color from the color panel over a Colors menu in the Page panel. The new 
color appears as the selected color in the menu. 

• To change the color of the page background, drag a color from the color panel over the page 
icon or over the Background menu in the Page panel. 
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To customize the color panel (Macintosh):

1 Choose Window > Show Color Panel.

2 Do one of the following:

• Double-click a color swatch in the color panel and choose a new color from the color picker; 
click OK. The new color replaces the old color in the color panel.

• Select colored text in a page and drag the text over a swatch in the color panel. The custom-
ized panel is saved when you save a page and is then available for all pages.

To customize the color panel (Windows):

1 Choose View > Show Color Panel.

2 Double-click a color swatch to open the color box.

3 Do one of the following:

• Choose a color from the color selection box or type in the color values.

• Select colored text in a page and drag the text over a swatch in the color panel.

4 Click OK. The customized panel is saved when you save a page and is then available 
for all pages.

Checking spelling
The PageMill Check Spelling command lets you check the spelling in a file. Referring to a 
language dictionary, PageMill highlights misspelled or unknown words and words with 
possible capitalization errors. 

PageMill also comes with an Internet Dictionary and allows you to install one user 
dictionary—a separate file that you customize to supplement the base-language dictionary. 
The user dictionary contains all the words added to the dictionary during spelling checks or 
when correcting capitalization. For example, you can store the name of your company or your 
product in a user dictionary to ensure that you spell these names correctly. You must store the 
user dictionary file in the Spelling folder within the PageMill Plug-ins folder. To create or use a 
second user dictionary, quit the PageMill application, move the existing user dictionary to 
another folder so that you can create a new one, and then restart PageMill. 
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To check spelling:

1 Click in a page or select a range of text.

2 Choose Search > Check Spelling.

3 For Search Path Scope, choose from the following options:

• Choose Page to search the entire Web page.

• Choose Object to search within tables and form elements.

4 Deselect the Deep option to ignore spelling in tables and forms.

5 Deselect Wrap if you don’t want to continue searching at the beginning of a document after 
reaching its end.

6 Click Start to begin the spell check.

7 As PageMill finds unfamiliar words or other errors, choose from the following options:

• Click Ignore to continue checking spelling without changing text.

• Enter a correction in the Change To text box, and click Change to correct the selected occur-
rence or click Change All to correct all misspelled occurrences in the text.

• Select a word from the Suggestions list and click Change to correct the selected occurrence or 
click Change All to correct all misspelled occurrences in the text.

• Click Ignore All to leave all instances of the text unchanged.

• Click Add to store the text in the user dictionary and not mark subsequent occurrences
as incorrect.
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Chapter 4: Adding Images, 
Movies, Sounds, and 
Plug-in Objects

ou can give your Web pages individuality by adding images, animated GIFs, movies, 
animations, and sounds. You can also use these objects as links to other locations. In a 
Web page, images and other media are part of the column of text that makes up a Web 

page and they flow with the text as you add and delete text. Images, animations, movies, 
and sounds take much longer to download than text, so if you expect your readers to view 
your page over a regular telephone line, minimize the number of large or unnecessary objects 
on your pages.

About file formats and plug-ins
To be recognized by PageMill and the browser, images, animations, movies, and sounds must 
be named with the correct filename extensions, for example, .gif, .mov, .wav, and so on. If the 
files are not named correctly, they will not be displayed or played in a Web page. 

Web browsers display images in GIF and JPEG formats. In addition to these two formats, the 
Macintosh version of PageMill lets you import PICT files and the Windows version of PageMill 
lets you import BMP files. The PICT or BMP files are converted to GIF format by PageMill. 

PageMill can also import Adobe Acrobat Portable Document Format (PDF) files, movies 
in the Macintosh QuickTime and QuickTime for Windows® format, and Macromedia 
Shockwave™ files. To use PDF, movie, or Shockwave files, you must have the corresponding 
Netscape plug-ins installed in the Browser Plug-ins folder in the PageMill Plug-ins folder. 
PageMill is compatible only with plug-ins compatible with Netscape 2.0.

(Macintosh only) Some Netscape plug-ins require that you increase the amount of memory 
allocated to Netscape in order for the plug-in to work. When you install a plug-in that requires 
more memory, increase the memory partition for PageMill, just as you would for Netscape. For 
example, the Macromedia Shockwave plug-in requires an additional 300K of RAM. 

Y
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Note: Netscape plug-ins vary in quality. Editing a page with a plug-in window puts more demands 
on the plug-in than viewing the page in a browser. Some plug-ins that work in a browser may 
not work well in PageMill. If PageMill detects any kind of problem with the plug-in, it will display 
a broken plug-in icon in place of the object. Since not all plug-in difficulties can be detected 
by PageMill, be sure and save your work before attempting to use a plug-in with PageMill for 
the first time. 

To insert the browser plug-ins:

1 Determine what Netscape plug-ins you need.

2 Put a copy of these plug-ins in the Browser Plug-ins folder inside the PageMill 
Plug-ins folder. (These plug-ins should also be in your Netscape Plug-ins folder.) 

Macintosh Note: To be sure you have all the same plug-ins in the two plug-ins folders, you can 
create an alias to your Netscape plug-ins folder, copy the alias folder into the PageMill Plug-ins 
folder, and then rename the folder Browser Plug-ins.

3 Restart PageMill.

Image and animation file formats

PageMill can open images in the following formats:

BMP (.bmp) Is the standard Windows bitmap image format on DOS and Windows computers. 
The Windows version of PageMill converts a copy of a BMP file into a GIF file.

(.dib) Is a type of BMP file and is treated like files with the BMP extension.

GIF (.gif) Is an 8-bit color format that can display up to 256 colors and is generally useful for 
nonphotographic images with a fairly narrow range of color, such as a company logo.

JPEG (.jpeg or .jpg) Is appropriate for images with a wide range of color, such as a 24-bit 
(millions of colors) photograph. 

Macintosh Picture (PICT) files Include files that you copy and paste or drag and drop from other 
applications such as Adobe Illustrator® 6.0 and Adobe Photoshop. The Macintosh version of 
PageMill converts a copy of a PICT file into a GIF file. 
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Animated GIF Contains a sequence of several images in a single file. Switching to Preview 
mode makes an animated GIF file cycle through the images like an old-fashioned flipbook. 
You can create the animated GIF file using GIFLoop, GIFConverter, or GifBuilder 
(http://iawww.epfl.ch/Staff/Yves.Piguet/clip2gif-home/GifBuilder.html).

Important: Only a few major browsers currently support animated GIF files, so be sure to preview 
your page in your intended browser to ensure that it appears as desired. Some browsers play an 
animation through only once, or display only the first or last frame of the animation. 

Progressive JPEG files Are similar to interlaced GIF files. You can import a progressive JPEG file, 
but the image does not display until you save and preview the page in Netscape or using 
another browser. To import a progressive JPEG file, you use the Place Object button in 
the toolbar.

Adobe Acrobat Portable Document Files (PDF) From any version of Adobe Acrobat can be 
imported. To be read, you must install the Adobe Acrobat 3.0 Reader and you must have the 
correct plug-in installed in the Browser Plug-ins folder. (See “About file formats and plug-ins” 
on page 77.)

(Macintosh only) To import images that are not in GIF, JPEG, BMP, or PICT format, you can 
use the Adobe ScreenReady application (available separately) to convert them as a batch into 
PICT graphics, which PageMill can import and convert directly. This works especially well 
with EPS files.

Shockwave (.dcr) Are Macromedia Director® movies that have been compressed using 
Afterburner. To use these files, you must have the correct plug-in installed in the Browser 
Plug-ins folder. (See “About file formats and plug-ins” on page 77.)

Java applets (.class, .java, .jav) Are animations created using the Java programming language. 
PageMill can recognize applets but cannot preview them.

Movie file formats

PageMill can open movies in the following formats:

QuickTime movies (.mov) Require that QuickTime 2.1 or later (Macintosh) and QuickTime for 
Windows 2.0 (Windows) be installed on your computer. The QuickTime plug-in must be 
installed in your Browser Plug-ins folder. (See “About file formats and plug-ins” on page 77.) 
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Macintosh Note: Before you can play a Macintosh QuickTime movie in a browser, you must 
flatten the movie. Flattening removes the resource fork from the Macintosh movie file. You can 
flatten movies using Adobe Premiere® 3.0 or later or other applications such as MoviePlayer™ 2.0, 
Movie Converter 1.0, or FlattenMooV. For instructions on flattening movies, see your application’s 
documentation or use the Adobe automatic Fax-back service, Adobe FaxYI, at 206-628-5737, and 
request FaxYI 200309 or FaxYI 143604.

Window AVI movies (.avi) Require the appropriate Browser plug-in be installed. (See “About file 
formats and plug-ins” on page 77.)

MPEG movies (.mpg or .mpeg) Require the appropriate Browser plug-in be installed. (See 
“About file formats and plug-ins” on page 77.)

Sound file formats

Many sound formats are available to browsers, depending on the equipment you use to record 
the sound and the computer you use to store the sound file. “Importing” a sound actually 
creates a link to the sound file; you can create the same effect by linking to the file. (See Chapter 
5, “Creating Links,” for more information.) Imported sound appears as linked text. To be 
recognized by PageMill and the browser, sound filenames must have the correct extension.

PageMill can import sound files in the following formats:

AU files (.au) Are the most commonly used format for cross-platform applications (the µ-law 
format is also called AU from the file extension used for these files).

Audio Interchange File Format files (.aiff, .aif, and .aifc) Are widely used on Macintosh and 
Silicon Graphics® computers.

WAVE files (.wav) Are used with Microsoft Windows applications. 

Importing an image, movie, or sound
An image on a Web page can be:

• A static picture that provides visual information. This chapter describes this use.

• A link to another resource. (See “Creating a link” on page 105.)

• An image map with multiple links to other resources. (See Chapter 6, “Creating Image 
Maps.”)

• A Submit button on a form. (See “Using an image as a Submit button” on page 169.)
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If you have many images to display, you can create a page of thumbnails, or small versions of 
each image in an image-editing application such as Adobe Photoshop, and link each thumbnail 
to a full-size version of the image. A page of thumbnails downloads much faster than a page 
of full-size images. Readers then can see the full-size version of any image by clicking its 
thumbnail. For information on choosing and using images to include on a page, see “Graphics 
considerations” on page 44.

You can add images, movies, and sounds to your Web page in any of these ways:

• Drag and drop from another page, from the Finder or a Windows directory window, or from 
another application. You can drag and drop images from Adobe Photoshop 3.0.4 or later 
and from Adobe Illustrator 6.0 and later (Macintosh) or Adobe Illustrator 7.0 and later 
(Windows) directly into PageMill. Note that dragging and dropping a selection onto an 
existing selection creates a link to it; for more information, see Chapter 5, “Creating Links.” 

Macintosh Note: To use drag and drop, you must have System 7.5 or System 7 Pro and the other 
application must support Drag Manager.

• Drag from another page or from another application using the PageMill Pasteboard. The 
Pasteboard has five pages to organize copied selections. Selections remain on the Pasteboard 
even after quitting and restarting PageMill. 

• Copy and paste from another page or from another application. For information about 
copying a graphic from your browser page, see your browser documentation.

• Use the File > Place command or the Place Object button in the toolbar.

• Use the File > Open command and choose from the image formats in the File Type menu; 
GIF, JPEG, or PICT (Macintosh) or Image Files (Windows). This opens the image in an 
Image window.
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• Drag the image icon from an Image window to your PageMill page.

Various ways to import images, animations, movies, and sounds into PageMill 

Important: Before adding images for the first time, set up the default Resource folder for images. 
See “Step 3: Structure your Web site” on page 49. 

To import an image, movie, or sound from another application by dragging and dropping:

1 Set up a window in PageMill and the window in the application containing the item you 
want to import so that both windows are visible.

2 Make sure that the PageMill window is in Edit mode. 

3 In the other application, select the image, animation, or sound.

4 Drag the image, animation, or sound from the other application into an open PageMill 
window, and position it on the page. 

Dragging and dropping an image imports it as a PICT or BMP file, which PageMill converts to 
a GIF file named Imagex.gif and places in the PageMill_Resources folder. For best results, don’t 
try to import movies by dragging and dropping.

Finder window

Photoshop window
Image
window

Pasteboard
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To import an image, movie, or sound from the Finder or a Windows directory window:

1 Set up a window in PageMill and the window containing the file icon so that both 
are visible.

2 Make sure that the PageMill window is in Edit mode. 

3 Select the image, animation, movie, or sound file icon and drag it into the open 
PageMill window.

Dragging a multilayered image file from Adobe Photoshop 3.0.4 and later drags only the active 
layer. To import all layers, flatten the layers in Photoshop before importing.

Note: Command-dragging a PICT file (Macintosh) or Ctrl-dragging a BMP file (Windows) 
displays a dialog box that you can use to name the converted file. Make sure that PageMill is the 
frontmost application before you drag.

To create a link to an image, movie, or sound, rather than placing it on the page: 

Command-drag (Macintosh) or Alt-drag (Windows) the file icon from the Finder or a Windows 
directory Window. (For more information about links, see Chapter 5, “Creating Links.”)

To add an image, movie, or sound to PageMill using the Pasteboard: 

1 Make sure that both windows are visible and that any PageMill windows are in Edit mode.

2 If the Pasteboard is not visible, choose Window > Show Pasteboard (Macintosh) or
View > Show Pasteboard (Windows).

3 Drag the image, movie, or sound from the Pasteboard.

To add an image, movie, or sound by cutting and pasting using the Clipboard:

1 Make sure that both windows are visible and that the PageMill window is in Edit mode.

2 In another application, select the image, movie, or sound and choose Edit > Copy. 

Macintosh Note: Adobe Illustrator 6.0 supports dragging and dropping files. If you are using 
Illustrator 3.0 or later up to version 6.0, you must convert Illustrator paths into a PICT image by 
pressing Command+Option+C instead of choosing Edit > Copy.

3 Switch to a page in PageMill.
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4 Click the page where you want to import the image, movie, or sound.

5 Choose Edit > Paste.

Copying and pasting an image imports it as a PICT file (Macintosh) or BMP file (Windows), 
which PageMill converts to GIF as Imagex.gif and places in the PageMill_Resources folder. 

To add an image, movie, or sound using the Place command or button:

1 Make sure the PageMill window is in Edit mode. 

2 Choose File > Place (or click the Place Object button (v) in the toolbar).

3 For Object Type, choose an option: 

• All (Macintosh) or All Files (Windows) to select all object types

• Images to select GIF and JPEG graphics (Macintosh), or .bmp, .dib, .gif, .jpg (Windows)

• Java applets

• Adobe Acrobat (PDF) files

• Sounds for AU, AI, AIFF, AIFC, and WAV formats

• HTML Files 

4 Locate the image, movie, or sound that you want to add. 

5 To specify an element not present on your hard drive, select the Remote URL option and 
enter the URL of the element. (For more information, see “About URLs” on page 104.) You can 
also create a local alias for remote objects.

6 Choose how to place the selected element, as follows:

• Click Place to have PageMill place data it recognizes into the appropriate object type—image, 
Java applet, Netscape plug-in object. 

• Click Link To to create a link to the object. 
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To add an image file from an Image window to your PageMill page:

1 Make sure that both windows are visible and that the PageMill window is in Edit mode.

2 Drag the GIF image icon from the Image window to the open PageMill page where you want 
to add it.

To add a media object (QuickTime movie, PDF file, Shockwave animation, and so on) to a
PageMill page:

Choose from the following options:

• Drag the file icon from the Finder or Windows directory window to your page.

• Choose File > Place to select and place the object on the page. 

If PageMill cannot recognize the file type but the filename has an extension, PageMill assumes 
that the file contains data for a plug-in and creates an empty Netscape plug-in data object 
(using the EMBED tag).

Macintosh Note: PageMill can recognize, but not preview, Java applets.

Many plug-in objects can be resized by selecting the object and dragging the handles that 
appear, or by using options in the Inspector palette’s Object panel.
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To play an animated GIF file, movie, animation, or a sound:

1 If the page is not in Preview mode, click the pen-and-paper icon in the upper right corner. 
Animations automatically play through one cycle when you switch to Preview mode. 

2 Choose from the following options:

• To play a movie, click the movie to start the playback. 

• To play a sound, click the sound.

PageMill does not load a movie or sound into local memory before starting playback. When 
you’re playing a multimedia object over a network, you might get slow, noisy, or unpredictable 
playback if the transmission is interrupted while the object is playing. To avoid this problem, 
store all multimedia objects on your local hard drive. 

Note: An alert message appears and the movie or sound won’t play if the supporting file format 
plug-in isn’t installed in the Browser Plug-ins folder. For more information, see “About file formats 
and plug-ins” on page 77.

Determining the download time of pages and objects
As you create your PageMill page, it’s helpful to know how much time graphics and other page 
objects will take to download from a browser. To avoid frustrating readers with lengthy delays 
as pages download, you can use the Download Statistics command to estimate the download 
time, and adjust your page design accordingly. 

To determine the size and download time of pages and selected objects:

1 In Edit mode, place the insertion point in a page or frame or select an object.

2 Choose Edit > Download Statistics. 
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The Download Statistics dialog box displays the selected element’s file size and estimated 
transfer time. The Object section shows the estimated download time for a selected object. The 
Page section shows the estimated download time for the active document plus its linked files. 
When the active document is a frameset file, the Frameset section shows the download time for 
the frameset including all its source documents and linked files. The green pie chart 
represents the first minute of download time. If the download will exceed one minute, PageMill 
uses a blue pie chart inside the green pie chart.

Download time is based on the modem’s average speed. The actual time to transfer informa-
tion may vary, for example, if the server is busy or if files are being downloaded from a 
great distance.

3 For kbps, choose the modem speed you expect readers to use. 

4 Click OK when you have finished viewing the information.

Maintaining links to imported files
It’s important to keep in mind how images link to your Web page, because moving an image or 
other linked file after you have imported it can break the link:

• Importing a GIF or JPEG file into PageMill creates a link from your Web page to that image 
wherever it resided when you imported it.

• Importing a PICT file or BMP file copies the file (leaving the original intact), converts the 
copy to GIF format as Imagex.gif (Image1.gif, Image2.gif, and so on), and stores the copy in the 
PageMill_Resources folder as the link to your Web page. The Web page links to the GIF copy, 
not to the PICT or BMP original. 

Properly setting up the PageMill_Resources folder ensures that all converted and linked images 
are stored in one place, inside the local root folder of your Web site. Use the Preferences 
command to set up the folder, before you import any PICT or BMP image files. For more 
information, see “Step 3: Structure your Web site” on page 49. Keep in mind that renaming the 
generic Imagex.gif breaks the link to the original file. To relink the file, you must locate the orig-
inal link and recreate the link using the renamed file.



CHAPTER 488
Adding Images, Movies, Sounds, and Plug-in Objects

Locating missing objects 
If an icon with a question mark appears where an image or other object should be when you 
preview a page, the object cannot be found on the disk. An object may be missing if you deleted, 
moved, or renamed the object on your computer. (See the previous section, “Maintaining links 
to imported files.”) The missing-image icon also displays the path of the object it’s looking for. 

Missing-object icon

Note: PageMill displays the missing-object icon if a file name contains the invalid “/” character, 
which is also invalid on the Web. To correct the problem, rename the file and then reimport or relink 
it to your PageMill page.

To find a missing object:

1 Double-click the missing-object icon.

2 Locate the object, and then click OK.

Finding and replacing objects
PageMill lets you search for and replace any object that you can select—including text, images, 
movies, sounds, and objects such as form controls, buttons, and links. 

To search for an object:

1 Select what you want to search for. You can select anything on a Web page—embedded 
objects such as links or form buttons or controls, text, and so on.
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2 Choose Search > Find.

3 In the Find dialog box, drag the selection, or copy and paste the selection into the Find text 
box. The selection appears in miniature.

4 For Find, choose from the following options:

• Choose Page Content to search for page objects.

• Choose Link Address to search for URLs that are underlying the links on the page.

5 For Search Path Scope, choose from the following options:

• Choose Page to search the entire Web page. 

• Choose Object to limit the search to within tables and form elements. 

6 Leave the Deep option selected to search inside of tables and forms; or deselect Deep to skip 
all occurrences inside tables and forms. (If you’re in a table, Deep applies to any nested tables.)

7 Leave the Wrap option selected to continue the search at the beginning of the page or object 
when you reach its end; deselect Wrap to stop at the end of the page or object.

8 Choose from the following Constraint options to limit the search:

• Choose Text Case to match the case (upper- or lowercase) of the selection.

• Choose Text Style to match the typeface style of the selection.

• Choose Whole Word to match the selection to occurrences as whole words.

• Choose Object Size to match the size of the original selection.

9 To replace the found selection with something else (text, an image, and so on), enter, drag, 
or copy and paste the replacement item in the Replace With text box. 
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10 Click Find. PageMill highlights found text or objects on the page, or displays the URL of 
found links in the Link Location bar.

11 Choose from the following options to continue the search:

• Choose Find Next to find the next occurrence of the selection.

• Choose Replace to replace the found occurrence with the item in the Replace With text box.

• Choose Replace & Find to replace the found occurrence with the item in the Replace With 
text box, and then find the next occurrence.

• Choose Replace All to change all occurrences of the found selection with the item in the 
Replace With text box.

Making part of an image transparent
You can make parts of a GIF file transparent in PageMill by selecting one color in the image and 
making it transparent. The transparent areas appear as the browser window’s background color 
(or pattern). If you use a single-image file more than once in your site, all instances of the image 
use the same transparency settings as the original file.

Because you can specify only one color as transparent for each image in PageMill, avoid
anti-aliasing the outside edges of a GIF image. An anti-aliased edge will contain variations of 
the background color that won’t be transparent, creating an unwanted halo against the page 
color or the background pattern.
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You can use an image-editing application to specify multiple colors for transparency—such as 
Adobe Photoshop 3.0.4 or later and its GIF89a Export module. 

GIF files do not lose color information when you apply transparency, so you can change the trans-
parency setting at any time. For example, if you applied transparency to red areas of an image and 
then later apply transparency to green areas, the original red color information reappears.

Image before transparency Transparency applied

To make part of an image transparent:

1 As an option, in an image-editing application, select the part of the image that will remain 
(not be transparent). Fill all other areas with one color (but not a color used in the parts of the 
image that you want visible). Save the file.

Note: You can switch to an editing program from within PageMill by adding the application to the 
Switch To window. See “Opening a page in another application” on page 53.

2 In PageMill, select the image and choose File > Open Selection, or choose File > Open and 
choose from the image formats. The image appears in an Image window.

3 In the Image window, select the transparency tool (D), and click the color that you filled 
with in step 1. 

4 Close the Image window and save the file.

To change a transparent area back into an opaque area:

1 In PageMill, hold down Command (Macintosh) or Alt (Windows) and double-click the 
image to open it in the Image window.

2 Select the transparency tool and click the transparent area.
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Displaying a text label instead of the image
When readers will be using browsers that cannot display graphics or have optional graphic 
display, you should include a text replacement for the image. In the Web browser, the text label 
appears in place of the image. 

To add a text label to an image:

1 Select the image.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or
View > Show Inspector (Windows).

3 Click the Object tab.

4 In the Alternate Label text box, type a label and then press Return or Enter.

Image label in browser

Changing the size of an image
You can resize an image visually or by a specific amount, either by pixel dimensions or as a 
percentage of the height or width of the browser window size. You can maintain the horizontal 
or vertical proportions of the image as you resize it.
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Resizing an image in PageMill always overrides the original image size, even if you later change 
the image dimensions in another application. To quickly change the dimensions of an image 
that appears on many pages, do not resize it in Adobe PageMill. Instead, resize the original 
image in an image-editing application to update all instances of the image at once.

Note: Reducing an image’s dimensions in PageMill doesn’t make the image download faster 
because PageMill doesn’t resample (reduce the number of pixels) in the images you resize. To make 
images download faster, resample them in an image-editing application such as Adobe Photoshop 
and then reimport them into PageMill.

To resize an image visually:

1 Select the image.

2 Drag one of the handles on the edge of the image, as follows:

• To resize only horizontally, drag the handle on the right edge.

• To resize only vertically, drag the handle on the bottom edge.

• To resize both dimensions, drag the handle at the bottom right corner.

• To maintain the original image proportions, click the handle, hold down the Shift key, 
and then drag the bottom right corner handle (you must hold down Shift before you 
begin dragging).

Original size Image resized

To resize an image numerically:

1 Select the image.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or 
View > Show Inspector (Windows).



CHAPTER 494
Adding Images, Movies, Sounds, and Plug-in Objects

3 Click the Object tab.

4 In the Width or Height option, choose a unit of measure from the menu:

• Pixels measures dimensions in screen pixels on the page.

• Percent refers to the window size, with 100% width or height equaling the window’s width or 
height. The image automatically resizes in proportion to the size of the browser window that 
displays it. Proportional resizing is useful, for example, for displaying a banner image at the full 
width of a browser window.

5 Specify new dimensions using one of the following options. You can move between fields 
by pressing Tab:

• To change the vertical dimension, deselect the Scale to Width option, and then type a value 
in the Height option.

• To change the horizontal dimension, deselect the Scale to Height option, and then type 
a value in the Width option.

• To reset the image to its original size, select Scale to Height and Scale to Width.

6 Press Return or Enter.
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Aligning an image with text
If you position an image within a line of text and the image is taller than the text, the image will 
increase the line spacing in that line of text. You can align the top, center, bottom, right, or left 
side of the image with the text. PageMill also supports wrapping text around an image. 

To align an image with text:

1 Select the image.

2 Click the Top Align Object (Q), Middle Align Object (W), Bottom Align Object (E), Left 
Align Object (R), or Right Align Object (F) button in the toolbar.

A. Top Align Object B. Middle Align Object C. Bottom Align Object
D. Left Align Object E. Right Align Object

To create a text wrap:

1 Select the image.

2 Click the Left Align Object button (R) or the Right Align Object button (F) to wrap 
multiple lines of text around the image. 

3 To end the text wrap, choose Edit > Insert Invisibles > Margin Break to insert a margin break 
character (/). The margin break inserts a line break that extends down below the image and 
resets the insertion point at the current left margin.

Adding a border to an image
You can add a border to an image. A border always surrounds the rectangular boundaries of an 
image, regardless of the image’s shape.

C D EBA
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Most browsers display a two-pixel border around a linked image and no border around 
unlinked images. Keep this convention in mind when using borders with linked and 
unlinked images:

• If you add a border to an unlinked image and you don’t want the border to look like a link 
border, specify a border width other than two pixels.

• If you remove a border from a linked image, design the image so that a reader can tell that it 
is a link.

To add or remove an image border:

1 Select the image.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or
View > Show Inspector (Windows).

3 In the Object panel, type a number into the Border option, or type zero to remove an existing 
border. (If you leave this option blank, the browser determines if a border will appear around 
the image.)

4 Press Return or Enter.

Border value 5 applied
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Creating an interlaced image
Interlacing prevents the undesirable display of empty areas of a page while large images are 
downloading by gradually revealing a GIF file. Web browsers that do not support interlacing 
can still display interlaced GIFs, but without the interlacing effect.

You can’t preview the interlaced effect in Adobe PageMill. To see the interlacing, you must load 
the page in a Web browser that supports interlaced GIF files.

To create an interlaced image:

1 Hold down Command (Macintosh) or Alt (Windows) and double-click a GIF image 
on a page.

2 In the Image window, click the interlace icon (u Macintosh) or (i Windows). 

3 Close the Image window and save the file. Interlacing affects all instances of the image that 
appear in the Web page.

Using an image as a page background
You can use an image as the background pattern for a page. When a Web browser that supports 
Netscape backgrounds displays the page, the browser will tile, or repeat, the pattern behind the 
text and graphics on the page. You can use any image that PageMill can import. For more infor-
mation, see “Image and animation file formats” on page 78.

A background image can detract from the effectiveness of a page if used improperly. Here are 
some considerations for creating an effective background:

• Don’t use an animated GIF file as a tiled background image. Browsers cannot run the anima-
tion sequence when the animated GIF is tiled as a background, and depending on the browser 
used, only the first or last frame of the image appears.

• Minimize the level of contrast and color saturation in the background image. An intensely 
colored or visually busy background can make the page text difficult to read.

• Use a small image so that it downloads quickly.

• Avoid using transparency in background images, because the Macintosh Netscape 2.0 
browser cannot display them.
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To add a page background using the Inspector palette:

1 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or 
View > Show Inspector (Windows).

2 Click the Page tab. The Background Image well is in the Page panel.

3 Choose from the following options:

• In the Page panel, click the page icon (Macintosh) or the File button (Windows) below the 
Background Image well, and locate and open a file. 

• Drag a file from the Finder or Windows directory window into the Background Image well.

• Select and drag an image from an open PageMill page into the Background Image well or 
drag an image from another application.
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To add a page background using the page icon:

1 Locate the image file or open the image in its own application.

2 Drag the file from the Finder, Windows directory window, or open document over the page 
icon on the PageMill page.

To remove a background image:

1 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or 
View > Show Inspector (Windows).

2 Click the Page tab.

3 Click the trash can icon (Macintosh) or the Clear button (Windows) below the Background 
Image well.

Adding horizontal rules
Horizontal rules are a useful option for dividing your Web page into sections. You can change 
the size (thickness) and width of a horizontal rule visually or numerically. Width specifies how 
far the rule extends across the page as a percentage of the page width or as pixels.

To add a horizontal rule:

1 Click where you want to insert the rule.

2 Click the Insert Horizontal Rule button (w) on the toolbar. 
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To make a horizontal rule unshaded:

1 Select the rule.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or
View > Show Inspector (Windows).

3 In the Object tab, select the No Shade option. 

To change the dimensions of a rule visually:

1 Select the rule you want to edit.

2 Drag one of the handles on the edge of the rule, as follows:

• To resize the horizontal dimension only, drag the handle on the right edge.

• To resize the vertical dimension only, drag the handle on the bottom edge.

• To resize both dimensions freely, drag the handle on the bottom right corner.

• To resize while keeping the most recent proportions of the rule, hold down the Shift key as 
you drag the bottom right corner handle.

To change the dimensions of a rule numerically:

1 Select the rule you want to edit.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or 
View > Show Inspector (Windows).
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3 In the Object tab, choose from the following resize options:

• To change the width, choose a Width option: Choose Percentage and enter a percentage 
to specify how far the rule extends across the default page; or choose Pixels and enter the 
width in pixels.

• To change the size, enter a value in the Size text box in pixels to specify the rule’s thickness.

A. Default horizontal rule B. Size 10, width 75% horizontal rule

4 Press Return or Enter.

A

B
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Chapter 5: Creating Links

link takes you from the current page to another location—somewhere else on the same 
page, on another page within your Web site, or on a page on any other server on the 
Internet. A link can be any text, image, or part of an image (called an image map) on 

your page. For more information about image maps, see Chapter 6, “Creating Image Maps.”.

How links appear on a Web page
In Adobe PageMill, as in most browsers, text links appear in blue, and image links appear with 
a blue border by default. When you’re in Preview mode and pass the pointer over a link, the 
pointer changes to a pointing hand. In a Web browser, after you use a link it usually changes 
color to let you know you’ve clicked it. However, the actual appearance and pointer behavior 
for links may vary depending on the settings in the reader’s Web browser.

A. Linked text B. Linked graphic

You can set the colors for normal, active, and visited links on Netscape-compatible browsers. 
For more information, see “Changing the color of text, links, and the page background” on 
page 71.

A

A B
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About URLs
Every link uses a URL, or Uniform Resource Locator, to find its destination. A URL is similar 
to the directory paths used in operating systems such as MS-DOS or UNIX, and includes the 
appropriate protocol required by the link. (For more information about structure of a URL, see 
“Using Web addresses” on page 41.) For example, a Web page could have a URL such as:

http://www.company.com/departments/sales/western.html

URLs are either absolute or relative:

• An absolute URL gives the complete pathname from the root of the server to the name of the 
page to be linked. An absolute URL won’t work if you move the file to another directory or 
server, because the URL no longer matches the directory names in the path. For example:

http://www.company.com/departments/sales/western.html

• A relative URL describes the location of the linked page relative to the current page. In the 
following example, the two periods tell the browser that the file is located in the folder above 
the folder containing the current page. If you move a file referenced by a relative URL to 
another directory or server, the link continues to work as long as the file exists one directory up 
in the hierarchy. 

../listformats.html

Important: If you must move a site between your computer and the Web server, relative URLs are 
more likely to preserve the links on both machines.

As long as PageMill supports the URL type, you can link to other URL types supported by 
World Wide Web browsers, such as ftp, gopher, and mailto. For example, to let readers of your 
page send you messages through e-mail, you can use the mailto URL type to link to an 
e-mail address.

PageMill supports the following URL protocols:

• file:// Opens a file on a mounted volume

• http:// Opens a World Wide Web page

• ftp:// Connects to a server using the file transfer protocol

• gopher:// Connects to a Gopher server

• telnet:// Connects to a server using Telnet

• news: Connects to a Usenet newsgroup
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• mailto: Sends an electronic mail message

• snews: Opens a secure newsgroup connection

• shttp:// Opens a secure World Wide Web connection 

The specific use of URLs is outside the scope of this guide. 

Creating a link
To create links in PageMill, you select the text or object that will be the link and then you specify 
the URL for the link destination. When a reader clicks on a link, they jump to the destination. 
This destination can be somewhere in the same page, somewhere in another HTML file, a 
graphic, movie, or other media object, another page on the Web, or another Internet service 
such as mailto. Having the correct URL address is critical to making the link work. Each link’s 
protocol must match the type of link that you’re creating. For more information, see “About 
URLs” on page 104.

A link to a page leads to the top of a page. (To link to a location elsewhere on a page, create an 
anchor first, and then link to the anchor. For more information, see “Creating an anchor” on 
page 112.) 

Creating a link to a PageMill or Netscape browser page

You can create a link in PageMill by dragging and dropping, by copying and pasting, by using 
the Place command, or by typing.

To create a link to a PageMill or Netscape page:

1 Open the page where you will create the link.

2 Select the text, image, or object that will be the link. 
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3 Choose from the following options:

• Open a PageMill destination page and drag the page icon and drop it onto the selection. (You 
must have saved a PageMill document before it’s page icon is available.)

• Drag a file icon from the Macintosh Finder or Windows directory window over the 
selected text. 

PageMill creates a relative link when you link pages by dragging and dropping. You don’t need 
to enter a URL.

• Drag linked text from the Pasteboard onto a page. (For more information, see “Keeping 
frequently used links handy” on page 116.)

• Drag linked text from a Netscape page or from the Netscape Bookmarks Window over the 
selected text. You can also drag links from Netscape into the Link Location bar.

• Click the Link Location bar at the bottom of the PageMill window, and type the URL of 
the destination page, then press Return or Enter. This is the only way to link to remote sites 
or resources.

• Choose File > Place. Select the file that you want to link to, and click Link To. (To link to a 
remote site, see “Creating a link to outside Web sites or other resources” on page 107.) 

Note: When you create links to files, be sure that you also store the files in your Web site folder before 
you upload your site. For more information, see “Step 3: Structure your Web site” on page 49.

Select text in first window . . . then drag page icon from second window to create link.
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Creating a link to an image or other object

You can create a link to an image or other object without placing the object on the page. The 
link address appears instead of the object itself.

To link to an image or object without inserting it on the page:

Hold down Command (Macintosh) or Alt (Windows), and drag the image file icon onto a page 
or choose File > Place, select the file, and click Link To. (For more information about placing 
images and objects, see Chapter 4, “Adding Images, Movies, Sounds, and Plug-in Objects.”

Creating a link to outside Web sites or other resources

When you’re creating links to remote Web sites or other Internet resources, you enter the 
URL by typing. 

1 Select the text or image that you want to become a link.

2 Do one of the following:

• Click the Link Location bar at the bottom of the PageMill window, and type the URL of the 
destination, then press Return or Enter. 

Note: If you type the first letter of the URL protocol, and then press the Tab key, PageMill enters
the rest of the URL protocol for you. (For example, to enter http:, type h and press Tab. PageMill 
enters ttp: and you can type the rest of the URL.) Use the same shortcut to enter the domain, by 
typing its first letter and pressing Tab to have PageMill fill in the rest (for example, .edu, .com, .net, 
and so on).
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• Choose File > Place. Select the Remote URL option and enter the URL of the file you will link 
to. Click Link To. The linked URL appears on the PageMill page.

Using local aliases

When you’re linking to resources outside of your root folder, you can create a local alias for the 
file or directory. You create a local alias when your site contains links that you reference using 
absolute paths. For example, you might create a local alias for a globally-referenced resource 
(one stored elsewhere on the Web) or for a clip art file that resides in your company’s Web site, 
but that you want to reference in your own page. Using a local alias prevents broken links when 
you upload your site to the Web server.

You create this local alias in the same way as you do local aliases for server-side image maps. See 
“Setting local aliases for a server-side image map” on page 124. 
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Creating a link to a PDF file

To use PDF files in PageMill, you must have the Adobe Acrobat 3.0 plug-in installed in your 
Browser Plug-ins folder. (See “About file formats and plug-ins” on page 77.)

Once the plug-in is installed, whenever you drag or place a PDF file on a page, a thumbnail of 
the first page of the document appears. This thumbnail is just like any other PageMill image. If 
you want the reader to be able to see the contents of the PDF file, you must create a link to the 
file. You can create a text link, or you can link the thumbnail to the PDF file. When clicked, in 
the browser, the text or thumbnail opens the PDF file to fill the current window. 

If you include PDF files, also include a link to the free Adobe Acrobat Reader so the reader can 
view the PDF file. You can use the Reader on the Macintosh, Windows, MS-DOS, and some 
UNIX systems. For more information, see the Adobe home page at http://www.adobe.com.

To create a text link to a PDF file:

Hold down Command (Macintosh) or Alt (Windows) as you drag the PDF file icon into the 
page. The linked URL appears on the page.

To create a link from the thumbnail to a PDF file:

1 Drag and drop the PDF file icon onto the PageMill page. 

2 Select the PDF thumbnail.

3 If necessary, choose Windows > Show Inspector (Macintosh) or View > Show Inspector 
(Windows) and click the Object tab.
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4 In the left column, type HREF, and in the right column type the URL of the PDF file.

Testing a link
PageMill allows you to test local links in Preview mode and remote links in a Netscape-
compatible browser. You must use the Preferences command to set the browser you want to use 
before testing remote links. You must also be connected to the Internet to test remote links.

To test a local link:

1 Make sure that any pages or images files containing links are stored in your Web site folder. 

2 If the page is not in Preview mode, click the pen-and-paper icon in the upper right corner. 

3 Click the link.

To test a remote link:

1 Choose Edit > Preferences, and click General.

2 Do one of the following:

• (Macintosh) In the Browsing section, choose Select Browser from the Remote Links menu 
and select the browser you wish to use.

• (Windows) In the Open Remote Links using text box, enter the name and path to the browser 
application or click the Browse button to locate the application.
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3 Click Open, then click OK to return to PageMill.

4 If the page is not in Preview mode, click the pen-and-paper icon in the upper right corner.

5 Click the link.

To view the URL for a link: 

1 Do one of the following options:

• In Preview mode, move the pointer over the link.

• In Edit mode, triple-click the link.

2 View the URL in the Link Location bar.

A. URL B. Link Location bar C. Link

Selecting and moving links
When you move text or an image that functions as a link, the link goes with the text or image.

To select all text connected by the same link:

Triple-click the linked text.

BA C
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To move linked text or a linked image:

1 Select the linked text or a linked image.

2 Do one of the following:

• Drag the link to another location on the same page, or to another page.

• Choose Edit > Copy. Click where you want to add a link, and choose Edit > Paste.

Finding and replacing links
You can use the PageMill search and replace feature to search for link addresses in your docu-
ment. This can be very valuable, for example, when you change servers or rearrange the 
structure of your Web site. 

To search for a link address:

1 Choose Search > Find.

2 In the Find dialog box, drag the link address, or copy and paste the address into the 
Find text box.

3 Choose Link Address to search for the URLs.

4 Set the other search options then replace the links. See “Finding and replacing objects” on 
page 88 for information on setting these options.

Creating an anchor
By default, links to Web pages always link to the top of the destination page. If you want to 
create a link to a place other than the top of the page, you need to create a destination in the 
page. These destinations are called anchors. Anchors help readers navigate through long pages. 
For example, a table of contents or a navigation bar at the top of the page can list topics that 
link to anchors attached to headings throughout the page.

PageMill names anchors as Anchorxxx using randomly generated numbers. You can change the 
name of an anchor using the Inspector palette. The change affects only the page—not links to 
that anchor on other pages. 



113

To create an anchor:

1 Save your page with a .html or .htm file extension. 

2 If the page is not in Edit mode, click the globe icon in the upper right corner of the page.

3 Open the destination page where you want to create an anchor. If necessary, scroll to the part 
of the page where you want the new anchor.

4 Do one of the following:

• Drag the page icon from the top of the page to where you want to place the anchor. 

• Click to the left of the text or object where you want to place the anchor, and choose 
Edit > Insert Invisible > Anchor.

Note: Anchors are always hidden in Preview mode and always visible in Edit mode (unless 
Edit > Hide Invisibles is chosen).

To rename an anchor:

1 Select the anchor. 

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or 
View > Show Inspector (Windows). 

3 Click the Object tab.

4 Type a new name for the anchor. Use only alphanumeric characters and do not use spaces in 
anchor names.

Note: Remember to change an anchor name before making links to the anchor. Changing the name 
after linking to the anchor breaks all links to the old anchor name.

To link to an anchor:

1 Select the text or object that will link to the anchor. 

2 Scroll to the anchor, or open the page containing the anchor. 
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3 Drag the anchor icon onto the selected text or selected object. 

To link to an anchor when both the link text and anchor are not visible:

1 Insert the anchor next to the text or object it will link to.

2 Select the text or object that will be the link and then drag and drop the anchor onto the 
text or object.

3 Choose Edit > Cut, move to the location outside of the current page, and then choose 
Edit > Paste to place the anchor in its final location.

To hide anchor icons:

Choose Edit > Hide Invisibles.

Select text in first window . . . then drag anchor icon from second window.
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To link to an anchor on the same page without moving the anchor:

Hold down Command (Macintosh) or Alt (Windows), and drag the anchor icon to another 
location on the page. The anchor name appears.

Removing a link
Removing a link from text returns the text to its normal text color. Removing a link from an 
image discards the border indicating a link.

To remove a link:

1 Click to select the linked text or a linked image.

2 Choose Edit > Remove Link.
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Keeping frequently used links handy
PageMill has several ways to keep frequently used links available so that you can just drag them 
onto the pages you create:

• Create a Web page containing frequently used links so that you can copy links from the file. 
Store the page on your computer and keep it open as you build a page. 

• If you are using Netscape Navigator, copy links from the Netscape Bookmarks file by opening 
the Bookmarks.html file. Drag the links from the file onto the PageMill page.

Store frequently used links on the Pasteboard. For example, if you keep a navigation 
bar on the Pasteboard, you can easily insert it in your Web pages as needed, instead of 
recreating each link in the navigation bar. To copy rather than remove something from the 
Pasteboard, hold down Option (Macintosh) or Ctrl (Windows) as you drag.
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Chapter 6: Creating Image Maps

mage maps are single images that contain multiple links. Clicking different parts 
of the image, called hotspots, activates different links and moves the reader to 
different locations.

You can use any GIF file or JPEG file to create an image map. To be effective, the image should 
contain easily discernible regions so that the reader understands where to click. For example, 
you can import an image to use as a visual menu bar and create hotspots over each object in 
the image. Clicking an object opens the page linked to that object.

About image maps
Adobe PageMill lets you create two types of image maps: client-side image maps and 
server-side image maps. The image maps differ in the location of the image map files and 
the speed with which the linked page appears. 

Client-side image maps Store the hotspot coordinates and links directly within the HTML page, 
not in a separate map-definition file as do server-side maps. Thus, it’s faster to display linked 
pages and you can test links for a client-side map without uploading to the Web server. When 
the reader passes the pointer over a hotspot, the client-side map shows its exact address. When 
the reader clicks a hotspot, the browser sends the server a URL. The server contacts the Web 
server storing the page and sends the page back to the browser.

Server-side image maps Require two files: an HTML file containing the image and a separate 
map-definition file for the link. This image map file is stored on the Web server. When the 
reader passes the pointer over a hotspot, the coordinate numbers of the image map appear. 
When the reader clicks a hotspot, the browser sends the click coordinates to the server, the 
server looks up the coordinates in the map file, then sends the URL back to the browser. The 
browser then sends a request for that URL back to the server, the server contacts the Web 
server storing the linked page, and finally the server sends the correct page back to the browser. 
Not only is this communication time-consuming, but maintaining the correct server-side files 
can be confusing. Server-side maps are slower and more difficult to manage than client-side 
image maps.

The following procedure explains how to create a client-side image map. For the steps required 
to create a server-side image map, see “Creating a server-side image map” on page 122.

I
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Creating a client-side image map
Creating a client-side image map requires three steps:

• Select the GIF or JPEG file on the PageMill page.

• Edit the image map by drawing the hotspots and creating links to them. (If the image map 
is used within a frameset, target the linked hotspots.)

• Test the links. 

Editing a client-side image map
You can use any GIF or JPEG file to create a client-side image map. You edit client-side 
image maps in the PageMill window. Editing a client-side image map is called in-line or in-place 
editing because it’s done within the page. 

To activate an image for a client-side image map:

1 If you are not in Edit mode, click the globe icon in the upper right corner. 

2 Double-click the image. A border appears around the selected image, and the drawing tools 
appear in the second line of the toolbar. 

Adding hotspots to a client-side image map

You add hotspots to an image map using the drawing tools in the toolbar. 

A. Selector tool B. Rectangle hotspot C. Circle hotspot D. Polygon hotspot
E. Show URLs F. Show hotspot label G. Hotspot color H. Shuffle hotspot

BA C D

H G F E
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To add hotspots:

1 Select a rectangle (d), circle (f), or polygon (g) tool from the toolbar.

2 Drag the tool over the image to draw a shape. PageMill numbers each hotspot as you draw 
it, with lower-numbered hotspots in front. 

A. Hotspot in image map

3 Create the links for the hotspots.

4 Choose File > Save Page.

Editing hotspots in a client-side image map

You can edit the hotspots you create by selecting them and then moving or resizing them, or 
changing their colors to make them more visible. 

To edit a hotspot:

1 Double-click the image to select the image map.

2 Click the Selector tool (a), then click a hotspot. Handles appear around the hotspot.

A
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3 Choose from the following options:

• To move a hotspot, drag the hotspot. Be careful not to drag the hotspot by its handles.

• To resize a hotspot, drag any of its handles.

Note: When moving or resizing hotspots, be sure the hotspot fits inside the image dimensions.

• To change the color of all hotspots, click the hotspot color tool (ç) and select a color. 

Note: Because the hotspot does not appear in the browser, it’s important to make the clickable area 
obvious to the reader when designing an image for image maps.

• To delete a hotspot, choose Edit > Clear, or press Delete (Macintosh) or Backspace 
(Windows).

Layering hotspots in a client-side image map

You can layer overlapping hotspots to change the order in which they are activated (frontmost 
first, with lower numbers in front of higher numbers). You can move a hotspot forward or 
backward in the layer order. 

To change the layering order of hotspots:

1 Select the hotspot.

2 Click the Shuffle Hotspot tool (q), and choose an option from the menu:

• Bring To Front moves the selected shape to the top layer.

• Send To Back moves the selected shape to the bottom layer.

• Shuffle Forward moves the selected shape forward one layer.

• Shuffle Back moves the selected shape back one layer.
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Creating and displaying links in a client-side image map

Once you’ve added a hotspot, you must link it to a destination. Linking a hotspot to another 
page or URL is just like linking text or images. (For more information, see “Creating a link” on 
page 105.) Be sure to save the file after you’ve linked the hotspots.

When you add a link, select a hotspot, or drag a link onto a hotspot, the filename of the link 
appears over the hotspot and the link URL appears in the Link Location bar. If the document 
has a title, the title appears in place of the filename.

You can turn off the display of links. Hiding the link names helps to avoid visually 
cluttered pages. 

To turn off link display:

Click the checkbox next to the Show Hotspot Label button (ªº Macintosh) or the Show 
Hotspot Label button (r Windows) in the toolbar.
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Testing a client-side image map
• To test a client-side image map, switch the page to Preview mode and click the hotspot. You 
can also preview client-side maps from the hard drive in the browser that supports them. If the 
client-side image map does not work as expected, make sure you have not resized the image 
after adding the hotspots. If you need to resize an image used as an image map, resize in an 
image-editing program such as Adobe Photoshop before you create the image map. If you 
resize in PageMill, the hotspot coordinates will be incorrect.

Creating a server-side image map
Creating a a server-side image map requires seven steps:

• Use the Preferences command to set the map format, line break format, and suffix prefer-
ences and to set local aliases.

• Open the GIF or JPEG file that you’re using as an image map in the Image window.

• Edit the image map by drawing the hotspots and creating links to them. 

• Create a link to a default page or errors page.

• In the Inspector palette, click the Object tab and mark the image as an image map.

• Test the links. 

Setting format preferences for a server-side image map
Setting up a server-side image map is more complicated than setting up a client-side image 
map. Links to server-side image maps may depend on a Common Gateway Interface (CGI) 
script that is closely tied to the type of server that publishes your Web site. (CGI is a language 
that allows communication between a Web browser and a Web server, such as a query to a 
database by a Web page. The proper use of CGI is outside the scope of this guide, but many 
sources for CGI information exist on the World Wide Web; or consult your Webmaster.)
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When you set up an image as a server-side map, Adobe PageMill creates an image map file that 
describes the links to the file (the hotspots) you created. The image map file must contain the 
Web server locations of link destinations. You can use only one image map file per image; 
however, you can use an image and image map file more than once in a site or on a page.

To create a server-side image map file, you must first obtain this information (available from 
your Internet Service Provider [ISP]):

• The server platform

• The Web site map format, NCSA or CERN 

• The location of your site’s root folder on the Web server (Remote Root Directory) 

• How to link the image to the image map file and script (often called the AHREF to 
the map file)

To specify the map format preferences:

1 Choose Edit > Preferences, and click Resources.

2 Choose a server type from the Map Format menu, as specified by your ISP: either NCSA or 
CERN. The map format controls how the shape, coordinate, and link information is specified 
in the map file.

3 Click OK.

To specify the line breaks and suffix preferences:

1 Choose Edit > Preferences, and click Page.

2 In the File Format section, use the Line Breaks menu to select the Web server platform (not 
the platform on which you are creating Web pages): Macintosh, UNIX, or DOS.
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3 Choose a suffix that matches the server platform:

• .html can be used for all platforms except DOS.

• .htm can be used for all servers with the exception of some UNIX servers (some UNIX servers 
prefer .html).

4 Click OK.

Setting local aliases for a server-side image map
A local alias provides the information PageMill needs to create the server-side image map file 
correctly. The local alias identifies the remote root directory (the URL to the Web site’s home 
page, minus the filename of the home page) and the local root folder (the site folder on the local 
hard drive that contains the site’s main home page and all linked files, images, and subfolders 
for that site).

The local root folder of the site on your computer corresponds to 
the remote root directory of the site on the Web server.

Local machine

marketing

images

departments

www.company.com

marketing

images
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To set up a local alias:

1 Choose Edit > Preferences, and click Server.

2 Next to the globe icon (Macintosh) or in the URL text box (Windows), enter the absolute 
URL to the top level of your site on the Web server, ending with a slash. For example, 
http://www.earthandware.com/. 

Macintosh

Windows
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3 Enter the name of the local root folder by doing one of the following:

• On a Macintosh, click the folder icon under the globe and select the top level of your local 
root folder; open the folder and click In Here. PageMill fills in the local root folder name in 
the dialog box.

Macintosh

Macintosh
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• In Windows, click the Browse button next to the Local Root Folder text box to locate the site 
folder on your hard disk; click OK. PageMill fills in the local root folder name in the dialog box.

Windows

Windows
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The above example tells PageMill to use http://www.earthandware.com/ for all image maps 
that you create inside the EarthAndWare folder. When PageMill writes out a map file, it will 
place http://www.earthandware.com/ in front of links to other files in the local hard disk folder. 

Macintosh Note: If you configured a remote alias in PageMill 1.0, the configuration will automat-
ically be converted the first time you start PageMill 2.0.

PageMill 2.0 supports setting server-side map preferences for multiple sites. If you are working 
on image maps for more than one site, set up server-side map preferences for each site. 
PageMill will use the correct remote root directory for all image maps in the corresponding 
local root folder.

To enter multiple local aliases:

Enter the first alias. Space for the second entry appears automatically. 

Macintosh
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Windows

Editing a server-side image map
You can use any GIF or JPEG file to create a server-side image map. Editing a server-side image 
map is called out-of-place editing, and is done in an Image window.

To open an image for a server-side image map:

1 Open the page containing the image.

2 Do one of the following:

• Select the image and choose File > Open Selection.

• Hold down Command (Macintosh) or Ctrl (Windows) and double-click to display the image 
in an Image window.
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Adding hotspots to a server-side image map

You add hotspots to an image map using the drawing tools in the Image window. 

Macintosh
A. Selector tool B. Rectangle hotspot C. Circle hotspot
D. Polygon hotspot E. Transparency tool F. Shuffle hotspot
G. Hotspot color H. Show hotspot label I. Make interlaced
J. Zoom boxes

Windows
A. Selector tool B. Rectangle hotspot C. Circle hotspot
D. Polygon hotspot E. Transparency tool F. Shuffle hotspot
G. Hotspot color H. Show hotspot label I. Make interlaced
J. Zoom boxes

A
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To add hotspots:

1 Select a rectangle (d), circle (f), or polygon (g) tool.

2 Drag the tool over the image to draw a shape. PageMill numbers each hotspot as you draw 
it, with lower-numbered hotspots in front. 

3 Click to close the Image window. When prompted, save the changes.

PageMill saves the new file containing the hotspot data in the same folder as the image, and 
names the data file the same as the image plus the extension .map. (For example, the image map 
for Sun.gif would be Sun.map.) The hotspot data contains the shape of the hotspot, the link 
path to the linked file, and the coordinates for the position of the hotspot. 

Important: Be sure you don’t scale the graphic after adding hotspots. Scaling changes the
image size but does not change the hotspot coordinates, so the hotspots will not appear in the 
correct location. 



CHAPTER 6132
Creating Image Maps

Editing hotspots in a server-side image map

You can edit the hotspots you create by selecting them and then moving or resizing them, or 
changing their colors to make them more visible. You can also layer overlapping hotspots to 
change the order in which they are activated (frontmost first, with lower numbers in front of 
higher numbers). You can move a hotspot forward or backward in the layer order. 

To edit a hotspot:

1 In the Image window, click the Selector tool (a), and click a hotspot to select it. Handles 
appear around the hotspot.

2 Choose from the following options:

• To move a hotspot, drag the hotspot. Be careful not to drag the hotspot by its handles.

• To resize a hotspot, drag any of its handles.

Note: When moving or resizing hotspots, be sure the hotspot fits inside the image dimensions.

• To change the color of a hotspot, click the hotspot color tool (ç) and select a color. 

Note: Because the hotspot does not appear in the browser, it’s important to make the clickable area 
obvious to the reader when designing an image for image maps.

• To delete a hotspot, choose Edit > Clear, or press Delete (Macintosh) or Backspace 
(Windows).

Layering hotspots in a server-side image map

You can layer overlapping hotspots to change the order in which they are activated (frontmost 
first, with lower numbers in front of higher numbers). You can move a hotspot forward or 
backward in the layer order. 
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To change the layering order of hotspots:

1 In the Image window, select the hotspot.

2 Click the Shuffle Hotspot tool (ß), and choose an option from the menu:

• Bring To Front moves the selected shape to the top layer.

• Send To Back moves the selected shape to the bottom layer.

• Shuffle Forward moves the selected shape forward one layer.

• Shuffle Back moves the selected shape back one layer.

Creating and displaying links in a server-side image map

Once you’ve added a hotspot, you must link it to a destination. Linking a hotspot to another 
page or URL is just like linking text or images.(For more information, see “Creating a link” on 
page 105.)

When you’re typing in a link, you enter the URL in the Link Location bar at the bottom of the 
Image window, then press Return or Enter.

When you select a hotspot or drag a link onto a hotspot, the filename of the link appears over 
the hotspot and the link URL appears in the Link Location bar. Be sure to save the file after 
you’ve linked the hotspots.

You can turn off the link display to make pages appear visually less cluttered.
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To turn off link display:

Click the checkbox next to the Show Hotspot Label button (ªº Macintosh) or the Show 
Hotspot Label button (r Windows) in the toolbar.

Creating a default link

A default link is used when someone clicks on an area of the image that is not covered by a 
hotspot. Generally you link it to a page that says something like “Sorry, try again,” or you can 
just link it to the HTML page containing the image map image so that the page simply reloads 
in the browser.

Note: It’s a good idea to specify a default link, because some image map servers or scripts won’t 
work unless you do. Ask your ISP if your image map script requires a default link.

To create a default link:

Do one of the following:

• Drag a page icon (:) onto the image.

• Drag an anchor icon (z) onto the image.

• Type a URL into the Link Location bar at the bottom of the page or image window, and then 
press Return or Enter.

Marking the image as a server-side image map
Before you can test the hotspot links for a server-side image map, you must mark the image as 
an image map.

To mark the image as an image map:

1 Click the image to select it.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or 
View > Show Inspector (Windows).

3 Click the Object tab.

4 In the Object panel, click the Behavior Map button at the bottom of the panel.
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Specifying the location of the server-side image map
Saving a server-side image map also saves a new file containing the hotspot link data with the 
same name as the image plus the extension .map. (For example, the image map for Sun.gif 
would be Sun.map.) PageMill stores the data file in the same folder as the image, in the format 
(NCSA or CERN) you set in the Preferences dialog box. (For more information, see “Setting 
format preferences for a server-side image map” on page 122.)

To implement the links to the server-side image map, you must specify where the CGI script 
and the image map data file will be stored on the server, with a pathname specific to the server. 
The pathname can vary depending on how your ISP has set up image maps to work on the 
server. (Ask your ISP, “What’s my link to the map file?”) 

Generally, the pathname to the image map is one of two types: an absolute or relative path from 
your HTML document to the map file that PageMill creates for the image; or a pathname that 
also includes a reference to the image map script on the server.

If you are using a CERN server, the server may have a variety of configurations. For more 
information, see the documentation for CERN server clickable-image support, or consult 
your Webmaster.

To enter the image map location:

1 Select the image in the PageMill window.

2 Type the pathname of the image map in the Link Location bar at the bottom of the page. For 
more information, see the following two sections.

Using relative or absolute pathnames to image map files

If you are using a Netscape server, such as Netsite™, use either a relative or absolute path from 
your HTML document to the image map file. For example, if the HTML file is in the same 
folder as an Images folder, and the Images folder contains the map file, type this relative 
pathname in the Link Location bar:

images/image.map

where image.map is the name of the map file associated with the image.

You could also type the full URL to the map file (http://www.company.com/~username/
images/image.map) or the absolute path from the root of the server to the map file 
(/~username/images/image.map) in the Link Location bar.
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Using pathnames to image map files that refer to the CGI script 

If you are using an NCSA server, depending on the server software your Web server uses, you 
may have to specify the directory containing the CGI script and the script name. Then specify 
the path to the image map data file. For more information, consult your ISP. For example, in 
the Link Location bar, type: 

/cgi-bin/imagemap/~username/images/image.map

where /cgi-bin/imagemap is the path from the root of the Web server to the image map script 
called imagemap, and /~username/images/image.map is the path from the root of the Web 
server to the map file for this particular image map.

(For more information about image maps, telephone the Adobe automated fax-back service at 
206-628-5737, and request FaxYI 201325.)

Testing a server-side image map
To make sure that an image map’s hotspots work as expected, test the map. To test a server-side 
map, upload your site to a Web server and then test the image map in your browser. If the 
server-side image map does not work, check to make sure that you:

• Specified the correct root folder location, if necessary, and server type in the Preferences 
dialog box. For more information, see “Setting format preferences for a server-side image map” 
on page 122.

• Set your line breaks to the platform of your Web server. For more information see “Setting 
format preferences for a server-side image map” on page 122.

• Specified the correct location of the CGI script and the image map data file on the server, with 
a pathname specific to the server. For more information, see “Specifying the location of the 
server-side image map” on page 135.

• Selected the Behavior Map option in the Object panel of the Inspector palette. For more 
information, see “Marking the image as a server-side image map” on page 134.
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• Have not resized the image in PageMill. If you need to resize an image used as an image map, 
resize in an image-editing program such as Adobe Photoshop before you create the image map. 
If you resize in PageMill, the hotspot coordinates will be incorrect.

• Created a default link for the image map if required by your server. For more information, 
see “Creating a default link” on page 134.

• Uploaded the contents of your local root (site) folder to your Web server to mirror the direc-
tory structure of your computer’s hard drive.
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Chapter 7: Adding Tables

ables are an efficient way to structure and summarize large amounts of data so that 
readers can scan and comprehend information quickly. Adobe PageMill tables can 
consist of cells, columns, rows, and a caption. Cells usually contain a heading, explana-

tory text, or numerical data, but in addition, can include links, lists, forms, images, sounds, or 
movies. You can also create a borderless table to help you lay out a page.

Anything that can act as a link on a regular page can also be a link in a table cell. For more infor-
mation, see Chapter 5, “Creating Links.”

Note: Some older browsers don’t support tables.

Table with borders
A. Caption B. Heading C. Row D. Border E. Column

T

C

B

A

D

E
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Layout table without borders in Preview mode

Creating a table
You create a table using the Insert Table button. You can also copy and paste Microsoft Excel 
files (and Excel Clipboard-type data) directly into PageMill. 

To create a table:

1 If the page is not in Edit mode, click the globe icon in the upper right corner of the 
Page window.

2 Click the page where you want to add a table.

3 Do one of the following:

• Click the Insert Table button (m) in the toolbar, and in the dialog box that appears, specify 
the size of the table by entering the number of rows and columns, and click OK. This method 
allows you to create up to 99 rows and 99 columns. You can also set the table and cell width 
constraints, the cell spacing and padding, and the border size in this dialog box. 

• Position the pointer over the Insert Table button (m) in the toolbar, and drag down and to 
the right to indicate the number of rows and columns. This method allows you to create up to 
10 rows and 10 columns.
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Drag to select table size . . .

Table appears on page

Note: You cannot have two tables next to each other; however, you can achieve the effect of having 
two tables in one line by nesting the tables within a single table. 

To add a table from Microsoft Excel:

1 Open the Microsoft Excel file, select the cells you want to copy, and choose Edit > Copy.

2 Activate the PageMill page into which you want to paste the table.

3 If the page is not in Edit mode, click the globe icon in the upper right corner of 
the Page window.

4 Choose Edit > Paste. The data flows automatically into a table (you do not need to create 
the table first). You can’t paste Excel data into an existing PageMill table structure. 
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Selecting a table cell or a table
In PageMill you can select an individual cell, multiple cells, the contents of a cell, or the table 
itself. When a thick line surrounds the outside of the table, you are working within the table. 
When a thin line surrounds the table, you are working with the table as a whole.

To select one or more table cells:

Click the pointer inside the table and drag to the border of the cell or cells. The entire table is 
highlighted with a thick line and the selected cell borders are highlighted. 

You select table cells when you want to constrain their width, format them as header cells or 
non-wrapping cells, change their alignment or background color, merge or split cells, or add 
and remove columns and rows. 

Selected cells
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To select cell contents:

• Click once to place the insertion point in the cell, then enter the contents or select and edit 
the contents as you would any other text or object. The entire table is highlighted with a thick 
line and the cell contents are highlighted.

Selected cell contents

To select an entire table:

Choose from the following options:

• Click anywhere inside the table to display the thick line around the table. Click the thick line. 

• Click outside of the table and drag into the table.

The table is outlined with a thin line with handles. You select the entire table when you want to 
change its width, add a caption, add a border around the table, change the cell spacing or 
padding, or align the table on the page.

Selected table



CHAPTER 7144
Adding Tables

Entering data in a cell
To enter or replace data in the cell, type, drag and drop, or cut and paste directly into the cell. 
The cells gets wider as you enter text. You can shorten a long entry in a table and prevent an 
awkward design with only a few wide columns by entering a line break. The line break moves 
the remaining data down one line without inserting an empty line.

A. Line breaks

To enter text or a number into a cell:

1 Click to place the insertion point in the cell.

2 Type the text.

3 To control the appearance of how text breaks in a cell, choose from the following options:

• To insert a line break, press Shift+Return (Macintosh) or Shift+Enter (Windows).

• To create a cell that appears empty, insert a space character in the cell.

To insert text, or add images, movies, and sounds to a cell:

Select the text or object you want to add and then drag it into the cell or use cut and paste, just 
as you would anywhere else on a page. For more information, see “Adding text to a page” on 
page 59 or “Importing an image, movie, or sound” on page 80.

When it’s created, each cell contains an invisible space. When you insert an object after the 
space, an empty line appears above the object. To remove the space, select it and press Delete 
(Macintosh) or Backspace (Windows). 

A
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To move through a table:

Choose from the following options:

• Press Tab to move sequentially through the cells.

• Press Shift+Tab to move to the previous (adjacent left) cell and select everything in that cell. 

• Hold down Control and press the arrow keys to move in a specific direction.

To delete a cell’s contents:

Select the cell contents, and press Delete (Macintosh) or Backspace (Windows) or choose 
Edit > Clear. 

Creating cells that span rows or columns
When you create a table, all the cells are the same size and are designed to hold one value. You 
can make cells span rows or columns. Larger cells are useful for entering long headings or for 
creating a special design effect. 

To join the cells in a row or column:

1 Select two or more adjacent cells.

2 Click the Join Cells button (1) in the toolbar.

Drag to select cells . . . Joined cells in a row

Drag to select cells . . . Joined cells in a column
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To separate joined cells:

Use one of the following methods:

• Choose Edit > Undo before performing any other actions. 

• To divide cells joined in a row, click the Split Cell Vertically button (9) in the toolbar.

• To divide cells joined in a column, click the Split Cell Horizontally button (0) in the toolbar.

Note: While joining cells combines the cell contents, separating the cells does not separate 
the contents. 

Formatting and aligning cell contents
You format the contents of a cell just as you do text in a page. To change the text appearance, 
apply any of the paragraph formats or character styles to a cell. For example, to create a bulleted 
list, select the text and then choose Bullet List from the Format menu in the toolbar. 

You can also change the alignment, color, and relative font size of a cell’s contents. For more 
information on changing formats, see “Applying paragraph formats” on page 62, “Applying 
character styles” on page 67, “Changing the font size” on page 70, and “Changing the color of 
text, links, and the page background” on page 71.

Note: You must format each cell in a table separately. If you select more than one cell, the text 
formatting options are dimmed.

By default, a table has the same color as the background color; you can change the color of the 
cells but you cannot change the color of a table border.
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To format and align cells using the Inspector:

1 Select one or more cells.

2 Choose Window > Show Inspector (Macintosh) or View > Show Inspector (Windows).

3 Choose from the following:

• To create a header cell, select Header Cell. Some browsers (such as Netscape Navigator) 
display a heading cell in centered, bold typeface. 

• To prevent text from wrapping, select No Wrap.

• To set alignment, select an option from the Vertical Align and Horizontal Align boxes.

To change the background color of cells:

1 Select one or more cells.

2 Choose Window > Show Inspector (Macintosh) or View > Show Inspector (Windows).

3 Choose one of the following options:

• Choose Custom from the Background menu, select a color, and click OK. 

• Choose Window > Show Color Panel (Macintosh) or View > Show Color Panel (Windows), 
and drag a color from the color panel onto the Background menu.

Note: Background cell color is lost when you join cells. Be sure you complete the table layout 
formatting before you assign background colors.
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Changing the cell width
Keep the following information in mind when you’re setting cell widths:

• HTML is not a page-layout application. The dimensions of a table and cells that you enter are 
sizing recommendations. The Web browser determines how the table appears.

• Changing the width constraint changes an HTML attribute value. The constraint is applied 
when the table is viewed in a browser.

• When there is more than one constrained cell in a column, the maximum pixel cell constraint 
and the minimum percent constraint is used. Percent constraints always take precedence over 
pixel constraints. 

• Cells are never made smaller than their largest item. For this reason, pixel values don’t always 
represent the actual width of a cell. If a cell contains an item too large to fit in the constrained 
width, the cell is sized to fit the item and the other cells shrink proportionally. 

• By default, every table cell contains a space. Because of this, inserting an image that is wider 
than the cell width pushes the image down a line (the text is wrapping). To avoid the extra 
space, delete the line break or set the cell to No Wrap. 

To constrain the cell width:

1 Select one or more cells.

2 Choose Window > Show Inspector (Macintosh) or View > Show Inspector (Windows).

3 Choose from the following size options:

• Percentage: Specify the percentage of the cell’s width.

• Pixels: Specify an amount. 

4 Enter a value in the Width text box. If you specify no cell width, the value floats and is 
proportionate to other entries.

Note: To constrain cell width as you create a table, choose Pixels or Percent from the Cell Width 
menu in the Insert Table dialog box. If you choose None, the unspecified values compensate for 
extra space left by the other specified values. For more information, see “Creating a table” on 
page 140.
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Adding columns and rows to tables
You can easily add or delete rows or columns to or from an existing table.

To add or delete a row or column:

1 Select adjacent cells in a row or column.

2 Choose from the following options:

• To add or delete a column, click the Insert Column (5) or Delete Column (6) button 
in the toolbar. 

• To add or delete a row, click the Insert Row (7) or Delete Row (8) button in the toolbar. 

• To add or delete multiple rows or columns, select that number of rows or columns before 
clicking the Insert button. For example, if you select five rows, five more rows will be added.

• To add an empty row above the first row (for example, for headings), insert a row and then 
cut and paste the original first row contents into the second row.

Drag to select row . . . Inserted row

Drag to select column . . . Inserted column

Changing the size of columns and rows
You can easily resize rows and columns in the table.

To change row and column sizes:

Move the pointer to the edge of the cell. When the double-headed arrow appears, drag to resize 
the row or column. Any resizing must fall within the layout constraints of the table. 
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Creating a nested table
Any item that you can place elsewhere on the page—including tables, graphics, and 
movies—you can also insert in a table. Thus, you can nest, or insert, one table inside another. 
You may want to nest tables when using a borderless table as a design aid, or to format the 
data in a single cell as a table. 

To create a new table inside an existing table:

1 Click a cell.

2 Position the pointer over the Insert Table button (m), and drag to define the number of cells 
in the table or click the button and enter the rows and columns in the dialog box. The new table 
appears inside the cell.

To nest an existing table inside another table:

Choose from the following options:

• Select an existing table, and drag it into a cell.

Drag entire table to a cell in another table
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Resulting table

• Select multiple cells in another table, and drag them into a cell.

• Select multiple cells in another table, and copy and paste them into a new cell.

Changing the table size
The number of columns you set for the table determines its width. You change the table width 
by dragging or entering values in the Inspector.

To resize a table using the handles:

1 Select the table. Handles appear at the right and bottom of the table.

2 Drag a handle to resize.

To constrain the width using the Inspector: 

1 Select the table.

2 Choose Window > Show Inspector (Macintosh) or View > Show Inspector (Windows).

• In the Object panel, for Width, choose from the following size options:

• Percentage: Specify the percentage of the page’s width. Use this option when you want a table 
to always take up a certain percentage of the browser window.

• Pixels: Specify an amount. Use this option when you want a table to remain the same size, no 
matter what the size of the browser window.



CHAPTER 7152
Adding Tables

3 Enter a value in the Width option. If you specify no cell width setting, the value floats and is 
proportionate to other entries. 

Note: To constrain the table width as you create a table, choose Pixels or Percent from the Table 
Width menu in the Insert Table dialog box. If you choose None, the unspecified value compensates 
for extra space. For more information, see “Creating a table” on page 140.

Centering a table in a browser (Macintosh 2.0 only)
When you want to align a table, you use the Text align buttons in the toolbar. Netscape 
Navigator, however, incorrectly displays tables that are center-aligned in PageMill. 
These tables appear as left-aligned when viewed in the Netscape browser.

To center a table in the Netscape browser:

1 Choose Edit > Preferences and click HTML.

2 In the HTML Syntax area, choose Center from the Alignment menu.

3 Click OK.

Changing the cell spacing and padding
Cell spacing is the amount of space between the cells—that is, the width of the shaded lines that 
separate the cells. Cell padding is the amount of space from the edge of the cell to the beginning 
of the cell’s contents. Changing the cell spacing or cell padding affects all cell dividers and 
cells. (Changing the cell spacing does not affect the border. For more information, see “Adding 
a border” on page 153.)

To change the cell spacing or padding:

1 Click within a cell, and then click the thick line surrounding the table to select it.

2 Choose Window > Show Inspector (Macintosh) or View > Show Inspector (Windows) to 
display the Inspector palette. 
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3 In the Object panel, choose from the following options:

• In the Cell Spacing text box, enter a pixel value up to 50. (The default is 2.)

• In the Cell Padding text box, enter a pixel value up to 50. (The default is 0.)

Note: To set the cell spacing and padding as you create the table, use the Insert Table dialog box. 
For more information, see “Creating a table” on page 140.

Cell Spacing=2 Cell Spacing=5

Cell Padding=0 Cell Padding=5

Adding a border
A border helps distinguish a table from the page background and from the other objects on a 
Web page. By default, a table has a border of 1 pixel. You cannot change the border color. 

To change the size of a table border:

1 Click within a cell, and then click the thick line surrounding the table to select it.

2 Choose Window > Show Inspector (Macintosh) or View > Show Inspector (Windows) to 
display the Inspector palette.
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3 In the Object panel, enter a pixel value in the Border text box to change the size of the table 
border, or enter a value of 0 to remove the border.

Note: To add a border as you create the table, use the Insert Table dialog box. For more information, 
see “Creating a table” on page 140.

Border=1 Border=5

To create the appearance of multiple columns on your page, use a table with a 
0-width border. See “Creating dynamic, fixed, and borderless tables” on page 155.

Adding a caption
You can include a caption for your table to describe its contents. A caption can appear above 
(the default) or below the table. Usually it’s more useful to readers to have the caption above 
the table so that they know what the table is about before they start reading it. 

To add a caption:

1 Click within a cell, and then click the thick line surrounding the table to select it.

2 Choose Window > Show Inspector (Macintosh) or View > Show Inspector (Windows) to 
display the Inspector palette.

3 In the Object panel, select the Caption option, and click a location above or below the table.

4 In the PageMill page, deselect the table. 

5 Triple-click to select the word “caption” and type a description of the table.
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To reposition or remove a caption:

1 Click within a cell, and then click the thick line surrounding the table to select it.

2 Choose Window > Show Inspector (Macintosh) or View > Show Inspector (Windows) to 
display the Inspector palette. 

3 In the Object panel, choose from the following options:

• To reposition the caption, click a button to the right of the Caption option to select a 
different location.

• To remove a caption, deselect the Caption option. 

Creating dynamic, fixed, and borderless tables
PageMill offers you a lot of control over a table’s appearance and structure. When you want to 
create a specific type of table, however, the interactions between cell and column width 
constraints may be confusing. It’s often helpful to create your table by setting as many of the 
parameters as possible in the Insert Table dialog box. This section provides examples of 
creating three different types of tables: 

• Dynamic tables resize to fit the width of the Web browser.

• Fixed tables do not resize when viewed in a Web browser.

• Page layout tables have no borders when viewed in a Web browser.

To create a dynamic table:

1 Click the Insert Table button (m) in the toolbar to display the Create Table dialog box. 

2 Choose Percent from the Table Width menu.

3 Enter a value in the Table Width option, for example, 75%. The table will then fill 75% of the 
Web browser window.

4 Enter the number of rows and columns.

5 Enter the cell spacing, cell padding, and table border values, and click OK.

To create a fixed table:

1 Click the Insert Table button (m) in the toolbar to display the Create Table dialog box. 

2 Choose Pixels from the Table Width menu.
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3 Enter a value for pixel width in the Table Width option.

4 Choose Pixels from the Cell Width menu.

5 Enter the number of rows and columns. 

6 Enter the cell spacing, cell padding, and table border values, and click OK.

Note: If you add an image to a table cell in a fixed table, be sure the image width does not 
exceed the cell width.

To create a page layout table:

1 Click the Insert Table button (m) in the toolbar to display the Create Table dialog box. 

2 Enter values for the Rows, Columns, Cell Spacing, and Cell Padding options.

3 Enter zero in the Border option.

4 Choose constraints for the Table Width and Cell Width, and click OK.

Note: Although PageMill displays a dotted-line border when you create the table, the border 
does not display in PageMill’s Preview mode or in the Web browser.
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Chapter 8: Creating Forms

Web page can function as a form. A form lets the reader type information and send 
it to the Web server, which can store, analyze, or act on the information depending 
on how it is programmed. For example, you can create a Web version of a product 

catalog and set up one of its pages as an order form that readers can use to order products using 
the Web. You can also use forms, for example, to let readers specify criteria for searching 
through your database, or for customizing their Web pages; to enter a password; to get 
customer feedback about products or services; and to collect information about your readers, 
such as age, income, and interests.

Creating a form involves two steps: 

• Adding the form controls and options to a page. 

• Linking to a script that acts on the data that the reader enters. This step is more complex 
because it requires a Common Gateway Interface (CGI) script written in a script or program-
ming language such as AppleScript® or Perl. Many Internet Service Providers (ISPs) have 
basic-form CGI scripts already running on their servers (for example, mailing the contents 
to a particular e-mail address); contact your ISP for more information.

In Adobe PageMill, you can have only one form on each page.

About form scripts
When the reader submits a form (presses the button that sends the data to the server), the server 
processes the data according to a CGI script. A script can simply send the contents of the form 
somewhere, or it can do more complex tasks, such as collecting data in a database or generating 
a new page based on the form’s content.

Every form you create must have a corresponding CGI script on the server, provided by you or 
your script programmer. To work properly, this script must recognize the names and values it 
receives from the form objects on your page. For more information, see “Associating a CGI 
script with a form” on page 169. (Specific information about programming CGI scripts is 
outside the scope of this guide, but many sources for CGI information exist on the World Wide 
Web, or you can consult your Webmaster for information about CGI script programmers 
in your area.)

A
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Options for forms in Adobe PageMill are limited only by the capabilities of the script 
programmer and programming language.

Adding form objects
You can add form objects to a page as easily as you can add text, graphics, or links. Form objects 
are available in the toolbar at the top of the page in Edit mode. (Click the globe icon in the 
upper right corner of the page to switch to Edit mode.)

A. Checkbox B. Text area C. Password field D. Submit button
E. Reset button F. Pop-up menu G. Text field H. Radio button

The form objects available in PageMill correspond to those available in HTML Version 2.0. 
In addition, the checkbox, radio button, text area, text field, and pop-up menu objects are 
standard user-interface objects. You must understand the guidelines for using standard user 
interface objects, so that your use corresponds to readers’ previous experiences with them. 
(For more information, see a user-interface reference book.) The following section describes 
the basic function of each object.

Adding checkboxes

Use checkboxes when you want readers to choose any combination of alternatives. You can 
customize each checkbox using the Inspector palette.

To add a checkbox:

1 In Edit mode, click the page where you want to add the checkbox.

2 Click the Checkbox button (e) in the toolbar.

A

H G F E
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To add a checkbox group:

1 In Edit mode, click the page where you want to add the first checkbox.

2 Click the Checkbox button (e) in the toolbar.

3 Click to select the checkbox.

4 For each additional checkbox in the group, hold down Option (Macintosh) or Ctrl 
(Windows) and drag an existing checkbox to copy it next to the previous checkbox.

To customize a checkbox:

1 In Edit mode, click to select a checkbox.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or 
View > Show Inspector (Windows).

3 In the Object panel, choose any of the following options to set attributes:

• Type a name to tell the form script which checkbox is sending data. You can rename the 
default to describe what the option represents. For example, you could name a checkbox 
“Overnight Delivery.”

• Type a value to tell the form script what a selected checkbox means. For example, you could 
give a checkbox named Overnight Delivery a value of “Yes.”

• Select Checked to tell PageMill whether the checkbox should be selected by default. For 
example, you could deselect Checked for a checkbox named Overnight Delivery because it is a 
more expensive option for a customer.
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4 Press Return or Enter.

Another way to set a checkbox to be selected or deselected by default is to 
triple-click it on the page when in Edit mode.

5 If you or the script programmer changed the name or value of the checkbox in step 3, check 
the new name and value to make sure that they match the values for this checkbox in the CGI 
script that interprets the form’s data. 

Adding radio buttons

Use radio buttons when you want readers to select only one alternative from a group, such as a 
color choice. Selecting a button deselects all other buttons in the group. You can customize each 
radio button using the Inspector palette.

A radio button group for a Red/White/Blue choice

To add a radio button group:

1 In Edit mode, click the page where you want to add the first radio button.

2 Click the Radio Button tool (j) in the toolbar.

3 Click to select the button.

4 For each additional button in the group, hold down Option (Macintosh) or Ctrl (Windows) 
and drag an existing button to copy it next to the previous button.

To customize a radio button:

1 In Edit mode, click to select a radio button.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or 
View > Show Inspector (Windows).
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3 In the Object panel, choose any of the following options to set attributes:

• Type a name to tell the form script which radio button group is sending data. A radio button 
group is defined by buttons with a common name. For example, you could change the 
numbered default name to a descriptive name for the option, such as “Colors.” 

Note: To ensure that all buttons in the radio button group have the same name and that the group 
works properly, name the button before you Option-drag (Macintosh) or Ctrl-drag (Windows) it.

• Type a value to tell the form script what value to send when the radio button is selected. For 
example, you could assign a value of “Blue.”

• Select Checked to have one radio button selected by default, and then deselect all other radio 
buttons in the group. You can select Checked for only one radio button per group.

4 Press Return or Enter.

5 If you or the script programmer changed the name and value of this radio button in step 3, 
check that the new name and value match the values for this radio button in the CGI script that 
interprets the form’s data.

Adding text fields

A text field lets a reader type text in a form. You can type default text in a text field to guide 
readers. You can choose from single-line, password, and resizable multiline text fields:

• A single-line text field lets readers enter specific information from a range too wide to list 
using radio buttons, checkboxes, or a scrollable list. Good examples are names, telephone 
numbers, and filenames.
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• A password field is a special kind of single-line text field. Typing text in a password field 
displays a series of bullets or asterisks that hide the actual text characters. (However, the text 
is not encrypted.)

Note: To use passwords or to set up security for directories or pages, contact your ISP. Passwords 
and security usually require scripting or server configuration that is beyond the scope of PageMill. 

• A text area, or multiline text field, lets a reader type a long passage of text. A text area can be 
scrolled if the text exceeds the size of the field. 

Note: PageMill does not support text wrap in a text field unless you edit the source code to include 
the <WRAP> attribute in the <TEXT AREA> tag. For more information on the <WRAP> 
attribute, call Adobe FaxYI at 206-628-5737 and request document 202144.

You can also customize a text field using the Inspector palette by renaming the text field (which 
isn’t visible to readers) or by resizing the text field visually or numerically. If you or the script 
programmer rename a text field, check that it matches the text field name in the corresponding 
CGI script. 

To add a single-line, password, or multiline text field:

1 In Edit mode, click the page where you want to add the text field.

2 Type a label for the text field.
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3 Click the Insert Text Area (k), Insert Text Field (l), or Insert Password Field (x) button 
on the button bar. 

A. Insert Text Area B. Insert Text Field C. Insert Password Field

4 For a single-line or multiline text field, to add text that appears by default, double-click in 
the text field and type the text.

To rename a text field:

1 In Edit mode, click the text field to select it.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or 
View > Show Inspector (Windows).

3 In the Object panel, type a new name in the Name text box.

4 Press Return or Enter.

To resize a single-line or password text field visually:

1 In Edit mode, click the text field to select it.

2 Drag the handle on the edge of the text field to resize the field.

To resize a single-line text field numerically:

1 In Edit mode, click the text field to select it.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or
View > Show Inspector (Windows).

3 In the Object panel, type the horizontal dimension of the text field, measured in 
monospaced characters, into the Size text box. The Maximum Length setting controls 
how many characters the reader can enter into the field.

4 Press Return or Enter.

CA B
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To resize a multiline text field visually:

1 In Edit mode, click the text field to select it.

2 Drag one of the handles on the edge of the text field as follows:

• To resize only the horizontal dimension, drag the handle on the right edge.

• To resize only the vertical dimension, drag the handle on the bottom edge.

• To resize both dimensions freely, drag the handle on the bottom right corner.

• To maintain the original proportions, Shift-drag the bottom right corner handle.

To resize a multiline text field numerically:

1 In Edit mode, click the text field to select it.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or
View > Show Inspector (Windows).

3 In the Object panel, type new dimensions as follows:

• Rows specifies the number of lines of text visible.

• Columns specifies the number of monospaced characters visible horizontally.

Adding a hidden field

Hidden fields appear only in HTML code, and do not appear on the form when viewed by 
readers. The most common use for hidden fields is mailback scripts. For example, many 
ISPs provide a standard CGI script for receiving form data and mailing it to your e-mail 
box. The CGI script requires a hidden field with the site owner’s mail address, so that the 
script knows what address to send the form information to. (See also Appendix B , “Viewing 
and Editing HTML Code.”)
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To add a hidden field:

1 In Edit mode, click the page where you want to add the hidden field.

2 Choose Edit > Insert Invisible > Hidden Field.

The field appears on the page as a small box with an H in it. This marker and hidden fields are 
visible only in Edit mode. To turn off the display of hidden fields, choose Edit > Hide Invisibles.

To customize a hidden field:

1 In Edit mode, click to select a hidden field on the page.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or 
View > Show Inspector (Windows).

3 In the Object panel, choose from the following options to set the attributes:

• Type a name to tell the form script which hidden field is sending data. You can rename the 
default to describe what the option represents. The name is determined by the CGI script. For 
example, the name of a hidden field might be “Mailed from.” Ask your ISP or the script designer 
for the exact name.

• Type a value to tell the form script what value to send when the hidden field is selected. This 
value is determined by the CGI script. For example, the value of a hidden field might be a 
personal e-mail address. Ask your ISP or the script designer for the exact value.

4 If you or the script programmer changed the name and value of this hidden field in step 3, 
check that the new name and value match those for this hidden field in the CGI script that 
interprets the form’s data.

Adding a pop-up menu or list-selection field

Pop-up menus and list-selection fields let readers choose from a set of alternatives:

• Use a pop-up menu when you want the reader to choose only one item from a group. In this 
way, a pop-up menu resembles a radio button group, but a pop-up menu takes up less space.

• Use a list-selection field when you want the reader to choose one or more items from a list. 
However, a list-selection field generally takes up more space than a pop-up menu, and it is less 
intuitive for making multiple selections than a group of checkboxes. To create a list-selection 
field, you create a pop-up menu first, and then convert it to a list-selection field.
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To add a pop-up menu:

1 In Edit mode, click the page where you want to add the pop-up menu or list-selection field.

2 Type a label for the pop-up menu.

3 Click the Pop-Up Menu button (n) in the toolbar.

To convert a pop-up menu to a list-selection field, or vice versa:

1 In Edit mode, click the pop-up menu.

2 Drag the handle at the bottom of the item border, as follows:

• To convert a pop-up menu to a list-selection field, drag the handle down until the field 
becomes the size you want or select the field and click Allow Multiple Selections in the Object 
panel of the Inspector.

• To turn a list-selection field into a pop-up menu, make sure the Allow Multiple Selections 
option in the Object panel of the Inspector is deselected, then drag the handle up until only
one item appears.

3 Click outside the pop-up menu or list-selection field.

To set up the choices in a pop-up menu or list-selection field:

1 In Edit mode, double-click the pop-up menu or list-selection field.

2 Choose Edit > Select All.

3 For each entry, type the entry and then press Return or Enter. 
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4 Make an item a default selection by choosing from the following options:

• For a pop-up menu, drag the triangle to position it next to a menu item.

• For a list-selection field, check the box next to an item in the list. (These checkboxes are 
for setting the default only; the reader will not see these checkboxes but will simply choose 
one option.)

Pop-up menu List-selection field

5 Click outside the pop-up menu or list-selection field.

To set a value for pop-up menu or list-selection field options:

1 In Edit mode, click to select the pop-up menu or list-selection field.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or 
View > Show Inspector (Windows).

3 In the Object panel, type a value next to the item name to tell the form script what value to 
send when the menu option is selected. This value is determined by the CGI script. Ask your 
ISP or the script designer for the exact value.

4 If you or the script programmer changed the name or value of a menu option, check that 
the new name and value match those for this hidden field in the CGI script that interprets 
the form’s data.

To resize a list-selection field visually:

In Edit mode, click the list-selection field and drag the handle at the bottom of the item border 
to resize it.
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To resize a pop-up menu or list-selection field numerically:

1 In Edit mode, select the pop-up menu or list-selection field.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or 
View > Show Inspector (Windows).

3 In the Object panel in the Items Visible text box, enter the number of items to display in the 
list-selection field. Additional items won’t be visible until the reader scrolls the field.

Note: Typing a value of 1 into the Items Visible option converts the field to a pop-up menu if the 
Allow Multiple Selections option is deselected.

To make multiple choices when browsing a list-selection field:

In Edit mode, click the selections you want in the list-selection field.

To allow or disallow multiple choices in a pop-up menu or list-selection field:

1 In Edit mode, select the pop-up menu or list-selection field.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or
View > Show Inspector (Windows).

3 In the Object panel, select or deselect the Allow Multiple Selections option.

Note: Selecting Allow Multiple Selections for a pop-up menu converts it to a list-selection field.

Adding Submit and Reset buttons

A Web page form does not send any form information to the Web server until the reader explic-
itly requests it to do so. Typically, readers send information by clicking a Submit button, and 
can clear a form and start over by clicking a Reset button. The exact names and appearances of 
the Submit and Reset buttons vary. Some Web pages use a graphic for a Submit button to match 
the graphic identity of the page. In PageMill, you can use only one Submit button per form.
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To add a Submit or Reset button:

1 In Edit mode, click the page where you want to add the button.

2 Click the Submit Button tool (o) or Reset Button tool (p) in the toolbar.

To change the text inside a Submit or Reset button:

1 In Edit mode, double-click the Submit Button tool (o) or Reset Button tool (p); then 
double-click the text inside it.

2 Type the text you want. The button will resize to accommodate the new label.

Using an image as a Submit button

To make a Submit button more visually consistent with the page design, you can create an 
image in another program and use it as a Submit button.

To use an image as a Submit button:

1 In Edit mode, click the image that you want to use as a button.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or
View > Show Inspector (Windows).

3 In the Object panel, select the Button Behavior option.

Associating a CGI script with a form
Clicking the Submit button causes the browser to send the values of every option and text 
field on a form to the Web server. Each form must have a corresponding CGI script on the 
server—provided by you or by your script programmer—that recognizes and can process the 
names and values it receives from the form objects on your page. Work with the CGI script 
programmer to ensure that the form objects’ names and values are consistent with those in the 
script. For more information about setting up names and values of form objects, see “Adding 
form objects” on page 158.

Note: PageMill does not support multiple forms (scripts) on a single page.
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To associate the appropriate CGI script with a form:

1 If the page is not in Edit mode, click the globe icon in the upper right corner.

2 To display the Inspector palette, choose Window > Show Inspector (Macintosh) or 
View > Show Inspector (Windows).

3 Click the Form tab (L).

4 Type the pathname for the CGI script into the Action text box.

5 In the pop-up menu to the right of the Action option, choose Get or Post. For more 
information about which option to choose, consult your script programmer or 
contact your ISP.
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Chapter 9: Using Frames

rames divide a browser window, so that more than one Web page can be shown at once. 
Frames appear as small separate windows. The content of each frame is a separate page 
(and separate file) with its own URL, independent of other frames. 

Frames let you create pages where only sections change. They are useful for displaying station-
ary items, such as a company logo or a navigation bar, and for displaying tables of contents or 
indexes, where clicking a word or image in one frame brings up a detailed description of the 
topic in an adjoining frame.

While both standard pages and frames use links to move to different locations, they differ in 
these ways:

• Clicking a link to a standard page displays the linked contents by replacing the contents of the 
open window or by opening a separate, overlapping window. 

• Clicking a link to a frame opens the linked contents inside one of the frames, leaving the 
other frames unchanged. The frame in which the link opens is the targeted frame. For more 
information, see “Targeting links in frames” on page 185.

A. User clicks link to page B. New page is displayed C. User clicks link to frame D. Linked information appears 
in the targeted frame on the page

F

B
D

CA
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Understanding frames and framesets
When you divide a page into frames, you’re creating two components: a frameset document, and 
frame source documents. The frameset document, which is created automatically by PageMill, 
works behind the scenes to organize the frames—it tells the browser how to display the frame 
windows and which documents to display inside each frame. Pages that appear in the frames 
are the frame source documents. In PageMill, the frameset filename appears in the Title bar 
when you’re working in a page containing frames. You cannot view the source code for a 
frameset document.

Not all browsers support frames, but Netscape Navigator 2.0 and later, Microsoft Internet 
Explorer 3.0 and later, and AOL Web Browser 3.0 and later do. If a browser doesn’t support 
frames, readers won’t see your frame document. You can include a “no frames” message page 
in one of the frames for these readers. You can edit this message to display what you want to 
appear in place of the frames. 

You can have as many frames in a frameset as you want. Keep in mind, however, that too many 
frames, like too many links, can make a page look cluttered and can confuse the reader. Multi-
ple small frames also restrict how much content can appear in each frame—so you can end up 
with only a few words or part of an image in a frame. Also, each individual frame requires 
another page to be loaded into the browser. Too many pages can cause long load times and an 
out-of-memory message for users with low modem speeds or smaller amounts of memory.

Here’s a suggested procedure for creating your framesets:

• Design your frameset first—decide which framesets will be static and which will be dynamic.

• Create and name the frames.

• Add the content to the frames. Save your frame source documents as you place or edit them 
in the frames.

• Save the frameset.

• Create the links.

• Target the links and save the frame documents with the links in place.

• Preview the links.
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Creating a frameset
The purpose of the frameset document is to store information about the size, placement, 
contents, and other attributes of each frame. To create a frameset, you divide the page into 
frames. In PageMill, dividing a page into frames is as simple as dragging a border. You can 
also nest frames (create one frameset inside of another).

To create a frameset:

1 If the page is not in Edit mode, click the globe icon in the upper right corner of the page.

2 Press Option (Macintosh) or Ctrl (Windows) and position the pointer just inside the thin 
line at the edge of the window until an arrow appears, indicating the direction to drag to 
create a frame.

A. Frame border

3 Choose from the following options:

• Option-drag (Macintosh) or Ctrl-drag (Windows) vertically or horizontally to 
create a frame.

Creating a horizontal frame Creating a vertical frame

A
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Resulting frames on page

• Command-Option–drag (Macintosh) or Ctrl-Shift-drag (Windows) to create a frame the 
full width or height of the window. 

Creating a full-width frame
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Resulting frames on page

• Place the insertion point in the page and choose Edit > Split Vertically (Macintosh) or 
Edit > Split Frames Vertically (Windows) or Edit > Split Horizontally (Macintosh) or 
Edit > Split Frames Horizontally (Windows). (You can also use this option to divide 
existing frames.)

To undo the creation of a frame:

Immediately after creating a frame, choose Edit > Undo.

To remove a frame:

1 Make sure the frame you want to delete is not selected.

2 Position the pointer over the thin line that defines the frame border. When you see the 
double-headed arrow, drag the frame border horizontally or vertically to the edge of the 
window or to the edge of an adjoining frame, then release the mouse. You will get a message 
asking if you want to delete the frame. 

3 Click OK.
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To change the explanatory message for browsers that don’t support frames:

1 Open a page containing frames. 

2 Choose Edit > No Frames Message. The default no frames message appears in a separate 
window: “Viewing this page requires a browser capable of displaying frames.”

3 Edit the message or type a new message into a separate page, drag and drop the text into the 
window, and choose Edit > Save Frameset.

Adding content to a frame
You can add elements to a frame as you would to any other Web page. You can also insert an 
existing page into a frame. 

Once you save a frame, you can add links. For more information, see “Saving frames and 
framesets” on page 183 and Chapter 5, “Creating Links.” 

To open a page in a frame:

1 Click within the frame to select it.

2 Do one of the following:

• Choose File > Insert Page (Macintosh) or File > Frameset > Insert Page (Windows), select a 
file from the Open dialog box, and click Open.

• Choose File > Insert New (Macintosh) or File > Frameset > Insert New (Windows) to insert 
a new blank page in the frame.

To add content to a frame:

1 In Edit mode, select the frame into which you’ll add content.

2 Do one of the following:

• Type text into the frame.

• Choose File > Place (or click the Place Object button (v) in the toolbar) to insert an image 
or other media object.

• Drag selected items from an open page to the frame. 

• Choose Edit > Copy or Cut to copy or cut a selection or a page; then choose Edit > Paste to 
paste it into a frame. 
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Editing the frameset layout and settings
Within a frameset, you can specify different settings, such as the layout of the frames, the frame 
names, the size of the frames, and whether scrollbars are visible. These settings are stored in the 
frameset file. You can adjust the following settings:

• frame name 

• frame size

• frame margins 

• scrollbar display

• frame reusability

• the location of the anchor on the page within the frame

Renaming a frame

Each frame is named by default as framexxx (Macintosh) or FramePagexx (Windows), where 
xxx is a randomly generated number. Names are used by other pages to designate a target 
for a link.

To rename a frame:

1 Click within a frame to select it.

2 To display the Inspector panel, choose Window > Show Inspector (Macintosh) or
View > Show Inspector (Windows).

3 In the Frame panel, select the default name and enter a new name. It’s best to give the frame 
a name that easily identifies the frame contents, for example, a frame containing a table of 
contents might be named TOC. Use only alphanumeric characters and do not use spaces in 
a frame name. 

4 Choose File > Save Frameset (Macintosh) or File > Frameset > Save Frameset (Windows).

Warning: Be sure you name the frames before you target any links to the frame. Renaming frames 
after targeting links breaks the links, so that the linked page opens in a new browser window instead 
of the desired frame. 
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Resizing a frame visually

You can resize a frame by simply dragging its borders.

To resize a frame visually:

1 Move the pointer over an edge of the frame that abuts another frame until a double-headed 
arrow appears.

2 Drag to resize the frame. You can’t resize by dragging from the outside edges of the window.

Text in left frame cut off Frame resized

3 Choose File > Save Frameset (Macintosh) or File > Frameset > Save Frameset (Windows).
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Resizing a frame in the Inspector palette

You can resize a frame numerically using the Inspector palette Height and Width options. 

To resize nested frames, use the Inspector’s Frames Resizing Box. The Frames Resizing Box in 
the Frame panel of the Inspector displays a series of nested squares. Each square represents a 
frame level. One square indicates the selected frame is one level deep and is the topmost level 
(that is, it’s not inside another frame). Any settings you enter apply to this frame. Two squares 
indicate the selected frame is nested inside another frame, three squares that the nested frame 
is nested inside another frame, and so on. Click a square to select it. The values you enter for 
Height or Width are applied to the selected frame.

To resize a single frame:

1 Click the frame in the PageMill page to select it.

2 To display the Inspector panel, choose Window > Show Inspector (Macintosh) or
View > Show Inspector (Windows).

3 In the Frame panel, for Width or Height, choose a unit of measurement, then enter a value:

• Choose Pixels and enter a value for the width in pixels. This creates a frame that will not be 
resized when the browser window is resized. This is useful when you want text or images to 
always be displayed at their full size, no matter what the browser window size. 

• Choose Percentage and enter a value to specify what proportion of the browser window 
will be used to display the frame. 100% width equals the width of the window. You can use 
the Percentage option, for example, to have a navigation menu display at the browser window’s 
full width.

• Choose Relative to make the frame proportional to the other frames in the frameset. Use inte-
gers greater than 0 (1, 2, 3, and so on) to set relative width and height. For example, if you set 
one frame column to a relative Width of 1, and the other frame column to 5, the second column 
will be 5 times the size of the first column. 

Note: If the frame fills the width of the window, the Height option appears. If the frame fills only 
part of the window, the Width option appears. When the combined frame widths do not equal the 
width of the browser window, the browser will adjust the frames by proportionally increasing or 
decreasing the frame dimensions. 

4 Choose File > Save Frameset (Macintosh) or File > Frameset > Save Frameset (Windows).
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To resize a nested frame:

1 Click within the frame in the PageMill page to select it.

2 To display the Inspector panel, choose Window > Show Inspector (Macintosh) or
View > Show Inspector (Windows).

3 Click the level of frame you want to resize in the frames resizing box.

4 In the Frame panel, for Width or Height, choose a unit of measurement, then enter a value.

When you’re resizing nested frames, the height and width can be changed for each nested level 
of the frame. The Width option is available when the selected level is related to the adjacent 
frames in terms of width. The Height option is available when the selected level is related to the 
adjacent frames in terms of height.

Resizing the height of a Resizing the width of a Resizing the height of a
top-level frame nested frame nested frame

5 Choose File > Save Frameset (Macintosh) or File > Frameset > Save Frameset (Windows).
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Setting frame margins

Margins determine how much space remains between the edge of the frame and the top, 
bottom, and sides of the page.

To set frame margins:

1 Click within a frame to select it.

2 To display the Inspector panel, choose Window > Show Inspector (Macintosh) or
View > Show Inspector (Windows).

3 In the Frame panel, for Margin Height and Width, enter new pixel values. Margins must be 
at least 1 pixel.

Determining scrollbar display

Scrollbars appear automatically for all frames. You can hide the scrollbars or make them appear 
only when the page in the frame exceeds the frame dimensions.

To set the display of scrollbars:

1 Click within a frame to select it.

2 To display the Inspector panel, choose Window > Show Inspector (Macintosh) or
View > Show Inspector (Windows).

3 In the Frame panel, choose one of the following Scrollbar options:

• Yes to always show scrollbars.

• No to never show scrollbars.
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• Auto to show scrollbars only when necessary.

Anchoring a frame

By default, the page in a frame is displayed starting at the top of the page. You can insert an 
anchor in the frame source document, so that when the frameset is opened, the page displays 
at the location of the anchor.

To anchor to a specific location on a page:

1 In the frame that contains the page you want to open to a specific location, scroll to 
the location.

2 Choose Edit > Insert Invisible > Anchor (if one does not already exist).

3 To display the Inspector panel, choose Window > Show Inspector (Macintosh) or
View > Show Inspector (Windows).

4 Drag and drop the anchor icon on the Anchor At field in the Inspector’s Frame panel, or type 
the anchor name in the field.

5 Save the page and frameset by choosing File > Save Everything (Macintosh) or File > 
Frameset > Save Everything (Windows). 
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Preventing frame resizing

By default, a reader can resize the frame in the browser. You can choose to keep the frame at its 
original size. 

To make a frame non-resizable:

1 Click within a frame to select it.

2 To display the Inspector panel, choose Window > Show Inspector (Macintosh) or
View > Show Inspector (Windows).

3 In the Frame panel, deselect the Viewer Resizable option. Any frames sharing a border with 
the frame will also be non-resizable.

Note: PageMill cannot correctly preview frame-based pages that have the Viewer Resizable option 
selected. To preview these frames, open the page in a Web browser. 

Saving frames and framesets
It’s recommended that you save frames and the frameset as you work. Before you save a 
frameset, be sure that the page and the individual frames appear as you want them to when the 
reader opens the page. For example, if you have followed a link, be sure and return to the orig-
inal page before saving the frameset.

PageMill prompts you to save frames and framesets when you:

• Switch to Preview mode and click a link that causes an unsaved frame to be replaced by a 
new frame document. 

• Switch to Preview mode and click a link that takes you out of the frameset before it has 
been saved. 

• Close a document with unsaved frames or close an unsaved frameset document.

Macintosh Note: When you are prompted to save on the Macintosh, PageMill displays a 
thumbnail of the frameset document, highlighting the frame that is not saved.

The frameset document is changed and must be saved whenever you create a new frame, 
move a frame border, change any frame attributes, rename the frameset, or edit the 
No Frames Message.
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To save the contents of a frame:

1 Click within a frame to select it.

2 Choose from the following options:

• Choose File > Save Frame. If you’re saving the frame for the first time, PageMill names the 
page with the name of the frame plus the .html or .htm extension. 

• Choose File > Save Frame As to save and rename the frame. Name the page with a 
.html extension.

• Choose File > Save a Copy As (Macintosh only) to rename and save a copy of the frame.

3 Click Save.

To save a frameset:

1 Choose one of the following commands:

• File > Save Frameset (Macintosh) or File > Frameset > Save Frameset (Windows) to name 
and save the layout and configuration of a frameset for the first time, or to replace an existing 
frameset’s layout and configuration

• File > Save Frameset As (Macintosh) or File > Frameset > Save Frameset As (Windows) to 
save and rename a frameset

• File > Save Frameset Copy As (Macintosh only) to rename and save a copy of the frameset file

• File > Save Everything (Macintosh) or File > Frameset > Save Everything to save any content 
changes to individual frames and to save the frameset file

2 Click Save.

To revert to the last saved version of a frame or a frameset:

Do one of the following:

• Click within a frame to select it and Choose File > Revert to Last Saved (Macintosh) or 
File > Frameset > Revert to Saved (Windows) to go back to the last saved version of a frame.

• In a page that contains frames, choose File > Revert to Last Saved Frameset (Macintosh) or 
File > Frameset > Revert to Saved Frameset (Windows) to go back to the last saved version 
of a frameset.
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Printing frames
You can print the contents of a selected frame as individual pages.

To print a frame:

1 Click within the frame to select it.

2 Choose File > Print Frame.

Targeting links in frames
When you want a link to display a page in a specific frame, you create the link and then target 
the link to a specific frame. If you do not define a target for a link, the linked page opens into 
the frame that contains the link.

You define the target using the target menu. In most cases, you’ll target a frame by dragging 
over the frame representation in the menu. Netscape’s special targets provide additional control 
over how frames are targeted within a frameset. These special targets are displayed in the top 
of the target menu.

To set a target frame by dragging: 

1 Create the link in a frame.

2 In Edit mode, triple-click to select the link. 

3 Do one of the following:

• Position the pointer on top of the link (Macintosh) or right-click the link (Windows) and 
press to display the target menu.

• Click the target button (•) in the lower right corner of the frameset window to display 
the target menu. 
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4 Drag the target icon over the frame you want to display the linked page.

To set a target using a special target option:

1 Create the link in a frame.

2 In Edit mode, triple-click to select the link. 

3 Do one of the following:

• Position the pointer on top of the link (Macintosh) or right-click the link (Windows) 
and press to display the target menu.

• Click the target button (•) in the lower right corner of the frameset window to display 
the target menu.



187

4 Choose an option from the target menu, as follows: 

• Default, to display the linked page in the same frame as the link or in the base target frame. 
A default target resets the link so it’s not targeted to a frame. You can also use this setting to 
clear a previous target.

• New Window, to display the linked page in a new window leaving the original browser 
window open.

• Parent Window, to display the linked page within a frameset that’s currently displayed inside 
another frameset, and open the page inside its own original, parent frameset.

Note: PageMill cannot correctly preview frame-based pages that have links using the Parent 
Window target. To preview these frames, open the page in a Web browser. 

• Same Frame, to display the linked page in the same frame as the link, just like the Default 
setting. Use this targeting option only when you want to override a base target. 

• Same Window, to display the linked page using the entire current browser window. If the 
linked document is a frameset document, the previous frameset is replaced by the new 
frameset. Use Same Window when the link is to a page that is part of a frameset and you want 
the frameset to open in a new window, not in the current frameset, that is, in the “same 
window” as it would normally open in if the link were opened outside of a frames page. 

Base Targets

Netscape enables you to add a <BASE TARGET> tag inside the <HEAD> tag in a frameset 
document (for example, <BASE TARGET=”main_window”>). When you specify a base target, 
the browser uses a default frame window for all links that don’t have defined targets, saving you 
from having to define each link separately. You specify a base target for the frame containing 
the link.

To assign a base target:

1 Click in the frame that will contain the links.

2 Choose Window > Show Inspector (Macintosh) or View > Show Inspector (Windows).

3 Click the Page tab.

4 Choose an option from the Base menu.

When you use a base target, you can’t target a link to open in the same frame as the link. To do 
this, use the Same Frame option.
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Overriding targeted frames
You can override targeted links so that instead of opening inside their targeted frame, they open 
in either the same window or a new window. You might want to do this to edit a frame or create 
additional links.

To override targeted frames:

In Preview mode, move the pointer over a targeted link and press the mouse button 
(Macintosh) or right-click (Windows) to display the menu. Choose New Window to display 
the linked page in a new, separate window or Same Window to display the linked page in the 
current window.

Moving from frame to frame 
Moving backward and forward in frames is different from moving backward and forward
in pages. When you preview links that are targeted to frames, the frame changes but the page 
does not change. This requires a method for moving inside of frame windows without leaving 
the frameset document.

To navigate in frames:

In Preview mode, click a link and move to the linked page. Move the pointer over an unlinked 
section of the page and press the mouse button (Macintosh) or right-click (Windows) to 
display a menu. Choose Back in Frame or Forward in Frame. 

Opening a frame in a window
Opening a frame into a separate window makes it easier to work on a page, give the page a title, 
and view its source code.

To open a frame in a separate window:

Click inside the frame and choose File > Open into Window (Macintosh) or File > Frameset > 
Open into Window (Windows). 
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Chapter 10: Uploading Your 
Web Site

our Web site becomes visible to other people only after you upload your Web site’s 
HTML page files to the Web server publishing your site. Before you upload your site, 
check for and correct any linking errors among your pages, and make sure that every 

HTML page file, image, and subfolder on your site is contained within the local root folder on 
your computer.

Uploading your Web site (Macintosh) 
On the Macintosh, if you create a Web site inside the local root (site) folder, you can upload 
everything in that folder (HTML documents, images, subdirectories) using an FTP program. 
The directory (or local root folder) structure on the Web server must mirror (or match) the 
directory structure on the Mac, to avoid breaking links. Ask your Internet Service Provider 
(ISP) for help on how to upload your Web files. 

If you are not publishing the files from your own computer or administering the Web server 
yourself, the way you transfer your site to the Web server depends on how you get to the Web:

• If you are using an ISP, talk with the Webmaster to determine how to transfer your pages to 
the Web server. In most cases, you may have FTP access only, so that you have to use FTP 
software such as Dartmouth’s Fetch to transfer the files to the server. For more information, see 
“Making a Fetch file transfer go smoothly (Macintosh)” on page 191. If you don’t have the 
capability of transferring your files electronically, your ISP may request that you send your files 
on removable media, such as floppy disks or a ZIP drive.

• If you work for a company that gives you file access to its Web server, you may be able to 
mount the server as a networked volume on your computer. This action lets you transfer your 
pages simply by copying them to the server from your desktop computer the way you would 
any other file. Again, consult with your company’s Webmaster to see if you have this option.

For more information, see “About the World Wide Web” on page 39.

Y



CHAPTER 10190
Uploading Your Web Site

Uploading your Web site (Windows)
On a Windows machine, if you create a Web site inside the local root (site) folder on your 
computer, you can upload everything in that folder (HTML documents, images, subdirecto-
ries) using the Uploader application. For more information on organizing your site, see 
“Step 3: Structure your Web site” on page 49.

Uploader is a separate application shipped with PageMill and installed by the Installer in your 
PageMill folder. Uploader can be started from Windows itself or can be launched from within 
PageMill. The first time you use Uploader you will be prompted to enter site and user informa-
tion. These settings then stay in effect until you change them.

To upload your Web site from within PageMill:

1 Choose File > Upload > Page to display the Site Mapping Information dialog box. 

2 For Site mapping name, enter a name that identifies the site for you, for example, 
Jane’s Home Page.

3 For Host name, enter the address of your ISP. You can enter a domain name, such as 
mc.isp.com, or an IP numeric address (which you can get from your provider). The name may 
be entered for you automatically.

4 For Remote folder, enter the name of the folder on the server that will store your files, for 
example, public_html. This is the relative path to the default directory on the server. Do not 
precede the path name with a slash (/).

5 For Local folder, enter the name of your local root folder, for example, 
c:\PageMill\root folder. This name may be entered for you automatically.

6 For User name, enter the login name provided by your ISP.

7 For Password, enter the Web access password provided by your ISP.

8 For Upload basis, choose one of the following:

• Previous log file, which uploads all files where the file date is different from the file date in the 
log or later than the date in the log. 

• Remote file status, which uploads files based on the Name, Size, and Date information for the 
files. If any of these identifiers is different from the file on the remote server, the file is uploaded. 

• Always, which uploads all files.

9 Click Save Password if you want PageMill to save your password.



191

10 Click OK.

11 Select the site you want to upload, and click Upload.

When uploading is complete, the dialog box closes. An error message appears if there is a 
problem during the uploading process.

Note: You cannot use proxy servers to upload your site.

To upload an object or frameset:

Select the object or frameset document and choose File > Upload > Object or 
File > Upload > Frameset.

When you upload an object, the file containing the object and the files associated with the 
object are uploaded. For example, uploading an image used in a server-side image map uploads 
the image file and the associated server-side image map file.

When you upload a frameset, the frameset document and the associated files are uploaded.

To upload your Web site from Windows:

1 Start the Uploader application.

2 Choose New or Edit if you need to change the site information.

3 Click Start Upload.

Making a Fetch file transfer go smoothly (Macintosh)
Dartmouth’s Fetch is a popular FTP file-transfer utility you can use to transfer files 
to a Macintosh, Windows, or UNIX-based Web server. Fetch is available at 
http://www.dartmouth.edu/pages/softdev/fetch.html and from the Info-Mac archive mirror
sites on the World Wide Web. Links to the Info-Mac archives appear on many Web sites that 
provide information about the Macintosh computer. Ask their ISP for support when uploading 
your files, as it is the provider’s responsibility to help you. 

Note: Fetch is an FTP file-transfer utility maintained by Dartmouth College, not to be confused 
with Extensis Fetch®. 
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Tips to make transfers smoother

If you use Fetch to transfer your files to the Web server, consider the following tips to help make 
transfers smoother:

• If Fetch prompts you for the file type, specify Raw Data. 

• Use the Raw Data format when you’re uploading graphics or other cross-platform files.

• Do not include spaces in filenames or characters other than A to Z, a to z, 0 to 9, and 
_ (underscore). If you include spaces, Fetch converts them to underscores. This changes the 
filenames, which breaks all of the links on your site. If you are uploading to DOS servers, you 
can use a single period, hyphens (-), and tildes (~). Windows NT as well as UNIX and 
Macintosh platforms support these characters.

• If you are transferring to a UNIX file server, be aware that UNIX is case-sensitive. 
For example, Test.html and test.html are considered two different filenames.

• Set up preferences. See the following section for more information.

Setting up Fetch preferences

In Fetch 3.0 or later, you can set Upload Preferences to prevent Fetch from adding extensions 
to your files and breaking file links.

To set up preferences in Fetch:

1 In Fetch, choose Customize > Preferences, and click the Upload tab.

2 For the default text format, choose Text from the pop-up menu.

3 For the default nontext format, choose Raw Data from the pop-up menu.

4 Deselect the Add .txt Suffix to Text Files option and the Add .bin suffix to Macintosh II files 
option to prevent Fetch from changing the filename suffix and breaking any links to the file. 

5 Click OK.

To upload files from Fetch on computers running System 7.5. or later:

1 Select Automatic in the Fetch window to have the application automatically upload files in 
the appropriate format. 

2 Drag and drop the Web site files from the Finder into the Fetch window.
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To upload files from Fetch on computers running System 7.1.2. or earlier:

1 Choose Remote > Put Files and Folders.

2 Locate the file or folders you want to upload and click Add.

3 Click Done.

4 Click OK to confirm your selection. Make sure the Text File format is set to Text and the 
Other Files format is Raw Data. 

If you upload files singly, be sure to put them in the right folders. 

To upload entire folders using Fetch:

1 In Fetch, press Option and click Put File, or choose Remote > Put Folders and Files.

2 Select the file and folders you want to upload.

3 Click Add.

4 Click Done.
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Appendix A: Troubleshooting

his appendix contains solutions to problems you may encounter when using Adobe 
PageMill. For last-minute information not included in this book, see the ReadMe file 
installed with the application.

Before you call technical support
Before calling technical support to report a problem, performing the following steps can solve 
many problems and often eliminates the need for telephone assistance.

To solve preliminary problems before calling technical support:

1 See the ReadMe file installed with the program for last-minute information not included 
in this user guide.

2 Restart your computer choosing from the following options:

• (Macintosh) Quit all open applications, hold down the Shift key, and choose 
Special > Restart; when the machine restarts and the desktop appears, release the Shift key. 
Then see if the problem reoccurs.

• (Windows) Exit all other open applications and restart your system in Safe Mode (Windows 95) 
or VGA Mode (Windows NT). Then see if the problem reoccurs.

3 Quit Adobe PageMill if it is still running, and do one of the following: 

• (Macintosh) Throw away the Adobe PageMill Preferences file (by dragging it from the Pref-
erences folder to the Trash), and empty the Trash. Restart your computer and reinstall Adobe 
PageMill. 

• (Windows) Uninstall PageMill and remove all of PageMill’s preferences from the Registry. 
Reinstall PageMill.

4 Don’t delete the files from the Web before calling. Technical Support may need to look at the 
files over the Web to determine the problem.

5 If the problem is with forms or CGI scripts, have the URL of the online help page available.

T
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6 Refer to the following Adobe sources for technical documents about PageMill that address 
the problem:

• At the Adobe Technical Support database at http://www.adobe.com/supportservice/
custsupport/tssearchdb.html/

This database functions like a net search and lets you look at the same documents that the 
Adobe technical support staff uses to troubleshoot calls.

• On the Adobe BBS, at 206/623-6984 in the Adobe PageMill conference

• On the Adobe automated fax-back system, Adobe FaxYI, at 206-628-5737 (start by 
requesting document 260099, the PageMill/SiteMill index)

• Via e-mail, by sending an Internet e-mail to the auto-responder at techdocs@adobe.com. 
Enter the desired document number in the subject field of the message (for example, document 
260099, the PageMill/SiteMill index). If you have never used the system before or if you don’t 
know the number of the document, enter Help into the subject line of the e-mail message.

Uninstalling PageMill (Windows only)
There may be instances when you need to uninstall the PageMill application. 

To uninstall:

1 Choose Start > Programs > Adobe > PageMill 2.0.

2 Choose Uninstall PageMill 2.0.

Transferring PageMill documents across platforms
If you will be uploading your files to servers using different platforms or a platform that does 
not match your system, you need to decide on specific file naming rules before you create, copy, 
or upload HTML files. Your ISP can provide information on server naming conventions, for 
example, the ability of the server to recognize long filenames. 

Windows 95 and Windows NT 4.0 support filenames of up to 255 characters. The Macintosh 
supports filenames of up to 31 characters. When a long filename is created for a Windows 
document, an automatic alias is generated following the older DOS convention of an eight 
character filename followed by a three-character extension (8.3). You cannot control this alias 
name (unless you only use the 8.3 convention in the original filename). Long filenames are 
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case-sensitive in Windows; however, the automatically generated alias converts all the letters to 
uppercase. If you copy files with longer filenames to servers that cannot support long 
filenames, the 8.3 alias is substituted for the long filename, breaking any links that reference the 
longer name. The following procedures can help you move your files quickly and easily.

When transferring PageMill documents between Windows and Macintosh:

1 Make sure the correct Netscape plug-in is installed on the computer to ensure that plug-ins 
can be viewed correctly.

2 Make sure the PageMill_Resources folder (or the folder you use for resources) is installed 
and mirrored correctly on both platforms.

3 To avoid problems, name your files using the eight-character filename and three-character 
extension convention.

When transferring PageMill documents from the Macintosh to the Windows platform:

1 Copy the files on disks formatted for Windows.

2 Use a file-transfer utility (for example, Apple File Exchange) to transfer the files, or transfer 
the files over a network. When transferring to a Windows-formatted disk, the Macintosh file-
names are converted to the 8.3 convention.

Examples: March3-7.html (Macintosh) is converted to !march3.htm (Windows), 
NewFile.html (Macintosh) is converted to Newfile.htm (Windows), My Document.html 
is converted to !mydocum.ent. 

Note: PageMill 2.0 for the Macintosh and PageMill 2.0 for Windows support the same HTML 
features and files will display similarly on either platform. 

When transferring PageMill documents from the Windows to the Macintosh platform:

Copy the files on disks formatted for Windows. When converting the names, Windows 95 and 
Windows NT 4.0 capitalize the filename and provide only a three-letter extension.

PageMill for the Macintosh includes versions 1.0, 1.0.1, 1.0.2, and 2.0. Files from any of these 
versions can also be opened in all versions of PageMill and can also be edited using a text editor 
such as SimpleText, or Wordpad. 

Examples: march3.html (Windows) is converted to MARCH3~.HTM (Macintosh), 
NewFile.html (Windows) is converted to NEWFIL~1.HTM (Macintosh), MyDocument. html 
is converted to MYDOCU~1.HTM (Macintosh).
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Common problems
This section describes common problems and their solutions.

Existing HTML page opens as a blank, gray screen

The HTML code has been altered in some way so that it can’t be understood by PageMill, 
therefore PageMill cannot display the page. Check the HTML code in Source View or open the 
file in a text editor, then correct the incorrect or incomplete tags.

Can’t select, edit, or drop anything on a page; or the Inspector palette 
is inactive

Make sure that the page is in Edit mode rather than Preview mode. Click the PageMill globe 
icon that appears in the upper right corner of the page in Preview mode to switch to Edit mode.

Page icon is blank

If no page icon appears to the left of the Title field at the top of the page, it means you haven’t 
saved the page. Save the page with an .htm or .html suffix and the icon will appear.

Unexpected question marks on the page

If question marks (?) appear in an opened HTML file, the file may contain an error such as 
overlapping tags, nonsupported tags, or illegal usage; or the file may not be in the HTML 
format. (These question marks do not appear in the browser.) If the page otherwise looks fine, 
you can delete the question marks, or edit the noninterpreted HTML code in the Inspector 
palette, and then save a new HTML file. For more information on editing HTML code, see 
Appendix B, “Viewing and Editing HTML Code.”

Question marks appear in place of an image

If the question mark (?) and pathname appear in place of an image, relink the image files. 
(See Chapter 5, “Creating Links.”)
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Questions marks are displayed in the browser in place of an image

If an image is not appearing in a document when viewed in a Web browser, try one of the 
following solutions:

• Change the browser’s preferences to display GIF and JPEG images automatically.

• Check the filenames and, if necessary, add the .gif or .jpeg (or .jpg) extension to the filename, 
then reinsert and relink the images. 

• Check the file format of the image. Open the image in an image-editing application and be 
sure you have saved the file as GIF or JPEG, and not just named it with the correct extension.

• Change the name of your Web site images and folders to names that conform to the UNIX 
file-naming standards, then reinsert or relink the images.

• Upload the image to the Web server as Raw Data. For more information see Chapter 10, 
“Uploading Your Web Site.”

• Upload your files to the Web server all at once. Uploading files individually can place them 
in different locations causing the local root folder and the remote Web server to have different 
structures. See “Step 3: Structure your Web site” on page 49 and Chapter 10, “Uploading Your 
Web Site.”

Colors in an imported image don’t match the original

Try converting the original CMYK image to RGB using an image-editing application such as 
Adobe Photoshop. Preview and adjust the colors, and then import the image into PageMill.

PageMill defines color using the RGB color model, used by computer monitors and GIF files to 
display colors. Applications that define color using the CMYK color model are often those 
designed for printed graphics, such as Adobe Illustrator. When importing images, PageMill 
converts to RGB any images that were defined using CMYK colors. The conversion can shift 
colors because the color range of the CMYK model differs significantly from the RGB model. 
For more information, see “Use a dither-free Web palette in your image-editing application” on 
page 45.
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Server-side image map hotspots aren’t active

Try the following: 

• In the Object panel of the Inspector palette, make sure that the Behavior option for the image 
is set to Map.

• If the image map doesn’t work from the server through a browser, check the image map
location in the Object panel of the Inspector palette. The location should have the correct path, 
expressed in the proper syntax for your Web server type.

• Be sure to preview your site from a true Web server.

Not enough memory

Try the following:

• Close unused images or HTML documents open in other windows.

• Quit other applications.

• (Macintosh only) Turn off unnecessary system extensions using an extension manager such 
as Apple Extensions Manager (included with System 7.5), or drag them to a folder outside the 
System Folder, and then restart.

• (Macintosh only) Increase the amount of memory Adobe PageMill uses. In the Finder, select 
the Adobe PageMill icon and choose File > Get Info. Increase the preferred size and then close 
the Get Info window.

QuickTime movie doesn’t display properly or won’t play

Try the following:

• Make sure that the QuickTime Player plug-in is installed in the Browser Plug-ins folder in 
the PageMill Plug-ins folder.

• Make sure that the proper version of QuickTime is installed on your system. PageMill 
requires that you have QuickTime 2.1 or later (Macintosh) or QuickTime 2.0 or later 
(Windows) installed on your system. 

• Double-click to start movie playback.

• (Macintosh) The movie may not be flattened. For more information, request documents 
200309 and 143604 from the Adobe automated fax-back system, Adobe FaxYI, at 206-628-5737. 
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PDF file can’t be read 

Make sure that:

• Adobe Acrobat Reader 3.0 or Adobe Acrobat Exchange 3.0 is installed.

• The PDFViewer plug-in is installed in the Browser Plug-ins folder in the PageMill 
Plug-ins folder.

Movie, PDF file, or animation doesn’t preview properly

• Try viewing the movie, file, or animation in Netscape or Microsoft Internet Explorer. If it still 
doesn’t preview correctly in these browsers, the problem may be caused by a limitation of the 
QuickTime, PDF Viewer, or Shockwave plug-in module and not by PageMill.

• Make sure the Netscape plug-in is in the Netscape browser’s Plug-in folder and in the 
Browsers Plug-ins folder (inside the PageMill Plug-ins folder).
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Appendix B: Viewing and Editing 
HTML Code

TML stands for HyperText Markup Language and is used to describe the structure of 
Web pages. Each file you create in Adobe PageMill contains the HTML source code 
for that page.

Although you don’t need to know HTML to create your Web pages, there may be times when 
you want to make slight changes in the HTML source code. For example, you might want to 
insert blinking text or other HTML tags not currently supported in PageMill (if you insert non-
supported code you will not be able to preview the effect in Preview mode). You might also 
want to check the HTML source code to verify the naming of one of your objects or links.

Viewing the HTML code
HTML code consists of ASCII text formatted by codes called tags. Tags appear in brackets. 
These tags are used by the browser to interpret the way the page should be displayed. HTML 
indicates the type of object you’re inserting (image, table, frame, and so on), text formatting, 
and the names and locations to the links in the page, and so on. For example,

<BLOCKQUOTE>
  <H4 ALIGN=CENTER>Welcome to our online catalog. Now you can order any item
  in stock by using our new interactive <A HREF="EWOrder.html">Order 

Form</A>.<STRONG><KBD>
  </KBD></STRONG></H4>

</BLOCKQUOTE>

Most of the time, you don’t need to worry about the HTML source code; it’s generated auto-
matically behind the scenes.

You can look at the source code for any Web page (but not for frameset pages). You can drag 
and drop page items onto a page in Source view, and PageMill converts them automatically to 
source code, and vice versa—dragging source code onto a PageMill page in Page view converts 
the code to what it describes, such as a graphic or text. The HTML source code is the PageMill 
interpretation of the code, until you save the file. For example, if you open a file containing the 
code <CENTER>, PageMill displays it in Source view as <P ALIGN CENTER>. Once you save 
the file, the on-screen display matches what is on your disk.

H
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To show or hide the HTML code for a page:

1 Open the page in PageMill.

2 Choose Edit > HTML Source. The command switches to either display or hide the 
HTML code.

The HTML source code is color-coded so you can identify the elements easily. You can change 
the display colors of comments and tags in the HTML Source view:

• HTML tags appear in blue.

• Text on a page appears in black.

• Comments appear in red.

To change the color codes:

1 Choose Edit > Preferences.

2 Scroll to the <Tag></Tag> HTML icon and select it (Macintosh), or click the HTML 
tab (Windows).

3 In the HTML Source View section, choose a Comment or Tag color option: Default or 
Custom. If you choose Custom, select a new color from the color picker or Color panel.

4 Click OK. 

Editing HTML code
PageMill has several features that are useful for editing a page’s source code. Some make it easier 
to read the code, and others protect the code from changes when the browser interprets it. You 
can hide these editing items when you view the page in Edit or Preview mode.

You can also specify how HTML interprets text set to a relative font size and aligned para-
graphs, using the Preferences command.

To edit in HTML Source view:

1 Choose Edit > HTML Source to switch to the Source view.

2 Click in the line of code where you want to add a comment or a hidden field. 

3 To add a comment in HTML, choose Edit > Insert Invisible > Comment. Type your 
comment between the dashed lines. The brackets and two dashed lines must surround 
the comment, for example, <!--Comment-->. 
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Comments are notes to yourself and do not show up in the browser. Some examples of 
comments you could add include: “Give credit to the photographer in this frame” or “Leave 
room for the trademark.” When Edit > Show Invisibles is chosen, comments appear as an 
icon (3) in Page view.

4 To add an anchor (z) in HTML Source view, choose Edit > Insert Invisible > Anchor. 
An anchor name appears in the source code. When Edit > Show Invisibles is chosen, hidden 
anchors appear as an icon in Page view. For more information about anchors, see “Creating an 
anchor” on page 112.

5 To add a margin break (/), choose Edit > Insert Invisible > Margin Break. The code 
<BR CLEAR="ALL"> appears in the source code. When Edit > Show Invisibles is chosen, 
invisible margin breaks appear as a return arrow icon. 

6 To add a hidden field (.), choose Edit > Insert Invisible >Hidden Field. 

Note: You can also enter comments, anchors, margin breaks, and hidden fields in Edit mode 
when you’re working in Page view.

To set how HTML interprets relative font size:

1 Choose Edit > Preferences.

2 Scroll to the <Tag></Tag> HTML icon and select if (Macintosh) or click the HTML 
tab (Windows).

3 In the HTML Syntax section, choose a Font Size option to determine how a browser displays 
relatively sized text: 

• SIZE Attribute to have the browser use its default tag

• <BIG>&<SMALL> Tags to use <BIG> and <SMALL> settings

4 Click OK. 

For more information about relative font sizes, see “Changing the font size” on page 70. 

To specify how HTML interprets paragraph alignment:

1 Choose Edit > Preferences.

2 Scroll to the <Tag></Tag> HTML icon and select it (Macintosh) or click the HTML 
tab (Windows).
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3 In the HTML Syntax section, specify how HTML interprets paragraph alignment options:

• <DIV> Tag to insert a <Div> tag (preferred by Netscape browsers) before an 
alignment option

• <P> Tag to insert a blank line before the alignment setting

• <CENTER> Tag to center objects

4 Click OK. 

PageMill does not support multiple alignment tags in a single document. When you select a 
new alignment tag from the Preferences dialog box, PageMill rewrites all the alignment tags 
in the document.

Note: Tables you align with the <P> tag do not appear centered in Netscape Navigator 3.0 and 
earlier, NCSA Mosiac 3.0b4 and earlier, or the America Online Web Browser 1.1 or earlier. Text 
you align with the <P> tag appears left-aligned in the America Online Web Browser 1.1 or earlier. 

Using HTML placeholders

You can prevent PageMill from examining or changing HTML code using the Edit > Insert 
Placeholder command (2). This command instructs PageMill to leave the enclosed HTML 
unchanged. The Placeholder command inserts two special comments in the HTML page: 
<!--NOEDIT--> and <!--/NOEDIT-->. (You can also place the <!--NOEDIT--> and 
<!--/NOEDIT--> comments in your HTML files before opening them in PageMill, to keep 
PageMill from examining and possibly altering portions of your files you want left unchanged.) 
The Placeholder appears as an icon in a PageMill page.

When PageMill reads in an HTML page, any text between these two comments is stored as 
a Placeholder, and PageMill won’t parse the text between the comments. The Placeholder 
displays a small icon in the text flow. You can use the Inspector palette to have a custom image 
(such as a graphic representation of what the HTML does) appear instead of the icon. You can 
edit the enclosed HTML directly in the Inspector palette, or in HTML Source view. PageMill 
remembers the Placeholder between sessions. 

These special comments also support pseudo attributes for placing an image in the PageMill 
page instead of the little icon. These attributes look exactly like an image tag. For example: 

<!--NOEDIT SRC="counter.gif" WIDTH=100 HEIGHT=50 --> 
<SPECIAL_COUNTER_TAG>
<!--/NOEDIT-->

Note:  There are no spaces between “<!--” and “NOEDIT.” Don’t omit the closing “ -->,” because 
they are comments.
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Tagging paragraphs

Pressing Return when editing a page inserts a blank link between paragraphs (<P>). 
Pressing Shift+Return starts a sentence on the next line without inserting a blank line 
in between (<BR>).

Using Java scripts
PageMill 2.0 does not test or run Java scripts, but you can open pages that contain them.

When PageMill encounters a <SCRIPT LANGUAGE =...> tag inside the <HEAD></HEAD> 
tag, it must process any HTML inside the script in order to find the </SCRIPT> tag. To prevent 
PageMill from altering the script, insert the placeholder <!--NOEDIT--> and <!--/NOEDIT--> 
before and after the script, instructing PageMill to ignore the script. 

Alternatively, place a <!-- on the line before the script begins, and a --> on the line after the 
script ends. Netscape and PageMill will treat the entire script as a comment and won’t process 
it; Java, however, won’t see the comment command and will process the script as expected. 
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AIFF movies 80

All Readable option 53

Allow Multiple Selections options 
168

Alternate Label option 92

Always option for uploading 190

anchors

adding to source code 205

creating 112

hiding 114

linking to 113

naming 113

animated GIF files

adding to page 85

playing 86

animated GIF format 79

animation formats 78

animations

adding to page 85

playing 86

previewing 55, 201

anti-aliasing 46

AU files 80

Audio Interchange File Format 80

AVI movies 80

B

Back button 56

Back in Frame option 188

background color, links 52

Background Image well in 

Inspector palette 52, 98

backgrounds

removing 99

setting color for pages 52

using images as 97

base font size 70

base target 187

Behavior button option 169

Behavior Map option 134, 136

BMP files

converted to GIF 82, 84

BMP image format 78

Bold character style 68

Bold tool 68

Border option 96, 154

borders

adding to an image 95

removing from an image 96

Bottom Align Object tool 95

Bring To Front option 120, 133

Browser Plug-ins folder 78, 86

browsers

border display 95

defined 39

fonts display 70

frames display 172, 176

image display 45

image formats 77

interlaced images display 97
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link display 103

Open Remote Links using 

option 110

resolution display 45

Select Browser option 110

selecting for remote link display 
110

table display 139

text labels for images in 92

Bullet list format 66

C

Caption option 154

Cell Padding option 153

Cell Spacing option 153

cells. See table cells

Center Align Text tool 67

CENTER tag 206

CERN 123

CGI. See Common Gateway 
Interface

character styles 67

applying 68

Bold 68

Citation 69

Code 69

Emphasis 68

Italic 68

Keyboard 69

logical 68

physical 68

Plain 68

Sample 69

Strong 68

Teletype 68

Variable 69

Check Spelling command 75

checkbox

adding 158

customizing 159

Checkbox tool 158

checking spelling 74

circle tool 119, 131

Citation character style 69

Clear command 62

client-side image maps

adding hotspots 118

creating 118

creating links in 121

defined 117

drawing tools 118

editing hotspots 119

image map file 123

layering hotspots 120

resizing 122

testing 122

turning off link display 121

Code character style 69

color palettes

dither-free 45

in pages 45

color panel

customizing 74

using 73

colors in imported image 199

column alignment 64

columns

adding to tables 149

alignment 64

deleting from tables 149

joining 145

resizing 149

comments

adding to pages 204

in source code 204

Common Gateway Interface (CGI)

action script 169

and forms 157

and image maps 135, 136

defined 122

path to 136

Copy command 61, 83, 112

cross-platform issues 196

customer service 3
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D

Decrease Font Size command 71

Deep search option 75, 89

default colors

changing 72

links 52

text 52

default folder for images 82

default link 134

Default option 187

Definition list format 66

Delete Column tool 149

Delete Row tool 149

deleting links 115

Deselect Wrap option 75

designing a page 42

dictionaries

adding to 75

using 74

Directory list format 66

displaying pages 55

dithered colors 45

DIV Tag 206

domain 41

Download Statistics command 86

downloading

estimating times for 86

images 44

pages from the Web 53

transferring files 86

drag-and-drop restrictions 59, 82

dragging and dropping

images 98

into frames 176

links 105

duplicating

graphics 15

objects 15

text 15

E

Edit mode 13, 54

effects, not supported 42

electronic mail 39, 105

e-mail. See electronic mail

EMBED tag 85

embedded objects, searching in 89

Emphasis character style 68

extensions for filenames 50

F

FaxYI 3
Fetch application 191

file formats

aifc 80

aiff 80

animation 78

AU 80

AVI 79

GIF 78

image 78

JPEG 78

movies 79

MPEG 79

PICT 78

QuickTime 79

Shockwave 77

sound 80

WAVE 80

file name extensions 50

File Transfer Protocol (FTP) 104

filename extensions 50

filenames

suffix preferences for 52

using correct extensions in 77

files

downloading 44, 86

importing 60

naming 50

opening 53

storing in a site folder 49

transferring cross-platform 196

Find command 89

font 71

font size

base 70

relative 71
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Font Size option 205

fonts, controlling 43

formats 62

Address 64

Bullet 66

Definition 67

Directory 66

Heading 64

in toolbar 63

Indent 65

List 65, 66

Menu 66

Numbered 66

Paragraph 64

Preformatted 64

Term 66

forms

and form scripts 157

associating a script with 169

checkboxes 158

defined 157

hidden fields 164

list-selection field 165

moving through fields 26

multiline text area 162

naming a text field 163

password field 162

pop-up menu 165

radio buttons 160

Reset button 168

resizing a text field 163

Submit button 168

text fields 161

Forward button 56

Forward in Frame option 188

Frame panel 57

frame source documents 172

frames

adding images to 176

changing width of 178

creating 173

creating links in 185

defined 171

deleting 175

dividing 175

layout 177

margins 181

moving forward and backward 

in 188

naming 177

No Frames Message 176

non-resizable 183

opening pages in 176

placing objects in 176

printing 185

removing 175

resizing 178, 179, 183

reverting to last saved 184

saving 183

scrollbars 181

splitting 175

targeting links 185

Frames Resizing Box in Inspector 

palette 179

frameset documents 172

framesets

defined 172

opening 188

reverting to last saved 184

saving 184

FTP file-transfer 191

G

General option 54

Get option 170

GIF file format 91

GIF files, opening 81

GIF image format 45, 78

globe icon 13, 54

Gopher 39, 104

Graphics Interchange Format. See 
GIF image format

graphics. See images

H

Header Cell option 147

Heading format 65



213

Height option 94

helper application 47

hidden fields

adding 164

customizing 164

defined 164

Hide Inspector command 57

Hide Invisibles command 114

Home button 56

home page 40

Horizontal Align option 147

Horizontal Rule tool 99

horizontal rules 99

adding 23

resizing 100

Host name 190

Hotspot Color tool in Image 

Window 132

Hotspot Color tool in toolbar 120

hotspots

color 120, 132

defined 117

deleting 120, 132

drawing 119, 131

editing 119, 132

layering 120, 132, 133

link display 121, 134

moving 120, 132

numbering 119, 131

previewing 122

resizing 120, 132

shuffling 120

testing 122

HTML

adding anchors to 205

adding margin breaks to 205

and graphics 44

and layout 42

and special characters 70

and type 43

formatting in 46

non-interpreted code 206

paragraph alignment 205

placeholders 206

setting relative font size 205

switching to 204

tagging paragraphs 207

viewing 203

HTML formats. See tags

HTML option 53

HTML panel for Preferences 152, 
204

HTML Source command 204

HTML tags. See tags

hypertext links 39

Hypertext Markup Language. See 
HTML

I

identifying image maps 134

image alignment 95

image formats

GIF 78

JPEG 78

PICT 78

image icon in Image Window 85

image map hotspots. See hotspots

image maps. See client-side image 
maps and server-side image 
maps

Image window 17

adding images from 85

editing in 91

opening 129

opening an image in 91

images

adding a border 95

adding from Image Window 85

adding to pages 80

aligning 95

aligning with text 95

and non-graphic browsers 92

anti-aliasing 46, 90

as page background 97

as Submit button 169

avoiding dithering 45

border 95

color palettes 44
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creating thumbnails 81

display resolution 45

display widths 44

download time 44

dragging and dropping 84

duplicating 46

file size 44

importing 199

importing layered Photoshop 

files 83

including in a page 44

interlaced 97

positioning 16, 43

positioning on page 43

removing from background 99

replaced with question mark 87

resizing 85, 93

resizing and resampling 45

resolution 45

scaling 94

text label 92

text wrap 95

thumbnails 44

transparency 90

using in HTML documents 44

images. See graphics

importing

images, movies, and sounds 80

text files 60

Increase Font Size command 71

Indent format 65

Indent Left tool 63

Indent Right tool 63

in-line editing 118

Insert Column tool 149

Insert Invisible Anchor command 
113, 205

Insert Invisible Comment 

command 204

Insert Invisible Hidden Field 

command 165, 204

Insert Invisible Margin Break 

command 205

Insert New command 176

Insert Page command 176

Insert Placeholder command 206

Insert Row tool 149

Inspector palette 57

displaying panels in 57

hiding and showing 57

installing Adobe PageMill 4, 6
interlace tool 97

interlaced GIF images 97

Internet Dictionary 74

Internet Service Provider

defined 40

questions to ask of 48

Internet, defined 39

invalid characters and missing 

images 88

invisible margin breaks 95

ISO Latin-1 70

ISP. See Internet Service Provider

Italic character style 68

Italic tool 68

Items Visible option 168

J

Java applets 79, 85

Java scripts 207

Join Cells button 145

JPEG files, opening 81

JPEG image format 45, 78

K

kbps option for downloading 87

kerning 43

Keyboard character style 69

L

layout 47

leading 43

Left Align Text tool 67

letter spacing 43

line break format 52

line breaks 43, 64, 95

Line Breaks option 123
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line length 43

link address 21

Link Address search option 89

link destination 105

Link Location bar

entering links in 106, 107

typing image map location in 
135

viewing links in 111

Link To button 84, 106, 108

linking

to an anchor 113

to same page 115

to text or images 105

to URL 104

links

appearance 103

changing colors 52

color 71

copying 21

creating with URL 106, 107

default 134

default colors 52

default for server-side image 

maps 134

defined 47

deleting 115

dragging and dropping 105

dragging from Netscape 106

following 11

frequently used 116

in client-side image maps 121

in server-side image maps 124

in table cells 139

location of linked files 106

maintaining 87

missing 87

moving 111

previewing 55, 110

removing 115

searching for 89

selecting 14, 111

site links 49

storing on Pasteboard 116

targeting in frames 185

testing 110

to local aliases 124

turning off display 121, 134

viewing URL for 111

List format 65

lists

creating 66

nested 67

list-selection field

adding 165

allowing multiple choices 168

converting to a pop-up menu 
166

entering choices for 166

resizing 167, 168

local aliases

for remote resources 124

for server-side image maps 124

Local Links option 55

local root folder 87, 189, 190

logical styles, defined 68

M

Macromedia Shockwave 77

map format 48, 123

margin breaks

adding to source code 205

inserting 95

Margin Height option 181

Margin Width option 181

memory 200

Menu list format 66

Microsoft Excel tables 140

Middle Align Object tool 95

mirroring a Web site 189

missing images 87

monospaced text 68

monospaced, defined 64

movie file formats 79

movies

adding to pages 80

cannot play 200
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playing 86

previewing 55

MPEG movies 80

N

NCSA 123

NCSA server 123

nested

frames 173, 180

lists 67

tables 150

tables, searching in 89

Netscape plug-ins 77

New Page command 51

New Window option 55, 187

No Frames Message command 176

No Shade option 100

No Wrap option 147

NOEDIT tag 206

Nondithering colors 45

non-interpreted tags 52

Numbered list format 66

O

Object panel 57, 85

Object search option 75, 89

Object Size search option 89

Object Type option 84

objects

finding 87

replacing 87, 89

resizing 85

Open command 53, 81

Open in Window command 188

Open Pages option 54

Open Selection command 91

outline font 44

P

P tag 206

Page Content search option 89

Page icon 198

page layout, maintaining in an 

HTML page 47

Page panel 51, 57

Page panel in Preferences 51

Page search option 89

PageMill Resources folder 87

pages

adding images to 80

adding movies to 80

adding sound to 80

background color 52, 71

background pattern 52

cannot open 198

color palettes in 45

creating 51

creating frames in 173

designing 42

determining the appearance of 
46

displaying in same or new 

window 55

including links 47

inserting in frames 176

Java applets in 79

moving between 56

naming 50

opening 51, 53

planning 49

preserving layout 47

removing background images 

from 99

saving 51

Shockwave files in 79

structuring 46

uploading 190

using images as backgrounds in 
97

viewing 54

viewing preferences 54

paragraph alignment 205

paragraph formats. See formats

Paragraph spacing 44

Parent Window option 187

password field 162

Paste command 61, 84, 112

Pasteboard 83, 116
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paths, importing from Adobe 

Illustrator 83

PDF files

displaying in HTML pages 47

linking to 109

previewing 201

pen-and-paper icon 13, 54

photographs and JPEG format 78

Photoshop files, preserving layers 
83

physical styles, defined 68

PICT files

converted to GIF format 84, 87

opening 81

PICT image format 78

Place command 84, 176

Place Object tool 84

Plain character style 68

plug-ins

and PDF files 47

in Browser Plug-ins folder 77, 
78

polygon tool 119, 131

pop-up menu

adding 165

converting to a list-selection 

fields 166

entering choices for 166

resizing 168

Post option 170

Preferences command 49, 51, 52, 
54, 123

Preferences file 195

Preformatted format 64

Preview mode

defined 54

switching to 54

previewing

interlaced images 97

Java applets 85

links 55

movies 55

sounds 55

Previous Log file option for 

uploading 190

Print Frame command 185

Progressive JPEG files 79

protocol 41

Q

question mark icon 87

question marks 198

QuickTime for Windows format 
77

QuickTime format 77

QuickTime movies 79

QuickTime PowerPlug 2

R

Radio Button tool 160

radio buttons

adding 160

customizing 160

Raw Data option 199

raw data transfer 192

rectangle tool 119, 131

relative font size 71, 205

relative pathnames 135

Remote file status for uploading 
190

remote links

adding 110

testing 110

Remote Root Directory 123

remote server, transferring Web 

site to 189

Remote URL option 84, 108

Remove Link command 115

replacing found objects 89

resampling images 45

Reset button

adding 168

editing text in 169

Reset Button tool 169

resizing images 45

Resource folder 50, 82, 87
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Resources 49

Resources panel for Preferences 
123

reverse type fonts 44

Revert to Last Saved command 184

Revert to Last Saved Frameset 184

Right Align Text tool 67

root folder, defined 49

root folder. See local root folder

rows

adding to tables 149

deleting from tables 149

joining 145

resizing 149

S

Same Frame option 187

Same Window option 55, 187

Sample character style 69

Save A Copy As command 184

Save Everything command 184

Save Frame As command 184

Save Frame command 184

Save Frameset As command 184

Save Frameset command 176, 184

Save Page As command 52

Save Page command 52, 119

Scale to Height option 94

Scale to Width option 94

script, CGI 122, 157

scrollbars, displaying in frames 181

Search Path Scope option 75, 89

secure newsgroup 105

secure World Wide Web 

connection 105

Selector tool 119

Send To Back option 120, 133

Server panel for Preferences 125

server requirements, determining 
48

server-side image maps

adding hotspots to 130

CERN server 123, 135

creating 122

creating links in 133

default link 134

defined 117

drawing tools 130

editing 129

editing hotspots 132

image map file 123

information needed for 123

layering hotspots 132

line break preference 123

map file location 135

map format 123

marking as an 134

NCSA server 123, 136

resizing 137

server location preferences 123

specifying server type 123

testing 136

troubleshooting 136

turning off link display 134

shadow font 44

Shockwave

memory requirements 77

using in PageMill 79

Show Color Panel command 73, 
147

Show Inspector command 57

Show Pasteboard command 15, 
83

Shuffle Back option 120, 133

Shuffle Forward option 120, 133

Shuffle Hotspot tool 120, 133

single-line text field 161

site folder 49, 189, 190

Site mapping 190

Size option 100

sound file formats 80

sounds

adding to pages 80

playing 86

previewing 55
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source code

adding anchors to 205

adding margin breaks 205

paragraph alignment 205

placeholders 206

setting relative font size 205

tagging paragraphs 207

viewing 203

special characters 70

spell-checking 74

spelling dictionaries 74

Split Cell Horizontally button 146

Split Cell Vertically button 146

Split Horizontally command 175

Split Vertically command 175

Start Upload command 191

Strong logical character style 68

structuring a Web site 49

Submit button

adding 168

editing text in 169

tool 169

using an image as 169

Suffix option for file formats 52, 
124

Switch To command 53

Switch To panel for Preferences 53

switching modes 55

T

table cells

aligning contents 147

blank 144

changing color 147

changing width 148

contents

creating headers 147

deleting 145

dividing 146

formatting 146, 147

joining 145

padding 152

selecting 142

selecting contents of 143

spacing 152

word wrap in 147

Table tool 140

tables

adding blank rows at beginning 
149

adding rows and columns 149

aligning in Netscape 206

aligning text 147

as layout devices 139

borderless 139, 154

borders 153, 154

captions 154

cell padding 152

cell spacing 152

centering in Netscape 152

changing color of cells 147

changing column size 149

changing row size 149

changing width 151

creating 140

creating empty cells 144

deleting cells 145

deleting rows and columns 149

dividing cells 146

dragging and dropping into cells 
144

entering data 144

formatting 147

header cells 147

joining cells 145

links in 139

moving from cell to cell 145

nested 150

resizing 151

selecting 142

word wrap 147

tabs 44

tags

changing color of 204

defined 42

non-interpreted 52

target icon 185
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targets

base 187

for frames 185

overriding 188

special 187

technical support 3, 195

Teletype character style 68

Teletype tool 68

Telnet 39, 104

Term list format 66

text

adding 59

aligning in table cells 147

aligning with images 95

color 52, 71

computer code 69

computer messages 69

copying 61

default color 52, 71

deleting 62

formats 62

importing 60

monospaced 68

pasting 61

word wrap in tables 147

text area in forms 162

Text Case search option 89

Text Color tool 72

text entry fields

adding 162

defined 161

naming 162

resizing 163

Text panel 57

Text Style search option 89

thumbnails for images 81

tiling windows 56

Title pop-up menu 56

toolbar, defined 14

Top Align Object tool 95

tracking 43

transferring files across platforms 
197

transparency tool 91

transparent areas in images 90

troubleshooting 195

U

Uniform Resource Locator. See 
URL

uninstalling Adobe PageMill 196

Upload command 191

Upload Frameset command 191

Upload Object command 191

Upload Page command 190

uploading

framesets 191

objects 191

pages 190

using Fetch 191

Web site 189, 190

URL

creating links to

defined 41

entering into Link Location bar 
106, 107

searching for 89

secure connections 105

viewing in Link Location bar 
111

Usenet newsgroup 39, 104

user dictionaries 74

V

Variable character style 69

Vertical Align option 147

Viewer Resizable option 183

Visited Link Color option 52

W

WAVE sound format 80

Web addresses 41. See also URL

Web client 39

Web server

defined 39

platform 39

Web site

building 48

defined 40

designing 49
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maintaining 51

structuring 49

transferring to remote server 
189

uploading 189, 190

Whole Word search option 89

Width option (for frames) 179

Width option (for horizontal 

rules) 100

Width option (for image size) 94

Width option (for tables) 151

window display 56

word spacing 43

word wrap in tables 147

World Wide Web, defined 39

Wrap search option 89

wrapping text around images 95
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